4 #note that the Zw... functions are alternate names for the
5 #Nt... functions. (see www.sysinternals.com for details)
6 #if you change a Nt.. function DON'T FORGET to change the
9 001 stub CsrAllocateCaptureBuffer
10 002 stub CsrAllocateCapturePointer
11 003 stub CsrAllocateMessagePointer
12 004 stub CsrCaptureMessageBuffer
13 005 stub CsrCaptureMessageString
14 006 stub CsrCaptureTimeout
15 007 stub CsrClientCallServer
16 008 stub CsrClientConnectToServer
17 009 stub CsrClientMaxMessage
18 010 stub CsrClientSendMessage
19 011 stub CsrClientThreadConnect
20 012 stub CsrFreeCaptureBuffer
21 013 stub CsrIdentifyAlertableThread
23 015 stub CsrProbeForRead
24 016 stub CsrProbeForWrite
25 017 stub CsrSetPriorityClass
26 018 stub CsrpProcessCallbackRequest
27 019 stub DbgBreakPoint
30 022 stub DbgSsHandleKmApiMsg
31 023 stub DbgSsInitialize
32 024 stub DbgUiConnectToDbg
33 025 stub DbgUiContinue
34 026 stub DbgUiWaitStateChange
35 027 stub DbgUserBreakPoint
36 028 stub KiUserApcDispatcher
37 029 stub KiUserCallbackDispatcher
38 030 stub KiUserExceptionDispatcher
39 031 stub LdrAccessResource
40 032 stub LdrDisableThreadCalloutsForDll
41 033 stub LdrEnumResources
42 034 stub LdrFindEntryForAddress
43 035 stub LdrFindResourceDirectory_U
44 036 stub LdrFindResource_U
45 037 stub LdrGetDllHandle
46 038 stub LdrGetProcedureAddress
47 039 stub LdrInitializeThunk
49 041 stub LdrProcessRelocationBlock
50 042 stub LdrQueryImageFileExecutionOptions
51 043 stub LdrQueryProcessModuleInformation
52 044 stub LdrShutdownProcess
53 045 stub LdrShutdownThread
55 047 stub LdrVerifyImageMatchesChecksum
56 048 stub NPXEMULATORTABLE
57 049 stub NlsMbCodePageTag
58 050 stub NlsMbOemCodePageTag
59 051 stdcall NtAcceptConnectPort(long long long long long long) NtAcceptConnectPort
60 052 stub NtAccessCheck
61 053 stub NtAccessCheckAndAuditAlarm
62 054 stub NtAdjustGroupsToken
63 055 stdcall NtAdjustPrivilegesToken(long long long long long long) NtAdjustPrivilegesToken
64 056 stub NtAlertResumeThread
65 057 stub NtAlertThread
66 058 stub NtAllocateLocallyUniqueId
67 059 stub NtAllocateUuids
68 060 stub NtAllocateVirtualMemory
69 061 stub NtCallbackReturn
70 062 stub NtCancelIoFile
71 063 stub NtCancelTimer
73 065 stdcall NtClose(long) NtClose
74 066 stub NtCloseObjectAuditAlarm
75 067 stdcall NtCompleteConnectPort(long) NtCompleteConnectPort
76 068 stdcall NtConnectPort(long long long long long long long long) NtConnectPort
78 070 stdcall NtCreateDirectoryObject(long long long) NtCreateDirectoryObject
79 071 stdcall NtCreateEvent(long long long long long) NtCreateEvent
80 072 stub NtCreateEventPair
81 073 stdcall NtCreateFile(ptr long ptr ptr long long long ptr long long ptr) NtCreateFile
82 074 stub NtCreateIoCompletion
83 075 stdcall NtCreateKey(long long long long long long long) NtCreateKey
84 076 stdcall NtCreateMailslotFile(long long long long long long long long) NtCreateMailslotFile
85 077 stub NtCreateMutant
86 078 stub NtCreateNamedPipeFile
87 079 stdcall NtCreatePagingFile(long long long long) NtCreatePagingFile
88 080 stdcall NtCreatePort(long long long long long) NtCreatePort
89 081 stub NtCreateProcess
90 082 stub NtCreateProfile
91 083 stdcall NtCreateSection(long long long long long long long) NtCreateSection
92 084 stub NtCreateSemaphore
93 085 stub NtCreateSymbolicLinkObject
94 086 stub NtCreateThread
95 087 stdcall NtCreateTimer(long long long) NtCreateTimer
96 088 stub NtCreateToken
97 089 stdcall NtCurrentTeb() NtCurrentTeb
98 090 stub NtDelayExecution
101 093 stub NtDeleteValueKey
102 094 stdcall NtDeviceIoControlFile(long long long long long long long long long long) NtDeviceIoControlFile
103 095 stub NtDisplayString
104 096 stdcall NtDuplicateObject(long long long long long long long) NtDuplicateObject
105 097 stdcall NtDuplicateToken(long long long long long long) NtDuplicateToken
106 098 stub NtEnumerateBus
107 099 stub NtEnumerateKey
108 100 stub NtEnumerateValueKey
109 101 stub NtExtendSection
110 102 stub NtFlushBuffersFile
111 103 stub NtFlushInstructionCache
113 105 stub NtFlushVirtualMemory
114 106 stub NtFlushWriteBuffer
115 107 stub NtFreeVirtualMemory
116 108 stdcall NtFsControlFile(long long long long long long long long long long) NtFsControlFile
117 109 stub NtGetContextThread
118 110 stub NtGetPlugPlayEvent
119 111 stub NtGetTickCount
120 112 stub NtImpersonateClientOfPort
121 113 stub NtImpersonateThread
122 114 stub NtInitializeRegistry
123 115 stdcall NtListenPort(long long) NtListenPort
124 116 stub NtLoadDriver
127 119 stub NtLockVirtualMemory
128 120 stub NtMakeTemporaryObject
129 121 stdcall NtMapViewOfSection(long long long long long long long long long long) NtMapViewOfSection
130 122 stub NtNotifyChangeDirectoryFile
131 123 stub NtNotifyChangeKey
132 124 stdcall NtOpenDirectoryObject(long long long) NtOpenDirectoryObject
133 125 stdcall NtOpenEvent(long long long) NtOpenEvent
134 126 stub NtOpenEventPair
135 127 stdcall NtOpenFile(ptr long ptr ptr long long) NtOpenFile
136 128 stub NtOpenIoCompletion
137 129 stdcall NtOpenKey(ptr long ptr) NtOpenKey
138 130 stub NtOpenMutant
139 131 stub NtOpenObjectAuditAlarm
140 132 stub NtOpenProcess
141 133 stdcall NtOpenProcessToken(long long long) NtOpenProcessToken
142 134 stdcall NtOpenSection(long long long) NtOpenSection
143 135 stub NtOpenSemaphore
144 136 stub NtOpenSymbolicLinkObject
145 137 stub NtOpenThread
146 138 stdcall NtOpenThreadToken(long long long long) NtOpenThreadToken
148 140 stub NtPlugPlayControl
149 141 stub NtPrivilegeCheck
150 142 stub NtPrivilegeObjectAuditAlarm
151 143 stub NtPrivilegedServiceAuditAlarm
152 144 stub NtProtectVirtualMemory
153 145 stub NtPulseEvent
154 146 stub NtQueryAttributesFile
155 147 stub NtQueryDefaultLocale
156 148 stub NtQueryDirectoryFile
157 149 stdcall NtQueryDirectoryObject(long long long long long long long) NtQueryDirectoryObject
158 150 stub NtQueryEaFile
159 151 stub NtQueryEvent
160 152 stdcall NtQueryInformationFile(long long long long long) NtQueryInformationFile
161 153 stub NtQueryInformationPort
162 154 stdcall NtQueryInformationProcess(long long long long long) NtQueryInformationProcess
163 155 stdcall NtQueryInformationThread (long long long long long) NtQueryInformationThread
164 156 stdcall NtQueryInformationToken (long long long long long) NtQueryInformationToken
165 157 stub NtQueryIntervalProfile
166 158 stub NtQueryIoCompletion
168 160 stub NtQueryMutant
169 161 stdcall NtQueryObject(long long long long long) NtQueryObject
170 162 stub NtQueryPerformanceCounter
171 163 stub NtQuerySection
172 164 stub NtQuerySecurityObject
173 165 stub NtQuerySemaphore
174 166 stub NtQuerySymbolicLinkObject
175 167 stub NtQuerySystemEnvironmentValue
176 168 stdcall NtQuerySystemInformation(long long long long) NtQuerySystemInformation
177 169 stdcall NtQuerySystemTime(ptr) GetSystemTimeAsFileTime
178 170 stub NtQueryTimer
179 171 stdcall NtQueryTimerResolution(long long long) NtQueryTimerResolution
180 172 stdcall NtQueryValueKey(long long long long long long) NtQueryValueKey
181 173 stub NtQueryVirtualMemory
182 174 stub NtQueryVolumeInformationFile
183 175 stub NtRaiseException
184 176 stub NtRaiseHardError
185 177 stdcall NtReadFile(long long long long long long long long long) NtReadFile
186 178 stub NtReadRequestData
187 179 stub NtReadVirtualMemory
188 180 stub NtRegisterNewDevice
189 181 stdcall NtRegisterThreadTerminatePort(long) NtRegisterThreadTerminatePort
190 182 stub NtReleaseMutant
191 183 stub NtReleaseProcessMutant
192 184 stub NtReleaseSemaphore
193 185 stub NtRemoveIoCompletion
194 186 stub NtReplaceKey
196 188 stdcall NtReplyWaitReceivePort(long long long long) NtReplyWaitReceivePort
197 189 stub NtReplyWaitReplyPort
198 190 stub NtRequestPort
199 191 stdcall NtRequestWaitReplyPort(long long long) NtRequestWaitReplyPort
200 192 stub NtResetEvent
201 193 stub NtRestoreKey
202 194 stdcall NtResumeThread(long long) NtResumeThread
204 196 stub NtSetContextThread
205 197 stub NtSetDefaultHardErrorPort
206 198 stub NtSetDefaultLocale
208 200 stdcall NtSetEvent(long long) NtSetEvent
209 201 stub NtSetHighEventPair
210 202 stub NtSetHighWaitLowEventPair
211 203 stub NtSetHighWaitLowThread
212 204 stdcall NtSetInformationFile(long long long long long) NtSetInformationFile
213 205 stub NtSetInformationKey
214 206 stub NtSetInformationObject
215 207 stdcall NtSetInformationProcess(long long long long) NtSetInformationProcess
216 208 stdcall NtSetInformationThread(long long long long) NtSetInformationThread
217 209 stub NtSetInformationToken
218 210 stdcall NtSetIntervalProfile(long long) NtSetIntervalProfile
219 211 stub NtSetIoCompletion
220 212 stub NtSetLdtEntries
221 213 stub NtSetLowEventPair
222 214 stub NtSetLowWaitHighEventPair
223 215 stub NtSetLowWaitHighThread
224 216 stub NtSetSecurityObject
225 217 stub NtSetSystemEnvironmentValue
226 218 stub NtSetSystemInformation
227 219 stub NtSetSystemPowerState
228 220 stub NtSetSystemTime
229 221 stdcall NtSetTimer(long long long long long long) NtSetTimer
230 222 stub NtSetTimerResolution
231 223 stdcall NtSetValueKey(long long long long long long) NtSetValueKey
232 224 stdcall NtSetVolumeInformationFile(long long long long long) NtSetVolumeInformationFile
233 225 stub NtShutdownSystem
234 226 stub NtStartProfile
235 227 stub NtStopProfile
236 228 stub NtSuspendThread
237 229 stub NtSystemDebugControl
238 230 stub NtTerminateProcess
239 231 stdcall NtTerminateThread(long long) NtTerminateThread
241 233 stub NtUnloadDriver
243 235 stub NtUnlockFile
244 236 stub NtUnlockVirtualMemory
245 237 stub NtUnmapViewOfSection
246 238 stub NtVdmControl
248 240 stub NtWaitForMultipleObjects
249 241 stub NtWaitForProcessMutant
250 242 stdcall NtWaitForSingleObject(long long long) NtWaitForSingleObject
251 243 stub NtWaitHighEventPair
252 244 stub NtWaitLowEventPair
254 246 stub NtWriteRequestData
255 247 stub NtWriteVirtualMemory
256 248 stub PfxFindPrefix
257 249 stub PfxInitialize
258 250 stub PfxInsertPrefix
259 251 stub PfxRemovePrefix
260 252 stub RestoreEm87Context
261 253 stub RtlAbortRXact
262 254 stub RtlAbsoluteToSelfRelativeSD
263 255 stdcall RtlAcquirePebLock() RtlAcquirePebLock
264 256 stub RtlAcquireResourceExclusive
265 257 stub RtlAcquireResourceShared
266 258 stdcall RtlAddAccessAllowedAce(long long long long) RtlAddAccessAllowedAce
267 259 stub RtlAddAccessDeniedAce
268 260 stdcall RtlAddAce(ptr long long ptr long) RtlAddAce
269 261 stub RtlAddActionToRXact
270 262 stub RtlAddAttributeActionToRXact
271 263 stub RtlAddAuditAccessAce
272 264 stdcall RtlAdjustPrivilege(long long long long) RtlAdjustPrivilege
273 265 stdcall RtlAllocateAndInitializeSid (ptr long long long long long long long long long ptr) RtlAllocateAndInitializeSid
274 266 stdcall RtlAllocateHeap(long long long) HeapAlloc
275 267 stub RtlAnsiCharToUnicodeChar
276 268 stub RtlAnsiStringToUnicodeSize
277 269 stdcall RtlAnsiStringToUnicodeString(ptr ptr long) RtlAnsiStringToUnicodeString
278 270 stub RtlAppendAsciizToString
279 271 stub RtlAppendStringToString
280 272 stub RtlAppendUnicodeStringToString
281 273 stub RtlAppendUnicodeToString
282 274 stub RtlApplyRXact
283 275 stub RtlApplyRXactNoFlush
284 276 stub RtlAreAllAccessesGranted
285 277 stub RtlAreAnyAccessesGranted
286 278 stub RtlAreBitsClear
287 279 stub RtlAreBitsSet
289 281 stub RtlCaptureStackBackTrace
290 282 stub RtlCharToInteger
291 283 stub RtlCheckRegistryKey
292 284 stub RtlClearAllBits
293 285 stub RtlClearBits
294 286 stub RtlCompactHeap
295 287 stub RtlCompareMemory
296 288 stub RtlCompareMemoryUlong
297 289 stub RtlCompareString
298 290 stub RtlCompareUnicodeString
299 291 stub RtlCompressBuffer
300 292 stub RtlConsoleMultiByteToUnicodeN
301 293 stub RtlConvertExclusiveToShared
302 294 stub RtlConvertLongToLargeInteger
303 295 stub RtlConvertSharedToExclusive
304 296 stub RtlConvertSidToUnicodeString
305 297 stub RtlConvertUiListToApiList
306 298 stub RtlConvertUlongToLargeInteger
308 300 stub RtlCopyLuidAndAttributesArray
309 301 stub RtlCopySecurityDescriptor
310 302 stdcall RtlCopySid(long ptr ptr) RtlCopySid
311 303 stub RtlCopySidAndAttributesArray
312 304 stub RtlCopyString
313 305 stub RtlCopyUnicodeString
314 306 stdcall RtlCreateAcl(ptr long long) RtlCreateAcl
315 307 stub RtlCreateAndSetSD
316 308 stdcall RtlCreateEnvironment(long long) RtlCreateEnvironment
317 309 stdcall RtlCreateHeap(long long long) HeapCreate
318 310 stub RtlCreateProcessParameters
319 311 stub RtlCreateQueryDebugBuffer
320 312 stub RtlCreateRegistryKey
321 313 stdcall RtlCreateSecurityDescriptor(ptr long) RtlCreateSecurityDescriptor
322 314 stub RtlCreateTagHeap
323 315 stub RtlCreateUnicodeString
324 316 stub RtlCreateUnicodeStringFromAsciiz
325 317 stub RtlCreateUserProcess
326 318 stub RtlCreateUserSecurityObject
327 319 stub RtlCreateUserThread
328 320 stub RtlCustomCPToUnicodeN
329 321 stub RtlCutoverTimeToSystemTime
330 322 stub RtlDeNormalizeProcessParams
331 323 stub RtlDecompressBuffer
332 324 stub RtlDecompressFragment
334 326 stub RtlDeleteAce
335 327 stdcall RtlDeleteCriticalSection(ptr) DeleteCriticalSection
336 328 stub RtlDeleteElementGenericTable
337 329 stub RtlDeleteRegistryValue
338 330 stub RtlDeleteResource
339 331 stdcall RtlDeleteSecurityObject(long) RtlDeleteSecurityObject
340 332 stdcall RtlDestroyEnvironment(long) RtlDestroyEnvironment
341 333 stdcall RtlDestroyHeap(long) HeapDestroy
342 334 stub RtlDestroyProcessParameters
343 335 stub RtlDestroyQueryDebugBuffer
344 336 stub RtlDetermineDosPathNameType_U
345 337 stub RtlDoesFileExists_U
346 338 stdcall RtlDosPathNameToNtPathName_U(ptr ptr long long) RtlDosPathNameToNtPathName_U
347 339 stub RtlDosSearchPath_U
348 340 stub RtlDumpResource
349 341 stub RtlEnlargedIntegerMultiply
350 342 stub RtlEnlargedUnsignedDivide
351 343 stub RtlEnlargedUnsignedMultiply
352 344 stdcall RtlEnterCriticalSection(ptr) EnterCriticalSection
353 345 stub RtlEnumProcessHeaps
354 346 stub RtlEnumerateGenericTable
355 347 stub RtlEnumerateGenericTableWithoutSplaying
356 348 stub RtlEqualComputerName
357 349 stub RtlEqualDomainName
358 350 stub RtlEqualLuid
359 351 stub RtlEqualPrefixSid
360 352 stdcall RtlEqualSid (long long) RtlEqualSid
361 353 stub RtlEqualString
362 354 stdcall RtlEqualUnicodeString(long long long) RtlEqualUnicodeString
363 355 stub RtlEraseUnicodeString
364 356 stub RtlExpandEnvironmentStrings_U
365 357 stub RtlExtendHeap
366 358 stdcall RtlExtendedIntegerMultiply(long long long) RtlExtendedIntegerMultiply
367 359 stdcall RtlExtendedLargeIntegerDivide(long long long ptr) RtlExtendedLargeIntegerDivide
368 360 stub RtlExtendedMagicDivide
369 361 stdcall RtlFillMemory(ptr long long) RtlFillMemory
370 362 stub RtlFillMemoryUlong
371 363 stub RtlFindClearBits
372 364 stub RtlFindClearBitsAndSet
373 365 stub RtlFindLongestRunClear
374 366 stub RtlFindLongestRunSet
375 367 stub RtlFindMessage
376 368 stub RtlFindSetBits
377 369 stub RtlFindSetBitsAndClear
378 370 stdcall RtlFirstFreeAce(ptr ptr) RtlFirstFreeAce
379 371 stdcall RtlFormatCurrentUserKeyPath() RtlFormatCurrentUserKeyPath
380 372 stub RtlFormatMessage
381 373 stdcall RtlFreeAnsiString(long) RtlFreeAnsiString
382 374 stdcall RtlFreeHeap(long long long) HeapFree
383 375 stub RtlFreeOemString
384 376 stdcall RtlFreeSid (long) RtlFreeSid
385 377 stdcall RtlFreeUnicodeString(ptr) RtlFreeUnicodeString
386 378 stub RtlGenerate8dot3Name
387 379 stdcall RtlGetAce(ptr long ptr) RtlGetAce
388 380 stub RtlGetCallersAddress
389 381 stub RtlGetCompressionWorkSpaceSize
390 382 stub RtlGetControlSecurityDescriptor
391 383 stub RtlGetCurrentDirectory_U
392 384 stdcall RtlGetDaclSecurityDescriptor(long long long long) RtlGetDaclSecurityDescriptor
393 385 stub RtlGetElementGenericTable
394 386 stub RtlGetFullPathName_U
395 387 stub RtlGetGroupSecurityDescriptor
396 388 stub RtlGetLongestNtPathLength
397 389 stub RtlGetNtGlobalFlags
398 390 stdcall RtlGetNtProductType(ptr) RtlGetNtProductType
399 391 stub RtlGetOwnerSecurityDescriptor
400 392 stub RtlGetProcessHeaps
401 393 stub RtlGetSaclSecurityDescriptor
402 394 stub RtlGetUserInfoHeap
403 395 stub RtlIdentifierAuthoritySid
404 396 stub RtlImageDirectoryEntryToData
405 397 stdcall RtlImageNtHeader(long) RtlImageNtHeader
406 398 stub RtlImpersonateSelf
407 399 stdcall RtlInitAnsiString(ptr str) RtlInitAnsiString
408 400 stub RtlInitCodePageTable
409 401 stub RtlInitNlsTables
410 402 stdcall RtlInitString(ptr str) RtlInitString
411 403 stdcall RtlInitUnicodeString(ptr wstr) RtlInitUnicodeString
412 404 stub RtlInitializeBitMap
413 405 stub RtlInitializeContext
414 406 stdcall RtlInitializeCriticalSection(ptr) InitializeCriticalSection
415 407 stub RtlInitializeGenericTable
416 408 stub RtlInitializeRXact
417 409 stub RtlInitializeResource
418 410 stdcall RtlInitializeSid(ptr ptr long) RtlInitializeSid
419 411 stub RtlInsertElementGenericTable
420 412 stdcall RtlIntegerToChar(long long long long) RtlIntegerToChar
421 413 stub RtlIntegerToUnicodeString
422 414 stub RtlIsDosDeviceName_U
423 415 stub RtlIsGenericTableEmpty
424 416 stub RtlIsNameLegalDOS8Dot3
425 417 stdcall RtlIsTextUnicode(ptr long ptr) RtlIsTextUnicode
426 418 stub RtlLargeIntegerAdd
427 419 stub RtlLargeIntegerArithmeticShift
428 420 stub RtlLargeIntegerDivide
429 421 stub RtlLargeIntegerNegate
430 422 stub RtlLargeIntegerShiftLeft
431 423 stub RtlLargeIntegerShiftRight
432 424 stub RtlLargeIntegerSubtract
433 425 stub RtlLargeIntegerToChar
434 426 stdcall RtlLeaveCriticalSection(ptr) LeaveCriticalSection
435 427 stdcall RtlLengthRequiredSid(long) RtlLengthRequiredSid
436 428 stub RtlLengthSecurityDescriptor
437 429 stdcall RtlLengthSid(ptr) RtlLengthSid
438 430 stub RtlLocalTimeToSystemTime
440 432 stub RtlLookupElementGenericTable
441 433 stub RtlMakeSelfRelativeSD
442 434 stub RtlMapGenericMask
443 435 stdcall RtlMoveMemory(ptr ptr long) RtlMoveMemory
444 436 stdcall RtlMultiByteToUnicodeN(ptr long ptr ptr long) RtlMultiByteToUnicodeN
445 437 stub RtlMultiByteToUnicodeSize
446 438 stub RtlNewInstanceSecurityObject
447 439 stub RtlNewSecurityGrantedAccess
448 440 stdcall RtlNewSecurityObject(long long long long long long) RtlNewSecurityObject
449 441 stdcall RtlNormalizeProcessParams(ptr) RtlNormalizeProcessParams
450 442 stdcall RtlNtStatusToDosError(long) RtlNtStatusToDosError
451 443 stub RtlNumberGenericTableElements
452 444 stub RtlNumberOfClearBits
453 445 stub RtlNumberOfSetBits
454 446 stub RtlOemStringToUnicodeSize
455 447 stdcall RtlOemStringToUnicodeString(ptr ptr long) RtlOemStringToUnicodeString
456 448 stdcall RtlOemToUnicodeN(ptr long ptr ptr long) RtlOemToUnicodeN
457 449 stdcall RtlOpenCurrentUser(long ptr) RtlOpenCurrentUser
458 450 stub RtlPcToFileHeader
459 451 stub RtlPrefixString
460 452 stub RtlPrefixUnicodeString
461 453 stub RtlProtectHeap
462 454 stdcall RtlQueryEnvironmentVariable_U(long long long) RtlQueryEnvironmentVariable_U
463 455 stub RtlQueryInformationAcl
464 456 stub RtlQueryProcessBackTraceInformation
465 457 stub RtlQueryProcessDebugInformation
466 458 stub RtlQueryProcessHeapInformation
467 459 stub RtlQueryProcessLockInformation
468 460 stub RtlQueryRegistryValues
469 461 stub RtlQuerySecurityObject
470 462 stub RtlQueryTagHeap
471 463 stub RtlQueryTimeZoneInformation
472 464 stub RtlRaiseException
473 465 stub RtlRaiseStatus
475 467 stub RtlReAllocateHeap
476 468 stub RtlRealPredecessor
477 469 stub RtlRealSuccessor
478 470 stdcall RtlReleasePebLock() RtlReleasePebLock
479 471 stub RtlReleaseResource
480 472 stub RtlRemoteCall
481 473 stub RtlResetRtlTranslations
482 474 stub RtlRunDecodeUnicodeString
483 475 stub RtlRunEncodeUnicodeString
484 476 stub RtlSecondsSince1970ToTime
485 477 stub RtlSecondsSince1980ToTime
486 478 stub RtlSelfRelativeToAbsoluteSD
487 479 stub RtlSetAllBits
489 481 stub RtlSetCurrentDirectory_U
490 482 stub RtlSetCurrentEnvironment
491 483 stdcall RtlSetDaclSecurityDescriptor(ptr long ptr long) RtlSetDaclSecurityDescriptor
492 484 stdcall RtlSetEnvironmentVariable(long long long) RtlSetEnvironmentVariable
493 485 stdcall RtlSetGroupSecurityDescriptor(ptr ptr long) RtlSetGroupSecurityDescriptor
494 486 stub RtlSetInformationAcl
495 487 stdcall RtlSetOwnerSecurityDescriptor(ptr ptr long) RtlSetOwnerSecurityDescriptor
496 488 stdcall RtlSetSaclSecurityDescriptor(ptr long ptr long) RtlSetSaclSecurityDescriptor
497 489 stub RtlSetSecurityObject
498 490 stub RtlSetTimeZoneInformation
499 491 stub RtlSetUserFlagsHeap
500 492 stub RtlSetUserValueHeap
501 493 stdcall RtlSizeHeap(long long long) HeapSize
503 495 stub RtlStartRXact
504 496 stdcall RtlSubAuthorityCountSid(ptr) RtlSubAuthorityCountSid
505 497 stdcall RtlSubAuthoritySid(ptr long) RtlSubAuthoritySid
506 498 stub RtlSubtreePredecessor
507 499 stub RtlSubtreeSuccessor
508 500 stdcall RtlSystemTimeToLocalTime (long long) RtlSystemTimeToLocalTime
509 501 stub RtlTimeFieldsToTime
510 502 stdcall RtlTimeToElapsedTimeFields(long long) RtlTimeToElapsedTimeFields
511 503 stdcall RtlTimeToSecondsSince1970(ptr ptr) RtlTimeToSecondsSince1970
512 504 stdcall RtlTimeToSecondsSince1980(ptr ptr) RtlTimeToSecondsSince1980
513 505 stdcall RtlTimeToTimeFields (long long) RtlTimeToTimeFields
514 506 stub RtlUnicodeStringToAnsiSize
515 507 stdcall RtlUnicodeStringToAnsiString(ptr ptr long) RtlUnicodeStringToAnsiString
516 508 stub RtlUnicodeStringToCountedOemString
517 509 stub RtlUnicodeStringToInteger
518 510 stub RtlUnicodeStringToOemSize
519 511 stdcall RtlUnicodeStringToOemString(ptr ptr long) RtlUnicodeStringToOemString
520 512 stub RtlUnicodeToCustomCPN
521 513 stub RtlUnicodeToMultiByteN
522 514 stub RtlUnicodeToMultiByteSize
523 515 stdcall RtlUnicodeToOemN(ptr long ptr ptr long) RtlUnicodeToOemN
525 517 stub RtlUnlockHeap
527 519 stub RtlUpcaseUnicodeChar
528 520 stdcall RtlUpcaseUnicodeString(ptr ptr long) RtlUpcaseUnicodeString
529 521 stub RtlUpcaseUnicodeStringToAnsiString
530 522 stub RtlUpcaseUnicodeStringToCountedOemString
531 523 stub RtlUpcaseUnicodeStringToOemString
532 524 stub RtlUpcaseUnicodeToCustomCPN
533 525 stub RtlUpcaseUnicodeToMultiByteN
534 526 stub RtlUpcaseUnicodeToOemN
535 527 stub RtlUpperChar
536 528 stub RtlUpperString
537 529 stub RtlUsageHeap
539 531 stub RtlValidSecurityDescriptor
541 533 stub RtlValidateHeap
542 534 stub RtlValidateProcessHeaps
544 536 stub RtlWriteRegistryValue
546 538 stdcall RtlZeroMemory(ptr long) RtlZeroMemory
547 539 stub RtlpInitializeRtl
548 540 stub RtlpNtCreateKey
549 541 stub RtlpNtEnumerateSubKey
550 542 stub RtlpNtMakeTemporaryKey
551 543 stub RtlpNtOpenKey
552 544 stub RtlpNtQueryValueKey
553 545 stub RtlpNtSetValueKey
554 546 stub RtlpUnWaitCriticalSection
555 547 stub RtlpWaitForCriticalSection
556 548 stdcall RtlxAnsiStringToUnicodeSize(ptr) RtlxAnsiStringToUnicodeSize
557 549 stdcall RtlxOemStringToUnicodeSize(ptr) RtlxOemStringToUnicodeSize
558 550 stub RtlxUnicodeStringToAnsiSize
559 551 stub RtlxUnicodeStringToOemSize
560 552 stub SaveEm87Context
561 553 stdcall ZwAcceptConnectPort(long long long long long long) NtAcceptConnectPort
562 554 stub ZwAccessCheck
563 555 stub ZwAccessCheckAndAuditAlarm
564 556 stdcall ZwAdjustGroupsToken(long long long long long long) NtAdjustPrivilegesToken
565 557 stub ZwAdjustPrivilegesToken
566 558 stub ZwAlertResumeThread
567 559 stub ZwAlertThread
568 560 stub ZwAllocateLocallyUniqueId
569 561 stub ZwAllocateUuids
570 562 stub ZwAllocateVirtualMemory
571 563 stub ZwCallbackReturn
572 564 stub ZwCancelIoFile
573 565 stub ZwCancelTimer
574 566 stub ZwClearEvent
576 568 stub ZwCloseObjectAuditAlarm
577 569 stdcall ZwCompleteConnectPort(long) NtCompleteConnectPort
578 570 stdcall ZwConnectPort(long long long long long long long long) NtConnectPort
580 572 stdcall ZwCreateDirectoryObject(long long long) NtCreateDirectoryObject
581 573 stdcall ZwCreateEvent(long long long long long) NtCreateEvent
582 574 stub ZwCreateEventPair
583 575 stdcall ZwCreateFile(ptr long ptr ptr long long long ptr long long ptr) NtCreateFile
584 576 stub ZwCreateIoCompletion
585 577 stdcall ZwCreateKey(long long long long long long long) NtCreateKey
586 578 stdcall ZwCreateMailslotFile(long long long long long long long long) NtCreateMailslotFile
587 579 stub ZwCreateMutant
588 580 stub ZwCreateNamedPipeFile
589 581 stdcall ZwCreatePagingFile(long long long long) NtCreatePagingFile
590 582 stdcall ZwCreatePort(long long long long long) NtCreatePort
591 583 stub ZwCreateProcess
592 584 stub ZwCreateProfile
593 585 stdcall ZwCreateSection(long long long long long long long) NtCreateSection
594 586 stub ZwCreateSemaphore
595 587 stub ZwCreateSymbolicLinkObject
596 588 stub ZwCreateThread
597 589 stdcall ZwCreateTimer(long long long) NtCreateTimer
598 590 stub ZwCreateToken
599 591 stub ZwDelayExecution
600 592 stub ZwDeleteFile
602 594 stub ZwDeleteValueKey
603 595 stdcall ZwDeviceIoControlFile(long long long long long long long long long long) NtDeviceIoControlFile
604 596 stub ZwDisplayString
605 597 stdcall ZwDuplicateObject(long long long long long long long) NtDuplicateObject
606 598 stdcall ZwDuplicateToken(long long long long long long) NtDuplicateToken
607 599 stub ZwEnumerateBus
608 600 stub ZwEnumerateKey
609 601 stub ZwEnumerateValueKey
610 602 stub ZwExtendSection
611 603 stub ZwFlushBuffersFile
612 604 stub ZwFlushInstructionCache
614 606 stub ZwFlushVirtualMemory
615 607 stub ZwFlushWriteBuffer
616 608 stub ZwFreeVirtualMemory
617 609 stdcall ZwFsControlFile(long long long long long long long long long long) NtFsControlFile
618 610 stub ZwGetContextThread
619 611 stub ZwGetPlugPlayEvent
620 612 stub ZwGetTickCount
621 613 stub ZwImpersonateClientOfPort
622 614 stub ZwImpersonateThread
623 615 stub ZwInitializeRegistry
624 616 stdcall ZwListenPort(long long) NtListenPort
625 617 stub ZwLoadDriver
628 620 stub ZwLockVirtualMemory
629 621 stub ZwMakeTemporaryObject
630 622 stdcall ZwMapViewOfSection(long long long long long long long long long long) NtMapViewOfSection
631 623 stub ZwNotifyChangeDirectoryFile
632 624 stub ZwNotifyChangeKey
633 625 stdcall ZwOpenDirectoryObject(long long long) NtOpenDirectoryObject
634 626 stdcall ZwOpenEvent(long long long) NtOpenEvent
635 627 stub ZwOpenEventPair
636 628 stdcall ZwOpenFile(ptr long ptr ptr long long) NtOpenFile
637 629 stub ZwOpenIoCompletion
638 630 stdcall ZwOpenKey(ptr long ptr) NtOpenKey
639 631 stub ZwOpenMutant
640 632 stub ZwOpenObjectAuditAlarm
641 633 stub ZwOpenProcess
642 634 stdcall ZwOpenProcessToken(long long long) NtOpenProcessToken
643 635 stdcall ZwOpenSection(long long long) NtOpenSection
644 636 stub ZwOpenSemaphore
645 637 stub ZwOpenSymbolicLinkObject
646 638 stub ZwOpenThread
647 639 stdcall ZwOpenThreadToken(long long long long) NtOpenThreadToken
649 641 stub ZwPlugPlayControl
650 642 stub ZwPrivilegeCheck
651 643 stub ZwPrivilegeObjectAuditAlarm
652 644 stub ZwPrivilegedServiceAuditAlarm
653 645 stub ZwProtectVirtualMemory
654 646 stub ZwPulseEvent
655 647 stub ZwQueryAttributesFile
656 648 stub ZwQueryDefaultLocale
657 649 stub ZwQueryDirectoryFile
658 650 stdcall ZwQueryDirectoryObject(long long long long long long long) NtQueryDirectoryObject
659 651 stub ZwQueryEaFile
660 652 stub ZwQueryEvent
661 653 stdcall ZwQueryInformationFile(long long long long long) NtQueryInformationFile
662 654 stub ZwQueryInformationPort
663 655 stdcall ZwQueryInformationProcess(long long long long long) NtQueryInformationProcess
664 656 stdcall ZwQueryInformationThread(long long long long long) NtQueryInformationThread
665 657 stdcall ZwQueryInformationToken(long long long long long) NtQueryInformationToken
666 658 stub ZwQueryIntervalProfile
667 659 stub ZwQueryIoCompletion
669 661 stub ZwQueryMutant
670 662 stdcall ZwQueryObject(long long long long long) NtQueryObject
671 663 stub ZwQueryPerformanceCounter
672 664 stub ZwQuerySection
673 665 stub ZwQuerySecurityObject
674 666 stub ZwQuerySemaphore
675 667 stub ZwQuerySymbolicLinkObject
676 668 stub ZwQuerySystemEnvironmentValue
677 669 stdcall ZwQuerySystemInformation(long long long long) NtQuerySystemInformation
678 670 stdcall ZwQuerySystemTime(ptr) GetSystemTimeAsFileTime
679 671 stub ZwQueryTimer
680 672 stub ZwQueryTimerResolution
681 673 stub ZwQueryValueKey
682 674 stub ZwQueryVirtualMemory
683 675 stub ZwQueryVolumeInformationFile
684 676 stub ZwRaiseException
685 677 stub ZwRaiseHardError
686 678 stdcall ZwReadFile(long long long long long long long long long) NtReadFile
687 679 stub ZwReadRequestData
688 680 stub ZwReadVirtualMemory
689 681 stub ZwRegisterNewDevice
690 682 stdcall ZwRegisterThreadTerminatePort(long) NtRegisterThreadTerminatePort
691 683 stub ZwReleaseMutant
692 684 stub ZwReleaseProcessMutant
693 685 stub ZwReleaseSemaphore
694 686 stub ZwRemoveIoCompletion
695 687 stub ZwReplaceKey
697 689 stdcall ZwReplyWaitReceivePort(long long long long) NtReplyWaitReceivePort
698 690 stub ZwReplyWaitReplyPort
699 691 stub ZwRequestPort
700 692 stdcall ZwRequestWaitReplyPort(long long long) NtRequestWaitReplyPort
701 693 stub ZwResetEvent
702 694 stub ZwRestoreKey
703 695 stdcall ZwResumeThread(long long) NtResumeThread
705 697 stub ZwSetContextThread
706 698 stub ZwSetDefaultHardErrorPort
707 699 stub ZwSetDefaultLocale
709 701 stdcall ZwSetEvent(long long) NtSetEvent
710 702 stub ZwSetHighEventPair
711 703 stub ZwSetHighWaitLowEventPair
712 704 stub ZwSetHighWaitLowThread
713 705 stdcall ZwSetInformationFile(long long long long long) NtSetInformationFile
714 706 stub ZwSetInformationKey
715 707 stub ZwSetInformationObject
716 708 stdcall ZwSetInformationProcess(long long long long) NtSetInformationProcess
717 709 stdcall ZwSetInformationThread(long long long long) NtSetInformationThread
718 710 stub ZwSetInformationToken
719 711 stdcall ZwSetIntervalProfile(long long) NtSetIntervalProfile
720 712 stub ZwSetIoCompletion
721 713 stub ZwSetLdtEntries
722 714 stub ZwSetLowEventPair
723 715 stub ZwSetLowWaitHighEventPair
724 716 stub ZwSetLowWaitHighThread
725 717 stub ZwSetSecurityObject
726 718 stub ZwSetSystemEnvironmentValue
727 719 stub ZwSetSystemInformation
728 720 stub ZwSetSystemPowerState
729 721 stub ZwSetSystemTime
730 722 stdcall ZwSetTimer(long long long long long long) NtSetTimer
731 723 stub ZwSetTimerResolution
732 724 stdcall ZwSetValueKey(long long long long long long) NtSetValueKey
733 725 stdcall ZwSetVolumeInformationFile(long long long long long) NtSetVolumeInformationFile
734 726 stub ZwShutdownSystem
735 727 stub ZwStartProfile
736 728 stub ZwStopProfile
737 729 stub ZwSuspendThread
738 730 stub ZwSystemDebugControl
739 731 stub ZwTerminateProcess
740 732 stdcall ZwTerminateThread(long long) NtTerminateThread
742 734 stub ZwUnloadDriver
744 736 stub ZwUnlockFile
745 737 stub ZwUnlockVirtualMemory
746 738 stub ZwUnmapViewOfSection
747 739 stub ZwVdmControl
749 741 stub ZwWaitForMultipleObjects
750 742 stub ZwWaitForProcessMutant
751 743 stdcall ZwWaitForSingleObject(long long long) NtWaitForSingleObject
752 744 stub ZwWaitHighEventPair
753 745 stub ZwWaitLowEventPair
755 747 stub ZwWriteRequestData
756 748 stub ZwWriteVirtualMemory
758 750 stub __eCommonExceptions
759 751 stub __eEmulatorInit
782 774 stub __eFDIVRPreg
854 846 stub __eFSUBRPreg
868 860 stub __eGetStatusWord
869 861 stub _alloca_probe
870 862 register _chkstk() NTDLL_chkstk
872 864 cdecl _ftol(double) CRTDLL__ftol
876 868 cdecl _memicmp(str str long) CRTDLL__memicmp
880 872 cdecl _strcmpi(str str) CRTDLL__strcmpi
881 873 cdecl _stricmp(str str) CRTDLL__strcmpi
883 875 cdecl _strnicmp(str str long) CRTDLL__strnicmp
884 876 cdecl _strupr(str) CRTDLL__strupr
887 879 cdecl _wcsicmp(wstr wstr) CRTDLL__wcsicmp
888 880 cdecl _wcslwr(wstr) CRTDLL__wcslwr
889 881 cdecl _wcsnicmp(wstr wstr long) CRTDLL__wcsnicmp
890 882 cdecl _wcsupr(wstr) CRTDLL__wcsupr
893 885 cdecl atoi(str) atoi
894 886 cdecl atol(str) atol
899 891 cdecl isalpha(long) isalpha
900 892 cdecl isdigit(long) isdigit
901 893 cdecl islower(long) islower
902 894 cdecl isprint(long) isprint
903 895 cdecl isspace(long) isspace
904 896 cdecl isupper(long) isupper
907 899 cdecl isxdigit(long) isxdigit
911 903 cdecl memchr(ptr long long) memchr
912 904 cdecl memcmp(ptr ptr long) memcmp
913 905 cdecl memcpy(ptr ptr long) memcpy
914 906 cdecl memmove(ptr ptr long) memmove
915 907 cdecl memset(ptr long long) memset
919 911 varargs sprintf() wsprintf32A
921 913 varargs sscanf() sscanf
922 914 cdecl strcat(str str) strcat
923 915 cdecl strchr(str long) strchr
924 916 cdecl strcmp(str str) strcmp
925 917 cdecl strcpy(ptr str) strcpy
926 918 cdecl strcspn(str str) strcspn
927 919 cdecl strlen(str) strlen
928 920 cdecl strncat(str str long) strncat
929 921 cdecl strncmp(str str long) strncmp
930 922 cdecl strncpy(ptr str long) strncpy
931 923 cdecl strpbrk(str str long) strpbrk
932 924 cdecl strrchr(str long) strrchr
933 925 cdecl strspn(str str) strspn
934 926 cdecl strstr(str str) strstr
935 927 varargs swprintf() wsprintf32W
937 929 cdecl tolower(long) tolower
938 930 cdecl toupper(long) toupper
941 933 cdecl vsprintf(ptr str ptr) CRTDLL_vsprintf
942 934 cdecl wcscat(wstr wstr) CRTDLL_wcscat
943 935 cdecl wcschr(wstr long) CRTDLL_wcschr
944 936 cdecl wcscmp(wstr wstr) CRTDLL_wcscmp
945 937 cdecl wcscpy(ptr wstr) CRTDLL_wcscpy
947 939 cdecl wcslen(wstr) CRTDLL_wcslen
949 941 cdecl wcsncmp(wstr wstr long) CRTDLL_wcsncmp
950 942 cdecl wcsncpy(ptr wstr long) CRTDLL_wcsncpy
952 944 cdecl wcsrchr(wstr long) CRTDLL_wcsrchr
953 945 cdecl wcsspn(wstr wstr) CRTDLL_wcsspn
954 946 cdecl wcsstr(wstr wstr) CRTDLL_wcsstr
955 947 cdecl wcstok(wstr wstr) CRTDLL_wcstok
956 948 cdecl wcstol(wstr ptr long) CRTDLL_wcstol
957 949 cdecl wcstombs(ptr ptr long) CRTDLL_wcstombs
962 952 stub NtDeleteAtom
964 954 stub NtQueryFullAttributesFile
965 955 stub NtQueueApcThread
966 956 stub NtReadFileScatter
967 957 stub NtSignalAndWaitForSingleObject
968 958 stub NtWriteFileGather
969 959 stub NtYieldExecution
970 960 stub RtlAddAtomToAtomTable
971 961 stub RtlAllocateHandle
972 962 stub RtlCreateAtomTable
973 963 stub RtlDeleteAtomFromAtomTable
974 964 stub RtlFreeHandle
975 965 stub RtlInitializeHandleTable
976 966 stub RtlIsValidHandle
977 967 stub RtlLookupAtomInAtomTable
978 968 stub RtlQueryAtomInAtomTable
979 969 stdcall RtlTryEnterCriticalSection(ptr) TryEnterCriticalSection
980 970 stub RtlEnumerateProperties
981 971 stub RtlSetPropertyClassId
982 972 stub RtlSetPropertyNames
983 973 stub RtlQueryPropertyNames
984 974 stub RtlFlushPropertySet
985 975 stub RtlSetProperties
986 976 stub RtlQueryProperties
987 977 stub RtlQueryPropertySet
988 978 stub RtlSetUnicodeCallouts
989 979 stub RtlPropertySetNameToGuid
990 980 stub RtlGuidToPropertySetName
991 981 stub RtlClosePropertySet
992 982 stub RtlCreatePropertySet
995 985 stub RtlSetPropertySetClassId