pdh: Implement and test PdhLookupPerfIndexByName{A, W} and PdhLookupPerfNameByIndex...
[wine] / dlls / pdh / pdh.spec
1 1 stub PdhPlaGetLogFileNameA
2 @ stub PdhAdd009CounterA
3 @ stub PdhAdd009CounterW
4 @ stdcall PdhAddCounterA(ptr str long ptr)
5 @ stdcall PdhAddCounterW(ptr wstr long ptr)
6 @ stub PdhBindInputDataSourceA
7 @ stub PdhBindInputDataSourceW
8 @ stub PdhBrowseCountersA
9 @ stub PdhBrowseCountersHA
10 @ stub PdhBrowseCountersHW
11 @ stub PdhBrowseCountersW
12 @ stub PdhCalculateCounterFromRawValue
13 @ stub PdhCloseLog
14 @ stdcall PdhCloseQuery(ptr)
15 @ stdcall PdhCollectQueryData(ptr)
16 @ stub PdhCollectQueryDataEx
17 @ stub PdhComputeCounterStatistics
18 @ stub PdhConnectMachineA
19 @ stub PdhConnectMachineW
20 @ stub PdhCreateSQLTablesA
21 @ stub PdhCreateSQLTablesW
22 @ stub PdhEnumLogSetNamesA
23 @ stub PdhEnumLogSetNamesW
24 @ stub PdhEnumMachinesA
25 @ stub PdhEnumMachinesHA
26 @ stub PdhEnumMachinesHW
27 @ stub PdhEnumMachinesW
28 @ stub PdhEnumObjectItemsA
29 @ stub PdhEnumObjectItemsHA
30 @ stub PdhEnumObjectItemsHW
31 @ stub PdhEnumObjectItemsW
32 @ stub PdhEnumObjectsA
33 @ stub PdhEnumObjectsHA
34 @ stub PdhEnumObjectsHW
35 @ stub PdhEnumObjectsW
36 @ stub PdhExpandCounterPathA
37 @ stub PdhExpandCounterPathW
38 @ stub PdhExpandWildCardPathA
39 @ stub PdhExpandWildCardPathHA
40 @ stub PdhExpandWildCardPathHW
41 @ stub PdhExpandWildCardPathW
42 @ stub PdhFormatFromRawValue
43 @ stdcall PdhGetCounterInfoA(ptr long ptr ptr)
44 @ stdcall PdhGetCounterInfoW(ptr long ptr ptr)
45 @ stdcall PdhGetCounterTimeBase(ptr ptr)
46 @ stub PdhGetDataSourceTimeRangeA
47 @ stub PdhGetDataSourceTimeRangeH
48 @ stub PdhGetDataSourceTimeRangeW
49 @ stub PdhGetDefaultPerfCounterA
50 @ stub PdhGetDefaultPerfCounterHA
51 @ stub PdhGetDefaultPerfCounterHW
52 @ stub PdhGetDefaultPerfCounterW
53 @ stub PdhGetDefaultPerfObjectA
54 @ stub PdhGetDefaultPerfObjectHA
55 @ stub PdhGetDefaultPerfObjectHW
56 @ stub PdhGetDefaultPerfObjectW
57 @ stub PdhGetDllVersion
58 @ stub PdhGetFormattedCounterArrayA
59 @ stub PdhGetFormattedCounterArrayW
60 @ stdcall PdhGetFormattedCounterValue(ptr long ptr ptr)
61 @ stub PdhGetLogFileSize
62 @ stub PdhGetLogFileTypeA
63 @ stub PdhGetLogFileTypeW
64 @ stub PdhGetLogSetGUID
65 @ stub PdhGetRawCounterArrayA
66 @ stub PdhGetRawCounterArrayW
67 @ stdcall PdhGetRawCounterValue(ptr ptr ptr)
68 @ stub PdhIsRealTimeQuery
69 @ stub PdhListLogFileHeaderA
70 @ stub PdhListLogFileHeaderW
71 @ stub PdhLogServiceCommandA
72 @ stub PdhLogServiceCommandW
73 @ stub PdhLogServiceControlA
74 @ stub PdhLogServiceControlW
75 @ stdcall PdhLookupPerfIndexByNameA(str str ptr)
76 @ stdcall PdhLookupPerfIndexByNameW(wstr wstr ptr)
77 @ stdcall PdhLookupPerfNameByIndexA(str long ptr ptr)
78 @ stdcall PdhLookupPerfNameByIndexW(wstr long ptr ptr)
79 @ stub PdhMakeCounterPathA
80 @ stub PdhMakeCounterPathW
81 @ stub PdhOpenLogA
82 @ stub PdhOpenLogW
83 @ stdcall PdhOpenQuery(wstr long ptr) PdhOpenQueryW
84 @ stdcall PdhOpenQueryA(str long ptr)
85 @ stub PdhOpenQueryH
86 @ stdcall PdhOpenQueryW(wstr long ptr)
87 @ stub PdhParseCounterPathA
88 @ stub PdhParseCounterPathW
89 @ stub PdhParseInstanceNameA
90 @ stub PdhParseInstanceNameW
91 @ stub PdhPlaAddItemA
92 @ stub PdhPlaAddItemW
93 @ stub PdhPlaCreateA
94 @ stub PdhPlaCreateW
95 @ stub PdhPlaDeleteA
96 @ stub PdhPlaDeleteW
97 @ stub PdhPlaEnumCollectionsA
98 @ stub PdhPlaEnumCollectionsW
99 @ stub PdhPlaGetInfoA
100 @ stub PdhPlaGetInfoW
101 @ stub PdhPlaGetLogFileNameW
102 @ stub PdhPlaGetScheduleA
103 @ stub PdhPlaGetScheduleW
104 @ stub PdhPlaRemoveAllItemsA
105 @ stub PdhPlaRemoveAllItemsW
106 @ stub PdhPlaScheduleA
107 @ stub PdhPlaScheduleW
108 @ stub PdhPlaSetInfoA
109 @ stub PdhPlaSetInfoW
110 @ stub PdhPlaSetItemListA
111 @ stub PdhPlaSetItemListW
112 @ stub PdhPlaSetRunAsA
113 @ stub PdhPlaSetRunAsW
114 @ stub PdhPlaStartA
115 @ stub PdhPlaStartW
116 @ stub PdhPlaStopA
117 @ stub PdhPlaStopW
118 @ stub PdhPlaValidateInfoA
119 @ stub PdhPlaValidateInfoW
120 @ stub PdhReadRawLogRecord
121 @ stub PdhRelogA
122 @ stub PdhRelogW
123 @ stdcall PdhRemoveCounter(ptr)
124 @ stub PdhSelectDataSourceA
125 @ stub PdhSelectDataSourceW
126 @ stdcall PdhSetCounterScaleFactor(ptr long)
127 @ stub PdhSetDefaultRealTimeDataSource
128 @ stub PdhSetLogSetRunID
129 @ stub PdhSetQueryTimeRange
130 @ stub PdhTranslate009CounterA
131 @ stub PdhTranslate009CounterW
132 @ stub PdhTranslateLocaleCounterA
133 @ stub PdhTranslateLocaleCounterW
134 @ stub PdhUpdateLogA
135 @ stub PdhUpdateLogFileCatalog
136 @ stub PdhUpdateLogW
137 @ stub PdhValidatePathA
138 @ stub PdhValidatePathW
139 @ stub PdhVbAddCounter
140 @ stub PdhVbCreateCounterPathList
141 @ stub PdhVbGetCounterPathElements
142 @ stub PdhVbGetCounterPathFromList
143 @ stub PdhVbGetDoubleCounterValue
144 @ stub PdhVbGetLogFileSize
145 @ stub PdhVbGetOneCounterPath
146 @ stub PdhVbIsGoodStatus
147 @ stub PdhVbOpenLog
148 @ stub PdhVbOpenQuery
149 @ stub PdhVbUpdateLog
150 @ stub PdhVerifySQLDBA
151 @ stub PdhVerifySQLDBW
152 @ stub PdhiPla2003SP1Installed
153 @ stub PdhiPlaFormatBlanksA
154 @ stub PdhiPlaFormatBlanksW
155 @ stub PdhiPlaGetVersion
156 @ stub PdhiPlaRunAs
157 @ stub PdhiPlaSetRunAs
158 @ stub PlaTimeInfoToMilliSeconds