ole32: Remove some assertions in the stuctured storage code by
[wine] / dlls / msvcrt / msvcrt.spec
1 # msvcrt.dll - MS VC++ Run Time Library
2
3 @ cdecl $I10_OUTPUT() MSVCRT_I10_OUTPUT
4 @ cdecl -i386 -norelay ??0__non_rtti_object@@QAE@ABV0@@Z(ptr) __thiscall_MSVCRT___non_rtti_object_copy_ctor
5 @ cdecl -i386 -norelay ??0__non_rtti_object@@QAE@PBD@Z(ptr) __thiscall_MSVCRT___non_rtti_object_ctor
6 @ cdecl -i386 -norelay ??0bad_cast@@QAE@ABQBD@Z(ptr) __thiscall_MSVCRT_bad_cast_ctor
7 @ cdecl -i386 -norelay ??0bad_cast@@QAE@ABV0@@Z(ptr) __thiscall_MSVCRT_bad_cast_copy_ctor
8 @ cdecl -i386 -norelay ??0bad_typeid@@QAE@ABV0@@Z(ptr) __thiscall_MSVCRT_bad_typeid_copy_ctor
9 @ cdecl -i386 -norelay ??0bad_typeid@@QAE@PBD@Z(ptr) __thiscall_MSVCRT_bad_typeid_ctor
10 @ cdecl -i386 -norelay ??0exception@@QAE@ABQBD@Z(ptr) __thiscall_MSVCRT_exception_ctor
11 @ cdecl -i386 -norelay ??0exception@@QAE@ABV0@@Z(ptr) __thiscall_MSVCRT_exception_copy_ctor
12 @ cdecl -i386 -norelay ??0exception@@QAE@XZ() __thiscall_MSVCRT_exception_default_ctor
13 @ cdecl -i386 -norelay ??1__non_rtti_object@@UAE@XZ() __thiscall_MSVCRT___non_rtti_object_dtor
14 @ cdecl -i386 -norelay ??1bad_cast@@UAE@XZ() __thiscall_MSVCRT_bad_cast_dtor
15 @ cdecl -i386 -norelay ??1bad_typeid@@UAE@XZ() __thiscall_MSVCRT_bad_typeid_dtor
16 @ cdecl -i386 -norelay ??1exception@@UAE@XZ() __thiscall_MSVCRT_exception_dtor
17 @ cdecl -i386 -norelay ??1type_info@@UAE@XZ() __thiscall_MSVCRT_type_info_dtor
18 @ cdecl ??2@YAPAXI@Z(long) MSVCRT_operator_new
19 @ cdecl ??_U@YAPAXI@Z(long) MSVCRT_operator_new
20 @ cdecl ??3@YAXPAX@Z(ptr) MSVCRT_operator_delete
21 @ cdecl ??_V@YAXPAX@Z(ptr) MSVCRT_operator_delete
22 @ cdecl -i386 -norelay ??4__non_rtti_object@@QAEAAV0@ABV0@@Z(ptr) __thiscall_MSVCRT___non_rtti_object_opequals
23 @ cdecl -i386 -norelay ??4bad_cast@@QAEAAV0@ABV0@@Z(ptr) __thiscall_MSVCRT_bad_cast_opequals
24 @ cdecl -i386 -norelay ??4bad_typeid@@QAEAAV0@ABV0@@Z(ptr) __thiscall_MSVCRT_bad_typeid_opequals
25 @ cdecl -i386 -norelay ??4exception@@QAEAAV0@ABV0@@Z(ptr) __thiscall_MSVCRT_exception_opequals
26 @ cdecl -i386 -norelay ??8type_info@@QBEHABV0@@Z(ptr) __thiscall_MSVCRT_type_info_opequals_equals
27 @ cdecl -i386 -norelay ??9type_info@@QBEHABV0@@Z(ptr) __thiscall_MSVCRT_type_info_opnot_equals
28 @ extern -i386 ??_7__non_rtti_object@@6B@ MSVCRT___non_rtti_object_vtable
29 @ extern -i386 ??_7bad_cast@@6B@ MSVCRT_bad_cast_vtable
30 @ extern -i386 ??_7bad_typeid@@6B@ MSVCRT_bad_typeid_vtable
31 @ extern -i386 ??_7exception@@6B@ MSVCRT_exception_vtable
32 @ cdecl -i386 -norelay ??_E__non_rtti_object@@UAEPAXI@Z(long) __thiscall_MSVCRT___non_rtti_object_vector_dtor
33 @ cdecl -i386 -norelay ??_Ebad_cast@@UAEPAXI@Z(long) __thiscall_MSVCRT_bad_cast_vector_dtor
34 @ cdecl -i386 -norelay ??_Ebad_typeid@@UAEPAXI@Z(long) __thiscall_MSVCRT_bad_typeid_vector_dtor
35 @ cdecl -i386 -norelay ??_Eexception@@UAEPAXI@Z(long) __thiscall_MSVCRT_exception_vector_dtor
36 @ cdecl -i386 -norelay ??_G__non_rtti_object@@UAEPAXI@Z(long) __thiscall_MSVCRT___non_rtti_object_scalar_dtor
37 @ cdecl -i386 -norelay ??_Gbad_cast@@UAEPAXI@Z(long) __thiscall_MSVCRT_bad_cast_scalar_dtor
38 @ cdecl -i386 -norelay ??_Gbad_typeid@@UAEPAXI@Z(long) __thiscall_MSVCRT_bad_typeid_scalar_dtor
39 @ cdecl -i386 -norelay ??_Gexception@@UAEPAXI@Z(long) __thiscall_MSVCRT_exception_scalar_dtor
40 @ cdecl ?_query_new_handler@@YAP6AHI@ZXZ() MSVCRT__query_new_handler
41 @ cdecl ?_query_new_mode@@YAHXZ() MSVCRT__query_new_mode
42 @ cdecl ?_set_new_handler@@YAP6AHI@ZP6AHI@Z@Z(ptr) MSVCRT__set_new_handler
43 @ cdecl ?_set_new_mode@@YAHH@Z(long) MSVCRT__set_new_mode
44 @ cdecl ?_set_se_translator@@YAP6AXIPAU_EXCEPTION_POINTERS@@@ZP6AXI0@Z@Z(ptr) MSVCRT__set_se_translator
45 @ cdecl -i386 -norelay ?before@type_info@@QBEHABV1@@Z(ptr) __thiscall_MSVCRT_type_info_before
46 @ cdecl -i386 -norelay ?name@type_info@@QBEPBDXZ() __thiscall_MSVCRT_type_info_name
47 @ cdecl -i386 -norelay ?raw_name@type_info@@QBEPBDXZ() __thiscall_MSVCRT_type_info_raw_name
48 @ cdecl ?set_new_handler@@YAP6AXXZP6AXXZ@Z(ptr) MSVCRT__set_new_handler
49 @ cdecl ?set_terminate@@YAP6AXXZP6AXXZ@Z(ptr) MSVCRT_set_terminate
50 @ cdecl ?set_unexpected@@YAP6AXXZP6AXXZ@Z(ptr) MSVCRT_set_unexpected
51 @ cdecl ?terminate@@YAXXZ() MSVCRT_terminate
52 @ cdecl ?unexpected@@YAXXZ() MSVCRT_unexpected
53 @ cdecl -i386 -norelay ?what@exception@@UBEPBDXZ() __thiscall_MSVCRT_what_exception
54 @ cdecl _CIacos()
55 @ cdecl _CIasin()
56 @ cdecl _CIatan()
57 @ cdecl _CIatan2()
58 @ cdecl _CIcos()
59 @ cdecl _CIcosh()
60 @ cdecl _CIexp()
61 @ cdecl _CIfmod()
62 @ cdecl _CIlog()
63 @ cdecl _CIlog10()
64 @ cdecl _CIpow()
65 @ cdecl _CIsin()
66 @ cdecl _CIsinh()
67 @ cdecl _CIsqrt()
68 @ cdecl _CItan()
69 @ cdecl _CItanh()
70 @ cdecl _CxxThrowException(long long)
71 @ cdecl -i386 -norelay _EH_prolog()
72 @ cdecl _Getdays()
73 @ cdecl _Getmonths()
74 @ cdecl _Gettnames()
75 @ extern _HUGE MSVCRT__HUGE
76 @ cdecl _Strftime(str long str ptr ptr)
77 @ cdecl _XcptFilter(long ptr)
78 @ cdecl -i386 -norelay __CxxFrameHandler(ptr ptr ptr ptr)
79 @ stub __CxxLongjmpUnwind #(ptr) stdcall
80 @ cdecl __RTCastToVoid(ptr) MSVCRT___RTCastToVoid
81 @ cdecl __RTDynamicCast(ptr long ptr ptr long) MSVCRT___RTDynamicCast
82 @ cdecl __RTtypeid(ptr) MSVCRT___RTtypeid
83 @ stub __STRINGTOLD #(ptr ptr str long)
84 @ extern __argc MSVCRT___argc
85 @ extern __argv MSVCRT___argv
86 @ extern __badioinfo MSVCRT___badioinfo
87 @ stub __crtCompareStringA
88 @ stub __crtGetLocaleInfoW
89 @ cdecl __crtLCMapStringA(long long str long ptr long long long)
90 @ cdecl __dllonexit(ptr ptr ptr)
91 @ cdecl __doserrno() MSVCRT___doserrno
92 @ cdecl __fpecode()
93 @ stub __get_app_type
94 @ cdecl __getmainargs(ptr ptr ptr long ptr)
95 @ extern __initenv MSVCRT___initenv
96 @ cdecl __isascii(long) MSVCRT___isascii
97 @ cdecl __iscsym(long) MSVCRT___iscsym
98 @ cdecl __iscsymf(long) MSVCRT___iscsymf
99 # extern __lc_codepage
100 @ stub __lc_collate
101 # extern __lc_handle
102 @ cdecl __lconv_init()
103 @ extern __mb_cur_max MSVCRT___mb_cur_max
104 @ cdecl __p___argc()
105 @ cdecl __p___argv()
106 @ cdecl __p___initenv()
107 @ cdecl __p___mb_cur_max()
108 @ cdecl __p___wargv()
109 @ cdecl __p___winitenv()
110 @ cdecl __p__acmdln()
111 @ cdecl __p__amblksiz()
112 @ cdecl __p__commode()
113 @ cdecl __p__daylight() MSVCRT___p__daylight
114 @ cdecl __p__dstbias()
115 @ cdecl __p__environ()
116 @ stub __p__fileinfo #()
117 @ cdecl __p__fmode()
118 @ cdecl __p__iob()
119 @ stub __p__mbcasemap #()
120 @ cdecl __p__mbctype()
121 @ cdecl __p__osver()
122 @ cdecl __p__pctype()
123 @ cdecl __p__pgmptr()
124 @ stub __p__pwctype #()
125 @ cdecl __p__timezone() MSVCRT___p__timezone
126 @ cdecl __p__tzname()
127 @ cdecl __p__wcmdln()
128 @ cdecl __p__wenviron()
129 @ cdecl __p__winmajor()
130 @ cdecl __p__winminor()
131 @ cdecl __p__winver()
132 @ cdecl __p__wpgmptr()
133 @ extern __pioinfo MSVCRT___pioinfo
134 @ stub __pxcptinfoptrs #()
135 @ cdecl __set_app_type(long) MSVCRT___set_app_type
136 @ extern __setlc_active MSVCRT___setlc_active
137 @ cdecl __setusermatherr(ptr) MSVCRT___setusermatherr
138 @ cdecl __threadhandle() kernel32.GetCurrentThread
139 @ cdecl __threadid() kernel32.GetCurrentThreadId
140 @ cdecl __toascii(long) MSVCRT___toascii
141 @ cdecl __unDName(ptr str long ptr ptr long)
142 @ cdecl __unDNameEx(ptr str long ptr ptr ptr long)
143 @ extern __unguarded_readlc_active MSVCRT___unguarded_readlc_active
144 @ extern __wargv MSVCRT___wargv
145 @ cdecl __wgetmainargs(ptr ptr ptr long ptr)
146 @ extern __winitenv MSVCRT___winitenv
147 @ cdecl _abnormal_termination()
148 @ cdecl _access(str long)
149 @ extern _acmdln MSVCRT__acmdln
150 @ stdcall _adj_fdiv_m16i(long)
151 @ stdcall _adj_fdiv_m32(long)
152 @ stdcall _adj_fdiv_m32i(long)
153 @ stdcall _adj_fdiv_m64(double)
154 @ cdecl _adj_fdiv_r()
155 @ stdcall _adj_fdivr_m16i(long)
156 @ stdcall _adj_fdivr_m32(long)
157 @ stdcall _adj_fdivr_m32i(long)
158 @ stdcall _adj_fdivr_m64(double)
159 @ cdecl _adj_fpatan()
160 @ cdecl _adj_fprem()
161 @ cdecl _adj_fprem1()
162 @ cdecl _adj_fptan()
163 @ extern _adjust_fdiv MSVCRT__adjust_fdiv 
164 # extern _aexit_rtn
165 @ cdecl _amsg_exit(long)
166 @ cdecl _assert(str str long) MSVCRT__assert
167 @ stub _atodbl #(ptr str)
168 @ cdecl -ret64 _atoi64(str) ntdll._atoi64
169 @ stub _atoldbl #(ptr str)
170 @ cdecl _beep(long long)
171 @ cdecl _beginthread (ptr long ptr)
172 @ cdecl _beginthreadex (ptr long ptr ptr long ptr)
173 @ cdecl _c_exit() MSVCRT__c_exit
174 @ cdecl _cabs(long) MSVCRT__cabs
175 @ cdecl _callnewh(long)
176 @ cdecl _cexit() MSVCRT__cexit
177 @ cdecl _cgets(str)
178 @ cdecl _chdir(str)
179 @ cdecl _chdrive(long)
180 @ cdecl _chgsign( double )
181 @ cdecl -i386 -norelay _chkesp()
182 @ cdecl _chmod(str long)
183 @ cdecl _chsize (long long)
184 @ cdecl _clearfp()
185 @ cdecl _close(long)
186 @ cdecl _commit(long)
187 @ extern _commode MSVCRT__commode
188 @ cdecl _control87(long long)
189 @ cdecl _controlfp(long long)
190 @ cdecl _copysign( double double )
191 @ varargs _cprintf(str)
192 @ cdecl _cputs(str)
193 @ cdecl _creat(str long)
194 @ varargs _cscanf(str)
195 @ extern _ctype MSVCRT__ctype
196 @ cdecl _cwait(ptr long long)
197 @ extern _daylight MSVCRT___daylight
198 @ extern _dstbias MSVCRT__dstbias
199 @ cdecl _dup (long)
200 @ cdecl _dup2 (long long)
201 @ cdecl _ecvt(double long ptr ptr)
202 @ cdecl _endthread ()
203 @ cdecl _endthreadex(long)
204 @ extern _environ
205 @ cdecl _eof(long)
206 @ cdecl _errno() MSVCRT__errno
207 @ cdecl _except_handler2(ptr ptr ptr ptr)
208 @ cdecl _except_handler3(ptr ptr ptr ptr)
209 @ varargs _execl(str str)
210 @ varargs _execle(str str)
211 @ varargs _execlp(str str)
212 @ varargs _execlpe(str str)
213 @ cdecl _execv(str str)
214 @ cdecl _execve(str str str) MSVCRT__execve
215 @ cdecl _execvp(str str)
216 @ cdecl _execvpe(str str str)
217 @ cdecl _exit(long) MSVCRT__exit
218 @ cdecl _expand(ptr long)
219 @ cdecl _fcloseall() MSVCRT__fcloseall
220 @ cdecl _fcvt(double long ptr ptr)
221 @ cdecl _fdopen(long str) MSVCRT__fdopen
222 @ cdecl _fgetchar()
223 @ cdecl _fgetwchar()
224 @ cdecl _filbuf(ptr) MSVCRT__filbuf
225 # extern _fileinfo
226 @ cdecl _filelength(long)
227 @ cdecl -ret64 _filelengthi64(long)
228 @ cdecl _fileno(ptr) MSVCRT__fileno
229 @ cdecl _findclose(long) MSVCRT__findclose
230 @ cdecl _findfirst(str ptr) MSVCRT__findfirst
231 @ cdecl _findfirsti64(str ptr) MSVCRT__findfirsti64
232 @ cdecl _findnext(long ptr) MSVCRT__findnext
233 @ cdecl _findnexti64(long ptr) MSVCRT__findnexti64
234 @ cdecl _finite( double )
235 @ cdecl _flsbuf(long ptr) MSVCRT__flsbuf
236 @ cdecl _flushall()
237 @ extern _fmode MSVCRT__fmode
238 @ cdecl _fpclass(double)
239 @ stub _fpieee_flt #(long ptr ptr)
240 @ cdecl _fpreset()
241 @ cdecl _fputchar(long)
242 @ cdecl _fputwchar(long)
243 @ cdecl _fsopen(str str long) MSVCRT__fsopen
244 @ cdecl _fstat(long ptr) MSVCRT__fstat
245 @ cdecl _fstati64(long ptr) MSVCRT__fstati64
246 @ cdecl _ftime(ptr)
247 @ cdecl -ret64 _ftol() ntdll._ftol
248 @ cdecl _fullpath(ptr str long)
249 @ cdecl _futime(long ptr)
250 @ cdecl _gcvt(double long str)
251 @ cdecl _get_osfhandle(long)
252 @ cdecl _get_sbh_threshold()
253 @ stub _get_terminate
254 @ stub _get_unexpected
255 @ cdecl _getch()
256 @ cdecl _getche()
257 @ cdecl _getcwd(str long)
258 @ cdecl _getdcwd(long str long)
259 @ cdecl _getdiskfree(long ptr) MSVCRT__getdiskfree
260 @ cdecl _getdllprocaddr(long str long)
261 @ cdecl _getdrive()
262 @ cdecl _getdrives() kernel32.GetLogicalDrives
263 @ stub _getmaxstdio #()
264 @ cdecl _getmbcp()
265 @ cdecl _getpid() kernel32.GetCurrentProcessId
266 @ stub _getsystime #(ptr)
267 @ cdecl _getw(ptr) MSVCRT__getw
268 @ cdecl _getws(ptr) MSVCRT__getws
269 @ cdecl _global_unwind2(ptr)
270 @ cdecl _heapadd (ptr long)
271 @ cdecl _heapchk()
272 @ cdecl _heapmin()
273 @ cdecl _heapset(long)
274 @ stub _heapused #(ptr ptr)
275 @ cdecl _heapwalk(ptr)
276 @ cdecl _hypot(double double)
277 @ cdecl _i64toa(long long ptr long) ntdll._i64toa
278 @ cdecl _i64tow(long long ptr long) ntdll._i64tow
279 @ cdecl _initterm(ptr ptr)
280 @ stub _inp #(long) -i386
281 @ stub _inpd #(long) -i386
282 @ stub _inpw #(long) -i386
283 @ extern _iob MSVCRT__iob
284 @ cdecl _isatty(long)
285 @ cdecl _isctype(long long)
286 @ stub _ismbbalnum #(long)
287 @ stub _ismbbalpha #(long)
288 @ stub _ismbbgraph #(long)
289 @ stub _ismbbkalnum #(long)
290 @ cdecl _ismbbkana(long)
291 @ stub _ismbbkprint #(long)
292 @ stub _ismbbkpunct #(long)
293 @ cdecl _ismbblead(long)
294 @ stub _ismbbprint #(long)
295 @ stub _ismbbpunct #(long)
296 @ cdecl _ismbbtrail(long)
297 @ cdecl _ismbcalnum(long)
298 @ cdecl _ismbcalpha(long)
299 @ cdecl _ismbcdigit(long)
300 @ cdecl _ismbcgraph(long)
301 @ cdecl _ismbchira(long)
302 @ cdecl _ismbckata(long)
303 @ stub _ismbcl0 #(long)
304 @ stub _ismbcl1 #(long)
305 @ stub _ismbcl2 #(long)
306 @ stub _ismbclegal #(long)
307 @ cdecl _ismbclower(long)
308 @ cdecl _ismbcprint(long)
309 @ cdecl _ismbcpunct(long)
310 @ cdecl _ismbcspace(long)
311 @ cdecl _ismbcsymbol(long)
312 @ cdecl _ismbcupper(long)
313 @ cdecl _ismbslead(ptr ptr)
314 @ cdecl _ismbstrail(ptr ptr)
315 @ cdecl _isnan( double )
316 @ cdecl _itoa(long ptr long) ntdll._itoa
317 @ cdecl _itow(long ptr long) ntdll._itow
318 @ cdecl _j0(double)
319 @ cdecl _j1(double)
320 @ cdecl _jn(long double)
321 @ cdecl _kbhit()
322 @ cdecl _lfind(ptr ptr ptr long ptr)
323 @ cdecl _loaddll(str)
324 @ cdecl _local_unwind2(ptr long)
325 @ cdecl _lock(long)
326 @ cdecl _locking(long long long)
327 @ cdecl _logb( double )
328 @ cdecl -i386 _longjmpex(ptr long) MSVCRT_longjmp
329 @ cdecl _lrotl(long long)
330 @ cdecl _lrotr(long long)
331 @ cdecl _lsearch(ptr ptr long long ptr)
332 @ cdecl _lseek(long long long)
333 @ cdecl -ret64 _lseeki64(long double long)
334 @ cdecl _ltoa(long ptr long) ntdll._ltoa
335 @ cdecl _ltow(long ptr long) ntdll._ltow
336 @ cdecl _makepath(str str str str str)
337 @ cdecl _matherr(ptr) MSVCRT__matherr
338 @ cdecl _mbbtombc(long)
339 @ stub _mbbtype #(long long)
340 # extern _mbcasemap
341 @ cdecl _mbccpy (str str)
342 @ stub _mbcjistojms #(long)
343 @ stub _mbcjmstojis #(long)
344 @ cdecl _mbclen(ptr)
345 @ stub _mbctohira #(long)
346 @ stub _mbctokata #(long)
347 @ cdecl _mbctolower(long)
348 @ stub _mbctombb #(long)
349 @ cdecl _mbctoupper(long)
350 @ extern _mbctype MSVCRT_mbctype
351 @ stub _mbsbtype #(str long)
352 @ cdecl _mbscat(str str)
353 @ cdecl _mbschr(str long)
354 @ cdecl _mbscmp(str str)
355 @ cdecl _mbscoll(str str)
356 @ cdecl _mbscpy(ptr str)
357 @ cdecl _mbscspn (str str)
358 @ cdecl _mbsdec(ptr ptr)
359 @ cdecl _mbsdup(str) _strdup
360 @ cdecl _mbsicmp(str str)
361 @ cdecl _mbsicoll(str str)
362 @ cdecl _mbsinc(str)
363 @ cdecl _mbslen(str)
364 @ cdecl _mbslwr(str)
365 @ cdecl _mbsnbcat (str str long)
366 @ cdecl _mbsnbcmp(str str long)
367 @ cdecl _mbsnbcnt(ptr long)
368 @ stub _mbsnbcoll #(str str long)
369 @ cdecl _mbsnbcpy(ptr str long)
370 @ cdecl _mbsnbicmp(str str long)
371 @ stub _mbsnbicoll #(str str long)
372 @ cdecl _mbsnbset(str long long)
373 @ cdecl _mbsncat(str str long)
374 @ cdecl _mbsnccnt(str long)
375 @ cdecl _mbsncmp(str str long)
376 @ stub _mbsncoll #(str str long)
377 @ cdecl _mbsncpy(str str long)
378 @ cdecl _mbsnextc(str)
379 @ cdecl _mbsnicmp(str str long)
380 @ stub _mbsnicoll #(str str long)
381 @ cdecl _mbsninc(str long)
382 @ cdecl _mbsnset(str long long)
383 @ cdecl _mbspbrk(str str)
384 @ cdecl _mbsrchr(str long)
385 @ cdecl _mbsrev(str)
386 @ cdecl _mbsset(str long)
387 @ cdecl _mbsspn(str str)
388 @ stub _mbsspnp #(str str)
389 @ cdecl _mbsstr(str str)
390 @ cdecl _mbstok(str str)
391 @ cdecl _mbstrlen(str)
392 @ cdecl _mbsupr(str)
393 @ cdecl _memccpy(ptr ptr long long) ntdll._memccpy
394 @ cdecl _memicmp(str str long) ntdll._memicmp
395 @ cdecl _mkdir(str)
396 @ cdecl _mktemp(str)
397 @ cdecl _msize(ptr)
398 @ cdecl _nextafter(double double)
399 @ cdecl _onexit(ptr) MSVCRT__onexit
400 @ varargs _open(str long)
401 @ cdecl _open_osfhandle(long long)
402 @ extern _osver MSVCRT__osver
403 @ stub _outp #(long long)
404 @ stub _outpd #(long long)
405 @ stub _outpw #(long long)
406 @ cdecl _pclose (ptr) MSVCRT__pclose
407 @ extern _pctype MSVCRT__pctype
408 @ extern _pgmptr MSVCRT__pgmptr
409 @ cdecl _pipe (ptr long long)
410 @ cdecl _popen (str str) MSVCRT__popen
411 @ cdecl _purecall()
412 @ cdecl _putch(long)
413 @ cdecl _putenv(str)
414 @ cdecl _putw(long ptr) MSVCRT__putw
415 @ cdecl _putws(wstr)
416 # extern _pwctype
417 @ cdecl _read(long ptr long)
418 @ cdecl _rmdir(str)
419 @ cdecl _rmtmp()
420 @ cdecl _rotl(long long)
421 @ cdecl _rotr(long long)
422 @ cdecl _safe_fdiv()
423 @ cdecl _safe_fdivr()
424 @ cdecl _safe_fprem()
425 @ cdecl _safe_fprem1()
426 @ cdecl _scalb( double long)
427 @ cdecl _searchenv(str str ptr)
428 @ stdcall -i386 _seh_longjmp_unwind(ptr)
429 @ cdecl _set_error_mode(long)
430 @ cdecl _set_sbh_threshold(long)
431 @ cdecl _seterrormode(long)
432 @ cdecl -i386 -norelay _setjmp(ptr) MSVCRT__setjmp
433 @ cdecl -i386 -norelay _setjmp3(ptr long) MSVCRT__setjmp3
434 @ stub _setmaxstdio #(long)
435 @ cdecl _setmbcp(long)
436 @ cdecl _setmode(long long)
437 @ stub _setsystime #(ptr long)
438 @ cdecl _sleep(long)
439 @ varargs _snprintf(str long str) MSVCRT__snprintf
440 @ varargs _snwprintf(wstr long wstr) MSVCRT__snwprintf
441 @ varargs _sopen(str long long) MSVCRT__sopen
442 @ varargs _spawnl(long str str)
443 @ varargs _spawnle(long str str)
444 @ varargs _spawnlp(long str str)
445 @ varargs _spawnlpe(long str str)
446 @ cdecl _spawnv(long str ptr)
447 @ cdecl _spawnve(long str ptr ptr)
448 @ cdecl _spawnvp(long str ptr)
449 @ cdecl _spawnvpe(long str ptr ptr)
450 @ cdecl _splitpath(str ptr ptr ptr ptr) ntdll._splitpath
451 @ cdecl _stat(str ptr) MSVCRT__stat
452 @ cdecl _stati64(str ptr) MSVCRT__stati64
453 @ cdecl _statusfp()
454 @ cdecl _strcmpi(str str) ntdll._strcmpi
455 @ cdecl _strdate(ptr)
456 @ cdecl _strdup(str)
457 @ cdecl _strerror(long)
458 @ cdecl _stricmp(str str) ntdll._stricmp
459 @ cdecl _stricoll(str str) MSVCRT__stricoll
460 @ cdecl _strlwr(str) ntdll._strlwr
461 @ stub _strncoll #(str str long)
462 @ cdecl _strnicmp(str str long) ntdll._strnicmp
463 @ stub _strnicoll #(str str long)
464 @ cdecl _strnset(str long long)
465 @ cdecl _strrev(str)
466 @ cdecl _strset(str long)
467 @ cdecl _strtime(ptr)
468 @ cdecl _strupr(str) ntdll._strupr
469 @ cdecl _swab(str str long) MSVCRT__swab
470 @ extern _sys_errlist MSVCRT__sys_errlist
471 @ extern _sys_nerr MSVCRT__sys_nerr
472 @ cdecl _tell(long)
473 @ cdecl -ret64 _telli64(long)
474 @ cdecl _tempnam(str str)
475 @ extern _timezone MSVCRT___timezone
476 @ cdecl _tolower(long) MSVCRT__tolower
477 @ cdecl _toupper(long) MSVCRT__toupper
478 @ extern _tzname MSVCRT__tzname
479 @ cdecl _tzset() MSVCRT__tzset
480 @ cdecl _ui64toa(long long ptr long) ntdll._ui64toa
481 @ cdecl _ui64tow(long long ptr long) ntdll._ui64tow
482 @ cdecl _ultoa(long ptr long) ntdll._ultoa
483 @ cdecl _ultow(long ptr long) ntdll._ultow
484 @ cdecl _umask(long)
485 @ cdecl _ungetch(long)
486 @ cdecl _unlink(str)
487 @ cdecl _unloaddll(long)
488 @ cdecl _unlock(long)
489 @ cdecl _utime(str ptr)
490 @ cdecl _vsnprintf(ptr long ptr ptr) MSVCRT_vsnprintf
491 @ cdecl _vsnwprintf(ptr long wstr long) MSVCRT_vsnwprintf
492 @ cdecl _waccess(wstr long)
493 @ cdecl _wasctime(ptr) MSVCRT__wasctime
494 @ cdecl _wchdir(wstr)
495 @ cdecl _wchmod(wstr long)
496 @ extern _wcmdln MSVCRT__wcmdln
497 @ cdecl _wcreat(wstr long)
498 @ cdecl _wcsdup(wstr)
499 @ cdecl _wcsicmp(wstr wstr) ntdll._wcsicmp
500 @ cdecl _wcsicoll(wstr wstr)
501 @ cdecl _wcslwr(wstr) ntdll._wcslwr
502 @ stub _wcsncoll #(wstr wstr long)
503 @ cdecl _wcsnicmp(wstr wstr long) ntdll._wcsnicmp
504 @ stub _wcsnicoll #(wstr wstr long)
505 @ cdecl _wcsnset(wstr long long)
506 @ cdecl _wcsrev(wstr)
507 @ cdecl _wcsset(wstr long)
508 @ cdecl _wcsupr(wstr) ntdll._wcsupr
509 @ cdecl _wctime(ptr) MSVCRT__wctime
510 @ extern _wenviron
511 @ stub _wexecl #(wstr wstr) varargs
512 @ stub _wexecle #(wstr wstr) varargs
513 @ stub _wexeclp #(wstr wstr) varargs
514 @ stub _wexeclpe #(wstr wstr) varargs
515 @ stub _wexecv #(wstr ptr)
516 @ stub _wexecve #(wstr ptr ptr)
517 @ stub _wexecvp #(wstr ptr)
518 @ stub _wexecvpe #(wstr ptr ptr)
519 @ cdecl _wfdopen(long wstr) MSVCRT__wfdopen
520 @ cdecl _wfindfirst(wstr ptr) MSVCRT__wfindfirst
521 @ cdecl _wfindfirsti64(wstr ptr) MSVCRT__wfindfirsti64
522 @ cdecl _wfindnext(long ptr) MSVCRT__wfindnext
523 @ cdecl _wfindnexti64(long ptr) MSVCRT__wfindnexti64
524 @ cdecl _wfopen(wstr wstr) MSVCRT__wfopen
525 @ stub _wfreopen #(wstr wstr ptr) MSVCRT__wfreopen
526 @ cdecl _wfsopen(wstr wstr long) MSVCRT__wfsopen
527 @ cdecl _wfullpath(ptr wstr long)
528 @ cdecl _wgetcwd(wstr long)
529 @ cdecl _wgetdcwd(long wstr long)
530 @ cdecl _wgetenv(wstr)
531 @ extern _winmajor MSVCRT__winmajor
532 @ extern _winminor MSVCRT__winminor
533 @ extern _winver MSVCRT__winver
534 @ cdecl _wmakepath(wstr wstr wstr wstr wstr)
535 @ cdecl _wmkdir(wstr)
536 @ cdecl _wmktemp(wstr)
537 @ varargs _wopen(wstr long)
538 @ stub _wperror #(wstr)
539 @ extern _wpgmptr MSVCRT__wpgmptr
540 @ cdecl _wpopen (wstr wstr) MSVCRT__wpopen
541 @ cdecl _wputenv(wstr)
542 @ cdecl _wremove(wstr)
543 @ cdecl _wrename(wstr wstr)
544 @ cdecl _write(long ptr long)
545 @ cdecl _wrmdir(wstr)
546 @ stub _wsearchenv #(wstr wstr ptr)
547 @ cdecl _wsetlocale(long wstr) MSVCRT__wsetlocale
548 @ varargs _wsopen (wstr long long) MSVCRT__wsopen
549 @ stub _wspawnl #(long wstr wstr) varargs
550 @ stub _wspawnle #(long wstr wstr) varargs
551 @ stub _wspawnlp #(long wstr wstr) varargs
552 @ stub _wspawnlpe #(long wstr wstr) varargs
553 @ stub _wspawnv #(long wstr ptr)
554 @ stub _wspawnve #(long wstr ptr ptr)
555 @ stub _wspawnvp #(long wstr ptr)
556 @ stub _wspawnvpe #(long wstr ptr ptr)
557 @ cdecl _wsplitpath(wstr wstr wstr wstr wstr)
558 @ cdecl _wstat(wstr ptr) MSVCRT__wstat
559 @ cdecl _wstati64(wstr ptr) MSVCRT__wstati64
560 @ cdecl _wstrdate(ptr)
561 @ cdecl _wstrtime(ptr)
562 @ stub _wsystem #(wstr)
563 @ cdecl _wtempnam(wstr wstr)
564 @ stub _wtmpnam #(ptr)
565 @ cdecl _wtoi(wstr) ntdll._wtoi
566 @ cdecl _wtoi64(wstr) ntdll._wtoi64
567 @ cdecl _wtol(wstr) ntdll._wtol
568 @ cdecl _wunlink(wstr)
569 @ cdecl _wutime(wstr ptr)
570 @ cdecl _y0(double)
571 @ cdecl _y1(double)
572 @ cdecl _yn(long double )
573 @ cdecl abort() MSVCRT_abort
574 @ cdecl abs(long) ntdll.abs
575 @ cdecl acos(double) MSVCRT_acos
576 @ cdecl asctime(ptr) MSVCRT_asctime
577 @ cdecl asin(double) MSVCRT_asin
578 @ cdecl atan(double) MSVCRT_atan
579 @ cdecl atan2(double double) MSVCRT_atan2
580 @ cdecl atexit(ptr) MSVCRT_atexit
581 @ cdecl atof(str) MSVCRT_atof
582 @ cdecl atoi(str) ntdll.atoi
583 @ cdecl atol(str) ntdll.atol
584 @ cdecl bsearch(ptr ptr long long ptr) ntdll.bsearch
585 @ cdecl calloc(long long) MSVCRT_calloc
586 @ cdecl ceil(double) MSVCRT_ceil
587 @ cdecl clearerr(ptr) MSVCRT_clearerr
588 @ cdecl clock() MSVCRT_clock
589 @ cdecl cos(double) MSVCRT_cos
590 @ cdecl cosh(double) MSVCRT_cosh
591 @ cdecl ctime(ptr) MSVCRT_ctime
592 @ cdecl difftime(long long) MSVCRT_difftime
593 @ cdecl div(long long) MSVCRT_div
594 @ cdecl exit(long) MSVCRT_exit
595 @ cdecl exp(double) MSVCRT_exp
596 @ cdecl fabs(double) MSVCRT_fabs
597 @ cdecl fclose(ptr) MSVCRT_fclose
598 @ cdecl feof(ptr) MSVCRT_feof
599 @ cdecl ferror(ptr) MSVCRT_ferror
600 @ cdecl fflush(ptr) MSVCRT_fflush
601 @ cdecl fgetc(ptr) MSVCRT_fgetc
602 @ cdecl fgetpos(ptr ptr) MSVCRT_fgetpos
603 @ cdecl fgets(ptr long ptr) MSVCRT_fgets
604 @ cdecl fgetwc(ptr) MSVCRT_fgetwc
605 @ cdecl fgetws(ptr long ptr) MSVCRT_fgetws
606 @ cdecl floor(double) MSVCRT_floor
607 @ cdecl fmod(double double) MSVCRT_fmod
608 @ cdecl fopen(str str) MSVCRT_fopen
609 @ varargs fprintf(ptr str) MSVCRT_fprintf
610 @ cdecl fputc(long ptr) MSVCRT_fputc
611 @ cdecl fputs(str ptr) MSVCRT_fputs
612 @ cdecl fputwc(long ptr) MSVCRT_fputwc
613 @ cdecl fputws(wstr ptr) MSVCRT_fputws
614 @ cdecl fread(ptr long long ptr) MSVCRT_fread
615 @ cdecl free(ptr) MSVCRT_free
616 @ cdecl freopen(str str ptr) MSVCRT_freopen
617 @ cdecl frexp(double ptr) MSVCRT_frexp
618 @ varargs fscanf(ptr str) MSVCRT_fscanf
619 @ cdecl fseek(ptr long long) MSVCRT_fseek
620 @ cdecl fsetpos(ptr ptr) MSVCRT_fsetpos
621 @ cdecl ftell(ptr) MSVCRT_ftell
622 @ varargs fwprintf(ptr wstr) MSVCRT_fwprintf
623 @ cdecl fwrite(ptr long long ptr) MSVCRT_fwrite
624 @ varargs fwscanf(ptr wstr) MSVCRT_fwscanf
625 @ cdecl getc(ptr) MSVCRT_getc
626 @ cdecl getchar() MSVCRT_getchar
627 @ cdecl getenv(str) MSVCRT_getenv
628 @ cdecl gets(str) MSVCRT_gets
629 @ cdecl getwc(ptr) MSVCRT_getwc
630 @ cdecl getwchar() MSVCRT_getwchar
631 @ cdecl gmtime(ptr) MSVCRT_gmtime
632 @ cdecl is_wctype(long long) ntdll.iswctype
633 @ cdecl isalnum(long) MSVCRT_isalnum
634 @ cdecl isalpha(long) MSVCRT_isalpha
635 @ cdecl iscntrl(long) MSVCRT_iscntrl
636 @ cdecl isdigit(long) MSVCRT_isdigit
637 @ cdecl isgraph(long) MSVCRT_isgraph
638 @ cdecl isleadbyte(long) MSVCRT_isleadbyte
639 @ cdecl islower(long) MSVCRT_islower
640 @ cdecl isprint(long) MSVCRT_isprint
641 @ cdecl ispunct(long) MSVCRT_ispunct
642 @ cdecl isspace(long) MSVCRT_isspace
643 @ cdecl isupper(long) MSVCRT_isupper
644 @ cdecl iswalnum(long) MSVCRT_iswalnum
645 @ cdecl iswalpha(long) ntdll.iswalpha
646 @ cdecl iswascii(long) MSVCRT_iswascii
647 @ cdecl iswcntrl(long) MSVCRT_iswcntrl
648 @ cdecl iswctype(long long) ntdll.iswctype
649 @ cdecl iswdigit(long) MSVCRT_iswdigit
650 @ cdecl iswgraph(long) MSVCRT_iswgraph
651 @ cdecl iswlower(long) MSVCRT_iswlower
652 @ cdecl iswprint(long) MSVCRT_iswprint
653 @ cdecl iswpunct(long) MSVCRT_iswpunct
654 @ cdecl iswspace(long) MSVCRT_iswspace
655 @ cdecl iswupper(long) MSVCRT_iswupper
656 @ cdecl iswxdigit(long) MSVCRT_iswxdigit
657 @ cdecl isxdigit(long) MSVCRT_isxdigit
658 @ cdecl labs(long) ntdll.labs
659 @ cdecl ldexp( double long) MSVCRT_ldexp
660 @ cdecl ldiv(long long) MSVCRT_ldiv
661 @ cdecl localeconv() MSVCRT_localeconv
662 @ cdecl localtime(ptr) MSVCRT_localtime
663 @ cdecl log(double) MSVCRT_log
664 @ cdecl log10(double) MSVCRT_log10
665 @ cdecl -i386 longjmp(ptr long) MSVCRT_longjmp
666 @ cdecl malloc(long) MSVCRT_malloc
667 @ cdecl mblen(ptr long) MSVCRT_mblen
668 @ cdecl mbstowcs(ptr str long) ntdll.mbstowcs
669 @ cdecl mbtowc(wstr str long) MSVCRT_mbtowc
670 @ cdecl memchr(ptr long long) ntdll.memchr
671 @ cdecl memcmp(ptr ptr long) ntdll.memcmp
672 @ cdecl memcpy(ptr ptr long) ntdll.memcpy
673 @ cdecl memmove(ptr ptr long) ntdll.memmove
674 @ cdecl memset(ptr long long) ntdll.memset
675 @ cdecl mktime(ptr) MSVCRT_mktime
676 @ cdecl modf(double ptr) MSVCRT_modf
677 @ cdecl perror(str) MSVCRT_perror
678 @ cdecl pow(double double) MSVCRT_pow
679 @ varargs printf(str) MSVCRT_printf
680 @ cdecl putc(long ptr) MSVCRT_putc
681 @ cdecl putchar(long) MSVCRT_putchar
682 @ cdecl puts(str) MSVCRT_puts
683 @ cdecl putwc(long ptr) MSVCRT_fputwc
684 @ cdecl putwchar(long) _fputwchar
685 @ cdecl qsort(ptr long long ptr) ntdll.qsort
686 @ stub raise #(long)
687 @ cdecl rand() MSVCRT_rand
688 @ cdecl realloc(ptr long) MSVCRT_realloc
689 @ cdecl remove(str) MSVCRT_remove
690 @ cdecl rename(str str) MSVCRT_rename
691 @ cdecl rewind(ptr) MSVCRT_rewind
692 @ varargs scanf(str) MSVCRT_scanf
693 @ cdecl setbuf(ptr ptr) MSVCRT_setbuf
694 @ cdecl setlocale(long str) MSVCRT_setlocale
695 @ cdecl setvbuf(ptr str long long) MSVCRT_setvbuf
696 @ cdecl signal(long long) MSVCRT_signal
697 @ cdecl sin(double) MSVCRT_sin
698 @ cdecl sinh(double) MSVCRT_sinh
699 @ varargs sprintf(ptr str) MSVCRT_sprintf
700 @ cdecl sqrt(double) MSVCRT_sqrt
701 @ cdecl srand(long) MSVCRT_srand
702 @ varargs sscanf(str str) MSVCRT_sscanf
703 @ cdecl strcat(str str) ntdll.strcat
704 @ cdecl strchr(str long) ntdll.strchr
705 @ cdecl strcmp(str str) ntdll.strcmp
706 @ cdecl strcoll(str str) MSVCRT_strcoll
707 @ cdecl strcpy(ptr str) ntdll.strcpy
708 @ cdecl strcspn(str str) ntdll.strcspn
709 @ cdecl strerror(long) MSVCRT_strerror
710 @ cdecl strftime(str long str ptr) MSVCRT_strftime
711 @ cdecl strlen(str) ntdll.strlen
712 @ cdecl strncat(str str long) ntdll.strncat
713 @ cdecl strncmp(str str long) ntdll.strncmp
714 @ cdecl strncpy(ptr str long) ntdll.strncpy
715 @ cdecl strpbrk(str str) ntdll.strpbrk
716 @ cdecl strrchr(str long) ntdll.strrchr
717 @ cdecl strspn(str str) ntdll.strspn
718 @ cdecl strstr(str str) ntdll.strstr
719 @ cdecl strtod(str ptr) MSVCRT_strtod
720 @ cdecl strtok(str str) MSVCRT_strtok
721 @ cdecl strtol(str ptr long) ntdll.strtol
722 @ cdecl strtoul(str ptr long) ntdll.strtoul
723 @ cdecl strxfrm(ptr str long) MSVCRT_strxfrm
724 @ varargs swprintf(wstr wstr) MSVCRT_swprintf
725 @ varargs swscanf(wstr wstr) MSVCRT_swscanf
726 @ cdecl system(str) MSVCRT_system
727 @ cdecl tan(double) MSVCRT_tan
728 @ cdecl tanh(double) MSVCRT_tanh
729 @ cdecl time(ptr) MSVCRT_time
730 @ cdecl tmpfile() MSVCRT_tmpfile
731 @ cdecl tmpnam(ptr) MSVCRT_tmpnam
732 @ cdecl tolower(long) ntdll.tolower
733 @ cdecl toupper(long) ntdll.toupper
734 @ cdecl towlower(long) ntdll.towlower
735 @ cdecl towupper(long) ntdll.towupper
736 @ cdecl ungetc(long ptr) MSVCRT_ungetc
737 @ cdecl ungetwc(long ptr) MSVCRT_ungetwc
738 @ cdecl vfprintf(ptr str long) MSVCRT_vfprintf
739 @ cdecl vfwprintf(ptr wstr long) MSVCRT_vfwprintf
740 @ cdecl vprintf(str long) MSVCRT_vprintf
741 @ cdecl vsprintf(ptr str ptr) ntdll.vsprintf
742 @ cdecl vswprintf(ptr wstr long) MSVCRT_vswprintf
743 @ cdecl vwprintf(wstr long) MSVCRT_vwprintf
744 @ cdecl wcscat(wstr wstr) ntdll.wcscat
745 @ cdecl wcschr(wstr long) ntdll.wcschr
746 @ cdecl wcscmp(wstr wstr) ntdll.wcscmp
747 @ cdecl wcscoll(wstr wstr) MSVCRT_wcscoll
748 @ cdecl wcscpy(ptr wstr) ntdll.wcscpy
749 @ cdecl wcscspn(wstr wstr) ntdll.wcscspn
750 @ cdecl wcsftime(ptr long wstr ptr) MSVCRT_wcsftime
751 @ cdecl wcslen(wstr) ntdll.wcslen
752 @ cdecl wcsncat(wstr wstr long) ntdll.wcsncat
753 @ cdecl wcsncmp(wstr wstr long) ntdll.wcsncmp
754 @ cdecl wcsncpy(ptr wstr long) ntdll.wcsncpy
755 @ cdecl wcspbrk(wstr wstr) MSVCRT_wcspbrk
756 @ cdecl wcsrchr(wstr long) ntdll.wcsrchr
757 @ cdecl wcsspn(wstr wstr) ntdll.wcsspn
758 @ cdecl wcsstr(wstr wstr) ntdll.wcsstr
759 @ cdecl wcstod(wstr ptr) MSVCRT_wcstod
760 @ cdecl wcstok(wstr wstr) MSVCRT_wcstok
761 @ cdecl wcstol(wstr ptr long) ntdll.wcstol
762 @ cdecl wcstombs(ptr ptr long) ntdll.wcstombs
763 @ cdecl wcstoul(wstr ptr long) ntdll.wcstoul
764 @ stub wcsxfrm #(ptr wstr long)
765 @ cdecl wctomb(ptr long) MSVCRT_wctomb
766 @ varargs wprintf(wstr) MSVCRT_wprintf
767 @ varargs wscanf(wstr) MSVCRT_wscanf
768 # extern __lc_collate_cp