Add implementation for RtlQueryRegistryValues, RtlCheckRegistryKey and
[wine] / dlls / netapi32 / netapi32.spec
1 @ stub I_BrowserDebugCall
2 @ stub I_BrowserDebugTrace
3 @ stdcall I_BrowserQueryEmulatedDomains(wstr ptr ptr)
4 @ stub I_BrowserQueryOtherDomains
5 @ stub I_BrowserQueryStatistics
6 @ stub I_BrowserResetNetlogonState
7 @ stub I_BrowserResetStatistics
8 @ stub I_BrowserServerEnum
9 @ stdcall I_BrowserSetNetlogonState(wstr wstr wstr long)
10 @ stub I_NetAccountDeltas
11 @ stub I_NetAccountSync
12 @ stub I_NetDatabaseDeltas
13 @ stub I_NetDatabaseRedo
14 @ stub I_NetDatabaseSync
15 @ stub I_NetDatabaseSync2
16 @ stub I_NetDfsCreateExitPoint
17 @ stub I_NetDfsCreateLocalPartition
18 @ stub I_NetDfsDeleteExitPoint
19 @ stub I_NetDfsDeleteLocalPartition
20 @ stub I_NetDfsFixLocalVolume
21 @ stub I_NetDfsGetVersion
22 @ stub I_NetDfsIsThisADomainName
23 @ stub I_NetDfsModifyPrefix
24 @ stub I_NetDfsSetLocalVolumeState
25 @ stub I_NetDfsSetServerInfo
26 @ stub I_NetGetDCList
27 @ stub I_NetListCanonicalize
28 @ stub I_NetListTraverse
29 @ stub I_NetLogonControl
30 @ stub I_NetLogonControl2
31 @ stub I_NetLogonSamLogoff
32 @ stub I_NetLogonSamLogon
33 @ stub I_NetLogonUasLogoff
34 @ stub I_NetLogonUasLogon
35 @ stub I_NetNameCanonicalize
36 @ stdcall I_NetNameCompare(ptr wstr wstr ptr ptr)
37 @ stdcall I_NetNameValidate(ptr wstr ptr ptr)
38 @ stub I_NetPathCanonicalize
39 @ stub I_NetPathCompare
40 @ stub I_NetPathType
41 @ stub I_NetServerAuthenticate
42 @ stub I_NetServerAuthenticate2
43 @ stub I_NetServerPasswordSet
44 @ stub I_NetServerReqChallenge
45 @ stub I_NetServerSetServiceBits
46 @ stub I_NetServerSetServiceBitsEx
47 @ stub NetAlertRaise
48 @ stub NetAlertRaiseEx
49 @ stdcall NetApiBufferAllocate(long ptr)
50 @ stdcall NetApiBufferFree(ptr)
51 @ stdcall NetApiBufferReallocate(ptr long ptr)
52 @ stdcall NetApiBufferSize(ptr ptr)
53 @ stub NetAuditClear
54 @ stub NetAuditRead
55 @ stub NetAuditWrite
56 @ stub NetBrowserStatisticsGet
57 @ stub NetConfigGet
58 @ stub NetConfigGetAll
59 @ stub NetConfigSet
60 @ stub NetConnectionEnum
61 @ stub NetDfsAdd
62 @ stub NetDfsEnum
63 @ stub NetDfsGetInfo
64 @ stub NetDfsManagerGetConfigInfo
65 @ stub NetDfsMove
66 @ stub NetDfsRemove
67 @ stub NetDfsRename
68 @ stub NetDfsSetInfo
69 @ stub NetEnumerateTrustedDomains
70 @ stub NetErrorLogClear
71 @ stub NetErrorLogRead
72 @ stub NetErrorLogWrite
73 @ stub NetFileClose
74 @ stub NetFileEnum
75 @ stub NetFileGetInfo
76 @ stub NetGetAnyDCName
77 @ stdcall NetGetDCName(wstr wstr ptr)
78 @ stub NetGetDisplayInformationIndex
79 @ stdcall NetGetJoinInformation(wstr ptr ptr)
80 @ stub NetGroupAdd
81 @ stub NetGroupAddUser
82 @ stub NetGroupDel
83 @ stub NetGroupDelUser
84 @ stub NetGroupEnum
85 @ stub NetGroupGetInfo
86 @ stub NetGroupGetUsers
87 @ stub NetGroupSetInfo
88 @ stub NetGroupSetUsers
89 @ stdcall NetLocalGroupAdd(wstr long ptr ptr)
90 @ stub NetLocalGroupAddMember
91 @ stub NetLocalGroupAddMembers
92 @ stub NetLocalGroupDel
93 @ stub NetLocalGroupDelMember
94 @ stub NetLocalGroupDelMembers
95 @ stub NetLocalGroupEnum
96 @ stub NetLocalGroupGetInfo
97 @ stub NetLocalGroupGetMembers
98 @ stub NetLocalGroupSetInfo
99 @ stdcall NetLocalGroupSetMembers(wstr wstr long ptr ptr)
100 @ stub NetMessageBufferSend
101 @ stub NetMessageNameAdd
102 @ stub NetMessageNameDel
103 @ stub NetMessageNameEnum
104 @ stub NetMessageNameGetInfo
105 @ stdcall NetQueryDisplayInformation(wstr long long long long ptr ptr)
106 @ stub NetRemoteComputerSupports
107 @ stub NetRemoteTOD
108 @ stub NetReplExportDirAdd
109 @ stub NetReplExportDirDel
110 @ stub NetReplExportDirEnum
111 @ stub NetReplExportDirGetInfo
112 @ stub NetReplExportDirLock
113 @ stub NetReplExportDirSetInfo
114 @ stub NetReplExportDirUnlock
115 @ stub NetReplGetInfo
116 @ stub NetReplImportDirAdd
117 @ stub NetReplImportDirDel
118 @ stub NetReplImportDirEnum
119 @ stub NetReplImportDirGetInfo
120 @ stub NetReplImportDirLock
121 @ stub NetReplImportDirUnlock
122 @ stub NetReplSetInfo
123 @ stub NetRplAdapterAdd
124 @ stub NetRplAdapterDel
125 @ stub NetRplAdapterEnum
126 @ stub NetRplBootAdd
127 @ stub NetRplBootDel
128 @ stub NetRplBootEnum
129 @ stub NetRplClose
130 @ stub NetRplConfigAdd
131 @ stub NetRplConfigDel
132 @ stub NetRplConfigEnum
133 @ stub NetRplGetInfo
134 @ stub NetRplOpen
135 @ stub NetRplProfileAdd
136 @ stub NetRplProfileClone
137 @ stub NetRplProfileDel
138 @ stub NetRplProfileEnum
139 @ stub NetRplProfileGetInfo
140 @ stub NetRplProfileSetInfo
141 @ stub NetRplSetInfo
142 @ stub NetRplSetSecurity
143 @ stub NetRplVendorAdd
144 @ stub NetRplVendorDel
145 @ stub NetRplVendorEnum
146 @ stub NetRplWkstaAdd
147 @ stub NetRplWkstaClone
148 @ stub NetRplWkstaDel
149 @ stub NetRplWkstaEnum
150 @ stub NetRplWkstaGetInfo
151 @ stub NetRplWkstaSetInfo
152 @ stub NetScheduleJobAdd
153 @ stub NetScheduleJobDel
154 @ stub NetScheduleJobEnum
155 @ stub NetScheduleJobGetInfo
156 @ stub NetServerComputerNameAdd
157 @ stub NetServerComputerNameDel
158 @ stub NetServerDiskEnum
159 @ stdcall NetServerEnum(wstr long ptr long ptr ptr long wstr ptr)
160 @ stub NetServerEnumEx
161 @ stdcall NetServerGetInfo(wstr long ptr)
162 @ stub NetServerSetInfo
163 @ stub NetServerTransportAdd
164 @ stub NetServerTransportAddEx
165 @ stub NetServerTransportDel
166 @ stub NetServerTransportEnum
167 @ stub NetServiceControl
168 @ stub NetServiceEnum
169 @ stub NetServiceGetInfo
170 @ stub NetServiceInstall
171 @ stub NetSessionDel
172 @ stub NetSessionEnum
173 @ stub NetSessionGetInfo
174 @ stub NetShareAdd
175 @ stub NetShareCheck
176 @ stub NetShareDel
177 @ stub NetShareDelSticky
178 @ stdcall NetShareEnum(wstr long ptr long ptr ptr ptr)
179 @ stub NetShareEnumSticky
180 @ stub NetShareGetInfo
181 @ stub NetShareSetInfo
182 @ stdcall NetStatisticsGet(wstr wstr long long ptr)
183 @ stub NetUseAdd
184 @ stub NetUseDel
185 @ stub NetUseEnum
186 @ stub NetUseGetInfo
187 @ stub NetUserAdd
188 @ stub NetUserChangePassword
189 @ stub NetUserDel
190 @ stdcall NetUserEnum(wstr long long ptr long ptr ptr ptr)
191 @ stub NetUserGetGroups
192 @ stdcall NetUserGetInfo(wstr wstr long ptr)
193 @ stub NetUserGetLocalGroups
194 @ stdcall NetUserModalsGet(wstr long ptr)
195 @ stub NetUserModalsSet
196 @ stub NetUserSetGroups
197 @ stub NetUserSetInfo
198 @ stdcall NetWkstaGetInfo(wstr long ptr)
199 @ stub NetWkstaSetInfo
200 @ stub NetWkstaTransportAdd
201 @ stub NetWkstaTransportDel
202 @ stdcall NetWkstaTransportEnum (wstr long ptr long ptr ptr ptr)
203 @ stub NetWkstaUserEnum
204 @ stdcall NetWkstaUserGetInfo(wstr long ptr)
205 @ stub NetWkstaUserSetInfo
206 @ stdcall NetapipBufferAllocate(long ptr) NetApiBufferAllocate
207 @ stdcall Netbios(ptr)
208 @ stub NetpAccessCheck
209 @ stub NetpAccessCheckAndAudit
210 @ stub NetpAllocConfigName
211 @ stub NetpAllocStrFromStr
212 @ stub NetpAllocStrFromWStr
213 @ stub NetpAllocTStrFromString
214 @ stub NetpAllocWStrFromStr
215 @ stub NetpAllocWStrFromWStr
216 @ stub NetpApiStatusToNtStatus
217 @ stub NetpAssertFailed
218 @ stub NetpCloseConfigData
219 @ stub NetpCopyStringToBuffer
220 @ stub NetpCreateSecurityObject
221 @ stub NetpDbgDisplayServerInfo
222 @ stub NetpDbgPrint
223 @ stdcall NetpDeleteSecurityObject(long) ntdll.RtlDeleteSecurityObject
224 @ stdcall NetpGetComputerName(ptr)
225 @ stub NetpGetConfigBool
226 @ stub NetpGetConfigDword
227 @ stub NetpGetConfigTStrArray
228 @ stub NetpGetConfigValue
229 @ stub NetpGetDomainName
230 @ stub NetpGetFileSecurity
231 @ stub NetpGetPrivilege
232 @ stub NetpHexDump
233 @ stdcall NetpInitOemString(ptr str) ntdll.RtlInitAnsiString
234 @ stub NetpIsRemote
235 @ stub NetpIsUncComputerNameValid
236 @ stub NetpLocalTimeZoneOffset
237 @ stub NetpLogonPutUnicodeString
238 @ stub NetpNetBiosAddName
239 @ stub NetpNetBiosCall
240 @ stub NetpNetBiosDelName
241 @ stub NetpNetBiosGetAdapterNumbers
242 @ stub NetpNetBiosHangup
243 @ stub NetpNetBiosReceive
244 @ stub NetpNetBiosReset
245 @ stub NetpNetBiosSend
246 @ stdcall NetpNetBiosStatusToApiStatus(long)
247 @ stub NetpNtStatusToApiStatus
248 @ stub NetpOpenConfigData
249 @ stub NetpPackString
250 @ stub NetpReleasePrivilege
251 @ stub NetpSetConfigBool
252 @ stub NetpSetConfigDword
253 @ stub NetpSetConfigTStrArray
254 @ stub NetpSetFileSecurity
255 @ stub NetpSmbCheck
256 @ stub NetpStringToNetBiosName
257 @ stub NetpTStrArrayEntryCount
258 @ stub NetpwNameCanonicalize
259 @ stub NetpwNameCompare
260 @ stub NetpwNameValidate
261 @ stub NetpwPathCanonicalize
262 @ stub NetpwPathCompare
263 @ stub NetpwPathType
264 @ stub NlBindingAddServerToCache
265 @ stub NlBindingRemoveServerFromCache
266 @ stub NlBindingSetAuthInfo
267 @ stub RxNetAccessAdd
268 @ stub RxNetAccessDel
269 @ stub RxNetAccessEnum
270 @ stub RxNetAccessGetInfo
271 @ stub RxNetAccessGetUserPerms
272 @ stub RxNetAccessSetInfo
273 @ stub RxNetServerEnum
274 @ stub RxNetUserPasswordSet
275 @ stub RxRemoteApi