1 # C RunTime DLL. All functions use cdecl!
6 @ cdecl ??2@YAPAXI@Z(long) CRTDLL_new
7 @ cdecl ??3@YAXPAX@Z(long) CRTDLL_delete
8 @ cdecl ?_set_new_handler@@YAP6AHI@ZP6AHI@Z@Z(ptr) CRTDLL_set_new_handler
19 @ cdecl _CIpow() CRTDLL__CIpow
27 @ cdecl __GetMainArgs(ptr ptr ptr long) CRTDLL__GetMainArgs
28 @ extern __argc_dll CRTDLL_argc_dll
29 @ extern __argv_dll CRTDLL_argv_dll
30 @ cdecl __dllonexit() CRTDLL___dllonexit
36 @ stub __mb_cur_max_dll
37 @ stub __pxcptinfoptrs
38 @ cdecl __threadhandle() GetCurrentThread
39 @ cdecl __threadid() GetCurrentThreadId
41 @ cdecl _abnormal_termination() CRTDLL__abnormal_termination
42 @ cdecl _access(str long) CRTDLL__access
43 @ extern _acmdln_dll CRTDLL_acmdln_dll
47 @ extern _basemajor_dll CRTDLL_basemajor_dll
48 @ extern _baseminor_dll CRTDLL_baseminor_dll
49 @ extern _baseversion_dll CRTDLL_baseversion_dll
54 @ cdecl _cexit(long) CRTDLL__cexit
56 @ cdecl _chdir(str) CRTDLL__chdir
57 @ cdecl _chdrive(long) CRTDLL__chdrive
62 @ cdecl _close(long) CRTDLL__close
64 @ extern _commode_dll CRTDLL_commode_dll
80 @ extern _environ_dll CRTDLL_environ_dll
82 @ cdecl _errno() CRTDLL__errno
83 @ cdecl _except_handler2(ptr ptr ptr ptr) CRTDLL__except_handler2
96 @ cdecl _fdopen(long ptr) CRTDLL__fdopen
104 @ cdecl _findfirst(str ptr) CRTDLL__findfirst
105 @ cdecl _findnext(long ptr) CRTDLL__findnext
109 @ extern _fmode_dll CRTDLL_fmode_dll
112 @ cdecl _fpreset() CRTDLL__fpreset
115 @ cdecl _fsopen(str str long) CRTDLL__fsopen
116 @ cdecl _fstat(long ptr) CRTDLL__fstat
118 @ cdecl _ftol() CRTDLL__ftol
119 @ cdecl _fullpath(ptr str long) CRTDLL__fullpath
122 @ stub _get_osfhandle
125 @ cdecl _getcwd(ptr long) CRTDLL__getcwd
126 @ cdecl _getdcwd(long ptr long) CRTDLL__getdcwd
128 @ stub _getdllprocaddr
129 @ cdecl _getdrive() CRTDLL__getdrive
134 @ cdecl _global_unwind2(ptr) CRTDLL__global_unwind2
139 @ cdecl _hypot(double double) hypot
140 @ cdecl _initterm(ptr ptr) CRTDLL__initterm
141 @ extern _iob CRTDLL_iob
142 @ cdecl _isatty(long) CRTDLL__isatty
143 @ cdecl _isctype(long long) CRTDLL__isctype
170 @ cdecl _itoa(long ptr long) CRTDLL__itoa
172 @ cdecl _j0(double) j0
173 @ cdecl _j1(double) j1
174 @ cdecl _jn(long double) jn
178 @ cdecl _local_unwind2(ptr long) CRTDLL__local_unwind2
181 @ cdecl _lrotl (long long) CRTDLL__lrotl
184 @ cdecl _lseek(long long long) CRTDLL__lseek
185 @ cdecl _ltoa(long str long) CRTDLL__ltoa
187 @ cdecl _makepath (ptr str str str str) CRTDLL__makepath
202 @ cdecl _mbscat(str str) strcat
205 @ cdecl _mbscpy(ptr str) strcpy
208 @ cdecl _mbsdup(str) CRTDLL__strdup
209 @ cdecl _mbsicmp(str str) CRTDLL__mbsicmp
210 @ cdecl _mbsinc(str) CRTDLL__mbsinc
211 @ cdecl _mbslen(str) CRTDLL__mbslen
228 @ cdecl _mbsrchr(str long) CRTDLL__mbsrchr
238 @ cdecl _memicmp(str str long) CRTDLL__memicmp
239 @ cdecl _mkdir(str) CRTDLL__mkdir
244 @ cdecl _open(str long) CRTDLL__open
245 @ cdecl _open_osfhandle(long long) CRTDLL__open_osfhandle
246 @ extern _osmajor_dll CRTDLL_osmajor_dll
247 @ extern _osminor_dll CRTDLL_osminor_dll
248 @ extern _osmode_dll CRTDLL_osmode_dll
249 @ extern _osver_dll CRTDLL_osver_dll
250 @ extern _osversion_dll CRTDLL_osversion_dll
261 @ cdecl _read(long ptr long) CRTDLL__read
264 @ cdecl _rotl (long long) CRTDLL__rotl
269 @ cdecl _setjmp (ptr) CRTDLL__setjmp
270 @ cdecl _setmode(long long) CRTDLL__setmode
272 @ cdecl _sleep(long) CRTDLL__sleep
284 @ cdecl _splitpath (str ptr ptr ptr ptr) CRTDLL__splitpath
285 @ cdecl _stat (str ptr) CRTDLL__stat
287 @ cdecl _strcmpi(str str) CRTDLL__strcmpi
288 @ cdecl _strdate(str) CRTDLL__strdate
290 @ cdecl _strdup(str) CRTDLL__strdup
292 @ cdecl _stricmp(str str) CRTDLL__strcmpi
295 @ cdecl _strlwr(str) CRTDLL__strlwr
298 @ cdecl _strnicmp(str str long) CRTDLL__strnicmp
304 @ cdecl _strtime(str) CRTDLL__strtime
305 @ cdecl _strupr(str) CRTDLL__strupr
310 @ cdecl _tempnam(str ptr) CRTDLL__tempnam
316 @ cdecl _ultoa(long ptr long) CRTDLL__ultoa
320 @ cdecl _unlink(str) CRTDLL__unlink
325 @ cdecl _wcsdup(wstr) CRTDLL__wcsdup
326 @ cdecl _wcsicmp(wstr wstr) CRTDLL__wcsicmp
327 @ cdecl _wcsicoll(wstr wstr) CRTDLL__wcsicoll
328 @ cdecl _wcslwr(wstr) CRTDLL__wcslwr
329 @ cdecl _wcsnicmp(wstr wstr long) CRTDLL__wcsnicmp
330 @ cdecl _wcsnset(wstr long long) CRTDLL__wcsnset
331 @ cdecl _wcsrev(wstr) CRTDLL__wcsrev
332 @ cdecl _wcsset(wstr long) CRTDLL__wcsset
333 @ cdecl _wcsupr(wstr) CRTDLL__wcsupr
334 @ extern _winmajor_dll CRTDLL_winmajor_dll
335 @ extern _winminor_dll CRTDLL_winminor_dll
336 @ extern _winver_dll CRTDLL_winver_dll
337 @ cdecl _write(long ptr long) CRTDLL__write
340 @ cdecl _y0(double) y0
341 @ cdecl _y1(double) y1
342 @ cdecl _yn(long double) yn
344 @ cdecl abs(long) abs
345 @ cdecl acos(double) acos
346 @ cdecl asctime(ptr) asctime
347 @ cdecl asin(double) asin
348 @ cdecl atan(double) atan
349 @ cdecl atan2(double double) atan2
350 @ cdecl atexit(ptr) CRTDLL_atexit
351 @ cdecl atof(str) atof
352 @ cdecl atoi(str) atoi
353 @ cdecl atol(str) atol
354 @ cdecl bsearch(ptr ptr long long ptr) bsearch
355 @ cdecl calloc(long long) CRTDLL_calloc
356 @ cdecl ceil(double) ceil
358 @ cdecl clock() CRTDLL_clock
359 @ cdecl cos(double) cos
360 @ cdecl cosh(double) cosh
361 @ cdecl ctime(ptr) ctime
363 @ cdecl div(long long) div
364 @ cdecl exit(long) CRTDLL_exit
365 @ cdecl exp(double) exp
366 @ cdecl fabs(double) fabs
367 @ cdecl fclose(ptr) CRTDLL_fclose
368 @ cdecl feof(ptr) CRTDLL_feof
370 @ cdecl fflush(ptr) CRTDLL_fflush
371 @ cdecl fgetc(ptr) CRTDLL_fgetc
373 @ cdecl fgets(ptr long ptr) CRTDLL_fgets
375 @ cdecl floor(double) floor
376 @ cdecl fmod(double double) fmod
377 @ cdecl fopen(str str) CRTDLL_fopen
378 @ varargs fprintf(ptr str) CRTDLL_fprintf
379 @ cdecl fputc(long ptr) CRTDLL_fputc
380 @ cdecl fputs(str ptr) CRTDLL_fputs
382 @ cdecl fread(ptr long long ptr) CRTDLL_fread
383 @ cdecl free(ptr) CRTDLL_free
384 @ cdecl freopen(str str ptr) CRTDLL_freopen
385 @ cdecl frexp(double ptr) frexp
386 @ varargs fscanf(ptr str) CRTDLL_fscanf
387 @ cdecl fseek(ptr long long) CRTDLL_fseek
388 @ cdecl fsetpos(ptr ptr) CRTDLL_fsetpos
389 @ cdecl ftell(ptr) CRTDLL_ftell
391 @ cdecl fwrite(ptr long long ptr) CRTDLL_fwrite
393 @ cdecl getc(ptr) CRTDLL_getc
395 @ cdecl getenv (str) CRTDLL_getenv
396 @ cdecl gets(ptr) CRTDLL_gets
397 @ cdecl gmtime(ptr) gmtime
399 @ cdecl isalnum(long) isalnum
400 @ cdecl isalpha(long) isalpha
401 @ cdecl iscntrl(long) iscntrl
402 @ cdecl isdigit(long) isdigit
403 @ cdecl isgraph(long) isgraph
405 @ cdecl islower(long) islower
406 @ cdecl isprint(long) isprint
407 @ cdecl ispunct(long) ispunct
408 @ cdecl isspace(long) isspace
409 @ cdecl isupper(long) isupper
410 @ cdecl iswalnum(long) CRTDLL_iswalnum
411 @ cdecl iswalpha(long) CRTDLL_iswalpha
413 @ cdecl iswcntrl(long) CRTDLL_iswcntrl
414 @ cdecl iswctype(long long) CRTDLL_iswctype
415 @ cdecl iswdigit(long) CRTDLL_iswdigit
416 @ cdecl iswgraph(long) CRTDLL_iswgraph
417 @ cdecl iswlower(long) CRTDLL_iswlower
418 @ cdecl iswprint(long) CRTDLL_iswprint
419 @ cdecl iswpunct(long) CRTDLL_iswpunct
420 @ cdecl iswspace(long) CRTDLL_iswspace
421 @ cdecl iswupper(long) CRTDLL_iswupper
422 @ cdecl iswxdigit(long) CRTDLL_iswxdigit
423 @ cdecl isxdigit(long) isxdigit
424 @ cdecl labs(long) labs
425 @ cdecl ldexp(double long) ldexp
426 @ cdecl ldiv(long long) ldiv
428 @ cdecl localtime(ptr) localtime
429 @ cdecl log(double) log
430 @ cdecl log10(double) log10
431 @ cdecl longjmp(ptr long) CRTDLL_longjmp
432 @ cdecl malloc(ptr) CRTDLL_malloc
433 @ cdecl mblen(str long) mblen
434 @ cdecl mbstowcs(ptr str long) CRTDLL_mbstowcs
435 @ cdecl mbtowc(ptr ptr long) CRTDLL_mbtowc
436 @ cdecl memchr(ptr long long) memchr
437 @ cdecl memcmp(ptr ptr long) memcmp
438 @ cdecl memcpy(ptr ptr long) memcpy
439 @ cdecl memmove(ptr ptr long) memmove
440 @ cdecl memset(ptr long long) memset
441 @ cdecl mktime(ptr) mktime
442 @ cdecl modf(double ptr) modf
444 @ cdecl pow(double double) pow
445 @ varargs printf() printf
446 @ cdecl putc(long ptr) CRTDLL_putc
447 @ cdecl putchar(long) CRTDLL_putchar
448 @ cdecl puts(str) CRTDLL_puts
449 @ cdecl qsort(ptr long long ptr) qsort
451 @ cdecl rand() CRTDLL_rand
452 @ cdecl realloc(ptr long) CRTDLL_realloc
453 @ cdecl remove(str) CRTDLL_remove
454 @ cdecl rename(str str) CRTDLL_rename
457 @ cdecl setbuf(ptr ptr) CRTDLL_setbuf
458 @ cdecl setlocale(long ptr) CRTDLL_setlocale
460 @ cdecl signal(long ptr) CRTDLL_signal
461 @ cdecl sin(double) sin
462 @ cdecl sinh(double) sinh
463 @ varargs sprintf() sprintf
464 @ cdecl sqrt(double) sqrt
465 @ cdecl srand(long) CRTDLL_srand
466 @ varargs sscanf() sscanf
467 @ cdecl strcat(str str) strcat
468 @ cdecl strchr(str long) strchr
469 @ cdecl strcmp(str str) strcmp
470 @ cdecl strcoll(str str) strcoll
471 @ cdecl strcpy(ptr str) strcpy
472 @ cdecl strcspn(str str) strcspn
473 @ cdecl strerror(long) strerror
474 @ cdecl strftime(ptr long str ptr) strftime
475 @ cdecl strlen(str) strlen
476 @ cdecl strncat(str str long) strncat
477 @ cdecl strncmp(str str long) strncmp
478 @ cdecl strncpy(ptr str long) strncpy
479 @ cdecl strpbrk(str str) strpbrk
480 @ cdecl strrchr(str long) strrchr
481 @ cdecl strspn(str str) strspn
482 @ cdecl strstr(str str) strstr
483 @ cdecl strtod(str ptr) strtod
484 @ cdecl strtok(str str) strtok
485 @ cdecl strtol(str ptr long) strtol
486 @ cdecl strtoul(str ptr long) strtoul
487 @ cdecl strxfrm(ptr str long) strxfrm
488 @ varargs swprintf(wstr wstr) wsprintfW
490 @ cdecl system(str) CRTDLL_system
491 @ cdecl tan(double) tan
492 @ cdecl tanh(double) tanh
493 @ cdecl time(ptr) CRTDLL_time
495 @ cdecl tmpnam(str) CRTDLL_tmpnam
496 @ cdecl tolower(long) tolower
497 @ cdecl toupper(long) toupper
498 @ cdecl towlower(long) towlower
499 @ cdecl towupper(long) towupper
502 @ cdecl vfprintf(ptr str ptr) CRTDLL_vfprintf
505 @ cdecl vsprintf(ptr str ptr) CRTDLL_vsprintf
506 @ cdecl vswprintf(ptr wstr ptr) CRTDLL_vswprintf
508 @ cdecl wcscat(wstr wstr) CRTDLL_wcscat
509 @ cdecl wcschr(wstr long) CRTDLL_wcschr
510 @ cdecl wcscmp(wstr wstr) CRTDLL_wcscmp
511 @ cdecl wcscoll(wstr wstr) CRTDLL_wcscoll
512 @ cdecl wcscpy(ptr wstr) CRTDLL_wcscpy
513 @ cdecl wcscspn(wstr wstr) CRTDLL_wcscspn
515 @ cdecl wcslen(wstr) CRTDLL_wcslen
516 @ cdecl wcsncat(wstr wstr long) CRTDLL_wcsncat
517 @ cdecl wcsncmp(wstr wstr long) CRTDLL_wcsncmp
518 @ cdecl wcsncpy(ptr wstr long) CRTDLL_wcsncpy
519 @ cdecl wcspbrk(wstr wstr) CRTDLL_wcspbrk
520 @ cdecl wcsrchr(wstr long) CRTDLL_wcsrchr
521 @ cdecl wcsspn(wstr wstr) CRTDLL_wcsspn
522 @ cdecl wcsstr(wstr wstr) CRTDLL_wcsstr
524 @ cdecl wcstok(wstr wstr) CRTDLL_wcstok
525 @ cdecl wcstol(wstr ptr long) CRTDLL_wcstol
526 @ cdecl wcstombs(ptr ptr long) CRTDLL_wcstombs
529 @ cdecl wctomb(ptr long) CRTDLL_wctomb