4 1 stdcall @(str ptr) SHLWAPI_1
5 2 stdcall @(wstr ptr) SHLWAPI_2
6 3 stdcall @(str long) SHLWAPI_3
7 4 stdcall @(wstr long) SHLWAPI_4
8 5 stdcall @(str ptr long) SHLWAPI_5
9 6 stdcall @(wstr ptr long) SHLWAPI_6
10 7 stdcall @(long long ptr) SHLWAPI_7
11 8 stdcall @(long long) SHLWAPI_8
12 9 stdcall @(ptr) SHLWAPI_9
13 10 stdcall @(long long) SHLWAPI_10
14 11 stdcall @(long long long long long) SHLWAPI_11
16 13 stdcall @(ptr ptr) SHLWAPI_13
17 14 stdcall @(ptr ptr) SHLWAPI_14
18 15 stdcall @(ptr ptr) SHLWAPI_15
19 16 stdcall @(long long long long) SHLWAPI_16
21 18 stdcall @(ptr ptr) SHLWAPI_18
22 19 stdcall @(ptr) SHLWAPI_19
24 21 stdcall @(ptr long) SHLWAPI_21
25 22 stdcall @(ptr long) SHLWAPI_22
26 23 stdcall @(ptr ptr long) SHLWAPI_23
27 24 stdcall @(ptr ptr long) SHLWAPI_24
28 25 stdcall @(long) SHLWAPI_25
29 26 stdcall @(long) SHLWAPI_26
30 27 stdcall @(long) SHLWAPI_27
31 28 stdcall @(long) SHLWAPI_28
32 29 stdcall @(long) SHLWAPI_29
33 30 stdcall @(long) SHLWAPI_30
34 31 stdcall @(long) SHLWAPI_31
35 32 stdcall @(ptr) SHLWAPI_32
36 33 stdcall @(long) SHLWAPI_33
37 34 stdcall @(long) SHLWAPI_34
38 35 stdcall @(ptr long ptr) SHLWAPI_35
39 36 stdcall @(long long long wstr) SHLWAPI_36
40 37 forward @ user32.CallWindowProcW
41 38 forward @ user32.CharLowerW
42 39 forward @ user32.CharLowerBuffW
43 40 forward @ user32.CharNextW
44 41 forward @ user32.CharPrevW
46 43 forward @ user32.CharUpperW
47 44 forward @ user32.CharUpperBuffW
48 45 forward @ kernel32.CompareStringW
49 46 forward @ user32.CopyAcceleratorTableW
50 47 forward @ user32.CreateAcceleratorTableW
51 48 forward @ gdi32.CreateDCW
52 49 forward @ user32.CreateDialogParamA
53 50 forward @ kernel32.CreateDirectoryW
54 51 forward @ kernel32.CreateEventW
55 52 forward @ kernel32.CreateFileW
56 53 forward @ gdi32.CreateFontIndirectW
57 54 forward @ gdi32.CreateICW
58 55 forward @ user32.CreateWindowExW
59 56 forward @ user32.DefWindowProcW
60 57 forward @ kernel32.DeleteFileW
63 60 forward @ user32.DispatchMessageW
64 61 forward @ user32.DrawTextW
65 62 forward @ gdi32.EnumFontFamiliesW
66 63 forward @ gdi32.EnumFontFamiliesExW
67 64 forward @ kernel32.EnumResourceNamesW
68 65 forward @ kernel32.FindFirstFileW
69 66 forward @ kernel32.FindResourceW
70 67 forward @ user32.FindWindowW
71 68 forward @ kernel32.FormatMessageW
72 69 forward @ user32.GetClassInfoW
73 70 forward @ user32.GetClassLongW
74 71 forward @ user32.GetClassNameW
75 72 forward @ user32.GetClipboardFormatNameW
76 73 forward @ kernel32.GetCurrentDirectoryW
77 74 stdcall @(long long wstr long) SHLWAPI_74
78 75 forward @ kernel32.GetFileAttributesW
79 76 forward @ kernel32.GetFullPathNameW
80 77 forward @ kernel32.GetLocaleInfoW
81 78 forward @ user32.GetMenuStringW
82 79 forward @ user32.GetMessageW
83 80 forward @ kernel32.GetModuleFileNameW
84 81 forward @ kernel32.GetSystemDirectoryW
85 82 forward @ kernel32.SearchPathW
86 83 forward @ kernel32.GetModuleHandleW
87 84 forward @ gdi32.GetObjectW
88 85 forward @ kernel32.GetPrivateProfileIntW
89 86 forward @ kernel32.GetProfileStringW
90 87 forward @ user32.GetPropW
91 88 forward @ kernel32.GetStringTypeExW
92 89 forward @ kernel32.GetTempFileNameW
93 90 forward @ kernel32.GetTempPathW
94 91 forward @ gdi32.GetTextExtentPoint32W
95 92 forward @ gdi32.GetTextFaceW
96 93 forward @ gdi32.GetTextMetricsW
97 94 forward @ user32.GetWindowLongW
98 95 forward @ user32.GetWindowTextW
99 96 forward @ user32.GetWindowTextLengthW
100 97 forward @ kernel32.GetWindowsDirectoryW
101 98 forward @ user32.InsertMenuW
102 99 forward @ user32.IsDialogMessageW
103 100 forward @ user32.LoadAcceleratorsW
104 101 forward @ user32.LoadBitmapW
105 102 forward @ user32.LoadCursorW
106 103 forward @ user32.LoadIconW
107 104 forward @ user32.LoadImageW
108 105 forward @ kernel32.LoadLibraryExW
109 106 forward @ user32.LoadMenuW
110 107 forward @ user32.LoadStringW
111 108 forward @ user32.MessageBoxIndirectW
112 109 forward @ user32.ModifyMenuW
113 110 forward @ gdi32.GetCharWidth32W
114 111 forward @ gdi32.GetCharacterPlacementW
115 112 forward @ kernel32.CopyFileW
116 113 forward @ kernel32.MoveFileW
117 114 forward @ user32.OemToCharW
118 115 forward @ kernel32.OutputDebugStringW
119 116 forward @ user32.PeekMessageW
120 117 forward @ user32.PostMessageW
121 118 forward @ user32.PostThreadMessageW
122 119 forward @ advapi32.RegCreateKeyW
123 120 forward @ advapi32.RegCreateKeyExW
124 121 forward @ advapi32.RegDeleteKeyW
125 122 forward @ advapi32.RegEnumKeyW
126 123 forward @ advapi32.RegEnumKeyExW
127 124 forward @ advapi32.RegOpenKeyW
128 125 forward @ advapi32.RegOpenKeyExW
129 126 forward @ advapi32.RegQueryInfoKeyW
130 127 forward @ advapi32.RegQueryValueW
131 128 forward @ advapi32.RegQueryValueExW
132 129 forward @ advapi32.RegSetValueW
133 130 forward @ advapi32.RegSetValueExW
134 131 forward @ user32.RegisterClassW
135 132 forward @ user32.RegisterClipboardFormatW
136 133 forward @ user32.RegisterWindowMessageW
137 134 forward @ user32.RemovePropW
138 135 forward @ user32.SendDlgItemMessageW
139 136 forward @ user32.SendMessageW
140 137 forward @ kernel32.SetCurrentDirectoryW
143 140 forward @ user32.SetPropW
144 141 forward @ user32.SetWindowLongW
145 142 forward @ user32.SetWindowsHookExW
146 143 forward @ user32.SetWindowTextW
147 144 forward @ gdi32.StartDocW
148 145 forward @ user32.SystemParametersInfoW
149 146 forward @ user32.TranslateAcceleratorW
150 147 forward @ user32.UnregisterClassW
151 148 forward @ user32.VkKeyScanW
152 149 forward @ user32.WinHelpW
153 150 forward @ user32.wvsprintfW
154 151 stdcall @(str ptr long) SHLWAPI_151
155 152 stdcall @(wstr wstr long) SHLWAPI_152
156 153 stdcall @(long long long) SHLWAPI_153
157 154 stdcall @(wstr wstr long) SHLWAPI_154
158 155 stdcall @(str str) SHLWAPI_155
159 156 stdcall @(wstr wstr) SHLWAPI_156
161 158 stdcall @(wstr wstr) SHLWAPI_158
162 159 forward @ kernel32.CompareStringW
165 162 stdcall @(str long) SHLWAPI_162
167 164 stdcall @(ptr ptr ptr ptr ptr ptr) SHLWAPI_164
168 165 stdcall @(long long long long) SHLWAPI_165
172 169 stdcall @(long) SHLWAPI_169
173 170 stdcall @(str) SHLWAPI_170
175 172 stdcall @(ptr ptr) SHLWAPI_172
177 174 stdcall @(ptr ptr) SHLWAPI_174
178 175 stdcall @(ptr ptr) SHLWAPI_175
179 176 stdcall @(ptr ptr ptr ptr) SHLWAPI_176
184 181 stdcall @(long long long) SHLWAPI_181
186 183 stdcall @(ptr) SHLWAPI_183
196 193 stdcall @() SHLWAPI_193
202 199 stdcall @(ptr ptr) SHLWAPI_199
208 205 stdcall @(long str str ptr ptr ptr) SHLWAPI_205
209 206 stdcall @(long wstr wstr ptr ptr ptr) SHLWAPI_206
211 208 stdcall @(long long ptr ptr long) SHLWAPI_208
212 209 stdcall @(ptr) SHLWAPI_209
213 210 stdcall @(ptr long ptr) SHLWAPI_210
214 211 stdcall @(ptr long) SHLWAPI_211
218 215 stdcall @(long long long) SHLWAPI_215
220 217 stdcall @(wstr ptr ptr) SHLWAPI_217
221 218 stdcall @(long wstr ptr ptr) SHLWAPI_218
222 219 stdcall @(long long long long) SHLWAPI_219
225 222 stdcall @(long) SHLWAPI_222
226 223 stdcall @(long) SHLWAPI_223
239 236 stdcall @(ptr) SHLWAPI_236
240 237 stdcall @(ptr) SHLWAPI_237
242 239 stdcall @(long str long) SHLWAPI_239
243 240 stdcall @(long long long long) SHLWAPI_240
244 241 stdcall @() SHLWAPI_241
257 254 stub AssocQueryKeyA
258 255 stub AssocQueryKeyW
269 266 stdcall @(long long long long) SHLWAPI_266
270 267 stdcall @(long long long long) SHLWAPI_267
271 268 stdcall @(long long) SHLWAPI_268
279 276 stdcall @() SHLWAPI_276
281 278 stdcall @(long long long long long long) SHLWAPI_278
292 289 stdcall @(wstr long long) SHLWAPI_289
297 294 stdcall @(long long long long long) SHLWAPI_294
301 298 forward @ kernel32.WritePrivateProfileStringW
303 300 forward @ gdi32.CreateFontW
304 301 forward @ user32.DrawTextExW
305 302 forward @ user32.GetMenuItemInfoW
306 303 forward @ user32.InsertMenuItemW
307 304 forward @ gdi32.CreateMetaFileW
308 305 forward @ kernel32.CreateMutexW
309 306 forward @ kernel32.ExpandEnvironmentStringsW
310 307 forward @ kernel32.CreateSemaphoreW
311 308 forward @ kernel32.IsBadStringPtrW
312 309 forward @ kernel32.LoadLibraryW
313 310 forward @ kernel32.GetTimeFormatW
314 311 forward @ kernel32.GetDateFormatW
315 312 forward @ kernel32.GetPrivateProfileStringW
316 313 stdcall @(ptr long ptr long long) SHLWAPI_313
317 314 forward @ user32.RegisterClassExW
318 315 forward @ user32.GetClassInfoExW
319 316 stub SHCreateStreamOnFileAOld
320 317 stub SHCreateStreamOnFileWOld
321 318 stdcall @(long long wstr long) SHLWAPI_318
322 319 forward @ user32.FindWindowExW
323 320 stdcall @(str str) SHLWAPI_320
324 321 stdcall @(wstr wstr) SHLWAPI_321
325 322 stdcall @(str) SHLWAPI_322
326 323 stdcall @(wstr) SHLWAPI_323
335 332 forward @ user32.CallMsgFilterW
336 333 stdcall @(ptr) SHLWAPI_333
337 334 stdcall @(ptr wstr) SHLWAPI_334
338 335 stdcall @(ptr) SHLWAPI_335
339 336 stdcall @(ptr) SHLWAPI_336
340 337 stdcall @(wstr long ptr ptr long) SHLWAPI_337
341 338 forward @ kernel32.SetFileAttributesW
342 339 forward @ kernel32.GetNumberFormatW
343 340 forward @ user32.MessageBoxW
344 341 forward @ kernel32.FindNextFileW
345 342 stdcall @(ptr long long) SHInterlockedCompareExchange
349 346 stdcall @(wstr ptr long) SHLWAPI_346
350 347 forward @ advapi32.RegDeleteValueW
353 350 stdcall @(wstr ptr) SHLWAPI_350
354 351 stdcall @(wstr ptr long ptr) SHLWAPI_351
355 352 stdcall @(ptr wstr ptr ptr) SHLWAPI_352
359 356 stdcall @(long long long) SHLWAPI_356
360 357 stdcall @(wstr wstr wstr long long) SHLWAPI_357
361 358 stdcall @(ptr ptr ptr ptr ptr ptr) SHLWAPI_358
362 359 forward @ kernel32.OpenEventW
363 360 forward @ kernel32.RemoveDirectoryW
364 361 forward @ kernel32.GetShortPathNameW
365 362 forward @ advapi32.GetUserNameW
367 364 stdcall @(str str long) SHLWAPI_364
369 366 forward @ advapi32.RegEnumValueW
370 367 forward @ kernel32.WritePrivateProfileStructW
371 368 forward @ kernel32.GetPrivateProfileStructW
372 369 forward @ kernel32.CreateProcessW
373 370 stdcall @(long wstr long) SHLWAPI_370
379 376 stdcall @() SHLWAPI_376 # kernel32.GetUserDefaultUILanguage
380 377 stdcall @(str long long) SHLWAPI_377
381 378 stdcall @(wstr long long) SHLWAPI_378
384 381 stub AssocQueryStringA
385 382 stub AssocQueryStringByKeyA
386 383 stub AssocQueryStringByKeyW
387 384 stub AssocQueryStringW
388 385 stdcall ChrCmpIA(long long) ChrCmpIA
389 386 stdcall ChrCmpIW(long long) ChrCmpIW
390 387 stub ColorAdjustLuma
392 389 stdcall @(ptr) SHLWAPI_389
393 390 stdcall @(ptr ptr) SHLWAPI_390
394 391 stdcall @(ptr ptr ptr ptr ptr ) SHLWAPI_391
404 401 stdcall @(ptr) SHLWAPI_401
405 402 stdcall @(ptr) SHLWAPI_402
406 403 stdcall @(ptr) SHLWAPI_403
407 404 stdcall ColorHLSToRGB(long long long) ColorHLSToRGB
416 413 stdcall @(long) SHLWAPI_413
421 418 stdcall @(long) SHLWAPI_418
431 428 forward @ user32.TrackPopupMenuEx
434 431 stdcall @(long) SHLWAPI_431
437 434 forward @ user32.SendMessageTimeoutW
439 436 stdcall @(wstr ptr) SHLWAPI_436
440 437 stdcall @(long) SHLWAPI_437
445 442 forward @ kernel32.GetEnvironmentVariableW
446 443 forward @ kernel32.GetSystemWindowsDirectoryA
447 444 forward @ kernel32.GetSystemWindowsDirectoryW
448 445 stdcall ColorRGBToHLS(long ptr ptr ptr) ColorRGBToHLS
451 @ stdcall DllGetVersion (ptr) SHLWAPI_DllGetVersion
452 @ stdcall GetMenuPosFromID(ptr long) GetMenuPosFromID
453 @ stdcall HashData (ptr long ptr long) HashData
454 @ stub IntlStrEqWorkerA
455 @ stub IntlStrEqWorkerW
456 @ stdcall PathAddBackslashA (str) PathAddBackslashA
457 @ stdcall PathAddBackslashW (wstr) PathAddBackslashW
458 @ stdcall PathAddExtensionA (str str) PathAddExtensionA
459 @ stdcall PathAddExtensionW (wstr wstr) PathAddExtensionW
460 @ stdcall PathAppendA (str str) PathAppendA
461 @ stdcall PathAppendW (wstr wstr) PathAppendW
462 @ stdcall PathBuildRootA (ptr long) PathBuildRootA
463 @ stdcall PathBuildRootW (ptr long) PathBuildRootW
464 @ stdcall PathCanonicalizeA (ptr str) PathCanonicalizeA
465 @ stdcall PathCanonicalizeW (ptr wstr) PathCanonicalizeW
466 @ stdcall PathCombineA (ptr ptr ptr) PathCombineA
467 @ stdcall PathCombineW (ptr ptr ptr) PathCombineW
468 @ stdcall PathCommonPrefixA(str str ptr)PathCommonPrefixA
469 @ stdcall PathCommonPrefixW(wstr wstr ptr)PathCommonPrefixW
470 @ stdcall PathCompactPathA(long str long)PathCompactPathA
471 @ stdcall PathCompactPathExA(ptr str long long)PathCompactPathExA
472 @ stdcall PathCompactPathExW(ptr wstr long long)PathCompactPathExW
473 @ stdcall PathCompactPathW(long wstr long)PathCompactPathW
474 @ stdcall PathCreateFromUrlA(str ptr ptr long)PathCreateFromUrlA
475 @ stdcall PathCreateFromUrlW(wstr ptr ptr long)PathCreateFromUrlW
476 @ stdcall PathFileExistsA (str) PathFileExistsA
477 @ stdcall PathFileExistsW (wstr) PathFileExistsW
478 @ stdcall PathFindExtensionA (str) PathFindExtensionA
479 @ stdcall PathFindExtensionW (wstr) PathFindExtensionW
480 @ stdcall PathFindFileNameA (str) PathFindFileNameA
481 @ stdcall PathFindFileNameW (wstr) PathFindFileNameW
482 @ stdcall PathFindNextComponentA (str) PathFindNextComponentA
483 @ stdcall PathFindNextComponentW (wstr) PathFindNextComponentW
484 @ stdcall PathFindOnPathA (str ptr) PathFindOnPathA
485 @ stdcall PathFindOnPathW (wstr ptr) PathFindOnPathW
486 @ stdcall PathGetArgsA (str) PathGetArgsA
487 @ stdcall PathGetArgsW (wstr) PathGetArgsW
488 @ stdcall PathGetCharTypeA(long)PathGetCharTypeA
489 @ stdcall PathGetCharTypeW(long)PathGetCharTypeW
490 @ stdcall PathGetDriveNumberA (str) PathGetDriveNumberA
491 @ stdcall PathGetDriveNumberW (wstr) PathGetDriveNumberW
492 @ stdcall PathIsContentTypeA(str str)PathIsContentTypeA
493 @ stdcall PathIsContentTypeW(wstr wstr)PathIsContentTypeW
494 @ stdcall PathIsDirectoryA(str) PathIsDirectoryA
495 @ stdcall PathIsDirectoryW(wstr) PathIsDirectoryW
496 @ stdcall PathIsFileSpecA(str)PathIsFileSpecA
497 @ stdcall PathIsFileSpecW(wstr)PathIsFileSpecW
498 @ stdcall PathIsPrefixA(str str)PathIsPrefixA
499 @ stdcall PathIsPrefixW(wstr wstr)PathIsPrefixW
500 @ stdcall PathIsRelativeA (str) PathIsRelativeA
501 @ stdcall PathIsRelativeW (wstr) PathIsRelativeW
502 @ stdcall PathIsRootA(str) PathIsRootA
503 @ stdcall PathIsRootW(wstr) PathIsRootW
504 @ stdcall PathIsSameRootA(str str) PathIsSameRootA
505 @ stdcall PathIsSameRootW(wstr wstr) PathIsSameRootW
506 @ stdcall PathIsSystemFolderA(str long)PathIsSystemFolderA
507 @ stdcall PathIsSystemFolderW(wstr long)PathIsSystemFolderW
508 @ stdcall PathIsUNCA (str) PathIsUNCA
509 @ stdcall PathIsUNCServerA(str)PathIsUNCServerA
510 @ stdcall PathIsUNCServerShareA(str)PathIsUNCServerShareA
511 @ stdcall PathIsUNCServerShareW(wstr)PathIsUNCServerShareW
512 @ stdcall PathIsUNCServerW(wstr)PathIsUNCServerW
513 @ stdcall PathIsUNCW(wstr) PathIsUNCW
514 @ stdcall PathIsURLA(str) PathIsURLA
515 @ stdcall PathIsURLW(wstr) PathIsURLW
516 @ stdcall PathMakePrettyA(str) PathMakePrettyA
517 @ stdcall PathMakePrettyW(wstr) PathMakePrettyW
518 @ stdcall PathMakeSystemFolderA(str) PathMakeSystemFolderA
519 @ stdcall PathMakeSystemFolderW(wstr) PathMakeSystemFolderW
520 @ stdcall PathMatchSpecA (str str) PathMatchSpecA
521 @ stdcall PathMatchSpecW (wstr wstr) PathMatchSpecW
522 @ stdcall PathParseIconLocationA (str) PathParseIconLocationA
523 @ stdcall PathParseIconLocationW (wstr) PathParseIconLocationW
524 @ stdcall PathQuoteSpacesA (str) PathQuoteSpacesA
525 @ stdcall PathQuoteSpacesW (wstr) PathQuoteSpacesW
526 @ stdcall PathRelativePathToA(ptr str long str long)PathRelativePathToA
527 @ stdcall PathRelativePathToW(ptr str long str long)PathRelativePathToW
528 @ stdcall PathRemoveArgsA(str)PathRemoveArgsA
529 @ stdcall PathRemoveArgsW(wstr)PathRemoveArgsW
530 @ stdcall PathRemoveBackslashA (str) PathRemoveBackslashA
531 @ stdcall PathRemoveBackslashW (wstr) PathRemoveBackslashW
532 @ stdcall PathRemoveBlanksA(str) PathRemoveBlanksA
533 @ stdcall PathRemoveBlanksW(wstr) PathRemoveBlanksW
534 @ stdcall PathRemoveExtensionA(str)PathRemoveExtensionA
535 @ stdcall PathRemoveExtensionW(wstr)PathRemoveExtensionW
536 @ stdcall PathRemoveFileSpecA (str) PathRemoveFileSpecA
537 @ stdcall PathRemoveFileSpecW (wstr) PathRemoveFileSpecW
538 @ stdcall PathRenameExtensionA(str str)PathRenameExtensionA
539 @ stdcall PathRenameExtensionW(wstr wstr)PathRenameExtensionW
540 @ stdcall PathSearchAndQualifyA(str ptr long)PathSearchAndQualifyA
541 @ stdcall PathSearchAndQualifyW(wstr ptr long)PathSearchAndQualifyW
542 @ stdcall PathSetDlgItemPathA (long long ptr) PathSetDlgItemPathA
543 @ stdcall PathSetDlgItemPathW (long long ptr) PathSetDlgItemPathW
544 @ stdcall PathSkipRootA(str) PathSkipRootA
545 @ stdcall PathSkipRootW(wstr) PathSkipRootW
546 @ stdcall PathStripPathA(str) PathStripPathA
547 @ stdcall PathStripPathW(wstr) PathStripPathW
548 @ stdcall PathStripToRootA(str) PathStripToRootA
549 @ stdcall PathStripToRootW(wstr) PathStripToRootW
550 @ stdcall PathUnmakeSystemFolderA(str)PathUnmakeSystemFolderA
551 @ stdcall PathUnmakeSystemFolderW(wstr)PathUnmakeSystemFolderW
552 @ stdcall PathUnquoteSpacesA (str) PathUnquoteSpacesA
553 @ stdcall PathUnquoteSpacesW (wstr) PathUnquoteSpacesW
554 @ stdcall SHCreateShellPalette(long)SHCreateShellPalette
555 @ stdcall SHDeleteEmptyKeyA(long ptr) SHDeleteEmptyKeyA
556 @ stdcall SHDeleteEmptyKeyW(long ptr) SHDeleteEmptyKeyW
557 @ stdcall SHDeleteKeyA(long str) SHDeleteKeyA
558 @ stdcall SHDeleteKeyW(long wstr) SHDeleteKeyW
559 @ stdcall SHDeleteOrphanKeyA(long str) SHDeleteOrphanKeyA
560 @ stdcall SHDeleteOrphanKeyW(long wstr) SHDeleteOrphanKeyW
561 @ stdcall SHDeleteValueA(long str str) SHDeleteValueA
562 @ stdcall SHDeleteValueW(long wstr wstr) SHDeleteValueW
563 @ stdcall SHEnumKeyExA(long long str ptr) SHEnumKeyExA
564 @ stdcall SHEnumKeyExW(long long wstr ptr) SHEnumKeyExW
565 @ stdcall SHEnumValueA(long long str ptr ptr ptr ptr) SHEnumValueA
566 @ stdcall SHEnumValueW(long long wstr ptr ptr ptr ptr) SHEnumValueW
567 @ stdcall SHGetInverseCMAP ( ptr long ) SHGetInverseCMAP
568 @ stdcall SHGetValueA ( long str str ptr ptr ptr ) SHGetValueA
569 @ stdcall SHGetValueW ( long wstr wstr ptr ptr ptr ) SHGetValueW
570 @ stdcall SHIsLowMemoryMachine(long)SHIsLowMemoryMachine
571 @ stdcall SHOpenRegStreamA(long str str long)SHOpenRegStreamA
572 @ stdcall SHOpenRegStreamW(long wstr str long)SHOpenRegStreamW
573 @ stdcall SHOpenRegStream2A(long str str long)SHOpenRegStreamA
574 @ stdcall SHOpenRegStream2W(long wstr str long)SHOpenRegStreamW
575 @ stdcall SHQueryInfoKeyA(long ptr ptr ptr ptr) SHQueryInfoKeyA
576 @ stdcall SHQueryInfoKeyW(long ptr ptr ptr ptr) SHQueryInfoKeyW
577 @ stdcall SHQueryValueExA(long str ptr ptr ptr ptr) SHQueryValueExA
578 @ stdcall SHQueryValueExW(long wstr ptr ptr ptr ptr) SHQueryValueExW
579 @ stdcall SHRegCloseUSKey(ptr) SHRegCloseUSKey
580 @ stub SHRegCreateUSKeyA
581 @ stub SHRegCreateUSKeyW
582 @ stub SHRegDeleteEmptyUSKeyA
583 @ stub SHRegDeleteEmptyUSKeyW
584 @ stub SHRegDeleteUSValueA
585 @ stub SHRegDeleteUSValueW
586 @ stdcall SHRegEnumUSKeyA(long long str ptr long) SHRegEnumUSKeyA
587 @ stdcall SHRegEnumUSKeyW(long long wstr ptr long) SHRegEnumUSKeyW
588 @ stub SHRegEnumUSValueA
589 @ stub SHRegEnumUSValueW
590 @ stdcall SHRegGetBoolUSValueA(str str long long)SHRegGetBoolUSValueA
591 @ stdcall SHRegGetBoolUSValueW(wstr wstr long long)SHRegGetBoolUSValueW
592 @ stdcall SHRegGetUSValueA ( str str ptr ptr ptr long ptr long ) SHRegGetUSValueA
593 @ stdcall SHRegGetUSValueW ( wstr wstr ptr ptr ptr long ptr long ) SHRegGetUSValueW
594 @ stdcall SHRegOpenUSKeyA ( str long long long long ) SHRegOpenUSKeyA
595 @ stdcall SHRegOpenUSKeyW ( wstr long long long long ) SHRegOpenUSKeyW
596 @ stdcall SHRegQueryInfoUSKeyA ( long ptr ptr ptr ptr long ) SHRegQueryInfoUSKeyA
597 @ stdcall SHRegQueryInfoUSKeyW ( long ptr ptr ptr ptr long ) SHRegQueryInfoUSKeyW
598 @ stdcall SHRegQueryUSValueA ( long str ptr ptr ptr long ptr long ) SHRegQueryUSValueA
599 @ stdcall SHRegQueryUSValueW ( long wstr ptr ptr ptr long ptr long ) SHRegQueryUSValueW
600 @ stub SHRegSetUSValueA
601 @ stub SHRegSetUSValueW
602 @ stdcall SHRegWriteUSValueA (long str long ptr long long) SHRegWriteUSValueA
603 @ stdcall SHRegWriteUSValueW (long str long ptr long long) SHRegWriteUSValueW
604 @ stdcall SHSetValueA (long str str long ptr long) SHSetValueA
605 @ stdcall SHSetValueW (long wstr wstr long ptr long) SHSetValueW
606 @ stdcall StrCSpnA (str str) StrCSpnA
609 @ stdcall StrCSpnW (wstr wstr) StrCSpnW
610 @ stdcall StrCatBuffA (str str long) StrCatBuffA
611 @ stdcall StrCatBuffW (wstr wstr long) StrCatBuffW
612 @ stdcall StrCatW (ptr wstr) StrCatW
613 @ stdcall StrChrA (str long) StrChrA
616 @ stdcall StrChrW (wstr long) StrChrW
617 @ stdcall StrCmpIW (wstr wstr) StrCmpIW
618 @ stdcall StrCmpNA (str str long) StrCmpNA
619 @ stdcall StrCmpNIA (str str long) StrCmpNIA
620 @ stdcall StrCmpNIW (wstr wstr long) StrCmpNIW
621 @ stdcall StrCmpNW (wstr wstr long) StrCmpNW
622 @ stdcall StrCmpW (wstr wstr) StrCmpW
623 @ stdcall StrCpyNW (wstr wstr long) StrCpyNW
624 @ stdcall StrCpyW (ptr wstr) StrCpyW
625 @ stdcall StrDupA (str) StrDupA
626 @ stdcall StrDupW (wstr) StrDupW
627 @ stdcall StrFormatByteSizeA(long str long) StrFormatByteSizeA
628 @ stdcall StrFormatByteSizeW(long wstr long) StrFormatByteSizeW
629 @ stub StrFromTimeIntervalA
630 @ stub StrFromTimeIntervalW
631 @ stub StrIsIntlEqualA
632 @ stub StrIsIntlEqualW
633 @ stdcall StrNCatA(str str long) StrNCatA
634 @ stdcall StrNCatW(wstr wstr long) StrNCatW
637 @ stdcall StrRChrA (str str long) StrRChrA
638 @ stdcall StrRChrIA (str str long) StrRChrIA
639 @ stdcall StrRChrIW (str str long) StrRChrIW
640 @ stdcall StrRChrW (wstr wstr long) StrRChrW
645 @ stdcall StrStrA(str str)StrStrA
646 @ stdcall StrStrIA(str str)StrStrIA
647 @ stdcall StrStrIW(wstr wstr)StrStrIW
648 @ stdcall StrStrW(wstr wstr)StrStrW
649 @ stdcall StrToIntA(str)StrToIntA
650 @ stdcall StrToIntExA(str long ptr) StrToIntExA
651 @ stdcall StrToIntExW(wstr long ptr) StrToIntExW
652 @ stdcall StrToIntW(wstr)StrToIntW
653 @ stdcall StrTrimA(str str) StrTrimA
655 @ stdcall UrlApplySchemeA(str ptr ptr long) UrlApplySchemeA
656 @ stdcall UrlApplySchemeW(wstr ptr ptr long) UrlApplySchemeW
657 @ stdcall UrlCanonicalizeA(str ptr ptr long) UrlCanonicalizeA
658 @ stdcall UrlCanonicalizeW(wstr ptr ptr long) UrlCanonicalizeW
659 @ stdcall UrlCombineA(str str str ptr long) UrlCombineA
660 @ stdcall UrlCombineW(wstr wstr wstr ptr long) UrlCombineW
661 @ stdcall UrlCompareA(str str long) UrlCompareA
662 @ stdcall UrlCompareW(wstr wstr long) UrlCompareW
663 @ stub UrlCreateFromPathA
664 @ stub UrlCreateFromPathW
665 @ stdcall UrlEscapeA(str ptr ptr long)UrlEscapeA
666 @ stdcall UrlEscapeW(wstr ptr ptr long)UrlEscapeW
667 @ stdcall UrlGetLocationA(str) UrlGetLocationA
668 @ stdcall UrlGetLocationW(wstr) UrlGetLocationW
669 @ stdcall UrlGetPartA(str ptr ptr long long) UrlGetPartA
670 @ stdcall UrlGetPartW(wstr ptr ptr long long) UrlGetPartW
671 @ stdcall UrlHashA(str ptr long) UrlHashA
673 @ stdcall UrlIsA(str long) UrlIsA
674 @ stdcall UrlIsNoHistoryA(str) UrlIsNoHistoryA
675 @ stdcall UrlIsNoHistoryW(wstr) UrlIsNoHistoryW
676 @ stdcall UrlIsOpaqueA(str) UrlIsOpaqueA
677 @ stdcall UrlIsOpaqueW(wstr) UrlIsOpaqueW
678 @ stdcall UrlIsW(wstr long) UrlIsW
679 @ stdcall UrlUnescapeA(str ptr ptr long) UrlUnescapeA
680 @ stdcall UrlUnescapeW(wstr ptr ptr long) UrlUnescapeW
681 @ varargs wnsprintfA(ptr long str) wnsprintfA
682 @ varargs wnsprintfW(ptr long wstr) wnsprintfW
683 @ forward wvnsprintfA user32.wvsnprintfA
684 @ forward wvnsprintfW user32.wvsnprintfW
687 # exported in later versions
688 @ stdcall StrRetToBufA (ptr ptr ptr long) StrRetToBufA
689 @ stdcall StrRetToBufW (ptr ptr ptr long) StrRetToBufW
690 #@ stdcall StrRetToStrA (ptr ptr ptr) StrRetToStrA
691 #@ stdcall StrRetToStrW (ptr ptr ptr) StrRetToStrW
692 @ stdcall SHRegGetPathA(long str str ptr long)SHRegGetPathA
693 @ stdcall SHRegGetPathW(long wstr wstr ptr long)SHRegGetPathW
694 @ stub MLLoadLibraryA
695 @ stub MLLoadLibraryW
696 @ stdcall PathIsDirectoryEmptyA(str) PathIsDirectoryEmptyA
697 @ stdcall PathIsDirectoryEmptyW(wstr) PathIsDirectoryEmptyW
698 @ stdcall PathIsNetworkPathA(str) PathIsNetworkPathA
699 @ stdcall PathIsNetworkPathW(wstr) PathIsNetworkPathW
700 @ stdcall PathIsLFNFileSpecA(str) PathIsLFNFileSpecA
701 @ stdcall PathIsLFNFileSpecW(wstr) PathIsLFNFileSpecW
702 @ stdcall PathFindSuffixArrayA(str ptr long) PathFindSuffixArrayA
703 @ stdcall PathFindSuffixArrayW(wstr ptr long) PathFindSuffixArrayW
704 @ stdcall _SHGetInstanceExplorer@4(ptr) _SHGetInstanceExplorer
705 @ stdcall PathUndecorateA(str) PathUndecorateA
706 @ stdcall PathUndecorateW(wstr) PathUndecorateW
707 @ stub PathUnExpandEnvStringsA
708 @ stub PathUnExpandEnvStringsW
711 @ stub SHAutoComplete
712 @ stub SHCreateStreamOnFileA
713 @ stub SHCreateStreamOnFileW
714 @ stub SHCreateStreamWrapper
715 @ stub SHCreateThread
716 @ stdcall SHGetThreadRef (ptr) SHGetThreadRef
717 @ stdcall SHRegDuplicateHKey (long) SHRegDuplicateHKey
718 @ stdcall SHRegSetPathA(long str str str long) SHRegSetPathA
719 @ stdcall SHRegSetPathW(long wstr wstr wstr long) SHRegSetPathW
720 @ stub SHRegisterValidateTemplate
721 @ stdcall SHSetThreadRef (ptr) SHSetThreadRef
722 @ stub SHSkipJunction
725 @ stub StrFormatByteSize64A
726 @ stub StrFormatKBSizeA
727 @ stub StrFormatKBSizeW