Removed some unnecessary inclusions of wingdi.h and winuser.h
[wine] / dlls / crtdll / crtdll.spec
1 # C RunTime DLL. All functions use cdecl!
2 name    crtdll
3 type    win32
4 init    CRTDLL_Init
5
6 import  ntdll
7
8 @ cdecl ??2@YAPAXI@Z(long) CRTDLL_new
9 @ cdecl ??3@YAXPAX@Z(long) CRTDLL_delete
10 @ cdecl ?_set_new_handler@@YAP6AHI@ZP6AHI@Z@Z(ptr) CRTDLL_set_new_handler
11 @ stub _CIacos
12 @ stub _CIasin
13 @ stub _CIatan
14 @ stub _CIatan2
15 @ stub _CIcos
16 @ stub _CIcosh
17 @ stub _CIexp
18 @ stub _CIfmod
19 @ stub _CIlog
20 @ stub _CIlog10
21 @ forward _CIpow ntdll._CIpow
22 @ stub _CIsin
23 @ stub _CIsinh
24 @ stub _CIsqrt
25 @ stub _CItan
26 @ stub _CItanh
27 @ stub _HUGE_dll
28 @ stub _XcptFilter
29 @ cdecl __GetMainArgs(ptr ptr ptr long) CRTDLL__GetMainArgs
30 @ extern __argc_dll CRTDLL_argc_dll
31 @ extern __argv_dll CRTDLL_argv_dll
32 @ cdecl __dllonexit() CRTDLL___dllonexit
33 @ stub __doserrno
34 @ stub __fpecode
35 @ stub __isascii
36 @ stub __iscsym
37 @ stub __iscsymf
38 @ stub __mb_cur_max_dll
39 @ stub __pxcptinfoptrs
40 @ cdecl __threadhandle() GetCurrentThread
41 @ cdecl __threadid() GetCurrentThreadId
42 @ stub __toascii
43 @ cdecl _abnormal_termination() CRTDLL__abnormal_termination
44 @ cdecl _access(str long) CRTDLL__access
45 @ extern _acmdln_dll CRTDLL_acmdln_dll
46 @ stub _aexit_rtn_dll
47 @ stub _amsg_exit
48 @ stub _assert
49 @ extern _basemajor_dll CRTDLL_basemajor_dll
50 @ extern _baseminor_dll CRTDLL_baseminor_dll
51 @ extern _baseversion_dll CRTDLL_baseversion_dll
52 @ stub _beep
53 @ stub _beginthread
54 @ stub _c_exit
55 @ stub _cabs
56 @ cdecl _cexit(long) CRTDLL__cexit
57 @ stub _cgets
58 @ cdecl _chdir(str) CRTDLL__chdir
59 @ cdecl _chdrive(long) CRTDLL__chdrive
60 @ stub _chgsign
61 @ stub _chmod
62 @ stub _chsize
63 @ stub _clearfp
64 @ cdecl _close(long) CRTDLL__close
65 @ stub _commit
66 @ extern _commode_dll CRTDLL_commode_dll
67 @ stub _control87
68 @ stub _controlfp
69 @ stub _copysign
70 @ stub _cprintf
71 @ stub _cpumode_dll
72 @ stub _cputs
73 @ stub _creat
74 @ stub _cscanf
75 @ stub _ctype
76 @ stub _cwait
77 @ stub _daylight_dll
78 @ stub _dup
79 @ stub _dup2
80 @ stub _ecvt
81 @ stub _endthread
82 @ extern _environ_dll CRTDLL_environ_dll
83 @ stub _eof
84 @ cdecl _errno() CRTDLL__errno
85 @ cdecl _except_handler2(ptr ptr ptr ptr) CRTDLL__except_handler2
86 @ stub _execl
87 @ stub _execle
88 @ stub _execlp
89 @ stub _execlpe
90 @ stub _execv
91 @ stub _execve
92 @ stub _execvp
93 @ stub _execvpe
94 @ stub _exit
95 @ stub _expand
96 @ stub _fcloseall
97 @ stub _fcvt
98 @ cdecl _fdopen(long ptr) CRTDLL__fdopen
99 @ stub _fgetchar
100 @ stub _fgetwchar
101 @ stub _filbuf
102 @ stub _fileinfo_dll
103 @ stub _filelength
104 @ stub _fileno
105 @ stub _findclose
106 @ cdecl _findfirst(str ptr) CRTDLL__findfirst
107 @ cdecl _findnext(long ptr) CRTDLL__findnext
108 @ stub _finite
109 @ stub _flsbuf
110 @ stub _flushall
111 @ extern _fmode_dll CRTDLL_fmode_dll
112 @ stub _fpclass
113 @ stub _fpieee_flt
114 @ cdecl _fpreset() CRTDLL__fpreset
115 @ stub _fputchar
116 @ stub _fputwchar
117 @ cdecl _fsopen(str str long) CRTDLL__fsopen
118 @ cdecl _fstat(long ptr) CRTDLL__fstat
119 @ stub _ftime
120 @ forward _ftol ntdll._ftol
121 @ cdecl _fullpath(ptr str long) CRTDLL__fullpath
122 @ stub _futime
123 @ stub _gcvt
124 @ stub _get_osfhandle
125 @ stub _getch
126 @ stub _getche
127 @ cdecl _getcwd(ptr long) CRTDLL__getcwd
128 @ cdecl _getdcwd(long ptr long) CRTDLL__getdcwd
129 @ stub _getdiskfree
130 @ stub _getdllprocaddr
131 @ cdecl _getdrive() CRTDLL__getdrive
132 @ stub _getdrives
133 @ stub _getpid
134 @ stub _getsystime
135 @ stub _getw
136 @ cdecl _global_unwind2(ptr) CRTDLL__global_unwind2
137 @ stub _heapchk
138 @ stub _heapmin
139 @ stub _heapset
140 @ stub _heapwalk
141 @ cdecl _hypot(double double) hypot
142 @ cdecl _initterm(ptr ptr) CRTDLL__initterm
143 @ extern _iob CRTDLL_iob
144 @ cdecl _isatty(long) CRTDLL__isatty
145 @ cdecl _isctype(long long) CRTDLL__isctype
146 @ stub _ismbbalnum
147 @ stub _ismbbalpha
148 @ stub _ismbbgraph
149 @ stub _ismbbkalnum
150 @ stub _ismbbkana
151 @ stub _ismbbkpunct
152 @ stub _ismbblead
153 @ stub _ismbbprint
154 @ stub _ismbbpunct
155 @ stub _ismbbtrail
156 @ stub _ismbcalpha
157 @ stub _ismbcdigit
158 @ stub _ismbchira
159 @ stub _ismbckata
160 @ stub _ismbcl0
161 @ stub _ismbcl1
162 @ stub _ismbcl2
163 @ stub _ismbclegal
164 @ stub _ismbclower
165 @ stub _ismbcprint
166 @ stub _ismbcspace
167 @ stub _ismbcsymbol
168 @ stub _ismbcupper
169 @ stub _ismbslead
170 @ stub _ismbstrail
171 @ stub _isnan
172 @ forward _itoa ntdll._itoa
173 @ stub _itow
174 @ cdecl _j0(double) j0
175 @ cdecl _j1(double) j1
176 @ cdecl _jn(long double) jn
177 @ stub _kbhit
178 @ stub _lfind
179 @ stub _loaddll
180 @ cdecl _local_unwind2(ptr long) CRTDLL__local_unwind2
181 @ stub _locking
182 @ stub _logb
183 @ cdecl _lrotl (long long) CRTDLL__lrotl
184 @ stub _lrotr
185 @ stub _lsearch
186 @ cdecl _lseek(long long long) CRTDLL__lseek
187 @ forward _ltoa ntdll._ltoa
188 @ stub _ltow
189 @ cdecl _makepath (ptr str str str str) CRTDLL__makepath
190 @ stub _matherr
191 @ stub _mbbtombc
192 @ stub _mbbtype
193 @ stub _mbccpy
194 @ stub _mbcjistojms
195 @ stub _mbcjmstojis
196 @ stub _mbclen
197 @ stub _mbctohira
198 @ stub _mbctokata
199 @ stub _mbctolower
200 @ stub _mbctombb
201 @ stub _mbctoupper
202 @ stub _mbctype
203 @ stub _mbsbtype
204 @ cdecl _mbscat(str str) strcat
205 @ stub _mbschr
206 @ stub _mbscmp
207 @ cdecl _mbscpy(ptr str) strcpy
208 @ stub _mbscspn
209 @ stub _mbsdec
210 @ cdecl _mbsdup(str) CRTDLL__strdup
211 @ cdecl _mbsicmp(str str) CRTDLL__mbsicmp
212 @ cdecl _mbsinc(str) CRTDLL__mbsinc
213 @ cdecl _mbslen(str) CRTDLL__mbslen
214 @ stub _mbslwr
215 @ stub _mbsnbcat
216 @ stub _mbsnbcmp
217 @ stub _mbsnbcnt
218 @ stub _mbsnbcpy
219 @ stub _mbsnbicmp
220 @ stub _mbsnbset
221 @ stub _mbsncat
222 @ stub _mbsnccnt
223 @ stub _mbsncmp
224 @ stub _mbsncpy
225 @ stub _mbsnextc
226 @ stub _mbsnicmp
227 @ stub _mbsninc
228 @ stub _mbsnset
229 @ stub _mbspbrk
230 @ cdecl _mbsrchr(str long) CRTDLL__mbsrchr
231 @ stub _mbsrev
232 @ stub _mbsset
233 @ stub _mbsspn
234 @ stub _mbsspnp
235 @ stub _mbsstr
236 @ stub _mbstok
237 @ stub _mbstrlen
238 @ stub _mbsupr
239 @ stub _memccpy
240 @ forward _memicmp ntdll._memicmp
241 @ cdecl _mkdir(str) CRTDLL__mkdir
242 @ stub _mktemp
243 @ stub _msize
244 @ stub _nextafter
245 @ stub _onexit
246 @ cdecl _open(str long) CRTDLL__open
247 @ cdecl _open_osfhandle(long long) CRTDLL__open_osfhandle
248 @ extern _osmajor_dll CRTDLL_osmajor_dll
249 @ extern _osminor_dll CRTDLL_osminor_dll
250 @ extern _osmode_dll CRTDLL_osmode_dll
251 @ extern _osver_dll CRTDLL_osver_dll
252 @ extern _osversion_dll CRTDLL_osversion_dll
253 @ stub _pclose
254 @ stub _pctype_dll
255 @ stub _pgmptr_dll
256 @ stub _pipe
257 @ stub _popen
258 @ stub _purecall
259 @ stub _putch
260 @ stub _putenv
261 @ stub _putw
262 @ stub _pwctype_dll
263 @ cdecl _read(long ptr long) CRTDLL__read
264 @ stub _rmdir
265 @ stub _rmtmp
266 @ cdecl _rotl (long long) CRTDLL__rotl
267 @ stub _rotr
268 @ stub _scalb
269 @ stub _searchenv
270 @ stub _seterrormode
271 @ cdecl _setjmp (ptr) CRTDLL__setjmp
272 @ cdecl _setmode(long long) CRTDLL__setmode
273 @ stub _setsystime
274 @ cdecl _sleep(long) CRTDLL__sleep
275 @ stub _snprintf
276 @ stub _snwprintf
277 @ stub _sopen
278 @ stub _spawnl
279 @ stub _spawnle
280 @ stub _spawnlp
281 @ stub _spawnlpe
282 @ stub _spawnv
283 @ stub _spawnve
284 @ stub _spawnvp
285 @ stub _spawnvpe
286 @ cdecl _splitpath (str ptr ptr ptr ptr) CRTDLL__splitpath
287 @ cdecl _stat (str ptr) CRTDLL__stat
288 @ stub _statusfp
289 @ cdecl _strcmpi(str str) strcasecmp
290 @ cdecl _strdate(str) CRTDLL__strdate
291 @ stub _strdec
292 @ cdecl _strdup(str) CRTDLL__strdup
293 @ stub _strerror
294 @ cdecl _stricmp(str str) strcasecmp
295 @ stub _stricoll
296 @ stub _strinc
297 @ forward _strlwr ntdll._strlwr
298 @ stub _strncnt
299 @ stub _strnextc
300 @ cdecl _strnicmp(str str long) strncasecmp
301 @ stub _strninc
302 @ stub _strnset
303 @ stub _strrev
304 @ stub _strset
305 @ stub _strspnp
306 @ cdecl _strtime(str) CRTDLL__strtime
307 @ forward _strupr ntdll._strupr
308 @ stub _swab
309 @ stub _sys_errlist
310 @ stub _sys_nerr_dll
311 @ stub _tell
312 @ cdecl _tempnam(str ptr) CRTDLL__tempnam
313 @ stub _timezone_dll
314 @ stub _tolower
315 @ stub _toupper
316 @ stub _tzname
317 @ stub _tzset
318 @ forward _ultoa ntdll._ultoa
319 @ stub _ultow
320 @ stub _umask
321 @ stub _ungetch
322 @ cdecl _unlink(str) CRTDLL__unlink
323 @ stub _unloaddll
324 @ stub _utime
325 @ cdecl _vsnprintf(ptr long ptr ptr) vsnprintf
326 @ stub _vsnwprintf
327 @ cdecl _wcsdup(wstr) CRTDLL__wcsdup
328 @ forward _wcsicmp ntdll._wcsicmp
329 @ cdecl _wcsicoll(wstr wstr) CRTDLL__wcsicoll
330 @ forward _wcslwr forward._wcslwr
331 @ forward _wcsnicmp forward._wcsnicmp
332 @ cdecl _wcsnset(wstr long long) CRTDLL__wcsnset
333 @ cdecl _wcsrev(wstr) CRTDLL__wcsrev
334 @ cdecl _wcsset(wstr long) CRTDLL__wcsset
335 @ forward _wcsupr ntdll._wcsupr
336 @ extern _winmajor_dll CRTDLL_winmajor_dll
337 @ extern _winminor_dll CRTDLL_winminor_dll
338 @ extern _winver_dll CRTDLL_winver_dll
339 @ cdecl _write(long ptr long) CRTDLL__write
340 @ stub _wtoi
341 @ stub _wtol
342 @ cdecl _y0(double) y0
343 @ cdecl _y1(double) y1
344 @ cdecl _yn(long double) yn
345 @ stub abort
346 @ cdecl abs(long) abs
347 @ cdecl acos(double) acos
348 @ cdecl asctime(ptr) asctime
349 @ cdecl asin(double) asin
350 @ cdecl atan(double) atan
351 @ cdecl atan2(double double) atan2
352 @ cdecl atexit(ptr) CRTDLL_atexit
353 @ cdecl atof(str) atof
354 @ cdecl atoi(str) atoi
355 @ cdecl atol(str) atol
356 @ cdecl bsearch(ptr ptr long long ptr) bsearch
357 @ cdecl calloc(long long) CRTDLL_calloc
358 @ cdecl ceil(double) ceil
359 @ stub clearerr
360 @ cdecl clock() CRTDLL_clock
361 @ cdecl cos(double) cos
362 @ cdecl cosh(double) cosh
363 @ cdecl ctime(ptr) ctime
364 @ cdecl difftime(long long) CRTDLL_difftime
365 @ cdecl div(long long) div
366 @ cdecl exit(long) CRTDLL_exit
367 @ cdecl exp(double) exp
368 @ cdecl fabs(double) fabs
369 @ cdecl fclose(ptr) CRTDLL_fclose
370 @ cdecl feof(ptr) CRTDLL_feof
371 @ stub ferror
372 @ cdecl fflush(ptr) CRTDLL_fflush
373 @ cdecl fgetc(ptr) CRTDLL_fgetc
374 @ stub fgetpos
375 @ cdecl fgets(ptr long ptr) CRTDLL_fgets
376 @ stub fgetwc
377 @ cdecl floor(double) floor
378 @ cdecl fmod(double double) fmod
379 @ cdecl fopen(str str) CRTDLL_fopen
380 @ varargs fprintf(ptr str) CRTDLL_fprintf
381 @ cdecl fputc(long ptr) CRTDLL_fputc
382 @ cdecl fputs(str ptr) CRTDLL_fputs
383 @ stub fputwc
384 @ cdecl fread(ptr long long ptr) CRTDLL_fread
385 @ cdecl free(ptr) CRTDLL_free
386 @ cdecl freopen(str str ptr) CRTDLL_freopen
387 @ cdecl frexp(double ptr) frexp
388 @ varargs fscanf(ptr str) CRTDLL_fscanf
389 @ cdecl fseek(ptr long long) CRTDLL_fseek
390 @ cdecl fsetpos(ptr ptr) CRTDLL_fsetpos
391 @ cdecl ftell(ptr) CRTDLL_ftell
392 @ stub fwprintf
393 @ cdecl fwrite(ptr long long ptr) CRTDLL_fwrite 
394 @ stub fwscanf
395 @ cdecl getc(ptr) CRTDLL_getc
396 @ stub getchar
397 @ cdecl getenv (str) CRTDLL_getenv
398 @ cdecl gets(ptr) CRTDLL_gets
399 @ cdecl gmtime(ptr) gmtime
400 @ stub is_wctype
401 @ cdecl isalnum(long) isalnum
402 @ cdecl isalpha(long) isalpha
403 @ cdecl iscntrl(long) iscntrl
404 @ cdecl isdigit(long) isdigit
405 @ cdecl isgraph(long) isgraph
406 @ stub isleadbyte
407 @ cdecl islower(long) islower
408 @ cdecl isprint(long) isprint
409 @ cdecl ispunct(long) ispunct
410 @ cdecl isspace(long) isspace
411 @ cdecl isupper(long) isupper
412 @ cdecl iswalnum(long) CRTDLL_iswalnum
413 @ forward iswalpha ntdll.iswalpha
414 @ stub iswascii
415 @ cdecl iswcntrl(long) CRTDLL_iswcntrl
416 @ forward iswctype ntdll.iswctype
417 @ cdecl iswdigit(long) CRTDLL_iswdigit
418 @ cdecl iswgraph(long) CRTDLL_iswgraph
419 @ cdecl iswlower(long) CRTDLL_iswlower
420 @ cdecl iswprint(long) CRTDLL_iswprint
421 @ cdecl iswpunct(long) CRTDLL_iswpunct
422 @ cdecl iswspace(long) CRTDLL_iswspace
423 @ cdecl iswupper(long) CRTDLL_iswupper
424 @ cdecl iswxdigit(long) CRTDLL_iswxdigit
425 @ cdecl isxdigit(long) isxdigit
426 @ cdecl labs(long) labs
427 @ cdecl ldexp(double long) ldexp
428 @ cdecl ldiv(long long) ldiv
429 @ stub localeconv
430 @ cdecl localtime(ptr) localtime
431 @ cdecl log(double) log
432 @ cdecl log10(double) log10
433 @ cdecl longjmp(ptr long) CRTDLL_longjmp
434 @ cdecl malloc(ptr) CRTDLL_malloc
435 @ cdecl mblen(str long) mblen
436 @ forward mbstowcs ntdll.mbstowcs
437 @ cdecl mbtowc(ptr ptr long) CRTDLL_mbtowc
438 @ cdecl memchr(ptr long long) memchr
439 @ cdecl memcmp(ptr ptr long) memcmp
440 @ cdecl memcpy(ptr ptr long) memcpy
441 @ cdecl memmove(ptr ptr long) memmove
442 @ cdecl memset(ptr long long) memset 
443 @ cdecl mktime(ptr) mktime
444 @ cdecl modf(double ptr) modf
445 @ stub perror
446 @ cdecl pow(double double) pow
447 @ varargs printf() printf
448 @ cdecl putc(long ptr) CRTDLL_putc
449 @ cdecl putchar(long) CRTDLL_putchar
450 @ cdecl puts(str) CRTDLL_puts
451 @ cdecl qsort(ptr long long ptr) qsort
452 @ stub raise
453 @ cdecl rand() CRTDLL_rand
454 @ cdecl realloc(ptr long) CRTDLL_realloc
455 @ cdecl remove(str) CRTDLL_remove
456 @ cdecl rename(str str) CRTDLL_rename
457 @ stub rewind
458 @ stub scanf
459 @ cdecl setbuf(ptr ptr) CRTDLL_setbuf
460 @ cdecl setlocale(long ptr) CRTDLL_setlocale
461 @ stub setvbuf
462 @ cdecl signal(long ptr) CRTDLL_signal
463 @ cdecl sin(double) sin
464 @ cdecl sinh(double) sinh
465 @ varargs sprintf() sprintf
466 @ cdecl sqrt(double) sqrt
467 @ cdecl srand(long) CRTDLL_srand
468 @ varargs sscanf() sscanf
469 @ cdecl strcat(str str) strcat
470 @ cdecl strchr(str long) strchr
471 @ cdecl strcmp(str str) strcmp
472 @ cdecl strcoll(str str) strcoll
473 @ cdecl strcpy(ptr str) strcpy
474 @ cdecl strcspn(str str) strcspn
475 @ cdecl strerror(long) strerror
476 @ cdecl strftime(ptr long str ptr) strftime
477 @ cdecl strlen(str) strlen
478 @ cdecl strncat(str str long) strncat
479 @ cdecl strncmp(str str long) strncmp
480 @ cdecl strncpy(ptr str long) strncpy
481 @ cdecl strpbrk(str str) strpbrk
482 @ cdecl strrchr(str long) strrchr
483 @ cdecl strspn(str str) strspn
484 @ cdecl strstr(str str) strstr
485 @ cdecl strtod(str ptr) strtod
486 @ cdecl strtok(str str) strtok
487 @ cdecl strtol(str ptr long) strtol
488 @ cdecl strtoul(str ptr long) strtoul
489 @ cdecl strxfrm(ptr str long) strxfrm
490 @ varargs swprintf(wstr wstr) wsprintfW
491 @ stub swscanf
492 @ cdecl system(str) CRTDLL_system
493 @ cdecl tan(double) tan
494 @ cdecl tanh(double) tanh
495 @ cdecl time(ptr) CRTDLL_time
496 @ stub tmpfile
497 @ cdecl tmpnam(str) CRTDLL_tmpnam
498 @ cdecl tolower(long) tolower
499 @ cdecl toupper(long) toupper
500 @ forward towlower ntdll.towlower
501 @ forward towupper ntdll.towupper
502 @ stub ungetc
503 @ stub ungetwc
504 @ cdecl vfprintf(ptr str ptr) CRTDLL_vfprintf
505 @ stub vfwprintf
506 @ stub vprintf
507 @ cdecl vsprintf(ptr str ptr) vsprintf
508 @ cdecl vswprintf(ptr wstr ptr) CRTDLL_vswprintf
509 @ stub vwprintf
510 @ forward wcscat ntdll.wcscat
511 @ forward wcschr ntdll.wcschr
512 @ forward wcscmp ntdll.wcscmp
513 @ cdecl wcscoll(wstr wstr) CRTDLL_wcscoll
514 @ forward wcscpy ntdll.wcscpy
515 @ forward wcscspn ntdll.wcscspn
516 @ stub wcsftime
517 @ forward wcslen ntdll.wcslen
518 @ forward wcsncat ntdll.wcsncat
519 @ forward wcsncmp ntdll.wcsncmp
520 @ forward wcsncpy ntdll.wcsncpy
521 @ cdecl wcspbrk(wstr wstr) CRTDLL_wcspbrk
522 @ forward wcsrchr ntdll.wcsrchr
523 @ forward wcsspn ntdll.wcsspn
524 @ forward wcsstr ntdll.wcsstr
525 @ stub wcstod
526 @ forward wcstok ntdll.wcstok
527 @ forward wcstol ntdll.wcstol
528 @ forward wcstombs ntdll.wcstombs
529 @ stub wcstoul
530 @ stub wcsxfrm
531 @ cdecl wctomb(ptr long) CRTDLL_wctomb
532 @ stub wprintf
533 @ stub wscanf