oleaut32: Add a test for loading/saving an empty picture.
[wine] / dlls / setupx.dll16 / setupx.dll16.spec
1 #1    stub     WEP
2 2    pascal -ret16 IpOpen(str ptr) IpOpen16
3 3    stub     IpOpenAppend #(str word)
4 4    pascal -ret16 IpClose(word) IpClose16
5 5    stub     IpGetLongField #(word ptr word ptr)
6 6    stub     IpGetStringField #(word ptr word ptr word ptr)
7 7    stub     IpFindFirstLine #(word str str ptr)
8 8    stub     IpGetLineCount #(word str ptr)
9 9    stub     IpGetFieldCount #(word ptr ptr)
10 10   stub     IpGetIntField #(word ptr word ptr)
11 11   stub     IpFindNextLine #(word ptr)
12 12   stub     IpGetFileName #(word ptr word)
13 13   pascal -ret16 VcpQueueCopy(str str str str word word ptr word long) VcpQueueCopy16
14 14   stub     NOAUTORUNWNDPROC
15 15   stub     __DEBUGMSG
16 16   stub     __ASSERTMSG
17 17   pascal -ret16 VcpQueueDelete(str str word long) VcpQueueDelete16
18 18   stub     TpOpenFile #(str ptr word)
19 19   stub     TpCloseFile #(word)
20 20   stub     TpOpenSection #(word ptr str word)
21 21   stub     TpCloseSection #(word)
22 22   stub     TpCommitSection #(word word str word)
23 23   stub     TpGetLine #(word str str word word ptr)
24 24   stub     TpGetNextLine #(word str str ptr)
25 25   stub     TpInsertLine #(word str str word word word)
26 26   stub     TpReplaceLine #(word str str word word word)
27 27   stub     TpDeleteLine #(word word word word)
28 28   stub     TpMoveLine #(word word word word word word)
29 29   stub     TpGetLineContents #(word ptr word ptr word word word)
30 30   stub     TpGetPrivateProfileString #(str str str ptr word str)
31 31   stub     TpWritePrivateProfileString #(str str str str)
32 32   stub     TpGetProfileString #(str str str ptr word)
33 33   pascal -ret16 CtlSetLdd(ptr) CtlSetLdd16
34 34   pascal -ret16 CtlGetLdd(ptr) CtlGetLdd16
35 35   pascal -ret16 CtlFindLdd(ptr) CtlFindLdd16
36 36   pascal -ret16 CtlAddLdd(ptr) CtlAddLdd16
37 37   pascal -ret16 CtlDelLdd(word) CtlDelLdd16
38 38   pascal -ret16 CtlGetLddPath(word ptr) CtlGetLddPath16
39 39   stub     SURegCloseKey #(word)
40 40   stub     SURegCreateKey #(word)
41 41   stub     SURegDeleteKey #(word str)
42 42   stub     SURegDeleteValue #(word str)
43 43   stub     SURegEnumKey #(word long ptr long)
44 44   stub     SURegEnumValue #(word long str ptr ptr ptr ptr ptr)
45 45   stub     SURegFlush #()
46 46   stub     SURegInit #()
47 47   pascal   SURegOpenKey(word str ptr) SURegOpenKey
48 48   stub     SURegQueryValue
49 49   stub     SURegQueryValue16 #(word str ptr ptr)
50 50   pascal   SURegQueryValueEx(long str ptr ptr ptr ptr) SURegQueryValueEx
51 51   stub     SURegSetValue
52 52   stub     SURegSetValue16 #(word str long ptr long)
53 53   stub     SURegSetValueEx #(word str long long ptr long)
54 54   stub     SURegSaveKey #(word str ptr)
55 55   stub     SURegLoadKey #(word str str)
56 56   stub     SURegUnLoadKey #(word str)
57 60   stub     DiskInfoFromLdid #(word ptr)
58 61   pascal   suErrorToIds(word word) suErrorToIds16
59 62   pascal -ret16 TPWriteProfileString(str str str) TPWriteProfileString16
60 63   stub     SURPLSETUP
61 # does SUSTORELDIDPATH set the path of an LDID in the registry ?
62 64   stub     SUSTORELDIDPATH
63 65   stub     WILDCARDSTRCMPI
64 101  pascal -ret16 GenInstall(word str word) GenInstall16
65 102  stub     GenWinInitRename #(str str word)
66 103  pascal   GenFormStrWithoutPlaceHolders(str str word) GenFormStrWithoutPlaceHolders16
67 104  stub     SETUPX
68 105  stub     CfgSetupMerge #(word)
69 106  stub     INITDEPENDANTLDIDS
70 107  stub     CFGOBJFINDKEYCMD
71 108  stub     GenSURegSetValueEx
72 109  stub     GENINSTALLWITHQUEUE
73 110  stub     GenInstallEx #(word str word word ptr long)
74 111  stub     GenCopyLogConfig2Reg #(word word str)
75 112  stub     SUGetSetSetupFlags #(ptr word)
76 114  stub     CFGPARSELINE # returns array
77 115  stub     CFGSETAUTOPROCESS
78 116  stub     CFGOBJTOSTR
79 117  stub     CFGLNTOOBJ
80 118  stub     MATCHCMDEXT
81 119  stub     IpFindNextMatchLine #(word str ptr)
82 120  stub     P_SETDEFAULTOPTION
83 121  stub     CFGCLEANBOOT
84 122  stub     CFGMATCHCMDEXT
85 123  stub     CFGWASFILEUPDATED
86 124  stub     AUTOMATCHCMDEXT
87 125  stub     P_VALIDATEOC
88 126  stub     GENMAPROOTREGSTR2KEY
89 127  stub     P_CDROMOC
90 128  stub     P_MEDIAOC
91 129  stub     CFGCLEAN1STBOOT
92 130  stub     suFormatMessage
93 131  stub     suvFormatMessage #(word str str word ptr)
94 132  stub     suFormatMessageBox
95 #133  stub     suHelp # W98SE conflict !!
96 135  stub     suHelp #(word word)
97 #135  stub     P_WEBTVOC # W98SE conflict !!
98 136  stub     P_WBEMOC
99 137  stub     P_THEMESOC
100 138  stub     P_IMAGINGOC
101 139  stub     P_SCHEMESOC
102 140  stub     suVerConflict #(word ptr word ptr)
103 141  stub     suVerConflictInit #(word)
104 142  stub     suVerConflictTerm #(ptr)
105 # Emergency Boot Disk
106 143  stub     suCreateEBD #(word ptr long)
107 144  stub     suCopyToEBD
108 145  stub     sxIsMSDOS7Running #()
109 150  stub     DS_INIT
110 151  stub     DS_DESTROY
111 152  stub     DS_SSYNCDRIVES
112 153  stub     DS_GETDRIVEDATA
113 154  stub     DS_ADDSECTION
114 155  stub     DS_ENABLESECTION
115 156  stub     DS_DISABLESECTION
116 157  stub     DS_SETSWAPSIZE
117 158  stub     DS_SETREQUIREDPAD
118 159  stub     DS_SETAVAILABLEPAD
119 160  stub     SXUPDATEDS
120 170  stub     SUSETMEM
121 171  stub     WriteDMFBootData #(word ptr word)
122 200  pascal   VcpOpen(segptr ptr) VcpOpen16
123 201  pascal   VcpClose(word str) VcpClose16
124 202  pascal -ret16 vcpDefCallbackProc(ptr word word long long) vcpDefCallbackProc16
125 203  pascal   VcpEnumFiles(ptr long)
126 204  pascal -ret16 VcpQueueRename(str str str str word word long) VcpQueueRename16
127 205  pascal -ret16 vsmGetStringName(word ptr word) vsmGetStringName16
128 206  pascal -ret16 vsmStringDelete(word) vsmStringDelete16
129 207  pascal -ret16 vsmStringAdd(str) vsmStringAdd16
130 208  pascal   vsmGetStringRawName(word) vsmGetStringRawName16
131 209  stub     IpSaveRestorePosition #(word word)
132 210  pascal -ret16 IpGetProfileString(word str str ptr word) IpGetProfileString16
133 211  stub     IpOpenEx #(str ptr word)
134 212  stub     IpOpenAppendEx #(str word word)
135 213  pascal -ret16 vcpUICallbackProc(ptr word word long long) vcpUICallbackProc16
136 214  stub     VcpAddMRUPath #(str)
137 300  pascal -ret16 DiBuildCompatDrvList (ptr) DiBuildCompatDrvList16
138 301  pascal -ret16 DiBuildClassDrvList (ptr) DiBuildClassDrvList16
139 302  stub     DiDestroyDriverNodeList #(ptr)
140 303  pascal -ret16 DiCreateDeviceInfo (ptr str long long str str word) DiCreateDeviceInfo16
141 304  pascal -ret16 DiGetClassDevs(ptr str word word) DiGetClassDevs16
142 305  pascal -ret16 DiDestroyDeviceInfoList (ptr) DiDestroyDeviceInfoList16
143 306  stub     DiRemoveDevice #(ptr)
144 308  pascal -ret16 DiCallClassInstaller (word ptr) DiCallClassInstaller16
145 309  stub     DiCreateDriverNode #(ptr word word word str str str str str str long)
146 310  stub     DiDrawMiniIcon
147 311  stub     DiGetClassBitmapIndex #(str ptr)
148 312  stub     DiSelectDevice #(ptr)
149 313  stub     DiInstallDevice #(ptr)
150 314  stub     DiLoadClassIcon #(str ptr ptr)
151 315  stub     DiAskForOEMDisk #(ptr)
152 316  stub     Display_SetMode #(ptr word word word)
153 317  stub     Display_ClassInstaller #(word ptr)
154 318  pascal -ret16 DiCreateDevRegKey (ptr ptr word str word) DiCreateDevRegKey16
155 319  pascal -ret16 DiOpenDevRegKey (ptr ptr word) DiOpenDevRegKey16
156 320  stub     DiInstallDrvSection #(str str str str long)
157 321  pascal -ret16 DiInstallClass (str long) DiInstallClass16
158 322  stub     DiOpenClassRegKey #(ptr str)
159 323  stub     Display_SetFontSize #(str)
160 324  stub     Display_OpenFontSizeKey #(ptr)
161 325  stub     DiBuildClassDrvListFromOldInf #(ptr str ptr long)
162 326  stub     DiIsThereNeedToCopy #(word long)
163 333  stub     DiChangeState #(ptr long long long)
164 334  stub     WALKSUBTREE
165 340  stub     GetFctn #(word str str ptr ptr)
166 341  stub     DiBuildClassInfoList #(ptr)
167 342  stub     DiDestroyClassInfoList #(ptr)
168 343  stub     DiGetDeviceClassInfo #(ptr ptr)
169 344  pascal -ret16 DiDeleteDevRegKey (ptr word) DiDeleteDevRegKey16
170 350  stub     DiSelectOEMDrv #(word ptr)
171 351  stub     DiGetINFClass #(str word str long)
172 353  stub     DIPICKBESTDRIVER
173 355  stub     COPYINFFILE
174 360  stub     GenInfLCToDevNode #(word str  word word long)
175 361  stub     GETDOSMESSAGE
176 362  stub     Mouse_ClassInstaller #(word ptr)
177 363  stub     sxCompareDosAppVer #(str str)
178 364  stub     MONITOR_CLASSINSTALLER
179 365  stub     FCEGETRESDESOFFSET
180 366  stub     FCEGETALLOCVALUE
181 367  stub     FCEADDRESDES
182 368  stub     FCEDELETERESDES
183 369  stub     FCEINIT
184 370  stub     FCEGETRESDES
185 371  stub     FCEGETFIRSTVALUE
186 372  stub     FCEGETOTHERVALUE
187 373  stub     FCEGETVALIDATEVALUE
188 374  stub     FCEWRITETHISFORCEDCONFIGNOW
189 375  stub     SUCreatePropertySheetPage #(ptr)
190 376  stub     SUDestroyPropertySheetPage #(word)
191 377  stub     SUPropertySheet #(ptr)
192 380  stub     DiReadRegLogConf #(ptr str ptr ptr)
193 381  stub     DiReadRegConf #(ptr ptr ptr long)
194 390  stub     DiBuildPotentialDuplicatesList #(ptr ptr long ptr ptr)
195 395  stub     InitSubstrData #(ptr str)
196 396  stub     GetFirstSubstr #(ptr)
197 397  stub     GetNextSubstr #(ptr)
198 398  stub     INITSUBSTRDATAEX
199 400  stub     bIsFileInVMM32 #(str)
200 401  stub     DiInstallDriverFiles #(ptr)
201 405  stub     DiBuildClassInfoListEx #(ptr long)
202 406  stub     DiGetClassDevsEx #(ptr str str word word)
203 407  stub     DiCopyRegSubKeyValue #(word str str str)
204 408  stub     IPGETDRIVERDATE
205 409  stub     IPGETDRIVERVERSION
206 410  stub     IpGetVersionString #(str str ptr word str)
207 411  pascal   VcpExplain(ptr long) VcpExplain16
208 412  stub     DiBuildDriverIndex #(word)
209 413  stub     DiAddSingleInfToDrvIdx #(str word word)
210 414  stub     FCEGETFLAGS
211 450  stub     UiMakeDlgNonBold #(word)
212 451  stub     UiDeleteNonBoldFont #(word)
213 500  stub     SUEBDPAGE
214 501  stub     SUOCPAGE
215 502  stub     SXLISTSUBPROC
216 503  stub     SXFILLLB
217 504  stub     SXOCPAGEDLG
218 506  stub     SXOCBATCHSETTINGS
219 507  stub     SXOCFIXNEEDS
220 508  pascal -ret16 CtlSetLddPath(word str) CtlSetLddPath16
221 509  stub     SXCALLOCPROC
222 510  stub     BUILDINFOCS
223 511  stub     BUILDREGOCS
224 512  stub     DELETEOCS
225 520  stub     DiBuildClassDrvInfoList #(ptr)
226 521  stub     DiBuildCompatDrvInfoList #(ptr)
227 522  stub     DiDestroyDrvInfoList #(ptr)
228 523  stub     DiConvertDriverInfoToDriverNode #(ptr ptr)
229 524  stub     DISELECTBESTCOMPATDRV
230 525  stub     FirstBootMoveToDOSSTART #(str word)
231 526  stub     DOSOptEnableCurCfg #(str)
232 527  pascal -ret16 InstallHinfSection(word word str word) InstallHinfSection16
233 528  stub     SXMAKEUNCPATH
234 529  stub     SXISSBSSERVERFILE
235 530  stub     SXFINDBATCHFILES
236 531  stub     ISPANEUROPEAN
237 532  stub     UPGRADENIGGLINGS
238 533  stub     DISPLAY_ISSECONDDISPLAY
239 534  stub     ISWINDOWSFILE
240 540  stub     VERIFYSELECTEDDRIVER
241 575  stub     SXCALLMIGRATIONDLLS
242 576  stub     SXCALLMIGRATIONDLLS_RUNDLL
243 600  stub     PidConstruct #(str str str word)
244 601  stub     PidValidate #(str str)
245 602  stub     GETJAPANESEKEYBOARDTYPE
246 610  stub     CRC32COMPUTE
247 621  stub     SXSAVEINFO
248 622  stub     SXADDPAGEEX
249 623  stub     OPKREMOVEINSTALLEDNETDEVICE
250 640  stub     DOFIRSTRUNSCREENS
251 700  stub     SXSHOWREBOOTDLG
252 701  stub     SXSHOWREBOOTDLG_RUNDLL
253 750  stub     UIPOSITIONDIALOG
254 775  stub     ASPICLEAN
255 800  stub     EXTRACTCABFILE
256 825  stub     PIDGEN3
257 826  stub     GETSETUPINFO
258 827  stub     SETSETUPINFO
259 828  stub     GETKEYBOARDOPTIONS
260 829  stub     GETLOCALEOPTIONS
261 830  stub     SETINTLOPTIONS
262 831  stub     GETPRODUCTTYPE
263 832  stub     ISOPKMODE
264 833  stub     AUDITONETIMEINSTALL
265 834  stub     DISKDUP
266 835  stub     OPKPREINSTALL
267 836  stub     ISAUDITMODE
268 837  stub     ISAUDITAUTO
269 838  stub     GETVALIDEULA