Ordinal 342 is really named SHInterlockedCompareExchange.
[wine] / dlls / mapi32 / mapi32.spec
1 name mapi32
2 type win32
3
4 import ntdll.dll
5
6 debug_channels (mapi)
7
8 @ stub BMAPIAddress
9 @ stub BMAPIDetails
10 @ stub BMAPIFindNext
11 @ stub BMAPIGetAddress
12 @ stub BMAPIGetReadMail
13 @ stub BMAPIReadMail
14 @ stub BMAPIResolveName
15 @ stub BMAPISaveMail
16 @ stub BMAPISendMail
17 @ stub BuildDisplayTable@40
18 @ stub CbOfEncoded@4
19 @ stub CchOfEncoding@4
20 @ stub ChangeIdleRoutine@28
21 @ stub CloseIMsgSession@4
22 @ stub CreateIProp@24
23 @ stub CreateTable@36
24 @ stub DeinitMapiUtil@0
25 @ stub DeregisterIdleRoutine@4
26 @ stub DllCanUnloadNow
27 @ stub DllGetClassObject
28 @ stub EnableIdleRoutine@8
29 @ stub EncodeID@12
30 @ stub FBadColumnSet@4
31 @ stub FBadEntryList@4
32 @ stub FBadProp@4
33 @ stub FBadPropTag@4
34 @ stub FBadRestriction@4
35 @ stub FBadRglpNameID@8
36 @ stub FBadRglpszA@8
37 @ stub FBadRglpszW@8
38 @ stub FBadRow@4
39 @ stub FBadRowSet@4
40 @ stub FBadSortOrderSet@4
41 @ stub FBinFromHex@8
42 @ stub FDecodeID@12
43 @ stub FEqualNames@8
44 @ stub FGetComponentPath
45 # @ stub FGetComponentPath@20
46 @ stub FPropCompareProp@12
47 @ stub FPropContainsProp@12
48 @ stub FPropExists@8
49 @ stub FixMAPI
50 # @ stub FixMAPI@0
51 @ stub FreePadrlist@4
52 @ stub FreeProws@4
53 @ stub FtAdcFt@20
54 @ stub FtAddFt@16
55 @ stub FtDivFtBogus@20
56 @ stub FtMulDw@12
57 @ stub FtMulDwDw@8
58 @ stub FtNegFt@8
59 @ stub FtSubFt@16
60 @ stub FtgRegisterIdleRoutine@20
61 @ stub GetAttribIMsgOnIStg@12
62 @ stub GetOutlookVersion
63 # @ stub GetOutlookVersion@0
64 @ stub GetTnefStreamCodepage
65 # @ stub GetTnefStreamCodepage@12
66 @ stub HexFromBin@12
67 @ stub HrAddColumns@16
68 @ stub HrAddColumnsEx@20
69 @ stub HrAllocAdviseSink@12
70 @ stub HrComposeEID@28
71 @ stub HrComposeMsgID@24
72 @ stub HrDecomposeEID@28
73 @ stub HrDecomposeMsgID@24
74 @ stub HrDispatchNotifications@4
75 @ stub HrEntryIDFromSz@12
76 @ stub HrGetOmiProvidersFlags
77 # @ stub HrGetOmiProvidersFlags@8
78 @ stub HrGetOneProp@12
79 @ stub HrIStorageFromStream@16
80 @ stub HrQueryAllRows@24
81 @ stub HrSetOmiProvidersFlagsInvalid
82 # @ stub HrSetOmiProvidersFlagsInvalid@4
83 @ stub HrSetOneProp@8
84 @ stub HrSzFromEntryID@12
85 @ stub HrThisThreadAdviseSink@8
86 @ stub HrValidateIPMSubtree@20
87 @ stub HrValidateParameters@8
88 @ stub InstallFilterHook@4
89 @ stub IsBadBoundedStringPtr@8
90 @ stub LAUNCHWIZARD
91 @ stub LPropCompareProp@8
92 @ stub LaunchWizard@20
93 @ stub LpValFindProp@12
94 @ stub MAPIAddress
95 @ stub MAPIAdminProfiles
96 # @ stub MAPIAdminProfiles@8
97 @ stdcall MAPIAllocateBuffer(long ptr) MAPIAllocateBuffer
98 # @ stub MAPIAllocateBuffer@8
99 @ stub MAPIAllocateMore
100 # @ stub MAPIAllocateMore@12
101 @ stub MAPIDeinitIdle@0
102 @ stub MAPIDeleteMail
103 @ stub MAPIDetails
104 @ stub MAPIFindNext
105 @ stub MAPIFreeBuffer
106 # @ stub MAPIFreeBuffer@4
107 @ stub MAPIGetDefaultMalloc@0
108 @ stub MAPIInitIdle@4
109 @ stdcall MAPIInitialize(ptr) MAPIInitialize
110 # @ stub MAPIInitialize@4
111 @ stub MAPILogoff
112 @ stdcall MAPILogon(long ptr ptr long long ptr) MAPILogon
113 @ stdcall MAPILogonEx(long ptr ptr long ptr) MAPILogonEx
114 # @ stub MAPILogonEx@20
115 @ stub MAPIOpenFormMgr
116 # @ stub MAPIOpenFormMgr@8
117 @ stub MAPIOpenLocalFormContainer
118 # @ stub MAPIOpenLocalFormContainer@4
119 @ stub MAPIReadMail
120 @ stub MAPIResolveName
121 @ stub MAPISaveMail
122 @ stub MAPISendDocuments
123 @ stub MAPISendMail
124 @ stdcall MAPIUninitialize()    MAPIUninitialize
125 # @ stub MAPIUninitialize@0
126 @ stub MNLS_CompareStringW@24
127 @ stub MNLS_IsBadStringPtrW@8
128 @ stub MNLS_MultiByteToWideChar@24
129 @ stub MNLS_WideCharToMultiByte@32
130 @ stub MNLS_lstrcmpW@8
131 @ stub MNLS_lstrcpyW@8
132 @ stub MNLS_lstrlenW@4
133 @ stub MapStorageSCode@4
134 @ stub OpenIMsgOnIStg@44
135 @ stub OpenIMsgSession@12
136 @ stub OpenStreamOnFile
137 # @ stub OpenStreamOnFile@24
138 @ stub OpenTnefStream
139 # @ stub OpenTnefStream@28
140 @ stub OpenTnefStreamEx
141 # @ stub OpenTnefStreamEx@32
142 @ stub PRProviderInit
143 @ stub PpropFindProp@12
144 @ stub PropCopyMore@16
145 @ stub RTFSync
146 # @ stub RTFSync@12
147 @ stub ScBinFromHexBounded@12
148 @ stub ScCopyNotifications@16
149 @ stub ScCopyProps@16
150 @ stub ScCountNotifications@12
151 @ stub ScCountProps@12
152 @ stub ScCreateConversationIndex@16
153 @ stub ScDupPropset@16
154 @ stub ScGenerateMuid@4
155 @ stub ScInitMapiUtil@4
156 @ stub ScLocalPathFromUNC@12
157 @ stub ScMAPIXFromCMC
158 @ stub ScMAPIXFromSMAPI
159 @ stub ScRelocNotifications@20
160 @ stub ScRelocProps@20
161 @ stub ScUNCFromLocalPath@12
162 @ stub SetAttribIMsgOnIStg@16
163 @ stub SwapPlong@8
164 @ stub SwapPword@8
165 @ stub SzFindCh@8
166 @ stub SzFindLastCh@8
167 @ stub SzFindSz@8
168 @ stub UFromSz@4
169 @ stub UNKOBJ_COFree@8
170 @ stub UNKOBJ_Free@8
171 @ stub UNKOBJ_FreeRows@8
172 @ stub UNKOBJ_ScAllocate@12
173 @ stub UNKOBJ_ScAllocateMore@16
174 @ stub UNKOBJ_ScCOAllocate@12
175 @ stub UNKOBJ_ScCOReallocate@12
176 @ stub UNKOBJ_ScSzFromIdsAlloc@20
177 @ stub UlAddRef@4
178 @ stub UlFromSzHex@4
179 @ stub UlPropSize@4
180 @ stub UlRelease@4
181 @ stub WrapCompressedRTFStream
182 # @ stub WrapCompressedRTFStream@12
183 @ stub WrapProgress@20
184 @ stub WrapStoreEntryID@24
185 @ stub __CPPValidateParameters@8
186 @ stub __ValidateParameters@8
187 @ stub cmc_act_on
188 @ stub cmc_free
189 @ stub cmc_list
190 @ stub cmc_logoff
191 @ stub cmc_logon
192 @ stub cmc_look_up
193 @ stub cmc_query_configuration
194 @ stub cmc_read
195 @ stub cmc_send
196 @ stub cmc_send_documents