ole32: Add a test for CoCreateInstance doing object hosting by
[wine] / dlls / crypt32 / crypt32.spec
1 @ stdcall CertAddCRLContextToStore(long ptr long ptr)
2 @ stdcall CertAddCTLContextToStore(long ptr long ptr)
3 @ stdcall CertAddCertificateContextToStore(long ptr long ptr)
4 @ stdcall CertAddEncodedCRLToStore(long long ptr long long ptr)
5 @ stdcall CertAddEncodedCTLToStore(long long ptr long long ptr)
6 @ stdcall CertAddEncodedCertificateToStore(long long ptr long long ptr)
7 @ stub CertAddEncodedCertificateToSystemStoreA
8 @ stub CertAddEncodedCertificateToSystemStoreW
9 @ stdcall CertAddEnhancedKeyUsageIdentifier(ptr str)
10 @ stdcall CertAddSerializedElementToStore(ptr ptr long long long long ptr ptr)
11 @ stdcall CertAddStoreToCollection(ptr ptr long long)
12 @ stdcall CertAlgIdToOID(long)
13 @ stdcall CertCloseStore(ptr long)
14 @ stdcall CertCompareCertificate(long ptr ptr)
15 @ stdcall CertCompareCertificateName(long ptr ptr)
16 @ stdcall CertCompareIntegerBlob(ptr ptr)
17 @ stdcall CertComparePublicKeyInfo(long ptr ptr)
18 @ stdcall CertControlStore(long long long ptr)
19 @ stdcall CertCreateCRLContext(long ptr long)
20 @ stdcall CertCreateCTLContext(long ptr long)
21 @ stub CertCreateCertificateChainEngine
22 @ stdcall CertCreateCertificateContext(long ptr long)
23 @ stdcall CertCreateSelfSignCertificate(long ptr long ptr ptr ptr ptr ptr)
24 @ stdcall CertDeleteCRLFromStore(ptr)
25 @ stdcall CertDeleteCTLFromStore(ptr)
26 @ stdcall CertDeleteCertificateFromStore(ptr)
27 @ stdcall CertDuplicateCRLContext(ptr)
28 @ stdcall CertDuplicateCTLContext(ptr)
29 @ stdcall CertDuplicateCertificateContext(ptr)
30 @ stdcall CertDuplicateStore(ptr)
31 @ stdcall CertEnumCRLContextProperties(ptr long)
32 @ stdcall CertEnumCRLsInStore(ptr ptr)
33 @ stdcall CertEnumCTLContextProperties(ptr long)
34 @ stdcall CertEnumCTLsInStore(ptr ptr)
35 @ stdcall CertEnumCertificateContextProperties(ptr long)
36 @ stdcall CertEnumCertificatesInStore(long ptr)
37 @ stdcall CertFindAttribute(str long ptr)
38 @ stdcall CertFindCRLInStore(long long long long ptr ptr)
39 @ stub CertFindCTLInStore
40 @ stdcall CertFindCertificateInStore(long long long long ptr ptr)
41 @ stdcall CertFindCertificateInCRL(ptr ptr long ptr ptr)
42 @ stdcall CertFindExtension(str long ptr)
43 @ stdcall CertFindRDNAttr(str ptr)
44 @ stub CertFindSubjectInCTL
45 @ stdcall CertFreeCRLContext(ptr)
46 @ stdcall CertFreeCTLContext(ptr)
47 @ stub CertFreeCertificateChain
48 @ stub CertFreeCertificateChainEngine
49 @ stdcall CertFreeCertificateContext(ptr)
50 @ stdcall CertGetCRLContextProperty(ptr long ptr ptr)
51 @ stdcall CertGetCRLFromStore(ptr ptr ptr ptr)
52 @ stdcall CertGetCTLContextProperty(ptr long ptr ptr)
53 @ stub CertGetCertificateChain
54 @ stdcall CertGetCertificateContextProperty(ptr long ptr ptr)
55 @ stdcall CertGetEnhancedKeyUsage(ptr long ptr ptr)
56 @ stub CertGetIntendedKeyUsage
57 @ stdcall CertGetIssuerCertificateFromStore(long ptr ptr ptr)
58 @ stdcall CertGetNameStringA(ptr long long ptr ptr long)
59 @ stdcall CertGetNameStringW(ptr long long ptr ptr long)
60 @ stub CertGetPublicKeyLength
61 @ stdcall CertGetSubjectCertificateFromStore(ptr long ptr)
62 @ stdcall CertGetValidUsages(long ptr ptr ptr ptr)
63 @ stub CertIsRDNAttrsInCertificateName
64 @ stdcall CertIsValidCRLForCertificate(ptr ptr long ptr)
65 @ stdcall CertNameToStrA(long ptr long ptr long)
66 @ stdcall CertNameToStrW(long ptr long ptr long)
67 @ stdcall CertOIDToAlgId(str)
68 @ stdcall CertOpenStore(str long long long ptr)
69 @ stdcall CertOpenSystemStoreA(long str)
70 @ stdcall CertOpenSystemStoreW(long wstr)
71 @ stdcall CertRDNValueToStrA(long ptr ptr long)
72 @ stdcall CertRDNValueToStrW(long ptr ptr long)
73 @ stdcall CertRemoveEnhancedKeyUsageIdentifier(ptr str)
74 @ stdcall CertRemoveStoreFromCollection(long long)
75 @ stdcall CertSaveStore(long long long long ptr long)
76 @ stdcall CertSerializeCRLStoreElement(ptr long ptr ptr)
77 @ stdcall CertSerializeCTLStoreElement(ptr long ptr ptr)
78 @ stdcall CertSerializeCertificateStoreElement(ptr long ptr ptr)
79 @ stdcall CertSetCRLContextProperty(ptr long long ptr)
80 @ stdcall CertSetCTLContextProperty(ptr long long ptr)
81 @ stdcall CertSetCertificateContextProperty(ptr long long ptr)
82 @ stdcall CertSetEnhancedKeyUsage(ptr ptr)
83 @ stub CertStrToNameA
84 @ stub CertStrToNameW
85 @ stdcall CertVerifyCRLRevocation(long ptr long ptr)
86 @ stdcall CertVerifyCRLTimeValidity(ptr ptr)
87 @ stub CertVerifyCTLUsage
88 @ stub CertVerifyRevocation
89 @ stdcall CertVerifySubjectCertificateContext(ptr ptr ptr)
90 @ stdcall CertVerifyTimeValidity(ptr ptr)
91 @ stub CertVerifyValidityNesting
92 @ stub CreateFileU
93 @ stdcall CryptBinaryToStringA(ptr long long ptr ptr)
94 @ stub CryptBinaryToStringW # (ptr long long ptr ptr)
95 @ stdcall CryptStringToBinaryA(str long long ptr ptr ptr ptr)
96 @ stub CryptStringToBinaryW # (wstr long long ptr ptr ptr ptr)
97 @ stub CryptAcquireContextU
98 @ stub CryptCloseAsyncHandle
99 @ stub CryptCreateAsyncHandle
100 @ stub CryptDecodeMessage
101 @ stdcall CryptDecodeObject(long str ptr long long ptr ptr)
102 @ stdcall CryptDecodeObjectEx(long str ptr long long ptr ptr ptr)
103 @ stub CryptDecryptAndVerifyMessageSignature
104 @ stub CryptDecryptMessage
105 @ stdcall CryptEncodeObject(long str ptr ptr ptr)
106 @ stdcall CryptEncodeObjectEx(long str ptr long ptr ptr ptr)
107 @ stub CryptEncryptMessage
108 @ stub CryptEnumOIDFunction
109 @ stdcall CryptEnumOIDInfo(long long ptr ptr)
110 @ stub CryptEnumProvidersU
111 @ stub CryptExportPKCS8
112 @ stdcall CryptExportPublicKeyInfo(long long long ptr ptr)
113 @ stdcall CryptExportPublicKeyInfoEx(long long long str long ptr ptr ptr)
114 @ stdcall CryptFindOIDInfo(long ptr long)
115 @ stub CryptFormatObject
116 @ stdcall CryptFreeOIDFunctionAddress(long long)
117 @ stub CryptGetAsyncParam
118 @ stdcall CryptGetDefaultOIDDllList(long long ptr ptr)
119 @ stdcall CryptGetDefaultOIDFunctionAddress(long long wstr long ptr ptr)
120 @ stub CryptGetMessageCertificates
121 @ stub CryptGetMessageSignerCount
122 @ stdcall CryptGetOIDFunctionAddress(long long str long ptr ptr)
123 @ stdcall CryptGetOIDFunctionValue(long str str wstr ptr ptr ptr)
124 @ stdcall CryptHashCertificate(long long long ptr long ptr ptr)
125 @ stub CryptHashMessage
126 @ stub CryptHashPublicKeyInfo
127 @ stub CryptHashToBeSigned
128 @ stub CryptImportPKCS8
129 @ stdcall CryptImportPublicKeyInfo(long long ptr ptr)
130 @ stdcall CryptImportPublicKeyInfoEx(long long ptr long long ptr ptr)
131 @ stdcall CryptInitOIDFunctionSet(str long)
132 @ stdcall CryptInstallOIDFunctionAddress(ptr long str long ptr long)
133 @ stub CryptLoadSip
134 @ stdcall CryptMemAlloc(long)
135 @ stdcall CryptMemFree(ptr)
136 @ stdcall CryptMemRealloc(ptr long)
137 @ stub CryptMsgCalculateEncodedLength
138 @ stub CryptMsgClose
139 @ stub CryptMsgControl
140 @ stub CryptMsgCountersign
141 @ stub CryptMsgCountersignEncoded
142 @ stub CryptMsgEncodeAndSignCTL
143 @ stub CryptMsgGetAndVerifySigner
144 @ stub CryptMsgGetParam
145 @ stub CryptMsgOpenToDecode
146 @ stub CryptMsgOpenToEncode
147 @ stub CryptMsgSignCTL
148 @ stub CryptMsgUpdate
149 @ stub CryptMsgVerifyCountersignatureEncoded
150 @ stdcall CryptProtectData(ptr wstr ptr ptr ptr long ptr)
151 @ stdcall CryptQueryObject(long ptr long long long ptr ptr ptr ptr ptr ptr)
152 @ stdcall CryptRegisterDefaultOIDFunction(long str long wstr)
153 @ stdcall CryptRegisterOIDFunction(long str str wstr str)
154 @ stub CryptRegisterOIDInfo
155 @ stdcall CryptSIPAddProvider(ptr)
156 @ stdcall CryptSIPLoad(ptr long ptr)
157 @ stdcall CryptSIPRemoveProvider(ptr)
158 @ stdcall CryptSIPRetrieveSubjectGuid(wstr long ptr)
159 @ stub CryptSetAsyncParam
160 @ stdcall CryptSetOIDFunctionValue(long str str wstr long ptr long)
161 @ stub CryptSetProviderU
162 @ stub CryptSignAndEncodeCertificate
163 @ stub CryptSignAndEncryptMessage
164 @ stdcall CryptSignCertificate(long long long ptr long ptr ptr ptr ptr)
165 @ stub CryptSignHashU
166 @ stub CryptSignMessage
167 @ stub CryptSignMessageWithKey
168 @ stdcall CryptUnprotectData(ptr ptr ptr ptr ptr long ptr)
169 @ stdcall CryptUnregisterDefaultOIDFunction(long str wstr)
170 @ stdcall CryptUnregisterOIDFunction(long str str)
171 @ stub CryptUnregisterOIDInfo
172 @ stdcall CryptVerifyCertificateSignature(long long ptr long ptr)
173 @ stdcall CryptVerifyCertificateSignatureEx(long long long ptr long ptr long ptr)
174 @ stub CryptVerifyDetachedMessageHash
175 @ stub CryptVerifyDetachedMessageSignature
176 @ stub CryptVerifyMessageHash
177 @ stdcall CryptVerifyMessageSignature(ptr long ptr long ptr ptr ptr)
178 @ stub CryptVerifyMessageSignatureWithKey
179 @ stub CryptVerifySignatureU
180 @ stdcall I_CryptAllocTls()
181 @ stdcall I_CryptCreateLruCache(ptr ptr)
182 @ stub I_CryptCreateLruEntry
183 @ stdcall I_CryptDetachTls(long)
184 @ stdcall I_CryptFindLruEntryData(long long long)
185 @ stdcall I_CryptFlushLruCache(ptr long long)
186 @ stdcall I_CryptFreeLruCache(ptr long long)
187 @ stdcall I_CryptFreeTls(long long)
188 @ stub I_CryptGetDefaultCryptProv
189 @ stub I_CryptGetDefaultCryptProvForEncrypt
190 @ stdcall I_CryptGetOssGlobal(long)
191 @ stdcall I_CryptGetTls(long)
192 @ stub I_CryptInsertLruEntry
193 @ stdcall I_CryptInstallAsn1Module(long long long)
194 @ stdcall I_CryptInstallOssGlobal(long long long)
195 @ stub I_CryptReleaseLruEntry
196 @ stdcall I_CryptSetTls(long ptr)
197 @ stub I_CryptUninstallOssGlobal
198 @ stub PFXExportCertStore
199 @ stub PFXImportCertStore
200 @ stub RegCreateHKCUKeyExU
201 @ stub RegCreateKeyExU
202 @ stub RegDeleteValueU
203 @ stub RegEnumValueU
204 @ stub RegOpenHKCUKeyExU
205 @ stub RegOpenKeyExU
206 @ stub RegQueryInfoKeyU
207 @ stub RegQueryValueExU
208 @ stub RegSetValueExU