crypt32: Add a couple stubs, and implement the undocumented I_CryptReadTrustedPublish...
[wine] / dlls / crypt32 / crypt32.spec
1 @ stdcall CertAddCRLContextToStore(long ptr long ptr)
2 @ stdcall CertAddCTLContextToStore(long ptr long ptr)
3 @ stdcall CertAddCertificateContextToStore(long ptr long ptr)
4 @ stdcall CertAddEncodedCRLToStore(long long ptr long long ptr)
5 @ stdcall CertAddEncodedCTLToStore(long long ptr long long ptr)
6 @ stdcall CertAddEncodedCertificateToStore(long long ptr long long ptr)
7 @ stub CertAddEncodedCertificateToSystemStoreA
8 @ stub CertAddEncodedCertificateToSystemStoreW
9 @ stdcall CertAddEnhancedKeyUsageIdentifier(ptr str)
10 @ stdcall CertAddSerializedElementToStore(ptr ptr long long long long ptr ptr)
11 @ stdcall CertAddStoreToCollection(ptr ptr long long)
12 @ stdcall CertAlgIdToOID(long)
13 @ stdcall CertCloseStore(ptr long)
14 @ stdcall CertCompareCertificate(long ptr ptr)
15 @ stdcall CertCompareCertificateName(long ptr ptr)
16 @ stdcall CertCompareIntegerBlob(ptr ptr)
17 @ stdcall CertComparePublicKeyInfo(long ptr ptr)
18 @ stdcall CertControlStore(long long long ptr)
19 @ stdcall CertCreateCRLContext(long ptr long)
20 @ stdcall CertCreateCTLContext(long ptr long)
21 @ stub CertCreateCertificateChainEngine
22 @ stdcall CertCreateCertificateContext(long ptr long)
23 @ stdcall CertCreateSelfSignCertificate(long ptr long ptr ptr ptr ptr ptr)
24 @ stdcall CertDeleteCRLFromStore(ptr)
25 @ stdcall CertDeleteCTLFromStore(ptr)
26 @ stdcall CertDeleteCertificateFromStore(ptr)
27 @ stdcall CertDuplicateCRLContext(ptr)
28 @ stdcall CertDuplicateCTLContext(ptr)
29 @ stdcall CertDuplicateCertificateContext(ptr)
30 @ stdcall CertDuplicateStore(ptr)
31 @ stdcall CertEnumCRLContextProperties(ptr long)
32 @ stdcall CertEnumCRLsInStore(ptr ptr)
33 @ stdcall CertEnumCTLContextProperties(ptr long)
34 @ stdcall CertEnumCTLsInStore(ptr ptr)
35 @ stdcall CertEnumCertificateContextProperties(ptr long)
36 @ stdcall CertEnumCertificatesInStore(long ptr)
37 @ stdcall CertFindAttribute(str long ptr)
38 @ stdcall CertFindCRLInStore(long long long long ptr ptr)
39 @ stub CertFindCTLInStore
40 @ stdcall CertFindCertificateInStore(long long long long ptr ptr)
41 @ stdcall CertFindCertificateInCRL(ptr ptr long ptr ptr)
42 @ stdcall CertFindExtension(str long ptr)
43 @ stdcall CertFindRDNAttr(str ptr)
44 @ stub CertFindSubjectInCTL
45 @ stdcall CertFreeCRLContext(ptr)
46 @ stdcall CertFreeCTLContext(ptr)
47 @ stub CertFreeCertificateChain
48 @ stub CertFreeCertificateChainEngine
49 @ stdcall CertFreeCertificateContext(ptr)
50 @ stdcall CertGetCRLContextProperty(ptr long ptr ptr)
51 @ stdcall CertGetCRLFromStore(ptr ptr ptr ptr)
52 @ stdcall CertGetCTLContextProperty(ptr long ptr ptr)
53 @ stub CertGetCertificateChain
54 @ stdcall CertGetCertificateContextProperty(ptr long ptr ptr)
55 @ stdcall CertGetEnhancedKeyUsage(ptr long ptr ptr)
56 @ stub CertGetIntendedKeyUsage
57 @ stdcall CertGetIssuerCertificateFromStore(long ptr ptr ptr)
58 @ stdcall CertGetNameStringA(ptr long long ptr ptr long)
59 @ stdcall CertGetNameStringW(ptr long long ptr ptr long)
60 @ stub CertGetPublicKeyLength
61 @ stdcall CertGetSubjectCertificateFromStore(ptr long ptr)
62 @ stdcall CertGetValidUsages(long ptr ptr ptr ptr)
63 @ stub CertIsRDNAttrsInCertificateName
64 @ stdcall CertIsValidCRLForCertificate(ptr ptr long ptr)
65 @ stdcall CertNameToStrA(long ptr long ptr long)
66 @ stdcall CertNameToStrW(long ptr long ptr long)
67 @ stdcall CertOIDToAlgId(str)
68 @ stdcall CertOpenStore(str long long long ptr)
69 @ stdcall CertOpenSystemStoreA(long str)
70 @ stdcall CertOpenSystemStoreW(long wstr)
71 @ stdcall CertRDNValueToStrA(long ptr ptr long)
72 @ stdcall CertRDNValueToStrW(long ptr ptr long)
73 @ stdcall CertRemoveEnhancedKeyUsageIdentifier(ptr str)
74 @ stdcall CertRemoveStoreFromCollection(long long)
75 @ stdcall CertSaveStore(long long long long ptr long)
76 @ stdcall CertSerializeCRLStoreElement(ptr long ptr ptr)
77 @ stdcall CertSerializeCTLStoreElement(ptr long ptr ptr)
78 @ stdcall CertSerializeCertificateStoreElement(ptr long ptr ptr)
79 @ stdcall CertSetCRLContextProperty(ptr long long ptr)
80 @ stdcall CertSetCTLContextProperty(ptr long long ptr)
81 @ stdcall CertSetCertificateContextProperty(ptr long long ptr)
82 @ stdcall CertSetEnhancedKeyUsage(ptr ptr)
83 @ stdcall CertStrToNameA(long str long ptr ptr ptr ptr)
84 @ stdcall CertStrToNameW(long wstr long ptr ptr ptr ptr)
85 @ stdcall CertVerifyCRLRevocation(long ptr long ptr)
86 @ stdcall CertVerifyCRLTimeValidity(ptr ptr)
87 @ stub CertVerifyCTLUsage
88 @ stub CertVerifyRevocation
89 @ stdcall CertVerifySubjectCertificateContext(ptr ptr ptr)
90 @ stdcall CertVerifyTimeValidity(ptr ptr)
91 @ stub CertVerifyValidityNesting
92 @ stdcall CreateFileU(wstr long long ptr long long ptr) kernel32.CreateFileW
93 @ stdcall CryptBinaryToStringA(ptr long long ptr ptr)
94 @ stub CryptBinaryToStringW # (ptr long long ptr ptr)
95 @ stdcall CryptStringToBinaryA(str long long ptr ptr ptr ptr)
96 @ stub CryptStringToBinaryW # (wstr long long ptr ptr ptr ptr)
97 @ stub CryptAcquireContextU
98 @ stdcall CryptAcquireCertificatePrivateKey(ptr long ptr ptr ptr ptr)
99 @ stub CryptCloseAsyncHandle
100 @ stub CryptCreateAsyncHandle
101 @ stub CryptDecodeMessage
102 @ stdcall CryptDecodeObject(long str ptr long long ptr ptr)
103 @ stdcall CryptDecodeObjectEx(long str ptr long long ptr ptr ptr)
104 @ stub CryptDecryptAndVerifyMessageSignature
105 @ stub CryptDecryptMessage
106 @ stdcall CryptEncodeObject(long str ptr ptr ptr)
107 @ stdcall CryptEncodeObjectEx(long str ptr long ptr ptr ptr)
108 @ stub CryptEncryptMessage
109 @ stub CryptEnumOIDFunction
110 @ stdcall CryptEnumOIDInfo(long long ptr ptr)
111 @ stub CryptEnumProvidersU
112 @ stub CryptExportPKCS8
113 @ stdcall CryptExportPublicKeyInfo(long long long ptr ptr)
114 @ stdcall CryptExportPublicKeyInfoEx(long long long str long ptr ptr ptr)
115 @ stdcall CryptFindOIDInfo(long ptr long)
116 @ stub CryptFormatObject
117 @ stdcall CryptFreeOIDFunctionAddress(long long)
118 @ stub CryptGetAsyncParam
119 @ stdcall CryptGetDefaultOIDDllList(long long ptr ptr)
120 @ stdcall CryptGetDefaultOIDFunctionAddress(long long wstr long ptr ptr)
121 @ stub CryptGetMessageCertificates
122 @ stub CryptGetMessageSignerCount
123 @ stdcall CryptGetOIDFunctionAddress(long long str long ptr ptr)
124 @ stdcall CryptGetOIDFunctionValue(long str str wstr ptr ptr ptr)
125 @ stdcall CryptHashCertificate(long long long ptr long ptr ptr)
126 @ stub CryptHashMessage
127 @ stdcall CryptHashPublicKeyInfo(long long long long ptr ptr ptr)
128 @ stub CryptHashToBeSigned
129 @ stub CryptImportPKCS8
130 @ stdcall CryptImportPublicKeyInfo(long long ptr ptr)
131 @ stdcall CryptImportPublicKeyInfoEx(long long ptr long long ptr ptr)
132 @ stdcall CryptInitOIDFunctionSet(str long)
133 @ stdcall CryptInstallOIDFunctionAddress(ptr long str long ptr long)
134 @ stub CryptLoadSip
135 @ stdcall CryptMemAlloc(long)
136 @ stdcall CryptMemFree(ptr)
137 @ stdcall CryptMemRealloc(ptr long)
138 @ stub CryptMsgCalculateEncodedLength
139 @ stub CryptMsgClose
140 @ stub CryptMsgControl
141 @ stub CryptMsgCountersign
142 @ stub CryptMsgCountersignEncoded
143 @ stub CryptMsgEncodeAndSignCTL
144 @ stub CryptMsgGetAndVerifySigner
145 @ stub CryptMsgGetParam
146 @ stub CryptMsgOpenToDecode
147 @ stub CryptMsgOpenToEncode
148 @ stub CryptMsgSignCTL
149 @ stub CryptMsgUpdate
150 @ stub CryptMsgVerifyCountersignatureEncoded
151 @ stdcall CryptProtectData(ptr wstr ptr ptr ptr long ptr)
152 @ stdcall CryptQueryObject(long ptr long long long ptr ptr ptr ptr ptr ptr)
153 @ stdcall CryptRegisterDefaultOIDFunction(long str long wstr)
154 @ stdcall CryptRegisterOIDFunction(long str str wstr str)
155 @ stub CryptRegisterOIDInfo
156 @ stdcall CryptSIPAddProvider(ptr)
157 @ stdcall CryptSIPLoad(ptr long ptr)
158 @ stdcall CryptSIPRemoveProvider(ptr)
159 @ stdcall CryptSIPRetrieveSubjectGuid(wstr long ptr)
160 @ stub CryptSetAsyncParam
161 @ stdcall CryptSetOIDFunctionValue(long str str wstr long ptr long)
162 @ stub CryptSetProviderU
163 @ stub CryptSignAndEncodeCertificate
164 @ stub CryptSignAndEncryptMessage
165 @ stdcall CryptSignCertificate(long long long ptr long ptr ptr ptr ptr)
166 @ stub CryptSignHashU
167 @ stub CryptSignMessage
168 @ stub CryptSignMessageWithKey
169 @ stdcall CryptUnprotectData(ptr ptr ptr ptr ptr long ptr)
170 @ stdcall CryptUnregisterDefaultOIDFunction(long str wstr)
171 @ stdcall CryptUnregisterOIDFunction(long str str)
172 @ stub CryptUnregisterOIDInfo
173 @ stdcall CryptVerifyCertificateSignature(long long ptr long ptr)
174 @ stdcall CryptVerifyCertificateSignatureEx(long long long ptr long ptr long ptr)
175 @ stub CryptVerifyDetachedMessageHash
176 @ stub CryptVerifyDetachedMessageSignature
177 @ stub CryptVerifyMessageHash
178 @ stdcall CryptVerifyMessageSignature(ptr long ptr long ptr ptr ptr)
179 @ stub CryptVerifyMessageSignatureWithKey
180 @ stub CryptVerifySignatureU
181 @ stdcall I_CryptAllocTls()
182 @ stdcall I_CryptCreateLruCache(ptr ptr)
183 @ stub I_CryptCreateLruEntry
184 @ stdcall I_CryptDetachTls(long)
185 @ stdcall I_CryptFindLruEntryData(long long long)
186 @ stdcall I_CryptFlushLruCache(ptr long long)
187 @ stdcall I_CryptFreeLruCache(ptr long long)
188 @ stdcall I_CryptFreeTls(long long)
189 @ stdcall I_CryptGetDefaultCryptProv(long long long)
190 @ stub I_CryptGetDefaultCryptProvForEncrypt
191 @ stdcall I_CryptGetOssGlobal(long)
192 @ stdcall I_CryptGetTls(long)
193 @ stub I_CryptInsertLruEntry
194 @ stdcall I_CryptInstallAsn1Module(long long long)
195 @ stdcall I_CryptInstallOssGlobal(long long long)
196 @ stdcall I_CryptReadTrustedPublisherDWORDValueFromRegistry(wstr ptr)
197 @ stub I_CryptReleaseLruEntry
198 @ stdcall I_CryptSetTls(long ptr)
199 @ stdcall I_CryptUninstallAsn1Module(ptr)
200 @ stub I_CryptUninstallOssGlobal
201 @ stub PFXExportCertStore
202 @ stub PFXImportCertStore
203 @ stub RegCreateHKCUKeyExU
204 @ stub RegCreateKeyExU
205 @ stub RegDeleteValueU
206 @ stub RegEnumValueU
207 @ stub RegOpenHKCUKeyExU
208 @ stub RegOpenKeyExU
209 @ stub RegQueryInfoKeyU
210 @ stub RegQueryValueExU
211 @ stub RegSetValueExU