Made some more spec file entries optional or unnecessary.
[wine] / dlls / avifil32 / avifile.spec
1 # I'm just using "long" instead of "ptr" for the interface pointers,
2 # because they are 32-bit pointers, not converted to 16-bit format,
3 # but the app doesn't really need to know, it should never need to
4 # dereference the interface pointer itself (if we're lucky)...
5
6 1   stub     WEP
7 2   stub     DLLGETCLASSOBJECT
8 3   stub     DLLCANUNLOADNOW
9 4   stub     ___EXPORTEDSTUB
10 10  stub     _IID_IAVISTREAM
11 11  stub     _IID_IAVIFILE
12 12  stub     _IID_IAVIEDITSTREAM
13 13  stub     _IID_IGETFRAME
14 14  stub     _CLSID_AVISIMPLEUNMARSHAL
15 100 pascal   AVIFileInit() AVIFileInit
16 101 pascal   AVIFileExit() AVIFileExit
17 102 pascal   AVIFileOpen(ptr str word ptr) AVIFileOpenA
18 103 stub     AVISTREAMOPENFROMFILE
19 104 stub     AVISTREAMCREATE
20 105 stub     AVIMAKECOMPRESSEDSTREAM
21 106 stub     AVIMAKEFILEFROMSTREAMS
22 107 stub     AVIMAKESTREAMFROMCLIPBOARD
23 110 stub     AVISTREAMGETFRAME
24 111 stub     AVISTREAMGETFRAMECLOSE
25 112 stub     AVISTREAMGETFRAMEOPEN
26 120 stub     _AVISAVE
27 121 stub     AVISAVEV
28 122 stub     AVISAVEOPTIONS
29 123 stub     AVIBUILDFILTER
30 124 stub     AVISAVEOPTIONSFREE
31 130 stub     AVISTREAMSTART
32 131 stub     AVISTREAMLENGTH
33 132 stub     AVISTREAMTIMETOSAMPLE
34 133 stub     AVISTREAMSAMPLETOTIME
35 140 stub     AVIFILEADDREF
36 141 pascal   AVIFileRelease(long) AVIFileRelease
37 142 stub     AVIFILEINFO
38 143 pascal   AVIFileGetStream(long ptr long long) AVIFileGetStream
39 144 stub     AVIFILECREATESTREAM
40 146 stub     AVIFILEWRITEDATA
41 147 stub     AVIFILEREADDATA
42 148 stub     AVIFILEENDRECORD
43 160 stub     AVISTREAMADDREF
44 161 stub     AVISTREAMRELEASE
45 162 stub     AVISTREAMINFO
46 163 stub     AVISTREAMFINDSAMPLE
47 164 stub     AVISTREAMREADFORMAT
48 165 stub     AVISTREAMREADDATA
49 166 stub     AVISTREAMWRITEDATA
50 167 stub     AVISTREAMREAD
51 168 stub     AVISTREAMWRITE
52 169 stub     AVISTREAMSETFORMAT
53 180 stub     EDITSTREAMCOPY
54 181 stub     EDITSTREAMCUT
55 182 stub     EDITSTREAMPASTE
56 184 stub     CREATEEDITABLESTREAM
57 185 stub     AVIPUTFILEONCLIPBOARD
58 187 stub     AVIGETFROMCLIPBOARD
59 188 stub     AVICLEARCLIPBOARD
60 190 stub     EDITSTREAMCLONE
61 191 stub     EDITSTREAMSETNAME
62 192 stub     EDITSTREAMSETINFO
63 200 stub     AVISTREAMBEGINSTREAMING
64 201 stub     AVISTREAMENDSTREAMING