Set amounts read/written to 0, share Un/Lock code, unify ctors.
[wine] / dlls / shlwapi / shlwapi.spec
1 init SHLWAPI_LibMain
2
3 1   stdcall @(str ptr) SHLWAPI_1
4 2   stdcall @(wstr ptr) SHLWAPI_2
5 3   stdcall @(str long) SHLWAPI_3
6 4   stdcall @(wstr long) SHLWAPI_4
7 5   stdcall @(str ptr long) SHLWAPI_5
8 6   stdcall @(wstr ptr long) SHLWAPI_6
9 7   stdcall @(long long ptr) SHLWAPI_7
10 8   stdcall @(long long) SHLWAPI_8
11 9   stdcall @(ptr) SHLWAPI_9
12 10  stdcall @(long long) SHLWAPI_10
13 11  stdcall @(long long long long long) SHLWAPI_11
14 12  stdcall @(ptr long) SHLWAPI_12
15 13  stdcall @(ptr ptr) SHLWAPI_13
16 14  stdcall @(ptr ptr) SHLWAPI_14
17 15  stdcall @(ptr ptr) SHLWAPI_15
18 16  stdcall @(long long long long) SHLWAPI_16
19 17  stdcall @ (ptr ptr) SHLWAPI_17
20 18  stdcall @ (ptr ptr) SHLWAPI_18
21 19  stdcall @ (ptr) SHLWAPI_19
22 20  stdcall @ (ptr ptr) SHLWAPI_20
23 21  stdcall @ (ptr long) SHLWAPI_21
24 22  stdcall @ (ptr long) SHLWAPI_22
25 23  stdcall @(ptr ptr long) SHLWAPI_23
26 24  stdcall @(ptr ptr long) SHLWAPI_24
27 25  stdcall @(long) SHLWAPI_25
28 26  stdcall @(long) SHLWAPI_26
29 27  stdcall @(long) SHLWAPI_27
30 28  stdcall @(long) SHLWAPI_28
31 29  stdcall @(long) SHLWAPI_29
32 30  stdcall @(long) SHLWAPI_30
33 31  stdcall @(long) SHLWAPI_31
34 32  stdcall @(ptr)  SHLWAPI_32
35 33  stdcall @(long) SHLWAPI_33
36 34  stdcall @(long) SHLWAPI_34
37 35  stdcall @(ptr long ptr) SHLWAPI_35
38 36  stdcall @(long long long wstr) SHLWAPI_36
39 37  forward @ user32.CallWindowProcW
40 38  forward @ user32.CharLowerW
41 39  forward @ user32.CharLowerBuffW
42 40  forward @ user32.CharNextW
43 41  forward @ user32.CharPrevW
44 42  stub @
45 43  forward @ user32.CharUpperW
46 44  forward @ user32.CharUpperBuffW
47 45  forward @ kernel32.CompareStringW
48 46  forward @ user32.CopyAcceleratorTableW
49 47  forward @ user32.CreateAcceleratorTableW
50 48  forward @ gdi32.CreateDCW
51 49  forward @ user32.CreateDialogParamA
52 50  forward @ kernel32.CreateDirectoryW
53 51  forward @ kernel32.CreateEventW
54 52  forward @ kernel32.CreateFileW
55 53  forward @ gdi32.CreateFontIndirectW
56 54  forward @ gdi32.CreateICW
57 55  forward @ user32.CreateWindowExW
58 56  forward @ user32.DefWindowProcW
59 57  forward @ kernel32.DeleteFileW
60 58  stub @
61 59  stub @
62 60  forward @ user32.DispatchMessageW
63 61  forward @ user32.DrawTextW
64 62  forward @ gdi32.EnumFontFamiliesW
65 63  forward @ gdi32.EnumFontFamiliesExW
66 64  forward @ kernel32.EnumResourceNamesW
67 65  forward @ kernel32.FindFirstFileW
68 66  forward @ kernel32.FindResourceW
69 67  forward @ user32.FindWindowW
70 68  forward @ kernel32.FormatMessageW
71 69  forward @ user32.GetClassInfoW
72 70  forward @ user32.GetClassLongW
73 71  forward @ user32.GetClassNameW
74 72  forward @ user32.GetClipboardFormatNameW
75 73  forward @ kernel32.GetCurrentDirectoryW
76 74  stdcall @(long long wstr long) SHLWAPI_74
77 75  forward @ kernel32.GetFileAttributesW
78 76  forward @ kernel32.GetFullPathNameW
79 77  forward @ kernel32.GetLocaleInfoW
80 78  forward @ user32.GetMenuStringW
81 79  forward @ user32.GetMessageW
82 80  forward @ kernel32.GetModuleFileNameW
83 81  forward @ kernel32.GetSystemDirectoryW
84 82  forward @ kernel32.SearchPathW
85 83  forward @ kernel32.GetModuleHandleW
86 84  forward @ gdi32.GetObjectW
87 85  forward @ kernel32.GetPrivateProfileIntW
88 86  forward @ kernel32.GetProfileStringW
89 87  forward @ user32.GetPropW
90 88  forward @ kernel32.GetStringTypeExW
91 89  forward @ kernel32.GetTempFileNameW
92 90  forward @ kernel32.GetTempPathW
93 91  forward @ gdi32.GetTextExtentPoint32W
94 92  forward @ gdi32.GetTextFaceW
95 93  forward @ gdi32.GetTextMetricsW
96 94  forward @ user32.GetWindowLongW
97 95  forward @ user32.GetWindowTextW
98 96  forward @ user32.GetWindowTextLengthW
99 97  forward @ kernel32.GetWindowsDirectoryW
100 98  forward @ user32.InsertMenuW
101 99  forward @ user32.IsDialogMessageW
102 100 forward @ user32.LoadAcceleratorsW
103 101 forward @ user32.LoadBitmapW
104 102 forward @ user32.LoadCursorW
105 103 forward @ user32.LoadIconW
106 104 forward @ user32.LoadImageW
107 105 forward @ kernel32.LoadLibraryExW
108 106 forward @ user32.LoadMenuW
109 107 forward @ user32.LoadStringW
110 108 forward @ user32.MessageBoxIndirectW
111 109 forward @ user32.ModifyMenuW
112 110 forward @ gdi32.GetCharWidth32W
113 111 forward @ gdi32.GetCharacterPlacementW
114 112 forward @ kernel32.CopyFileW
115 113 forward @ kernel32.MoveFileW
116 114 forward @ user32.OemToCharW
117 115 forward @ kernel32.OutputDebugStringW
118 116 forward @ user32.PeekMessageW
119 117 forward @ user32.PostMessageW
120 118 forward @ user32.PostThreadMessageW
121 119 forward @ advapi32.RegCreateKeyW
122 120 forward @ advapi32.RegCreateKeyExW
123 121 forward @ advapi32.RegDeleteKeyW
124 122 forward @ advapi32.RegEnumKeyW
125 123 forward @ advapi32.RegEnumKeyExW
126 124 forward @ advapi32.RegOpenKeyW
127 125 forward @ advapi32.RegOpenKeyExW
128 126 forward @ advapi32.RegQueryInfoKeyW
129 127 forward @ advapi32.RegQueryValueW
130 128 forward @ advapi32.RegQueryValueExW
131 129 forward @ advapi32.RegSetValueW
132 130 forward @ advapi32.RegSetValueExW
133 131 forward @ user32.RegisterClassW
134 132 forward @ user32.RegisterClipboardFormatW
135 133 forward @ user32.RegisterWindowMessageW
136 134 forward @ user32.RemovePropW
137 135 forward @ user32.SendDlgItemMessageW
138 136 forward @ user32.SendMessageW
139 137 forward @ kernel32.SetCurrentDirectoryW
140 138 stub @
141 139 stub @
142 140 forward @ user32.SetPropW
143 141 forward @ user32.SetWindowLongW
144 142 forward @ user32.SetWindowsHookExW
145 143 forward @ user32.SetWindowTextW
146 144 forward @ gdi32.StartDocW
147 145 forward @ user32.SystemParametersInfoW
148 146 forward @ user32.TranslateAcceleratorW
149 147 forward @ user32.UnregisterClassW
150 148 forward @ user32.VkKeyScanW
151 149 forward @ user32.WinHelpW
152 150 forward @ user32.wvsprintfW
153 151 stdcall @(str ptr long) SHLWAPI_151
154 152 stdcall @(wstr wstr long) SHLWAPI_152
155 153 stdcall @(long long long) SHLWAPI_153
156 154 stdcall @(wstr wstr long) SHLWAPI_154
157 155 stdcall @(str str) SHLWAPI_155
158 156 stdcall @(wstr wstr) SHLWAPI_156
159 157 stub @
160 158 stdcall @(wstr wstr) SHLWAPI_158
161 159 forward @ kernel32.CompareStringW
162 160 stub @
163 161 stub @
164 162 stdcall @(str long) SHLWAPI_162
165 163 stub @
166 164 stdcall @(ptr ptr ptr ptr ptr ptr) SHLWAPI_164
167 165 stdcall @(long long long long) SHLWAPI_165
168 166 stdcall @(ptr) SHLWAPI_166
169 167 stub @
170 168 stub @
171 169 stdcall @(long) SHLWAPI_169
172 170 stdcall @(str) SHLWAPI_170
173 171 stub @
174 172 stdcall @(ptr ptr) SHLWAPI_172
175 173 stub @
176 174 stdcall @(ptr ptr) SHLWAPI_174
177 175 stdcall @(ptr ptr) SHLWAPI_175
178 176 stdcall @(ptr ptr ptr ptr) SHLWAPI_176
179 177 stub @
180 178 stub @
181 179 stub @
182 180 stub @
183 181 stdcall @(long long long) SHLWAPI_181
184 182 stub @
185 183 stdcall @(ptr) SHLWAPI_183
186 184 stdcall @(ptr ptr long) SHLWAPI_184
187 185 stub @
188 186 stub @
189 187 stub @
190 188 stub @
191 189 stub @
192 190 stub @
193 191 stub @
194 192 stub @
195 193 stdcall @() SHLWAPI_193
196 194 stub @
197 195 stub @
198 196 stub @
199 197 stub @
200 198 stub @
201 199 stdcall @(ptr ptr) SHLWAPI_199
202 200 stub @
203 201 stub @
204 202 stub @
205 203 stub @
206 204 stub @
207 205 stdcall @(long str str ptr ptr ptr) SHLWAPI_205
208 206 stdcall @(long wstr wstr ptr ptr ptr) SHLWAPI_206
209 207 stub @
210 208 stdcall @(long long ptr ptr long) SHLWAPI_208
211 209 stdcall @(ptr) SHLWAPI_209
212 210 stdcall @(ptr long ptr) SHLWAPI_210
213 211 stdcall @(ptr long) SHLWAPI_211
214 212 stdcall @(ptr ptr long) SHLWAPI_212
215 213 stdcall @(ptr) SHLWAPI_213
216 214 stdcall @(ptr ptr) SHLWAPI_214
217 215 stdcall @(long long long) SHLWAPI_215
218 216 stub @
219 217 stdcall @(wstr ptr ptr) SHLWAPI_217
220 218 stdcall @(long wstr ptr ptr) SHLWAPI_218
221 219 stdcall @(long long long long) SHLWAPI_219
222 220 stub @
223 221 stub @
224 222 stdcall @(long) SHLWAPI_222
225 223 stdcall @(long) SHLWAPI_223
226 224 stub @
227 225 stub @
228 226 stub @
229 227 stub @
230 228 stub @
231 229 stub @
232 230 stub @
233 231 stub @
234 232 stub @
235 233 stub @
236 234 stub @
237 235 stub @
238 236 stdcall @(ptr) SHLWAPI_236
239 237 stdcall @(ptr) SHLWAPI_237
240 238 stub @
241 239 stdcall @(long str long) SHLWAPI_239
242 240 stdcall @(long long long long) SHLWAPI_240
243 241 stdcall @() SHLWAPI_241
244 242 stub @
245 243 stub @
246 244 stub @
247 245 stub @
248 246 stub @
249 247 stub @
250 248 stub @
251 249 stub @
252 250 stub @
253 251 stub @
254 252 stub @
255 253 stub AssocCreate
256 254 stub AssocQueryKeyA
257 255 stub AssocQueryKeyW
258 256 stub @
259 257 stub @
260 258 stub @
261 259 stub @
262 260 stub @
263 261 stub @
264 262 stub @
265 263 stub @
266 264 stub @
267 265 stub @
268 266 stdcall @(long long long long) SHLWAPI_266
269 267 stdcall @(long long long long) SHLWAPI_267
270 268 stdcall @(long long) SHLWAPI_268
271 269 stub @
272 270 stub @
273 271 stub @
274 272 stub @
275 273 stub @
276 274 stub @
277 275 stub @
278 276 stdcall @() SHLWAPI_276
279 277 stub @
280 278 stdcall @(long long long long long long) SHLWAPI_278
281 279 stub @
282 280 stub @
283 281 stub @
284 282 stub @
285 283 stub @
286 284 stub @
287 285 stub @
288 286 stub @
289 287 stub @
290 288 stub @
291 289 stdcall @(wstr long long) SHLWAPI_289
292 290 stub @
293 291 stub @
294 292 stub @
295 293 stub @
296 294 stdcall @(long long long long long) SHLWAPI_294
297 295 stdcall @(wstr ptr wstr wstr) SHLWAPI_295
298 296 stub @
299 297 stub @
300 298 forward @ kernel32.WritePrivateProfileStringW
301 299 stub @
302 300 forward @ gdi32.CreateFontW
303 301 forward @ user32.DrawTextExW
304 302 forward @ user32.GetMenuItemInfoW
305 303 forward @ user32.InsertMenuItemW
306 304 forward @ gdi32.CreateMetaFileW
307 305 forward @ kernel32.CreateMutexW
308 306 forward @ kernel32.ExpandEnvironmentStringsW
309 307 forward @ kernel32.CreateSemaphoreW
310 308 forward @ kernel32.IsBadStringPtrW
311 309 forward @ kernel32.LoadLibraryW
312 310 forward @ kernel32.GetTimeFormatW
313 311 forward @ kernel32.GetDateFormatW
314 312 forward @ kernel32.GetPrivateProfileStringW
315 313 stdcall @(ptr long ptr long long) SHLWAPI_313
316 314 forward @ user32.RegisterClassExW
317 315 forward @ user32.GetClassInfoExW
318 316 stub SHCreateStreamOnFileAOld
319 317 stub SHCreateStreamOnFileWOld
320 318 stdcall @(long long wstr long) SHLWAPI_318
321 319 forward @ user32.FindWindowExW
322 320 stdcall @(str str) SHLWAPI_320
323 321 stdcall @(wstr wstr) SHLWAPI_321
324 322 stdcall @(str) SHLWAPI_322
325 323 stdcall @(wstr) SHLWAPI_323
326 324 stub @
327 325 stub @
328 326 stub @
329 327 stub @
330 328 stub @
331 329 stub @
332 330 stub @
333 331 stub @
334 332 forward @ user32.CallMsgFilterW
335 333 stdcall @(ptr) SHLWAPI_333
336 334 stdcall @(ptr wstr) SHLWAPI_334
337 335 stdcall @(ptr) SHLWAPI_335
338 336 stdcall @(ptr) SHLWAPI_336
339 337 stdcall @(wstr long ptr ptr long) SHLWAPI_337
340 338 forward @ kernel32.SetFileAttributesW
341 339 forward @ kernel32.GetNumberFormatW
342 340 forward @ user32.MessageBoxW
343 341 forward @ kernel32.FindNextFileW
344 342 stdcall @(ptr long long) SHInterlockedCompareExchange
345 343 stub @
346 344 stub @
347 345 stub @
348 346 stdcall @(wstr ptr long) SHLWAPI_346
349 347 forward @ advapi32.RegDeleteValueW
350 348 stub @
351 349 stub @
352 350 stdcall @(wstr ptr) SHLWAPI_350
353 351 stdcall @(wstr ptr long ptr) SHLWAPI_351
354 352 stdcall @(ptr wstr ptr ptr) SHLWAPI_352
355 353 stub @
356 354 stub @
357 355 stub @
358 356 stdcall @(long long long) SHLWAPI_356
359 357 stdcall @(wstr wstr wstr long long) SHLWAPI_357
360 358 stdcall @(ptr ptr ptr ptr ptr ptr) SHLWAPI_358
361 359 forward @ kernel32.OpenEventW
362 360 forward @ kernel32.RemoveDirectoryW
363 361 forward @ kernel32.GetShortPathNameW
364 362 forward @ advapi32.GetUserNameW
365 363 stub @
366 364 stdcall @(str str long) SHLWAPI_364
367 365 stub @
368 366 forward @ advapi32.RegEnumValueW
369 367 forward @ kernel32.WritePrivateProfileStructW
370 368 forward @ kernel32.GetPrivateProfileStructW
371 369 forward @ kernel32.CreateProcessW
372 370 stdcall @(long wstr long) SHLWAPI_370
373 371 stub @
374 372 stub @
375 373 stub @
376 374 stub @
377 375 stub @
378 376 stdcall @() SHLWAPI_376  # kernel32.GetUserDefaultUILanguage
379 377 stdcall @(str long long) SHLWAPI_377
380 378 stdcall @(wstr long long) SHLWAPI_378
381 379 stub @
382 380 stub @
383 381 stub AssocQueryStringA
384 382 stub AssocQueryStringByKeyA
385 383 stub AssocQueryStringByKeyW
386 384 stub AssocQueryStringW
387 385 stdcall ChrCmpIA(long long) ChrCmpIA
388 386 stdcall ChrCmpIW(long long) ChrCmpIW
389 387 stub ColorAdjustLuma
390 388 stub @
391 389 stdcall @(ptr) SHLWAPI_389
392 390 stdcall @(ptr ptr) SHLWAPI_390
393 391 stdcall @(ptr ptr ptr ptr ptr ) SHLWAPI_391
394 392 stub @
395 393 stub @
396 394 forward @ user32.CreateDialogIndirectParamA
397 395 stub @
398 396 stub @
399 397 stub @
400 398 stub @
401 399 stub @
402 400 stub @
403 401 stdcall @(ptr) SHLWAPI_401
404 402 stdcall @(ptr) SHLWAPI_402
405 403 stdcall @(ptr) SHLWAPI_403
406 404 stdcall ColorHLSToRGB(long long long) ColorHLSToRGB
407 405 stub @
408 406 stub @
409 407 stub @
410 408 stub @
411 409 stub @
412 410 stub @
413 411 stub @
414 412 stub @
415 413 stdcall @(long) SHLWAPI_413
416 414 stub @
417 415 stub @
418 416 stub @
419 417 stub @
420 418 stdcall @(long) SHLWAPI_418
421 419 stub @
422 420 stub @
423 421 stub @
424 422 stub @
425 423 stub @
426 424 stub @
427 425 stub @
428 426 stub @
429 427 stub @
430 428 forward @ user32.TrackPopupMenuEx
431 429 stub @
432 430 stdcall @(long long) SHLWAPI_430
433 431 stdcall @(long) SHLWAPI_431
434 432 stub @
435 433 stub @
436 434 forward @ user32.SendMessageTimeoutW
437 435 stub @
438 436 stdcall @(wstr ptr) SHLWAPI_436
439 437 stdcall @(long) SHLWAPI_437
440 438 stub @
441 439 stub @
442 440 stub @
443 441 stub @
444 442 forward @ kernel32.GetEnvironmentVariableW
445 443 forward @ kernel32.GetSystemWindowsDirectoryA
446 444 forward @ kernel32.GetSystemWindowsDirectoryW
447 445 stdcall ColorRGBToHLS(long ptr ptr ptr) ColorRGBToHLS
448 446 stub @
449
450 @ stdcall DllGetVersion (ptr) SHLWAPI_DllGetVersion
451 @ stdcall GetMenuPosFromID(ptr long) GetMenuPosFromID
452 @ stdcall HashData (ptr long ptr long) HashData
453 @ stub    IntlStrEqWorkerA
454 @ stub    IntlStrEqWorkerW
455 @ stdcall PathAddBackslashA (str) PathAddBackslashA
456 @ stdcall PathAddBackslashW (wstr) PathAddBackslashW
457 @ stdcall PathAddExtensionA (str str) PathAddExtensionA
458 @ stdcall PathAddExtensionW (wstr wstr) PathAddExtensionW
459 @ stdcall PathAppendA (str str) PathAppendA
460 @ stdcall PathAppendW (wstr wstr) PathAppendW
461 @ stdcall PathBuildRootA (ptr long) PathBuildRootA
462 @ stdcall PathBuildRootW (ptr long) PathBuildRootW
463 @ stdcall PathCanonicalizeA (ptr str) PathCanonicalizeA
464 @ stdcall PathCanonicalizeW (ptr wstr) PathCanonicalizeW
465 @ stdcall PathCombineA (ptr ptr ptr) PathCombineA
466 @ stdcall PathCombineW (ptr ptr ptr) PathCombineW
467 @ stdcall PathCommonPrefixA(str str ptr)PathCommonPrefixA
468 @ stdcall PathCommonPrefixW(wstr wstr ptr)PathCommonPrefixW
469 @ stdcall PathCompactPathA(long str long)PathCompactPathA
470 @ stdcall PathCompactPathExA(ptr str long long)PathCompactPathExA
471 @ stdcall PathCompactPathExW(ptr wstr long long)PathCompactPathExW
472 @ stdcall PathCompactPathW(long wstr long)PathCompactPathW
473 @ stdcall PathCreateFromUrlA(str ptr ptr long)PathCreateFromUrlA
474 @ stdcall PathCreateFromUrlW(wstr ptr ptr long)PathCreateFromUrlW
475 @ stdcall PathFileExistsA (str) PathFileExistsA
476 @ stdcall PathFileExistsW (wstr) PathFileExistsW
477 @ stdcall PathFindExtensionA (str) PathFindExtensionA
478 @ stdcall PathFindExtensionW (wstr) PathFindExtensionW
479 @ stdcall PathFindFileNameA (str) PathFindFileNameA
480 @ stdcall PathFindFileNameW (wstr) PathFindFileNameW
481 @ stdcall PathFindNextComponentA (str) PathFindNextComponentA
482 @ stdcall PathFindNextComponentW (wstr) PathFindNextComponentW
483 @ stdcall PathFindOnPathA (str ptr) PathFindOnPathA
484 @ stdcall PathFindOnPathW (wstr ptr) PathFindOnPathW
485 @ stdcall PathGetArgsA (str) PathGetArgsA
486 @ stdcall PathGetArgsW (wstr) PathGetArgsW
487 @ stdcall PathGetCharTypeA(long)PathGetCharTypeA
488 @ stdcall PathGetCharTypeW(long)PathGetCharTypeW
489 @ stdcall PathGetDriveNumberA (str) PathGetDriveNumberA
490 @ stdcall PathGetDriveNumberW (wstr) PathGetDriveNumberW
491 @ stdcall PathIsContentTypeA(str str)PathIsContentTypeA
492 @ stdcall PathIsContentTypeW(wstr wstr)PathIsContentTypeW
493 @ stdcall PathIsDirectoryA(str) PathIsDirectoryA
494 @ stdcall PathIsDirectoryW(wstr) PathIsDirectoryW
495 @ stdcall PathIsFileSpecA(str)PathIsFileSpecA
496 @ stdcall PathIsFileSpecW(wstr)PathIsFileSpecW
497 @ stdcall PathIsPrefixA(str str)PathIsPrefixA
498 @ stdcall PathIsPrefixW(wstr wstr)PathIsPrefixW
499 @ stdcall PathIsRelativeA (str) PathIsRelativeA
500 @ stdcall PathIsRelativeW (wstr) PathIsRelativeW
501 @ stdcall PathIsRootA(str) PathIsRootA
502 @ stdcall PathIsRootW(wstr) PathIsRootW
503 @ stdcall PathIsSameRootA(str str) PathIsSameRootA
504 @ stdcall PathIsSameRootW(wstr wstr) PathIsSameRootW
505 @ stdcall PathIsSystemFolderA(str long)PathIsSystemFolderA
506 @ stdcall PathIsSystemFolderW(wstr long)PathIsSystemFolderW
507 @ stdcall PathIsUNCA (str) PathIsUNCA
508 @ stdcall PathIsUNCServerA(str)PathIsUNCServerA
509 @ stdcall PathIsUNCServerShareA(str)PathIsUNCServerShareA
510 @ stdcall PathIsUNCServerShareW(wstr)PathIsUNCServerShareW
511 @ stdcall PathIsUNCServerW(wstr)PathIsUNCServerW
512 @ stdcall PathIsUNCW(wstr) PathIsUNCW
513 @ stdcall PathIsURLA(str) PathIsURLA
514 @ stdcall PathIsURLW(wstr) PathIsURLW
515 @ stdcall PathMakePrettyA(str) PathMakePrettyA
516 @ stdcall PathMakePrettyW(wstr) PathMakePrettyW
517 @ stdcall PathMakeSystemFolderA(str) PathMakeSystemFolderA
518 @ stdcall PathMakeSystemFolderW(wstr) PathMakeSystemFolderW
519 @ stdcall PathMatchSpecA  (str str) PathMatchSpecA
520 @ stdcall PathMatchSpecW  (wstr wstr) PathMatchSpecW
521 @ stdcall PathParseIconLocationA (str) PathParseIconLocationA
522 @ stdcall PathParseIconLocationW (wstr) PathParseIconLocationW
523 @ stdcall PathQuoteSpacesA (str) PathQuoteSpacesA
524 @ stdcall PathQuoteSpacesW (wstr) PathQuoteSpacesW
525 @ stdcall PathRelativePathToA(ptr str long str long)PathRelativePathToA
526 @ stdcall PathRelativePathToW(ptr str long str long)PathRelativePathToW
527 @ stdcall PathRemoveArgsA(str)PathRemoveArgsA
528 @ stdcall PathRemoveArgsW(wstr)PathRemoveArgsW
529 @ stdcall PathRemoveBackslashA (str) PathRemoveBackslashA
530 @ stdcall PathRemoveBackslashW (wstr) PathRemoveBackslashW
531 @ stdcall PathRemoveBlanksA(str) PathRemoveBlanksA
532 @ stdcall PathRemoveBlanksW(wstr) PathRemoveBlanksW
533 @ stdcall PathRemoveExtensionA(str)PathRemoveExtensionA
534 @ stdcall PathRemoveExtensionW(wstr)PathRemoveExtensionW
535 @ stdcall PathRemoveFileSpecA (str) PathRemoveFileSpecA
536 @ stdcall PathRemoveFileSpecW (wstr) PathRemoveFileSpecW
537 @ stdcall PathRenameExtensionA(str str)PathRenameExtensionA
538 @ stdcall PathRenameExtensionW(wstr wstr)PathRenameExtensionW
539 @ stdcall PathSearchAndQualifyA(str ptr long)PathSearchAndQualifyA
540 @ stdcall PathSearchAndQualifyW(wstr ptr long)PathSearchAndQualifyW
541 @ stdcall PathSetDlgItemPathA (long long ptr) PathSetDlgItemPathA
542 @ stdcall PathSetDlgItemPathW (long long ptr) PathSetDlgItemPathW
543 @ stdcall PathSkipRootA(str) PathSkipRootA
544 @ stdcall PathSkipRootW(wstr) PathSkipRootW
545 @ stdcall PathStripPathA(str) PathStripPathA
546 @ stdcall PathStripPathW(wstr) PathStripPathW
547 @ stdcall PathStripToRootA(str) PathStripToRootA
548 @ stdcall PathStripToRootW(wstr) PathStripToRootW
549 @ stdcall PathUnmakeSystemFolderA(str)PathUnmakeSystemFolderA
550 @ stdcall PathUnmakeSystemFolderW(wstr)PathUnmakeSystemFolderW
551 @ stdcall PathUnquoteSpacesA (str) PathUnquoteSpacesA
552 @ stdcall PathUnquoteSpacesW (wstr) PathUnquoteSpacesW
553 @ stdcall SHCreateShellPalette(long)SHCreateShellPalette
554 @ stdcall SHDeleteEmptyKeyA(long ptr) SHDeleteEmptyKeyA
555 @ stdcall SHDeleteEmptyKeyW(long ptr) SHDeleteEmptyKeyW
556 @ stdcall SHDeleteKeyA(long str) SHDeleteKeyA
557 @ stdcall SHDeleteKeyW(long wstr) SHDeleteKeyW
558 @ stdcall SHDeleteOrphanKeyA(long str) SHDeleteOrphanKeyA
559 @ stdcall SHDeleteOrphanKeyW(long wstr) SHDeleteOrphanKeyW
560 @ stdcall SHDeleteValueA(long  str  str) SHDeleteValueA
561 @ stdcall SHDeleteValueW(long wstr wstr) SHDeleteValueW
562 @ stdcall SHEnumKeyExA(long long str ptr) SHEnumKeyExA
563 @ stdcall SHEnumKeyExW(long long wstr ptr) SHEnumKeyExW
564 @ stdcall SHEnumValueA(long long str ptr ptr ptr ptr) SHEnumValueA
565 @ stdcall SHEnumValueW(long long wstr ptr ptr ptr ptr) SHEnumValueW
566 @ stdcall SHGetInverseCMAP ( ptr long ) SHGetInverseCMAP
567 @ stdcall SHGetValueA ( long str str ptr ptr ptr ) SHGetValueA
568 @ stdcall SHGetValueW ( long wstr wstr ptr ptr ptr ) SHGetValueW
569 @ stdcall SHIsLowMemoryMachine(long)SHIsLowMemoryMachine
570 @ stdcall SHOpenRegStreamA(long str str long)SHOpenRegStreamA
571 @ stdcall SHOpenRegStreamW(long wstr str long)SHOpenRegStreamW
572 @ stdcall SHOpenRegStream2A(long str str long)SHOpenRegStream2A
573 @ stdcall SHOpenRegStream2W(long wstr str long)SHOpenRegStream2W
574 @ stdcall SHQueryInfoKeyA(long ptr ptr ptr ptr) SHQueryInfoKeyA
575 @ stdcall SHQueryInfoKeyW(long ptr ptr ptr ptr) SHQueryInfoKeyW
576 @ stdcall SHQueryValueExA(long str ptr ptr ptr ptr) SHQueryValueExA
577 @ stdcall SHQueryValueExW(long wstr ptr ptr ptr ptr) SHQueryValueExW
578 @ stdcall SHRegCloseUSKey(ptr) SHRegCloseUSKey
579 @ stub    SHRegCreateUSKeyA
580 @ stub    SHRegCreateUSKeyW
581 @ stub    SHRegDeleteEmptyUSKeyA
582 @ stub    SHRegDeleteEmptyUSKeyW
583 @ stub    SHRegDeleteUSValueA
584 @ stub    SHRegDeleteUSValueW
585 @ stdcall SHRegEnumUSKeyA(long long str ptr long) SHRegEnumUSKeyA
586 @ stdcall SHRegEnumUSKeyW(long long wstr ptr long) SHRegEnumUSKeyW
587 @ stub    SHRegEnumUSValueA
588 @ stub    SHRegEnumUSValueW
589 @ stdcall SHRegGetBoolUSValueA(str str long long)SHRegGetBoolUSValueA
590 @ stdcall SHRegGetBoolUSValueW(wstr wstr long long)SHRegGetBoolUSValueW
591 @ stdcall SHRegGetUSValueA ( str str ptr ptr ptr long ptr long ) SHRegGetUSValueA
592 @ stdcall SHRegGetUSValueW ( wstr wstr ptr ptr ptr long ptr long ) SHRegGetUSValueW
593 @ stdcall SHRegOpenUSKeyA ( str long long long long ) SHRegOpenUSKeyA
594 @ stdcall SHRegOpenUSKeyW ( wstr long long long long ) SHRegOpenUSKeyW
595 @ stdcall SHRegQueryInfoUSKeyA ( long ptr ptr ptr ptr long ) SHRegQueryInfoUSKeyA
596 @ stdcall SHRegQueryInfoUSKeyW ( long ptr ptr ptr ptr long ) SHRegQueryInfoUSKeyW
597 @ stdcall SHRegQueryUSValueA ( long str ptr ptr ptr long ptr long ) SHRegQueryUSValueA
598 @ stdcall SHRegQueryUSValueW ( long wstr ptr ptr ptr long ptr long ) SHRegQueryUSValueW
599 @ stub    SHRegSetUSValueA
600 @ stub    SHRegSetUSValueW
601 @ stdcall SHRegWriteUSValueA (long str long ptr long long) SHRegWriteUSValueA
602 @ stdcall SHRegWriteUSValueW (long str long ptr long long) SHRegWriteUSValueW
603 @ stdcall SHSetValueA (long  str  str long ptr long) SHSetValueA
604 @ stdcall SHSetValueW (long wstr wstr long ptr long) SHSetValueW
605 @ stdcall StrCSpnA (str str) StrCSpnA
606 @ stub    StrCSpnIA
607 @ stub    StrCSpnIW
608 @ stdcall StrCSpnW (wstr wstr) StrCSpnW
609 @ stdcall StrCatBuffA (str str long) StrCatBuffA
610 @ stdcall StrCatBuffW (wstr wstr long) StrCatBuffW
611 @ stdcall StrCatW (ptr wstr) StrCatW
612 @ stdcall StrChrA (str long) StrChrA
613 @ stub    StrChrIA
614 @ stub    StrChrIW
615 @ stdcall StrChrW (wstr long) StrChrW
616 @ stdcall StrCmpIW (wstr wstr) StrCmpIW
617 @ stdcall StrCmpNA (str str long) StrCmpNA
618 @ stdcall StrCmpNIA (str str long) StrCmpNIA
619 @ stdcall StrCmpNIW (wstr wstr long) StrCmpNIW
620 @ stdcall StrCmpNW (wstr wstr long) StrCmpNW
621 @ stdcall StrCmpW (wstr wstr) StrCmpW
622 @ stdcall StrCpyNW (wstr wstr long) StrCpyNW
623 @ stdcall StrCpyW (ptr wstr) StrCpyW
624 @ stdcall StrDupA (str) StrDupA
625 @ stdcall StrDupW (wstr) StrDupW
626 @ stdcall StrFormatByteSizeA(long str long) StrFormatByteSizeA
627 @ stdcall StrFormatByteSizeW(long wstr long) StrFormatByteSizeW
628 @ stub    StrFromTimeIntervalA
629 @ stub    StrFromTimeIntervalW
630 @ stub    StrIsIntlEqualA
631 @ stub    StrIsIntlEqualW
632 @ stdcall StrNCatA(str str long) StrNCatA
633 @ stdcall StrNCatW(wstr wstr long) StrNCatW
634 @ stub    StrPBrkA
635 @ stub    StrPBrkW
636 @ stdcall StrRChrA (str str long) StrRChrA
637 @ stdcall StrRChrIA (str str long) StrRChrIA
638 @ stdcall StrRChrIW (str str long) StrRChrIW
639 @ stdcall StrRChrW (wstr wstr long) StrRChrW
640 @ stub    StrRStrIA
641 @ stub    StrRStrIW
642 @ stub    StrSpnA
643 @ stub    StrSpnW
644 @ stdcall StrStrA(str str)StrStrA
645 @ stdcall StrStrIA(str str)StrStrIA
646 @ stdcall StrStrIW(wstr wstr)StrStrIW
647 @ stdcall StrStrW(wstr wstr)StrStrW
648 @ stdcall StrToIntA(str)StrToIntA
649 @ stdcall StrToIntExA(str long ptr) StrToIntExA
650 @ stdcall StrToIntExW(wstr long ptr) StrToIntExW
651 @ stdcall StrToIntW(wstr)StrToIntW
652 @ stdcall StrTrimA(str str) StrTrimA
653 @ stub    StrTrimW
654 @ stdcall UrlApplySchemeA(str ptr ptr long) UrlApplySchemeA
655 @ stdcall UrlApplySchemeW(wstr ptr ptr long) UrlApplySchemeW
656 @ stdcall UrlCanonicalizeA(str ptr ptr long) UrlCanonicalizeA
657 @ stdcall UrlCanonicalizeW(wstr ptr ptr long) UrlCanonicalizeW
658 @ stdcall UrlCombineA(str str str ptr long) UrlCombineA
659 @ stdcall UrlCombineW(wstr wstr wstr ptr long) UrlCombineW
660 @ stdcall UrlCompareA(str str long) UrlCompareA
661 @ stdcall UrlCompareW(wstr wstr long) UrlCompareW
662 @ stub    UrlCreateFromPathA
663 @ stub    UrlCreateFromPathW
664 @ stdcall UrlEscapeA(str ptr ptr long)UrlEscapeA
665 @ stdcall UrlEscapeW(wstr ptr ptr long)UrlEscapeW
666 @ stdcall UrlGetLocationA(str) UrlGetLocationA
667 @ stdcall UrlGetLocationW(wstr) UrlGetLocationW
668 @ stdcall UrlGetPartA(str ptr ptr long long) UrlGetPartA
669 @ stdcall UrlGetPartW(wstr ptr ptr long long) UrlGetPartW
670 @ stdcall UrlHashA(str ptr long) UrlHashA
671 @ stub    UrlHashW
672 @ stdcall UrlIsA(str long) UrlIsA
673 @ stdcall UrlIsNoHistoryA(str) UrlIsNoHistoryA
674 @ stdcall UrlIsNoHistoryW(wstr) UrlIsNoHistoryW
675 @ stdcall UrlIsOpaqueA(str) UrlIsOpaqueA
676 @ stdcall UrlIsOpaqueW(wstr) UrlIsOpaqueW
677 @ stdcall UrlIsW(wstr long) UrlIsW
678 @ stdcall UrlUnescapeA(str ptr ptr long) UrlUnescapeA
679 @ stdcall UrlUnescapeW(wstr ptr ptr long) UrlUnescapeW
680 @ varargs wnsprintfA(ptr long str) wnsprintfA
681 @ varargs wnsprintfW(ptr long wstr) wnsprintfW
682 @ stdcall wvnsprintfA(ptr long str ptr) wvnsprintfA
683 @ stdcall wvnsprintfW(ptr long wstr ptr) wvnsprintfW
684
685
686 # exported in later versions
687 @ stdcall StrRetToBufA (ptr ptr ptr long) StrRetToBufA
688 @ stdcall StrRetToBufW (ptr ptr ptr long) StrRetToBufW
689 #@ stdcall StrRetToStrA (ptr ptr ptr) StrRetToStrA
690 #@ stdcall StrRetToStrW (ptr ptr ptr) StrRetToStrW
691 @ stdcall SHRegGetPathA(long str str ptr long)SHRegGetPathA
692 @ stdcall SHRegGetPathW(long wstr wstr ptr long)SHRegGetPathW
693 @ stub    MLLoadLibraryA
694 @ stub    MLLoadLibraryW
695 @ stdcall PathIsDirectoryEmptyA(str) PathIsDirectoryEmptyA
696 @ stdcall PathIsDirectoryEmptyW(wstr) PathIsDirectoryEmptyW
697 @ stdcall PathIsNetworkPathA(str) PathIsNetworkPathA
698 @ stdcall PathIsNetworkPathW(wstr) PathIsNetworkPathW
699 @ stdcall PathIsLFNFileSpecA(str) PathIsLFNFileSpecA
700 @ stdcall PathIsLFNFileSpecW(wstr) PathIsLFNFileSpecW
701 @ stdcall PathFindSuffixArrayA(str ptr long) PathFindSuffixArrayA
702 @ stdcall PathFindSuffixArrayW(wstr ptr long) PathFindSuffixArrayW
703 @ stdcall _SHGetInstanceExplorer@4(ptr) _SHGetInstanceExplorer
704 @ stdcall PathUndecorateA(str) PathUndecorateA
705 @ stdcall PathUndecorateW(wstr) PathUndecorateW
706 @ stub    PathUnExpandEnvStringsA
707 @ stub    PathUnExpandEnvStringsW
708 @ stub    SHCopyKeyA
709 @ stub    SHCopyKeyW
710 @ stub    SHAutoComplete
711 @ stdcall SHCreateStreamOnFileA(str long ptr) SHCreateStreamOnFileA
712 @ stdcall SHCreateStreamOnFileW(wstr long ptr) SHCreateStreamOnFileW
713 @ stdcall SHCreateStreamOnFileEx(wstr long long long ptr ptr) SHCreateStreamOnFileEx
714 @ stub    SHCreateStreamWrapper
715 @ stub    SHCreateThread
716 @ stdcall SHGetThreadRef (ptr) SHGetThreadRef
717 @ stdcall SHRegDuplicateHKey (long) SHRegDuplicateHKey
718 @ stdcall SHRegSetPathA(long str str str long) SHRegSetPathA
719 @ stdcall SHRegSetPathW(long wstr wstr wstr long) SHRegSetPathW
720 @ stub    SHRegisterValidateTemplate
721 @ stdcall SHSetThreadRef (ptr) SHSetThreadRef
722 @ stub    SHSkipJunction
723 @ stub    SHStrDupA
724 @ stub    SHStrDupW
725 @ stub    StrFormatByteSize64A
726 @ stub    StrFormatKBSizeA
727 @ stub    StrFormatKBSizeW