- Pull the buffer from the rpc message into the midl stub message
[wine] / dlls / netapi32 / netapi32.spec
1 init    NETAPI32_LibMain
2
3 @ stub I_BrowserDebugCall
4 @ stub I_BrowserDebugTrace
5 @ stdcall I_BrowserQueryEmulatedDomains(wstr ptr ptr) I_BrowserQueryEmulatedDomains
6 @ stub I_BrowserQueryOtherDomains
7 @ stub I_BrowserQueryStatistics
8 @ stub I_BrowserResetNetlogonState
9 @ stub I_BrowserResetStatistics
10 @ stub I_BrowserServerEnum
11 @ stdcall I_BrowserSetNetlogonState(wstr wstr wstr long) I_BrowserSetNetlogonState
12 @ stub I_NetAccountDeltas
13 @ stub I_NetAccountSync
14 @ stub I_NetDatabaseDeltas
15 @ stub I_NetDatabaseRedo
16 @ stub I_NetDatabaseSync
17 @ stub I_NetDatabaseSync2
18 @ stub I_NetDfsCreateExitPoint
19 @ stub I_NetDfsCreateLocalPartition
20 @ stub I_NetDfsDeleteExitPoint
21 @ stub I_NetDfsDeleteLocalPartition
22 @ stub I_NetDfsFixLocalVolume
23 @ stub I_NetDfsGetVersion
24 @ stub I_NetDfsIsThisADomainName
25 @ stub I_NetDfsModifyPrefix
26 @ stub I_NetDfsSetLocalVolumeState
27 @ stub I_NetDfsSetServerInfo
28 @ stub I_NetGetDCList
29 @ stub I_NetListCanonicalize
30 @ stub I_NetListTraverse
31 @ stub I_NetLogonControl
32 @ stub I_NetLogonControl2
33 @ stub I_NetLogonSamLogoff
34 @ stub I_NetLogonSamLogon
35 @ stub I_NetLogonUasLogoff
36 @ stub I_NetLogonUasLogon
37 @ stub I_NetNameCanonicalize
38 @ stub I_NetNameCompare
39 @ stub I_NetNameValidate
40 @ stub I_NetPathCanonicalize
41 @ stub I_NetPathCompare
42 @ stub I_NetPathType
43 @ stub I_NetServerAuthenticate
44 @ stub I_NetServerAuthenticate2
45 @ stub I_NetServerPasswordSet
46 @ stub I_NetServerReqChallenge
47 @ stub I_NetServerSetServiceBits
48 @ stub I_NetServerSetServiceBitsEx
49 @ stub NetAlertRaise
50 @ stub NetAlertRaiseEx
51 @ stdcall NetApiBufferAllocate(long ptr) NetApiBufferAllocate
52 @ stdcall NetApiBufferFree(ptr) NetApiBufferFree
53 @ stdcall NetApiBufferReallocate(ptr long ptr) NetApiBufferReallocate
54 @ stdcall NetApiBufferSize(ptr ptr) NetApiBufferSize
55 @ stub NetAuditClear
56 @ stub NetAuditRead
57 @ stub NetAuditWrite
58 @ stub NetBrowserStatisticsGet
59 @ stub NetConfigGet
60 @ stub NetConfigGetAll
61 @ stub NetConfigSet
62 @ stub NetConnectionEnum
63 @ stub NetDfsAdd
64 @ stub NetDfsEnum
65 @ stub NetDfsGetInfo
66 @ stub NetDfsManagerGetConfigInfo
67 @ stub NetDfsMove
68 @ stub NetDfsRemove
69 @ stub NetDfsRename
70 @ stub NetDfsSetInfo
71 @ stub NetEnumerateTrustedDomains
72 @ stub NetErrorLogClear
73 @ stub NetErrorLogRead
74 @ stub NetErrorLogWrite
75 @ stub NetFileClose
76 @ stub NetFileEnum
77 @ stub NetFileGetInfo
78 @ stub NetGetAnyDCName
79 @ stub NetGetDCName
80 @ stub NetGetDisplayInformationIndex
81 @ stub NetGroupAdd
82 @ stub NetGroupAddUser
83 @ stub NetGroupDel
84 @ stub NetGroupDelUser
85 @ stub NetGroupEnum
86 @ stub NetGroupGetInfo
87 @ stub NetGroupGetUsers
88 @ stub NetGroupSetInfo
89 @ stub NetGroupSetUsers
90 @ stub NetLocalGroupAdd
91 @ stub NetLocalGroupAddMember
92 @ stub NetLocalGroupAddMembers
93 @ stub NetLocalGroupDel
94 @ stub NetLocalGroupDelMember
95 @ stub NetLocalGroupDelMembers
96 @ stub NetLocalGroupEnum
97 @ stub NetLocalGroupGetInfo
98 @ stub NetLocalGroupGetMembers
99 @ stub NetLocalGroupSetInfo
100 @ stub NetLocalGroupSetMembers
101 @ stub NetMessageBufferSend
102 @ stub NetMessageNameAdd
103 @ stub NetMessageNameDel
104 @ stub NetMessageNameEnum
105 @ stub NetMessageNameGetInfo
106 @ stdcall NetQueryDisplayInformation(wstr long long long long ptr ptr) NetQueryDisplayInformation
107 @ stub NetRemoteComputerSupports
108 @ stub NetRemoteTOD
109 @ stub NetReplExportDirAdd
110 @ stub NetReplExportDirDel
111 @ stub NetReplExportDirEnum
112 @ stub NetReplExportDirGetInfo
113 @ stub NetReplExportDirLock
114 @ stub NetReplExportDirSetInfo
115 @ stub NetReplExportDirUnlock
116 @ stub NetReplGetInfo
117 @ stub NetReplImportDirAdd
118 @ stub NetReplImportDirDel
119 @ stub NetReplImportDirEnum
120 @ stub NetReplImportDirGetInfo
121 @ stub NetReplImportDirLock
122 @ stub NetReplImportDirUnlock
123 @ stub NetReplSetInfo
124 @ stub NetRplAdapterAdd
125 @ stub NetRplAdapterDel
126 @ stub NetRplAdapterEnum
127 @ stub NetRplBootAdd
128 @ stub NetRplBootDel
129 @ stub NetRplBootEnum
130 @ stub NetRplClose
131 @ stub NetRplConfigAdd
132 @ stub NetRplConfigDel
133 @ stub NetRplConfigEnum
134 @ stub NetRplGetInfo
135 @ stub NetRplOpen
136 @ stub NetRplProfileAdd
137 @ stub NetRplProfileClone
138 @ stub NetRplProfileDel
139 @ stub NetRplProfileEnum
140 @ stub NetRplProfileGetInfo
141 @ stub NetRplProfileSetInfo
142 @ stub NetRplSetInfo
143 @ stub NetRplSetSecurity
144 @ stub NetRplVendorAdd
145 @ stub NetRplVendorDel
146 @ stub NetRplVendorEnum
147 @ stub NetRplWkstaAdd
148 @ stub NetRplWkstaClone
149 @ stub NetRplWkstaDel
150 @ stub NetRplWkstaEnum
151 @ stub NetRplWkstaGetInfo
152 @ stub NetRplWkstaSetInfo
153 @ stub NetScheduleJobAdd
154 @ stub NetScheduleJobDel
155 @ stub NetScheduleJobEnum
156 @ stub NetScheduleJobGetInfo
157 @ stub NetServerComputerNameAdd
158 @ stub NetServerComputerNameDel
159 @ stub NetServerDiskEnum
160 @ stub NetServerEnum
161 @ stub NetServerEnumEx
162 @ stub NetServerGetInfo
163 @ stub NetServerSetInfo
164 @ stub NetServerTransportAdd
165 @ stub NetServerTransportAddEx
166 @ stub NetServerTransportDel
167 @ stub NetServerTransportEnum
168 @ stub NetServiceControl
169 @ stub NetServiceEnum
170 @ stub NetServiceGetInfo
171 @ stub NetServiceInstall
172 @ stub NetSessionDel
173 @ stub NetSessionEnum
174 @ stub NetSessionGetInfo
175 @ stub NetShareAdd
176 @ stub NetShareCheck
177 @ stub NetShareDel
178 @ stub NetShareDelSticky
179 @ stub NetShareEnum
180 @ stub NetShareEnumSticky
181 @ stub NetShareGetInfo
182 @ stub NetShareSetInfo
183 @ stub NetStatisticsGet
184 @ stub NetUseAdd
185 @ stub NetUseDel
186 @ stub NetUseEnum
187 @ stub NetUseGetInfo
188 @ stub NetUserAdd
189 @ stub NetUserChangePassword
190 @ stub NetUserDel
191 @ stub NetUserEnum
192 @ stub NetUserGetGroups
193 @ stdcall NetUserGetInfo(wstr wstr long ptr) NetUserGetInfo
194 @ stub NetUserGetLocalGroups
195 @ stub NetUserModalsGet
196 @ stub NetUserModalsSet
197 @ stub NetUserSetGroups
198 @ stub NetUserSetInfo
199 @ stub NetWkstaGetInfo
200 @ stub NetWkstaSetInfo
201 @ stub NetWkstaTransportAdd
202 @ stub NetWkstaTransportDel
203 @ stub NetWkstaTransportEnum
204 @ stub NetWkstaUserEnum
205 @ stdcall NetWkstaUserGetInfo(wstr long ptr) NetWkstaUserGetInfo
206 @ stub NetWkstaUserSetInfo
207 @ stdcall NetapipBufferAllocate(long ptr) NetApiBufferAllocate
208 @ stdcall Netbios(ptr) Netbios
209 @ stub NetpAccessCheck
210 @ stub NetpAccessCheckAndAudit
211 @ stub NetpAllocConfigName
212 @ stub NetpAllocStrFromStr
213 @ stub NetpAllocStrFromWStr
214 @ stub NetpAllocTStrFromString
215 @ stub NetpAllocWStrFromStr
216 @ stub NetpAllocWStrFromWStr
217 @ stub NetpApiStatusToNtStatus
218 @ stub NetpAssertFailed
219 @ stub NetpCloseConfigData
220 @ stub NetpCopyStringToBuffer
221 @ stub NetpCreateSecurityObject
222 @ stub NetpDbgDisplayServerInfo
223 @ stub NetpDbgPrint
224 @ forward NetpDeleteSecurityObject ntdll.RtlDeleteSecurityObject
225 @ stdcall NetpGetComputerName(ptr) NetpGetComputerName
226 @ stub NetpGetConfigBool
227 @ stub NetpGetConfigDword
228 @ stub NetpGetConfigTStrArray
229 @ stub NetpGetConfigValue
230 @ stub NetpGetDomainName
231 @ stub NetpGetFileSecurity
232 @ stub NetpGetPrivilege
233 @ stub NetpHexDump
234 @ forward NetpInitOemString ntdll.RtlInitAnsiString
235 @ stub NetpIsRemote
236 @ stub NetpIsUncComputerNameValid
237 @ stub NetpLocalTimeZoneOffset
238 @ stub NetpLogonPutUnicodeString
239 @ stub NetpNetBiosAddName
240 @ stub NetpNetBiosCall
241 @ stub NetpNetBiosDelName
242 @ stub NetpNetBiosGetAdapterNumbers
243 @ stub NetpNetBiosHangup
244 @ stub NetpNetBiosReceive
245 @ stub NetpNetBiosReset
246 @ stub NetpNetBiosSend
247 @ stub NetpNetBiosStatusToApiStatus
248 @ stub NetpNtStatusToApiStatus
249 @ stub NetpOpenConfigData
250 @ stub NetpPackString
251 @ stub NetpReleasePrivilege
252 @ stub NetpSetConfigBool
253 @ stub NetpSetConfigDword
254 @ stub NetpSetConfigTStrArray
255 @ stub NetpSetFileSecurity
256 @ stub NetpSmbCheck
257 @ stub NetpStringToNetBiosName
258 @ stub NetpTStrArrayEntryCount
259 @ stub NetpwNameCanonicalize
260 @ stub NetpwNameCompare
261 @ stub NetpwNameValidate
262 @ stub NetpwPathCanonicalize
263 @ stub NetpwPathCompare
264 @ stub NetpwPathType
265 @ stub NlBindingAddServerToCache
266 @ stub NlBindingRemoveServerFromCache
267 @ stub NlBindingSetAuthInfo
268 @ stub RxNetAccessAdd
269 @ stub RxNetAccessDel
270 @ stub RxNetAccessEnum
271 @ stub RxNetAccessGetInfo
272 @ stub RxNetAccessGetUserPerms
273 @ stub RxNetAccessSetInfo
274 @ stub RxNetServerEnum
275 @ stub RxNetUserPasswordSet
276 @ stub RxRemoteApi