- Indicate that StrRetToStrN{A|W} and StrRetToBuf{A|W} are identical
[wine] / dlls / shlwapi / shlwapi.spec
1 name shlwapi
2 type win32
3 init SHLWAPI_LibMain
4
5 import advapi32.dll
6 import user32.dll
7 import gdi32.dll
8 import kernel32.dll
9 import ntdll.dll
10
11 debug_channels (shell)
12
13 1   stdcall @(ptr ptr) SHLWAPI_1
14 2   stdcall @(wstr ptr) SHLWAPI_2
15 3   stub @
16 4   stub @
17 5   stub @
18 6   stub @
19 7   stub @
20 8   stub @
21 9   stub @
22 10  stub @
23 11  stub @
24 12  stub @
25 13  stub @
26 14  stub @
27 15  stdcall @(ptr ptr) SHLWAPI_15
28 16  stdcall @(long long long long) SHLWAPI_16
29 17  stub @
30 18  stdcall @(ptr ptr) SHLWAPI_18
31 19  stub @
32 20  stub @
33 21  stdcall @(ptr long) SHLWAPI_21
34 22  stdcall @(ptr long) SHLWAPI_22
35 23  stdcall @(ptr ptr long) SHLWAPI_23
36 24  stdcall @(ptr ptr long) SHLWAPI_24
37 25  stdcall @(long) SHLWAPI_25
38 26  stdcall @(long) SHLWAPI_26
39 27  stdcall @(long) SHLWAPI_27
40 28  stdcall @(long) SHLWAPI_28
41 29  stdcall @(long) SHLWAPI_29
42 30  stdcall @(long) SHLWAPI_30
43 31  stdcall @(long) SHLWAPI_31
44 32  stdcall @(ptr)  SHLWAPI_32
45 33  stdcall @(long) SHLWAPI_33
46 34  stdcall @(long) SHLWAPI_34
47 35  stdcall @(ptr long ptr) SHLWAPI_35
48 36  stub @
49 37  forward @ user32.CallWindowProcW
50 38  forward @ user32.CharLowerW
51 39  forward @ user32.CharLowerBuffW
52 40  stdcall @(wstr) SHLWAPI_40
53 41  stub @
54 42  stub @
55 43  forward @ user32.CharUpperW
56 44  forward @ user32.CharUpperBuffW
57 45  forward @ kernel32.CompareStringW
58 46  forward @ user32.CopyAcceleratorTableW
59 47  forward @ user32.CreateAcceleratorTableW
60 48  forward @ gdi32.CreateDCW
61 49  stub @
62 50  forward @ kernel32.CreateDirectoryW
63 51  forward @ kernel32.CreateEventW
64 52  forward @ kernel32.CreateFileW
65 53  forward @ gdi32.CreateFontIndirectW
66 54  forward @ gdi32.CreateICW
67 55  forward @ user32.CreateWindowExW
68 56  forward @ user32.DefWindowProcW
69 57  forward @ kernel32.DeleteFileW
70 58  stub @
71 59  stub @
72 60  forward @ user32.DispatchMessageW
73 61  stub @
74 62  forward @ gdi32.EnumFontFamiliesW
75 63  forward @ gdi32.EnumFontFamiliesExW
76 64  forward @ kernel32.EnumResourceNamesW
77 65  forward @ kernel32.FindFirstFileW
78 66  forward @ kernel32.FindResourceW
79 67  forward @ user32.FindWindowW
80 68  forward @ kernel32.FormatMessageW
81 69  forward @ user32.GetClassInfoW
82 70  forward @ user32.GetClassLongW
83 71  forward @ user32.GetClassNameW
84 72  forward @ user32.GetClipboardFormatNameW
85 73  forward @ kernel32.GetCurrentDirectoryW
86 74  stdcall @(long long wstr long) SHLWAPI_74
87 75  forward @ kernel32.GetFileAttributesW
88 76  forward @ kernel32.GetFullPathNameW
89 77  forward @ kernel32.GetLocaleInfoW
90 78  forward @ user32.GetMenuStringW
91 79  forward @ user32.GetMessageW
92 80  forward @ kernel32.GetModuleFileNameW
93 81  forward @ kernel32.GetSystemDirectoryW
94 82  forward @ kernel32.SearchPathW
95 83  forward @ kernel32.GetModuleHandleW
96 84  forward @ gdi32.GetObjectW
97 85  forward @ kernel32.GetPrivateProfileIntW
98 86  forward @ kernel32.GetProfileStringW
99 87  forward @ user32.GetPropW
100 88  forward @ kernel32.GetStringTypeExW
101 89  forward @ kernel32.GetTempFileNameW
102 90  forward @ kernel32.GetTempPathW
103 91  forward @ gdi32.GetTextExtentPoint32W
104 92  forward @ gdi32.GetTextFaceW
105 93  forward @ gdi32.GetTextMetricsW
106 94  forward @ user32.GetWindowLongW
107 95  forward @ user32.GetWindowTextW
108 96  forward @ user32.GetWindowTextLengthW
109 97  forward @ kernel32.GetWindowsDirectoryW
110 98  forward @ user32.InsertMenuW
111 99  forward @ user32.IsDialogMessageW
112 100 forward @ user32.LoadAcceleratorsW
113 101 forward @ user32.LoadBitmapW
114 102 forward @ user32.LoadCursorW
115 103 forward @ user32.LoadIconW
116 104 forward @ user32.LoadImageW
117 105 forward @ kernel32.LoadLibraryExW
118 106 forward @ user32.LoadMenuW
119 107 forward @ user32.LoadStringW
120 108 forward @ user32.MessageBoxIndirectW
121 109 forward @ user32.ModifyMenuW
122 110 forward @ gdi32.GetCharWidth32W
123 111 forward @ gdi32.GetCharacterPlacementW
124 112 forward @ kernel32.CopyFileW
125 113 forward @ kernel32.MoveFileW
126 114 forward @ user32.OemToCharW
127 115 forward @ kernel32.OutputDebugStringW
128 116 forward @ user32.PeekMessageW
129 117 forward @ user32.PostMessageW
130 118 forward @ user32.PostThreadMessageW
131 119 forward @ advapi32.RegCreateKeyW
132 120 forward @ advapi32.RegCreateKeyExW
133 121 forward @ advapi32.RegDeleteKeyW
134 122 forward @ advapi32.RegEnumKeyW
135 123 forward @ advapi32.RegEnumKeyExW
136 124 forward @ advapi32.RegOpenKeyW
137 125 forward @ advapi32.RegOpenKeyExW
138 126 forward @ advapi32.RegQueryInfoKeyW
139 127 forward @ advapi32.RegQueryValueW
140 128 forward @ advapi32.RegQueryValueExW
141 129 forward @ advapi32.RegSetValueW
142 130 forward @ advapi32.RegSetValueExW
143 131 forward @ user32.RegisterClassW
144 132 forward @ user32.RegisterClipboardFormatW
145 133 forward @ user32.RegisterWindowMessageW
146 134 forward @ user32.RemovePropW
147 135 forward @ user32.SendDlgItemMessageW
148 136 forward @ user32.SendMessageW
149 137 forward @ kernel32.SetCurrentDirectoryW
150 138 stub @
151 139 stub @
152 140 forward @ user32.SetPropW
153 141 forward @ user32.SetWindowLongW
154 142 forward @ user32.SetWindowsHookExW
155 143 stub @
156 144 forward @ gdi32.StartDocW
157 145 forward @ user32.SystemParametersInfoW
158 146 forward @ user32.TranslateAcceleratorW
159 147 forward @ user32.UnregisterClassW
160 148 forward @ user32.VkKeyScanW
161 149 forward @ user32.WinHelpW
162 150 forward @ user32.wvsprintfW
163 151 stdcall @(str ptr long) SHLWAPI_151
164 152 stdcall @(wstr wstr long) SHLWAPI_152
165 153 stdcall @(long long long) SHLWAPI_153
166 154 stdcall @(wstr wstr long) SHLWAPI_154
167 155 stub @
168 156 stdcall @(wstr wstr) SHLWAPI_156
169 157 stub @
170 158 stdcall @(wstr wstr) SHLWAPI_158
171 159 forward @ kernel32.CompareStringW
172 160 stub @
173 161 stub @
174 162 stdcall @(str long) SHLWAPI_162
175 163 stub @
176 164 stub @
177 165 stdcall @(long long long long) SHLWAPI_165
178 166 stub @
179 167 stub @
180 168 stub @
181 169 stdcall @(long) SHLWAPI_169
182 170 stdcall @(str) SHLWAPI_170
183 171 stub @
184 172 stub @
185 173 stub @
186 174 stub @
187 175 stub @
188 176 stub @
189 177 stub @
190 178 stub @
191 179 stub @
192 180 stub @
193 181 stdcall @(long long long) SHLWAPI_181
194 182 stub @
195 183 stdcall @(ptr) SHLWAPI_183
196 184 stub @
197 185 stub @
198 186 stub @
199 187 stub @
200 188 stub @
201 189 stub @
202 190 stub @
203 191 stub @
204 192 stub @
205 193 stdcall @() SHLWAPI_193
206 194 stub @
207 195 stub @
208 196 stub @
209 197 stub @
210 198 stub @
211 199 stub @
212 200 stub @
213 201 stub @
214 202 stub @
215 203 stub @
216 204 stub @
217 205 stdcall @(long str str ptr ptr ptr) SHLWAPI_205
218 206 stdcall @(long wstr wstr ptr ptr ptr) SHLWAPI_206
219 207 stub @
220 208 stub @
221 209 stub @
222 210 stub @
223 211 stub @
224 212 stub @
225 213 stub @
226 214 stub @
227 215 stdcall @(long long long) SHLWAPI_215
228 216 stub @
229 217 stdcall @(wstr ptr ptr) SHLWAPI_217
230 218 stdcall @(long wstr ptr ptr) SHLWAPI_218
231 219 stdcall @(long long long long) SHLWAPI_219
232 220 stub @
233 221 stub @
234 222 stdcall @(long) SHLWAPI_222
235 223 stdcall @(long) SHLWAPI_223
236 224 stub @
237 225 stub @
238 226 stub @
239 227 stub @
240 228 stub @
241 229 stub @
242 230 stub @
243 231 stub @
244 232 stub @
245 233 stub @
246 234 stub @
247 235 stub @
248 236 stub @
249 237 stdcall @(ptr) SHLWAPI_237
250 238 stub @
251 239 stub @
252 240 stdcall @(long long long long) SHLWAPI_240
253 241 stdcall @() SHLWAPI_241
254 242 stub @
255 243 stub @
256 244 stub @
257 245 stub @
258 246 stub @
259 247 stub @
260 248 stub @
261 249 stub @
262 250 stub @
263 251 stub @
264 252 stub @
265 253 stub AssocCreate
266 254 stub AssocQueryKeyA
267 255 stub AssocQueryKeyW
268 256 stub @
269 257 stub @
270 258 stub @
271 259 stub @
272 260 stub @
273 261 stub @
274 262 stub @
275 263 stub @
276 264 stub @
277 265 stub @
278 266 stdcall @(long long long long) SHLWAPI_266
279 267 stdcall @(long long long long) SHLWAPI_267
280 268 stdcall @(long long) SHLWAPI_268
281 269 stub @
282 270 stub @
283 271 stub @
284 272 stub @
285 273 stub @
286 274 stub @
287 275 stub @
288 276 stdcall @() SHLWAPI_276
289 277 stub @
290 278 stdcall @(long long long long long long) SHLWAPI_278
291 279 stub @
292 280 stub @
293 281 stub @
294 282 stub @
295 283 stub @
296 284 stub @
297 285 stub @
298 286 stub @
299 287 stub @
300 288 stub @
301 289 stdcall @(wstr long long) SHLWAPI_289
302 290 stub @
303 291 stub @
304 292 stub @
305 293 stub @
306 294 stdcall @(long long long long long) SHLWAPI_294
307 295 stub @
308 296 stub @
309 297 stub @
310 298 forward @ kernel32.WritePrivateProfileStringW
311 299 stub @
312 300 stub @
313 301 forward @ gdi32.DrawTextExW # FIXME CreateFontW
314 302 forward @ user32.GetMenuItemInfoW
315 303 forward @ user32.InsertMenuItemW
316 304 forward @ gdi32.CreateMetaFileW
317 305 forward @ kernel32.CreateMutexW
318 306 forward @ kernel32.ExpandEnvironmentStringsW
319 307 forward @ kernel32.CreateSemaphoreW
320 308 forward @ kernel32.IsBadStringPtrW
321 309 forward @ kernel32.LoadLibraryW
322 310 forward @ kernel32.GetTimeFormatW
323 311 forward @ kernel32.GetDateFormatW
324 312 forward @ kernel32.GetPrivateProfileStringW
325 313 stdcall @(ptr long ptr long long) SHLWAPI_313
326 314 forward @ user32.RegisterClassExW
327 315 forward @ user32.GetClassInfoExW
328 316 stub SHCreateStreamOnFileAOld
329 317 stub SHCreateStreamOnFileWOld
330 318 stdcall @(long long wstr long) SHLWAPI_318
331 319 forward @ user32.FindWindowExW
332 320 stdcall @(str str) SHLWAPI_320
333 321 stdcall @(wstr wstr) SHLWAPI_321
334 322 stdcall @(str) SHLWAPI_322
335 323 stdcall @(wstr) SHLWAPI_323
336 324 stub @
337 325 stub @
338 326 stub @
339 327 stub @
340 328 stub @
341 329 stub @
342 330 stub @
343 331 stub @
344 332 forward @ user32.CallMsgFilterW
345 333 stdcall @(ptr) SHLWAPI_333
346 334 stdcall @(ptr wstr) SHLWAPI_334
347 335 stdcall @(ptr) SHLWAPI_335
348 336 stdcall @(ptr) SHLWAPI_336
349 337 stdcall @(wstr long ptr ptr long) SHLWAPI_337
350 338 forward @ kernel32.SetFileAttributesW
351 339 forward @ kernel32.GetNumberFormatW
352 340 forward @ user32.MessageBoxW
353 341 forward @ kernel32.FindNextFileW
354 342 stdcall @(long long long long) SHLWAPI_342
355 343 stub @
356 344 stub @
357 345 stub @
358 346 stdcall @(wstr ptr long) SHLWAPI_346
359 347 forward @ advapi32.RegDeleteValueW
360 348 stub @
361 349 stub @
362 350 stub @
363 351 stub @
364 352 stub @
365 353 stub @
366 354 stub @
367 355 stub @
368 356 stub @
369 357 stdcall @(wstr wstr wstr long long) SHLWAPI_357
370 358 stdcall @(ptr ptr ptr ptr ptr ptr) SHLWAPI_358
371 359 forward @ kernel32.OpenEventW
372 360 forward @ kernel32.RemoveDirectoryW
373 361 forward @ kernel32.GetShortPathNameW
374 362 stub @
375 363 stub @
376 364 stdcall @(str str long) SHLWAPI_364
377 365 stub @
378 366 forward @ advapi32.RegEnumValueW
379 367 forward @ kernel32.WritePrivateProfileStructW
380 368 forward @ kernel32.GetPrivateProfileStructW
381 369 forward @ kernel32.CreateProcessW
382 370 stdcall @(long wstr long) SHLWAPI_370
383 371 stub @
384 372 stub @
385 373 stub @
386 374 stub @
387 375 stub @
388 376 stdcall @(long) SHLWAPI_376  # kernel32.GetUserDefaultUILanguage
389 377 stdcall @(long long long) SHLWAPI_377
390 378 stdcall @(long long long) SHLWAPI_378
391 379 stub @
392 380 stub @
393 381 stub AssocQueryStringA
394 382 stub AssocQueryStringByKeyA
395 383 stub AssocQueryStringByKeyW
396 384 stub AssocQueryStringW
397 385 stub ChrCmpIA
398 386 stub ChrCmpIW
399 387 stub ColorAdjustLuma
400 388 stub @
401 389 stdcall @(ptr) SHLWAPI_389
402 390 stdcall @(ptr ptr) SHLWAPI_390
403 391 stdcall @(ptr ptr ptr ptr ptr ) SHLWAPI_391
404 392 stub @
405 393 stub @
406 394 stub @
407 395 stub @
408 396 stub @
409 397 stub @
410 398 stub @
411 399 stub @
412 400 stub @
413 401 stdcall @(ptr) SHLWAPI_401
414 402 stdcall @(ptr) SHLWAPI_402
415 403 stdcall @(ptr) SHLWAPI_403
416 404 stdcall ColorHLSToRGB(long long long) ColorHLSToRGB
417 405 stub @
418 406 stub @
419 407 stub @
420 408 stub @
421 409 stub @
422 410 stub @
423 411 stub @
424 412 stub @
425 413 stub @
426 414 stub @
427 415 stub @
428 416 stub @
429 417 stub @
430 418 stub @
431 419 stub @
432 420 stub @
433 421 stub @
434 422 stub @
435 423 stub @
436 424 stub @
437 425 stub @
438 426 stub @
439 427 stub @
440 428 stub @
441 429 stub @
442 430 stub @
443 431 stdcall @(long) SHLWAPI_431
444 432 stub @
445 433 stub @
446 434 forward @ user32.SendMessageTimeoutW
447 435 stub @
448 436 stub @
449 437 stdcall @(long) SHLWAPI_437
450 438 stub @
451 439 stub @
452 440 stub @
453 441 stub @
454 442 forward @ kernel32.GetEnvironmentVariableW
455 443 forward @ kernel32.GetSystemWindowsDirectoryA
456 444 forward @ kernel32.GetSystemWindowsDirectoryW
457 445 stub ColorRGBToHLS
458 446 stub @
459
460 @ stdcall DllGetVersion (ptr) SHLWAPI_DllGetVersion
461 @ stdcall GetMenuPosFromID(ptr long) GetMenuPosFromID
462 @ stdcall HashData (ptr long ptr long) HashData
463 @ stub    IntlStrEqWorkerA
464 @ stub    IntlStrEqWorkerW
465 @ stdcall PathAddBackslashA (str) PathAddBackslashA
466 @ stdcall PathAddBackslashW (wstr) PathAddBackslashW
467 @ stdcall PathAddExtensionA (str str) PathAddExtensionA
468 @ stdcall PathAddExtensionW (wstr wstr) PathAddExtensionW
469 @ stdcall PathAppendA (str str) PathAppendA
470 @ stdcall PathAppendW (wstr wstr) PathAppendW
471 @ stdcall PathBuildRootA (ptr long) PathBuildRootA
472 @ stdcall PathBuildRootW (ptr long) PathBuildRootW
473 @ stdcall PathCanonicalizeA (ptr str) PathCanonicalizeA
474 @ stdcall PathCanonicalizeW (ptr wstr) PathCanonicalizeW
475 @ stdcall PathCombineA (ptr ptr ptr) PathCombineA
476 @ stdcall PathCombineW (ptr ptr ptr) PathCombineW
477 @ stdcall PathCommonPrefixA(str str ptr)PathCommonPrefixA
478 @ stdcall PathCommonPrefixW(wstr wstr ptr)PathCommonPrefixW
479 @ stdcall PathCompactPathA(long str long)PathCompactPathA
480 @ stdcall PathCompactPathExA(ptr str long long)PathCompactPathExA
481 @ stdcall PathCompactPathExW(ptr wstr long long)PathCompactPathExW
482 @ stdcall PathCompactPathW(long wstr long)PathCompactPathW
483 @ stdcall PathCreateFromUrlA(str ptr ptr long)PathCreateFromUrlA
484 @ stdcall PathCreateFromUrlW(wstr ptr ptr long)PathCreateFromUrlW
485 @ stdcall PathFileExistsA (str) PathFileExistsA
486 @ stdcall PathFileExistsW (wstr) PathFileExistsW
487 @ stdcall PathFindExtensionA (str) PathFindExtensionA
488 @ stdcall PathFindExtensionW (wstr) PathFindExtensionW
489 @ stdcall PathFindFileNameA (str) PathFindFileNameA
490 @ stdcall PathFindFileNameW (wstr) PathFindFileNameW
491 @ stdcall PathFindNextComponentA (str) PathFindNextComponentA
492 @ stdcall PathFindNextComponentW (wstr) PathFindNextComponentW
493 @ stdcall PathFindOnPathA (str ptr) PathFindOnPathA
494 @ stdcall PathFindOnPathW (wstr ptr) PathFindOnPathW
495 @ stdcall PathGetArgsA (str) PathGetArgsA
496 @ stdcall PathGetArgsW (wstr) PathGetArgsW
497 @ stdcall PathGetCharTypeA(long)PathGetCharTypeA
498 @ stdcall PathGetCharTypeW(long)PathGetCharTypeW
499 @ stdcall PathGetDriveNumberA (str) PathGetDriveNumberA
500 @ stdcall PathGetDriveNumberW (wstr) PathGetDriveNumberW
501 @ stdcall PathIsContentTypeA(str str)PathIsContentTypeA
502 @ stdcall PathIsContentTypeW(wstr wstr)PathIsContentTypeW
503 @ stdcall PathIsDirectoryA(str) PathIsDirectoryA
504 @ stdcall PathIsDirectoryW(wstr) PathIsDirectoryW
505 @ stdcall PathIsFileSpecA(str)PathIsFileSpecA
506 @ stdcall PathIsFileSpecW(wstr)PathIsFileSpecW
507 @ stdcall PathIsPrefixA(str str)PathIsPrefixA
508 @ stdcall PathIsPrefixW(wstr wstr)PathIsPrefixW
509 @ stdcall PathIsRelativeA (str) PathIsRelativeA
510 @ stdcall PathIsRelativeW (wstr) PathIsRelativeW
511 @ stdcall PathIsRootA(str) PathIsRootA
512 @ stdcall PathIsRootW(wstr) PathIsRootW
513 @ stdcall PathIsSameRootA(str str) PathIsSameRootA
514 @ stdcall PathIsSameRootW(wstr wstr) PathIsSameRootW
515 @ stdcall PathIsSystemFolderA(str long)PathIsSystemFolderA
516 @ stdcall PathIsSystemFolderW(wstr long)PathIsSystemFolderW
517 @ stdcall PathIsUNCA (str) PathIsUNCA
518 @ stdcall PathIsUNCServerA(str)PathIsUNCServerA
519 @ stdcall PathIsUNCServerShareA(str)PathIsUNCServerShareA
520 @ stdcall PathIsUNCServerShareW(wstr)PathIsUNCServerShareW
521 @ stdcall PathIsUNCServerW(wstr)PathIsUNCServerW
522 @ stdcall PathIsUNCW(wstr) PathIsUNCW
523 @ stdcall PathIsURLA(str) PathIsURLA
524 @ stdcall PathIsURLW(wstr) PathIsURLW
525 @ stdcall PathMakePrettyA(str) PathMakePrettyA
526 @ stdcall PathMakePrettyW(wstr) PathMakePrettyW
527 @ stdcall PathMakeSystemFolderA(str) PathMakeSystemFolderA
528 @ stdcall PathMakeSystemFolderW(wstr) PathMakeSystemFolderW
529 @ stdcall PathMatchSpecA  (str str) PathMatchSpecA
530 @ stdcall PathMatchSpecW  (wstr wstr) PathMatchSpecW
531 @ stdcall PathParseIconLocationA (str) PathParseIconLocationA
532 @ stdcall PathParseIconLocationW (wstr) PathParseIconLocationW
533 @ stdcall PathQuoteSpacesA (str) PathQuoteSpacesA
534 @ stdcall PathQuoteSpacesW (wstr) PathQuoteSpacesW
535 @ stdcall PathRelativePathToA(ptr str long str long)PathRelativePathToA
536 @ stdcall PathRelativePathToW(ptr str long str long)PathRelativePathToW
537 @ stdcall PathRemoveArgsA(str)PathRemoveArgsA
538 @ stdcall PathRemoveArgsW(wstr)PathRemoveArgsW
539 @ stdcall PathRemoveBackslashA (str) PathRemoveBackslashA
540 @ stdcall PathRemoveBackslashW (wstr) PathRemoveBackslashW
541 @ stdcall PathRemoveBlanksA(str) PathRemoveBlanksA
542 @ stdcall PathRemoveBlanksW(wstr) PathRemoveBlanksW
543 @ stdcall PathRemoveExtensionA(str)PathRemoveExtensionA
544 @ stdcall PathRemoveExtensionW(wstr)PathRemoveExtensionW
545 @ stdcall PathRemoveFileSpecA (str) PathRemoveFileSpecA
546 @ stdcall PathRemoveFileSpecW (wstr) PathRemoveFileSpecW
547 @ stdcall PathRenameExtensionA(str str)PathRenameExtensionA
548 @ stdcall PathRenameExtensionW(wstr wstr)PathRenameExtensionW
549 @ stdcall PathSearchAndQualifyA(str ptr long)PathSearchAndQualifyA
550 @ stdcall PathSearchAndQualifyW(wstr ptr long)PathSearchAndQualifyW
551 @ stdcall PathSetDlgItemPathA (long long ptr) PathSetDlgItemPathA
552 @ stdcall PathSetDlgItemPathW (long long ptr) PathSetDlgItemPathW
553 @ stdcall PathSkipRootA(str) PathSkipRootA
554 @ stdcall PathSkipRootW(wstr) PathSkipRootW
555 @ stdcall PathStripPathA(str) PathStripPathA
556 @ stdcall PathStripPathW(wstr) PathStripPathW
557 @ stdcall PathStripToRootA(str) PathStripToRootA
558 @ stdcall PathStripToRootW(wstr) PathStripToRootW
559 @ stdcall PathUnmakeSystemFolderA(str)PathUnmakeSystemFolderA
560 @ stdcall PathUnmakeSystemFolderW(wstr)PathUnmakeSystemFolderW
561 @ stdcall PathUnquoteSpacesA (str) PathUnquoteSpacesA
562 @ stdcall PathUnquoteSpacesW (wstr) PathUnquoteSpacesW
563 @ stdcall SHCreateShellPalette(long)SHCreateShellPalette
564 @ stdcall SHDeleteEmptyKeyA(long ptr) SHDeleteEmptyKeyA
565 @ stdcall SHDeleteEmptyKeyW(long ptr) SHDeleteEmptyKeyW
566 @ stdcall SHDeleteKeyA(long str) SHDeleteKeyA
567 @ stdcall SHDeleteKeyW(long wstr) SHDeleteKeyW
568 @ stub    SHDeleteOrphanKeyA
569 @ stub    SHDeleteOrphanKeyW
570 @ stdcall SHDeleteValueA(long  str  str) SHDeleteValueA
571 @ stdcall SHDeleteValueW(long wstr wstr) SHDeleteValueW
572 @ stub    SHEnumKeyExA
573 @ stub    SHEnumKeyExW
574 @ stub    SHEnumValueA
575 @ stub    SHEnumValueW
576 @ stdcall SHGetInverseCMAP ( ptr long ) SHGetInverseCMAP
577 @ stdcall SHGetValueA ( long str str ptr ptr ptr ) SHGetValueA
578 @ stdcall SHGetValueW ( long wstr wstr ptr ptr ptr ) SHGetValueW
579 @ stdcall SHIsLowMemoryMachine(long)SHIsLowMemoryMachine
580 @ stdcall SHOpenRegStreamA(long str str long)SHOpenRegStreamA
581 @ stdcall SHOpenRegStreamW(long wstr str long)SHOpenRegStreamW
582 @ stdcall SHOpenRegStream2A(long str str long)SHOpenRegStreamA
583 @ stdcall SHOpenRegStream2W(long wstr str long)SHOpenRegStreamW
584 @ stub    SHQueryInfoKeyA
585 @ stub    SHQueryInfoKeyW
586 @ stdcall SHQueryValueExA(long str ptr ptr ptr ptr) SHQueryValueExA
587 @ stdcall SHQueryValueExW(long wstr ptr ptr ptr ptr) SHQueryValueExW
588 @ stdcall SHRegCloseUSKey(ptr) SHRegCloseUSKey
589 @ stub    SHRegCreateUSKeyA
590 @ stub    SHRegCreateUSKeyW
591 @ stub    SHRegDeleteEmptyUSKeyA
592 @ stub    SHRegDeleteEmptyUSKeyW
593 @ stub    SHRegDeleteUSValueA
594 @ stub    SHRegDeleteUSValueW
595 @ stdcall SHRegEnumUSKeyA(long long str ptr long) SHRegEnumUSKeyA
596 @ stdcall SHRegEnumUSKeyW(long long wstr ptr long) SHRegEnumUSKeyW
597 @ stub    SHRegEnumUSValueA
598 @ stub    SHRegEnumUSValueW
599 @ stdcall SHRegGetBoolUSValueA(str str long long)SHRegGetBoolUSValueA
600 @ stdcall SHRegGetBoolUSValueW(wstr wstr long long)SHRegGetBoolUSValueW
601 @ stdcall SHRegGetUSValueA ( str str ptr ptr ptr long ptr long ) SHRegGetUSValueA
602 @ stdcall SHRegGetUSValueW ( wstr wstr ptr ptr ptr long ptr long ) SHRegGetUSValueW
603 @ stdcall SHRegOpenUSKeyA ( str long long long long ) SHRegOpenUSKeyA
604 @ stdcall SHRegOpenUSKeyW ( wstr long long long long ) SHRegOpenUSKeyW
605 @ stdcall SHRegQueryInfoUSKeyA ( long ptr ptr ptr ptr long ) SHRegQueryInfoUSKeyA
606 @ stdcall SHRegQueryInfoUSKeyW ( long ptr ptr ptr ptr long ) SHRegQueryInfoUSKeyW
607 @ stdcall SHRegQueryUSValueA ( long str ptr ptr ptr long ptr long ) SHRegQueryUSValueA
608 @ stdcall SHRegQueryUSValueW ( long wstr ptr ptr ptr long ptr long ) SHRegQueryUSValueW
609 @ stub    SHRegSetUSValueA
610 @ stub    SHRegSetUSValueW
611 @ stub    SHRegWriteUSValueA
612 @ stub    SHRegWriteUSValueW
613 @ stdcall SHSetValueA (long  str  str long ptr long) SHSetValueA
614 @ stdcall SHSetValueW (long wstr wstr long ptr long) SHSetValueW
615 @ stdcall StrCSpnA (str str) StrCSpnA
616 @ stub    StrCSpnIA
617 @ stub    StrCSpnIW
618 @ stdcall StrCSpnW (wstr wstr) StrCSpnW
619 @ stdcall StrCatBuffA (str str long) StrCatBuffA
620 @ stdcall StrCatBuffW (wstr wstr long) StrCatBuffW
621 @ stdcall StrCatW (ptr wstr) StrCatW
622 @ stdcall StrChrA (str long) StrChrA
623 @ stub    StrChrIA
624 @ stub    StrChrIW
625 @ stdcall StrChrW (wstr long) StrChrW
626 @ stdcall StrCmpIW (wstr wstr) StrCmpIW
627 @ stdcall StrCmpNA (str str long) StrCmpNA
628 @ stdcall StrCmpNIA (str str long) StrCmpNIA
629 @ stdcall StrCmpNIW (wstr wstr long) StrCmpNIW
630 @ stdcall StrCmpNW (wstr wstr long) StrCmpNW
631 @ stdcall StrCmpW (wstr wstr) StrCmpW
632 @ stdcall StrCpyNW (wstr wstr long) StrCpyNW
633 @ stdcall StrCpyW (ptr wstr) StrCpyW
634 @ stdcall StrDupA (str) StrDupA
635 @ stdcall StrDupW (wstr) StrDupW
636 @ stdcall StrFormatByteSizeA(long str long) StrFormatByteSizeA
637 @ stdcall StrFormatByteSizeW(long wstr long) StrFormatByteSizeW
638 @ stub    StrFromTimeIntervalA
639 @ stub    StrFromTimeIntervalW
640 @ stub    StrIsIntlEqualA
641 @ stub    StrIsIntlEqualW
642 @ stdcall StrNCatA(str str long) StrNCatA
643 @ stdcall StrNCatW(wstr wstr long) StrNCatW
644 @ stub    StrPBrkA
645 @ stub    StrPBrkW
646 @ stdcall StrRChrA (str str long) StrRChrA
647 @ stdcall StrRChrIA (str str long) StrRChrIA
648 @ stdcall StrRChrIW (str str long) StrRChrIW
649 @ stdcall StrRChrW (wstr wstr long) StrRChrW
650 @ stub    StrRStrIA
651 @ stub    StrRStrIW
652 @ stub    StrSpnA
653 @ stub    StrSpnW
654 @ stdcall StrStrA(str str)StrStrA
655 @ stdcall StrStrIA(str str)StrStrIA
656 @ stdcall StrStrIW(wstr wstr)StrStrIW
657 @ stdcall StrStrW(wstr wstr)StrStrW
658 @ stdcall StrToIntA(str)StrToIntA
659 @ stdcall StrToIntExA(str long ptr) StrToIntExA
660 @ stdcall StrToIntExW(wstr long ptr) StrToIntExW
661 @ stdcall StrToIntW(wstr)StrToIntW
662 @ stdcall StrTrimA(str str) StrTrimA
663 @ stub    StrTrimW
664 @ stub    UrlApplySchemeA
665 @ stdcall UrlApplySchemeW(str ptr ptr long) UrlApplySchemeW
666 @ stdcall UrlCanonicalizeA(str ptr ptr long) UrlCanonicalizeA
667 @ stdcall UrlCanonicalizeW(wstr ptr ptr long) UrlCanonicalizeW
668 @ stdcall UrlCombineA(str str str ptr long) UrlCombineA
669 @ stdcall UrlCombineW(wstr wstr wstr ptr long) UrlCombineW
670 @ stub    UrlCompareA
671 @ stub    UrlCompareW
672 @ stub    UrlCreateFromPathA
673 @ stub    UrlCreateFromPathW
674 @ stdcall UrlEscapeA(str ptr ptr long)UrlEscapeA
675 @ stdcall UrlEscapeW(wstr ptr ptr long)UrlEscapeW
676 @ stdcall UrlGetLocationA(str) UrlGetLocationA
677 @ stdcall UrlGetLocationW(wstr) UrlGetLocationW
678 @ stub    UrlGetPartA
679 @ stub    UrlGetPartW
680 @ stdcall UrlHashA(str ptr long) UrlHashA
681 @ stub    UrlHashW
682 @ stub    UrlIsA
683 @ stub    UrlIsNoHistoryA
684 @ stub    UrlIsNoHistoryW
685 @ stub    UrlIsOpaqueA
686 @ stub    UrlIsOpaqueW
687 @ stub    UrlIsW
688 @ stdcall UrlUnescapeA(str ptr ptr long) UrlUnescapeA
689 @ stdcall UrlUnescapeW(wstr ptr ptr long) UrlUnescapeW
690 @ varargs wnsprintfA(ptr long str) wnsprintfA
691 @ varargs wnsprintfW(ptr long wstr) wnsprintfW
692 @ forward wvnsprintfA user32.wvsnprintfA
693 @ forward wvnsprintfW user32.wvsnprintfW
694
695
696 # exported in later versions
697 @ stdcall StrRetToBufA (ptr ptr ptr long) StrRetToBufA
698 @ stdcall StrRetToBufW (ptr ptr ptr long) StrRetToBufW
699 #@ stdcall StrRetToStrA (ptr ptr ptr) StrRetToStrA
700 #@ stdcall StrRetToStrW (ptr ptr ptr) StrRetToStrW
701 @ stdcall SHRegGetPathA(long str str ptr long)SHRegGetPathA
702 @ stdcall SHRegGetPathW(long wstr wstr ptr long)SHRegGetPathW
703 @ stub    PathIsDirectoryEmptyA
704 @ stub    PathIsDirectoryEmptyW
705 @ stub    PathIsNetworkPathA
706 @ stub    PathIsNetworkPathW
707 @ stub    PathIsLFNFileSpecA
708 @ stub    PathIsLFNFileSpecW
709 @ stub    PathFindSuffixArrayA
710 @ stub    PathFindSuffixArrayW
711 @ stdcall _SHGetInstanceExplorer@4(ptr) _SHGetInstanceExplorer
712 @ stub    PathUndecorateA
713 @ stub    PathUndecorateW
714 @ stub    PathUnExpandEnvStringsA
715 @ stub    PathUnExpandEnvStringsW
716 @ stub    SHCopyKeyA
717 @ stub    SHCopyKeyW
718 @ stub    SHAutoComplete
719 @ stub    SHCreateStreamOnFileA
720 @ stub    SHCreateStreamOnFileW
721 @ stub    SHCreateStreamWrapper
722 @ stub    SHCreateThread
723 @ stub    SHGetThreadRef
724 @ stub    SHRegDuplicateHKey
725 @ stub    SHRegSetPathA
726 @ stub    SHRegSetPathW
727 @ stub    SHRegisterValidateTemplate
728 @ stub    SHSetThreadRef
729 @ stub    SHSkipJunction
730 @ stub    SHStrDupA
731 @ stub    SHStrDupW
732 @ stub    StrFormatByteSize64A
733 @ stub    StrFormatKBSizeA
734 @ stub    StrFormatKBSizeW