Stub cmc_query_configuration() and add xcmc.h header file.
[wine] / dlls / mapi32 / mapi32.spec
1   8 stub @
2  10 stdcall MAPILogonEx(long ptr ptr long ptr)
3  11 stdcall MAPILogonEx@20(long ptr ptr long ptr) MAPILogonEx
4  12 stdcall MAPIAllocateBuffer(long ptr)
5  13 stdcall MAPIAllocateBuffer@8(long ptr) MAPIAllocateBuffer
6  14 stdcall MAPIAllocateMore(long ptr ptr)
7  15 stdcall MAPIAllocateMore@12(long ptr ptr) MAPIAllocateMore
8  16 stdcall MAPIFreeBuffer(ptr)
9  17 stdcall MAPIFreeBuffer@4(ptr) MAPIFreeBuffer
10  18 stub MAPIAdminProfiles
11  19 stub MAPIAdminProfiles@8
12  20 stdcall MAPIInitialize(ptr)
13  21 stdcall MAPIInitialize@4(ptr) MAPIInitialize
14  22 stdcall MAPIUninitialize()
15  23 stdcall MAPIUninitialize@0() MAPIUninitialize
16  24 stub PRProviderInit
17  25 stub LAUNCHWIZARD
18  26 stub LaunchWizard@20
19  27 stub DllGetClassObject
20  28 stub DllCanUnloadNow
21  29 stub MAPIOpenFormMgr
22  30 stub MAPIOpenFormMgr@8
23  31 stub MAPIOpenLocalFormContainer
24  32 stub MAPIOpenLocalFormContainer@4
25  33 stdcall ScInitMapiUtil@4(long) ScInitMapiUtil
26  34 stdcall DeinitMapiUtil@0() DeinitMapiUtil
27  35 stub ScGenerateMuid@4
28  36 stub HrAllocAdviseSink@12
29  41 stub WrapProgress@20
30  42 stdcall HrThisThreadAdviseSink@8(ptr ptr) HrThisThreadAdviseSink
31  43 stub ScBinFromHexBounded@12
32  44 stub FBinFromHex@8
33  45 stub HexFromBin@12
34  46 stub BuildDisplayTable@40
35  47 stdcall SwapPlong@8(ptr long) SwapPlong
36  48 stdcall SwapPword@8(ptr long) SwapPword
37  49 stub MAPIInitIdle@4
38  50 stub MAPIDeinitIdle@0
39  51 stub InstallFilterHook@4
40  52 stub FtgRegisterIdleRoutine@20
41  53 stub EnableIdleRoutine@8
42  54 stub DeregisterIdleRoutine@4
43  55 stub ChangeIdleRoutine@28
44  59 stub MAPIGetDefaultMalloc@0
45  60 stub CreateIProp@24
46  61 stub CreateTable@36
47  62 stdcall MNLS_lstrlenW@4(wstr) MNLS_lstrlenW
48  63 stdcall MNLS_lstrcmpW@8(wstr wstr) MNLS_lstrcmpW
49  64 stdcall MNLS_lstrcpyW@8(ptr wstr) MNLS_lstrcpyW
50  65 stdcall MNLS_CompareStringW@24(long wstr wstr) MNLS_CompareStringW
51  66 stdcall MNLS_MultiByteToWideChar@24(long long str long ptr long) kernel32.MultiByteToWideChar
52  67 stdcall MNLS_WideCharToMultiByte@32(long long wstr long ptr long ptr ptr) kernel32.WideCharToMultiByte
53  68 stdcall MNLS_IsBadStringPtrW@8(ptr long) kernel32.IsBadStringPtrW
54  72 stub FEqualNames@8
55  73 stub WrapStoreEntryID@24
56  74 stub IsBadBoundedStringPtr@8
57  75 stub HrQueryAllRows@24
58  76 stdcall PropCopyMore@16(ptr ptr ptr ptr) PropCopyMore
59  77 stdcall UlPropSize@4(ptr) UlPropSize
60  78 stdcall FPropContainsProp@12(ptr ptr long) FPropContainsProp
61  79 stdcall FPropCompareProp@12(ptr long ptr) FPropCompareProp
62  80 stdcall LPropCompareProp@8(ptr ptr) LPropCompareProp
63  81 stub HrAddColumns@16
64  82 stub HrAddColumnsEx@20
65 121 stdcall -ret64 FtAddFt@16(long long long long) MAPI32_FtAddFt
66 122 stub FtAdcFt@20
67 123 stdcall -ret64 FtSubFt@16(long long long long) MAPI32_FtSubFt
68 124 stdcall -ret64 FtMulDw@12(long long long) MAPI32_FtMulDw
69 125 stdcall -ret64 FtMulDwDw@8(long long) MAPI32_FtMulDwDw
70 126 stdcall -ret64 FtNegFt@8(long long) MAPI32_FtNegFt
71 127 stub FtDivFtBogus@20
72 128 stdcall UlAddRef@4(ptr) UlAddRef
73 129 stdcall UlRelease@4(ptr) UlRelease
74 130 stdcall SzFindCh@8(str long) shlwapi.StrChrA
75 131 stdcall SzFindLastCh@8(str str long) shlwapi.StrRChrA
76 132 stdcall SzFindSz@8(str str) shlwapi.StrStrA
77 133 stub UFromSz@4
78 135 stub HrGetOneProp@12
79 136 stub HrSetOneProp@8
80 137 stub FPropExists@8
81 138 stdcall PpropFindProp@12(ptr long long) PpropFindProp
82 139 stub FreePadrlist@4
83 140 stub FreeProws@4
84 141 stub HrSzFromEntryID@12
85 142 stub HrEntryIDFromSz@12
86 143 stub HrComposeEID@28
87 144 stub HrDecomposeEID@28
88 145 stub HrComposeMsgID@24
89 146 stub HrDecomposeMsgID@24
90 147 stdcall OpenStreamOnFile@24(ptr ptr ptr ptr ptr ptr) OpenStreamOnFile
91 148 stdcall OpenStreamOnFile(ptr ptr ptr ptr ptr ptr)
92 149 stub OpenTnefStream@28
93 150 stub OpenTnefStream
94 151 stub OpenTnefStreamEx@32
95 152 stub OpenTnefStreamEx
96 153 stub GetTnefStreamCodepage@12
97 154 stub GetTnefStreamCodepage
98 155 stub UlFromSzHex@4
99 156 stub UNKOBJ_ScAllocate@12
100 157 stub UNKOBJ_ScAllocateMore@16
101 158 stub UNKOBJ_Free@8
102 159 stub UNKOBJ_FreeRows@8
103 160 stub UNKOBJ_ScCOAllocate@12
104 161 stub UNKOBJ_ScCOReallocate@12
105 162 stub UNKOBJ_COFree@8
106 163 stub UNKOBJ_ScSzFromIdsAlloc@20
107 164 stub ScCountNotifications@12
108 165 stub ScCopyNotifications@16
109 166 stub ScRelocNotifications@20
110 170 stdcall ScCountProps@12(long ptr ptr) ScCountProps
111 171 stub ScCopyProps@16
112 172 stub ScRelocProps@20
113 173 stdcall LpValFindProp@12(long long ptr) LpValFindProp
114 174 stub ScDupPropset@16
115 175 stdcall FBadRglpszA@8(ptr long) FBadRglpszA
116 176 stdcall FBadRglpszW@8(ptr long) FBadRglpszW
117 177 stdcall FBadRowSet@4(ptr) FBadRowSet
118 178 stub FBadRglpNameID@8
119 179 stdcall FBadPropTag@4(long) FBadPropTag
120 180 stdcall FBadRow@4(ptr) FBadRow
121 181 stdcall FBadProp@4(ptr) FBadProp
122 182 stdcall FBadColumnSet@4(ptr) FBadColumnSet
123 183 stub RTFSync@12
124 184 stub RTFSync
125 185 stub WrapCompressedRTFStream@12
126 186 stub WrapCompressedRTFStream
127 187 stub __ValidateParameters@8
128 188 stub __CPPValidateParameters@8
129 189 stub FBadSortOrderSet@4
130 190 stub FBadEntryList@4
131 191 stub FBadRestriction@4
132 192 stub ScUNCFromLocalPath@12
133 193 stub ScLocalPathFromUNC@12
134 194 stub HrIStorageFromStream@16
135 195 stub HrValidateIPMSubtree@20
136 196 stub OpenIMsgSession@12
137 197 stub CloseIMsgSession@4
138 198 stub OpenIMsgOnIStg@44
139 199 stub SetAttribIMsgOnIStg@16
140 200 stub GetAttribIMsgOnIStg@12
141 201 stub MapStorageSCode@4
142 202 stub ScMAPIXFromCMC
143 203 stub ScMAPIXFromSMAPI
144 204 stub EncodeID@12
145 205 stub FDecodeID@12
146 206 stub CchOfEncoding@4
147 207 stub CbOfEncoded@4
148 208 stub MAPISendDocuments
149 209 stdcall MAPILogon(long ptr ptr long long ptr)
150 210 stub MAPILogoff
151 211 stub MAPISendMail
152 212 stub MAPISaveMail
153 213 stub MAPIReadMail
154 214 stub MAPIFindNext
155 215 stub MAPIDeleteMail
156 217 stub MAPIAddress
157 218 stub MAPIDetails
158 219 stub MAPIResolveName
159 220 stub BMAPISendMail
160 221 stub BMAPISaveMail
161 222 stub BMAPIReadMail
162 223 stub BMAPIGetReadMail
163 224 stub BMAPIFindNext
164 225 stub BMAPIAddress
165 226 stub BMAPIGetAddress
166 227 stub BMAPIDetails
167 228 stub BMAPIResolveName
168 229 stub cmc_act_on
169 230 stub cmc_free
170 231 stub cmc_list
171 232 stub cmc_logoff
172 233 stub cmc_logon
173 234 stub cmc_look_up
174 235 stdcall cmc_query_configuration( long long ptr ptr )
175 236 stub cmc_read
176 237 stub cmc_send
177 238 stub cmc_send_documents
178 239 stub HrDispatchNotifications@4
179 241 stub HrValidateParameters@8
180 244 stub ScCreateConversationIndex@16
181 246 stub HrGetOmiProvidersFlags
182 247 stub HrGetOmiProvidersFlags@8
183 248 stub HrSetOmiProvidersFlagsInvalid
184 249 stub HrSetOmiProvidersFlagsInvalid@4
185 250 stub GetOutlookVersion
186 251 stub GetOutlookVersion@0
187 252 stub FixMAPI
188 253 stub FixMAPI@0
189 # This entry point is sometimes used to detect if the mapi dll came from Outlook
190 #254 stub FGetComponentPath
191 #255 stub FGetComponentPath@20