Windows must update the right edge (-1) of the last panel upon drawing
[wine] / dlls / crtdll / crtdll.spec
1 # C RunTime DLL. All functions use cdecl!
2 name    crtdll
3 type    win32
4 init    CRTDLL_Init
5
6 @ cdecl ??2@YAPAXI@Z(long) CRTDLL_new
7 @ cdecl ??3@YAXPAX@Z(long) CRTDLL_delete
8 @ cdecl ?_set_new_handler@@YAP6AHI@ZP6AHI@Z@Z(ptr) CRTDLL_set_new_handler
9 @ stub _CIacos
10 @ stub _CIasin
11 @ stub _CIatan
12 @ stub _CIatan2
13 @ stub _CIcos
14 @ stub _CIcosh
15 @ stub _CIexp
16 @ stub _CIfmod
17 @ stub _CIlog
18 @ stub _CIlog10
19 @ cdecl _CIpow() CRTDLL__CIpow
20 @ stub _CIsin
21 @ stub _CIsinh
22 @ stub _CIsqrt
23 @ stub _CItan
24 @ stub _CItanh
25 @ stub _HUGE_dll
26 @ stub _XcptFilter
27 @ cdecl __GetMainArgs(ptr ptr ptr long) CRTDLL__GetMainArgs
28 @ extern __argc_dll CRTDLL_argc_dll
29 @ extern __argv_dll CRTDLL_argv_dll
30 @ cdecl __dllonexit() CRTDLL___dllonexit
31 @ stub __doserrno
32 @ stub __fpecode
33 @ stub __isascii
34 @ stub __iscsym
35 @ stub __iscsymf
36 @ stub __mb_cur_max_dll
37 @ stub __pxcptinfoptrs
38 @ cdecl __threadhandle() GetCurrentThread
39 @ cdecl __threadid() GetCurrentThreadId
40 @ stub __toascii
41 @ cdecl _abnormal_termination() CRTDLL__abnormal_termination
42 @ cdecl _access(str long) CRTDLL__access
43 @ extern _acmdln_dll CRTDLL_acmdln_dll
44 @ stub _aexit_rtn_dll
45 @ stub _amsg_exit
46 @ stub _assert
47 @ extern _basemajor_dll CRTDLL_basemajor_dll
48 @ extern _baseminor_dll CRTDLL_baseminor_dll
49 @ extern _baseversion_dll CRTDLL_baseversion_dll
50 @ stub _beep
51 @ stub _beginthread
52 @ stub _c_exit
53 @ stub _cabs
54 @ cdecl _cexit(long) CRTDLL__cexit
55 @ stub _cgets
56 @ cdecl _chdir(str) CRTDLL__chdir
57 @ cdecl _chdrive(long) CRTDLL__chdrive
58 @ stub _chgsign
59 @ stub _chmod
60 @ stub _chsize
61 @ stub _clearfp
62 @ cdecl _close(long) CRTDLL__close
63 @ stub _commit
64 @ extern _commode_dll CRTDLL_commode_dll
65 @ stub _control87
66 @ stub _controlfp
67 @ stub _copysign
68 @ stub _cprintf
69 @ stub _cpumode_dll
70 @ stub _cputs
71 @ stub _creat
72 @ stub _cscanf
73 @ stub _ctype
74 @ stub _cwait
75 @ stub _daylight_dll
76 @ stub _dup
77 @ stub _dup2
78 @ stub _ecvt
79 @ stub _endthread
80 @ extern _environ_dll CRTDLL_environ_dll
81 @ stub _eof
82 @ cdecl _errno() CRTDLL__errno
83 @ cdecl _except_handler2(ptr ptr ptr ptr) CRTDLL__except_handler2
84 @ stub _execl
85 @ stub _execle
86 @ stub _execlp
87 @ stub _execlpe
88 @ stub _execv
89 @ stub _execve
90 @ stub _execvp
91 @ stub _execvpe
92 @ stub _exit
93 @ stub _expand
94 @ stub _fcloseall
95 @ stub _fcvt
96 @ cdecl _fdopen(long ptr) CRTDLL__fdopen
97 @ stub _fgetchar
98 @ stub _fgetwchar
99 @ stub _filbuf
100 @ stub _fileinfo_dll
101 @ stub _filelength
102 @ stub _fileno
103 @ stub _findclose
104 @ cdecl _findfirst(str ptr) CRTDLL__findfirst
105 @ cdecl _findnext(long ptr) CRTDLL__findnext
106 @ stub _finite
107 @ stub _flsbuf
108 @ stub _flushall
109 @ extern _fmode_dll CRTDLL_fmode_dll
110 @ stub _fpclass
111 @ stub _fpieee_flt
112 @ cdecl _fpreset() CRTDLL__fpreset
113 @ stub _fputchar
114 @ stub _fputwchar
115 @ cdecl _fsopen(str str long) CRTDLL__fsopen
116 @ cdecl _fstat(long ptr) CRTDLL__fstat
117 @ stub _ftime
118 @ cdecl _ftol() CRTDLL__ftol
119 @ cdecl _fullpath(ptr str long) CRTDLL__fullpath
120 @ stub _futime
121 @ stub _gcvt
122 @ stub _get_osfhandle
123 @ stub _getch
124 @ stub _getche
125 @ cdecl _getcwd(ptr long) CRTDLL__getcwd
126 @ cdecl _getdcwd(long ptr long) CRTDLL__getdcwd
127 @ stub _getdiskfree
128 @ stub _getdllprocaddr
129 @ cdecl _getdrive() CRTDLL__getdrive
130 @ stub _getdrives
131 @ stub _getpid
132 @ stub _getsystime
133 @ stub _getw
134 @ cdecl _global_unwind2(ptr) CRTDLL__global_unwind2
135 @ stub _heapchk
136 @ stub _heapmin
137 @ stub _heapset
138 @ stub _heapwalk
139 @ cdecl _hypot(double double) hypot
140 @ cdecl _initterm(ptr ptr) CRTDLL__initterm
141 @ extern _iob CRTDLL_iob
142 @ cdecl _isatty(long) CRTDLL__isatty
143 @ cdecl _isctype(long long) CRTDLL__isctype
144 @ stub _ismbbalnum
145 @ stub _ismbbalpha
146 @ stub _ismbbgraph
147 @ stub _ismbbkalnum
148 @ stub _ismbbkana
149 @ stub _ismbbkpunct
150 @ stub _ismbblead
151 @ stub _ismbbprint
152 @ stub _ismbbpunct
153 @ stub _ismbbtrail
154 @ stub _ismbcalpha
155 @ stub _ismbcdigit
156 @ stub _ismbchira
157 @ stub _ismbckata
158 @ stub _ismbcl0
159 @ stub _ismbcl1
160 @ stub _ismbcl2
161 @ stub _ismbclegal
162 @ stub _ismbclower
163 @ stub _ismbcprint
164 @ stub _ismbcspace
165 @ stub _ismbcsymbol
166 @ stub _ismbcupper
167 @ stub _ismbslead
168 @ stub _ismbstrail
169 @ stub _isnan
170 @ cdecl _itoa(long ptr long) CRTDLL__itoa
171 @ stub _itow
172 @ cdecl _j0(double) j0
173 @ cdecl _j1(double) j1
174 @ cdecl _jn(long double) jn
175 @ stub _kbhit
176 @ stub _lfind
177 @ stub _loaddll
178 @ cdecl _local_unwind2(ptr long) CRTDLL__local_unwind2
179 @ stub _locking
180 @ stub _logb
181 @ cdecl _lrotl (long long) CRTDLL__lrotl
182 @ stub _lrotr
183 @ stub _lsearch
184 @ cdecl _lseek(long long long) CRTDLL__lseek
185 @ cdecl _ltoa(long str long) CRTDLL__ltoa
186 @ stub _ltow
187 @ cdecl _makepath (ptr str str str str) CRTDLL__makepath
188 @ stub _matherr
189 @ stub _mbbtombc
190 @ stub _mbbtype
191 @ stub _mbccpy
192 @ stub _mbcjistojms
193 @ stub _mbcjmstojis
194 @ stub _mbclen
195 @ stub _mbctohira
196 @ stub _mbctokata
197 @ stub _mbctolower
198 @ stub _mbctombb
199 @ stub _mbctoupper
200 @ stub _mbctype
201 @ stub _mbsbtype
202 @ cdecl _mbscat(str str) strcat
203 @ stub _mbschr
204 @ stub _mbscmp
205 @ cdecl _mbscpy(ptr str) strcpy
206 @ stub _mbscspn
207 @ stub _mbsdec
208 @ cdecl _mbsdup(str) CRTDLL__strdup
209 @ cdecl _mbsicmp(str str) CRTDLL__mbsicmp
210 @ cdecl _mbsinc(str) CRTDLL__mbsinc
211 @ cdecl _mbslen(str) CRTDLL__mbslen
212 @ stub _mbslwr
213 @ stub _mbsnbcat
214 @ stub _mbsnbcmp
215 @ stub _mbsnbcnt
216 @ stub _mbsnbcpy
217 @ stub _mbsnbicmp
218 @ stub _mbsnbset
219 @ stub _mbsncat
220 @ stub _mbsnccnt
221 @ stub _mbsncmp
222 @ stub _mbsncpy
223 @ stub _mbsnextc
224 @ stub _mbsnicmp
225 @ stub _mbsninc
226 @ stub _mbsnset
227 @ stub _mbspbrk
228 @ cdecl _mbsrchr(str long) CRTDLL__mbsrchr
229 @ stub _mbsrev
230 @ stub _mbsset
231 @ stub _mbsspn
232 @ stub _mbsspnp
233 @ stub _mbsstr
234 @ stub _mbstok
235 @ stub _mbstrlen
236 @ stub _mbsupr
237 @ stub _memccpy
238 @ cdecl _memicmp(str str long) CRTDLL__memicmp
239 @ cdecl _mkdir(str) CRTDLL__mkdir
240 @ stub _mktemp
241 @ stub _msize
242 @ stub _nextafter
243 @ stub _onexit
244 @ cdecl _open(str long) CRTDLL__open
245 @ cdecl _open_osfhandle(long long) CRTDLL__open_osfhandle
246 @ extern _osmajor_dll CRTDLL_osmajor_dll
247 @ extern _osminor_dll CRTDLL_osminor_dll
248 @ extern _osmode_dll CRTDLL_osmode_dll
249 @ extern _osver_dll CRTDLL_osver_dll
250 @ extern _osversion_dll CRTDLL_osversion_dll
251 @ stub _pclose
252 @ stub _pctype_dll
253 @ stub _pgmptr_dll
254 @ stub _pipe
255 @ stub _popen
256 @ stub _purecall
257 @ stub _putch
258 @ stub _putenv
259 @ stub _putw
260 @ stub _pwctype_dll
261 @ cdecl _read(long ptr long) CRTDLL__read
262 @ stub _rmdir
263 @ stub _rmtmp
264 @ cdecl _rotl (long long) CRTDLL__rotl
265 @ stub _rotr
266 @ stub _scalb
267 @ stub _searchenv
268 @ stub _seterrormode
269 @ cdecl _setjmp (ptr) CRTDLL__setjmp
270 @ cdecl _setmode(long long) CRTDLL__setmode
271 @ stub _setsystime
272 @ cdecl _sleep(long) CRTDLL__sleep
273 @ stub _snprintf
274 @ stub _snwprintf
275 @ stub _sopen
276 @ stub _spawnl
277 @ stub _spawnle
278 @ stub _spawnlp
279 @ stub _spawnlpe
280 @ stub _spawnv
281 @ stub _spawnve
282 @ stub _spawnvp
283 @ stub _spawnvpe
284 @ cdecl _splitpath (str ptr ptr ptr ptr) CRTDLL__splitpath
285 @ cdecl _stat (str ptr) CRTDLL__stat
286 @ stub _statusfp
287 @ cdecl _strcmpi(str str) CRTDLL__strcmpi
288 @ cdecl _strdate(str) CRTDLL__strdate
289 @ stub _strdec
290 @ cdecl _strdup(str) CRTDLL__strdup
291 @ stub _strerror
292 @ cdecl _stricmp(str str) CRTDLL__strcmpi
293 @ stub _stricoll
294 @ stub _strinc
295 @ cdecl _strlwr(str) CRTDLL__strlwr
296 @ stub _strncnt
297 @ stub _strnextc
298 @ cdecl _strnicmp(str str long) CRTDLL__strnicmp
299 @ stub _strninc
300 @ stub _strnset
301 @ stub _strrev
302 @ stub _strset
303 @ stub _strspnp
304 @ cdecl _strtime(str) CRTDLL__strtime
305 @ cdecl _strupr(str) CRTDLL__strupr
306 @ stub _swab
307 @ stub _sys_errlist
308 @ stub _sys_nerr_dll
309 @ stub _tell
310 @ cdecl _tempnam(str ptr) CRTDLL__tempnam
311 @ stub _timezone_dll
312 @ stub _tolower
313 @ stub _toupper
314 @ stub _tzname
315 @ stub _tzset
316 @ cdecl _ultoa(long ptr long) CRTDLL__ultoa
317 @ stub _ultow
318 @ stub _umask
319 @ stub _ungetch
320 @ cdecl _unlink(str) CRTDLL__unlink
321 @ stub _unloaddll
322 @ stub _utime
323 @ stub _vsnprintf
324 @ stub _vsnwprintf
325 @ cdecl _wcsdup(wstr) CRTDLL__wcsdup
326 @ cdecl _wcsicmp(wstr wstr) CRTDLL__wcsicmp
327 @ cdecl _wcsicoll(wstr wstr) CRTDLL__wcsicoll
328 @ cdecl _wcslwr(wstr) CRTDLL__wcslwr
329 @ cdecl _wcsnicmp(wstr wstr long) CRTDLL__wcsnicmp
330 @ cdecl _wcsnset(wstr long long) CRTDLL__wcsnset
331 @ cdecl _wcsrev(wstr) CRTDLL__wcsrev
332 @ cdecl _wcsset(wstr long) CRTDLL__wcsset
333 @ cdecl _wcsupr(wstr) CRTDLL__wcsupr
334 @ extern _winmajor_dll CRTDLL_winmajor_dll
335 @ extern _winminor_dll CRTDLL_winminor_dll
336 @ extern _winver_dll CRTDLL_winver_dll
337 @ cdecl _write(long ptr long) CRTDLL__write
338 @ stub _wtoi
339 @ stub _wtol
340 @ cdecl _y0(double) y0
341 @ cdecl _y1(double) y1
342 @ cdecl _yn(long double) yn
343 @ stub abort
344 @ cdecl abs(long) abs
345 @ cdecl acos(double) acos
346 @ cdecl asctime(ptr) asctime
347 @ cdecl asin(double) asin
348 @ cdecl atan(double) atan
349 @ cdecl atan2(double double) atan2
350 @ cdecl atexit(ptr) CRTDLL_atexit
351 @ cdecl atof(str) atof
352 @ cdecl atoi(str) atoi
353 @ cdecl atol(str) atol
354 @ cdecl bsearch(ptr ptr long long ptr) bsearch
355 @ cdecl calloc(long long) CRTDLL_calloc
356 @ cdecl ceil(double) ceil
357 @ stub clearerr
358 @ cdecl clock() CRTDLL_clock
359 @ cdecl cos(double) cos
360 @ cdecl cosh(double) cosh
361 @ cdecl ctime(ptr) ctime
362 @ stub difftime
363 @ cdecl div(long long) div
364 @ cdecl exit(long) CRTDLL_exit
365 @ cdecl exp(double) exp
366 @ cdecl fabs(double) fabs
367 @ cdecl fclose(ptr) CRTDLL_fclose
368 @ cdecl feof(ptr) CRTDLL_feof
369 @ stub ferror
370 @ cdecl fflush(ptr) CRTDLL_fflush
371 @ cdecl fgetc(ptr) CRTDLL_fgetc
372 @ stub fgetpos
373 @ cdecl fgets(ptr long ptr) CRTDLL_fgets
374 @ stub fgetwc
375 @ cdecl floor(double) floor
376 @ cdecl fmod(double double) fmod
377 @ cdecl fopen(str str) CRTDLL_fopen
378 @ varargs fprintf(ptr str) CRTDLL_fprintf
379 @ cdecl fputc(long ptr) CRTDLL_fputc
380 @ cdecl fputs(str ptr) CRTDLL_fputs
381 @ stub fputwc
382 @ cdecl fread(ptr long long ptr) CRTDLL_fread
383 @ cdecl free(ptr) CRTDLL_free
384 @ cdecl freopen(str str ptr) CRTDLL_freopen
385 @ cdecl frexp(double ptr) frexp
386 @ varargs fscanf(ptr str) CRTDLL_fscanf
387 @ cdecl fseek(ptr long long) CRTDLL_fseek
388 @ cdecl fsetpos(ptr ptr) CRTDLL_fsetpos
389 @ cdecl ftell(ptr) CRTDLL_ftell
390 @ stub fwprintf
391 @ cdecl fwrite(ptr long long ptr) CRTDLL_fwrite 
392 @ stub fwscanf
393 @ cdecl getc(ptr) CRTDLL_getc
394 @ stub getchar
395 @ cdecl getenv (str) CRTDLL_getenv
396 @ cdecl gets(ptr) CRTDLL_gets
397 @ cdecl gmtime(ptr) gmtime
398 @ stub is_wctype
399 @ cdecl isalnum(long) isalnum
400 @ cdecl isalpha(long) isalpha
401 @ cdecl iscntrl(long) iscntrl
402 @ cdecl isdigit(long) isdigit
403 @ cdecl isgraph(long) isgraph
404 @ stub isleadbyte
405 @ cdecl islower(long) islower
406 @ cdecl isprint(long) isprint
407 @ cdecl ispunct(long) ispunct
408 @ cdecl isspace(long) isspace
409 @ cdecl isupper(long) isupper
410 @ cdecl iswalnum(long) CRTDLL_iswalnum
411 @ cdecl iswalpha(long) CRTDLL_iswalpha
412 @ stub iswascii
413 @ cdecl iswcntrl(long) CRTDLL_iswcntrl
414 @ cdecl iswctype(long long) CRTDLL_iswctype
415 @ cdecl iswdigit(long) CRTDLL_iswdigit
416 @ cdecl iswgraph(long) CRTDLL_iswgraph
417 @ cdecl iswlower(long) CRTDLL_iswlower
418 @ cdecl iswprint(long) CRTDLL_iswprint
419 @ cdecl iswpunct(long) CRTDLL_iswpunct
420 @ cdecl iswspace(long) CRTDLL_iswspace
421 @ cdecl iswupper(long) CRTDLL_iswupper
422 @ cdecl iswxdigit(long) CRTDLL_iswxdigit
423 @ cdecl isxdigit(long) isxdigit
424 @ cdecl labs(long) labs
425 @ cdecl ldexp(double long) ldexp
426 @ cdecl ldiv(long long) ldiv
427 @ stub localeconv
428 @ cdecl localtime(ptr) localtime
429 @ cdecl log(double) log
430 @ cdecl log10(double) log10
431 @ cdecl longjmp(ptr long) CRTDLL_longjmp
432 @ cdecl malloc(ptr) CRTDLL_malloc
433 @ cdecl mblen(str long) mblen
434 @ cdecl mbstowcs(ptr str long) CRTDLL_mbstowcs
435 @ cdecl mbtowc(ptr ptr long) CRTDLL_mbtowc
436 @ cdecl memchr(ptr long long) memchr
437 @ cdecl memcmp(ptr ptr long) memcmp
438 @ cdecl memcpy(ptr ptr long) memcpy
439 @ cdecl memmove(ptr ptr long) memmove
440 @ cdecl memset(ptr long long) memset 
441 @ cdecl mktime(ptr) mktime
442 @ cdecl modf(double ptr) modf
443 @ stub perror
444 @ cdecl pow(double double) pow
445 @ varargs printf() printf
446 @ cdecl putc(long ptr) CRTDLL_putc
447 @ cdecl putchar(long) CRTDLL_putchar
448 @ cdecl puts(str) CRTDLL_puts
449 @ cdecl qsort(ptr long long ptr) qsort
450 @ stub raise
451 @ cdecl rand() CRTDLL_rand
452 @ cdecl realloc(ptr long) CRTDLL_realloc
453 @ cdecl remove(str) CRTDLL_remove
454 @ cdecl rename(str str) CRTDLL_rename
455 @ stub rewind
456 @ stub scanf
457 @ cdecl setbuf(ptr ptr) CRTDLL_setbuf
458 @ cdecl setlocale(long ptr) CRTDLL_setlocale
459 @ stub setvbuf
460 @ cdecl signal(long ptr) CRTDLL_signal
461 @ cdecl sin(double) sin
462 @ cdecl sinh(double) sinh
463 @ varargs sprintf() sprintf
464 @ cdecl sqrt(double) sqrt
465 @ cdecl srand(long) CRTDLL_srand
466 @ varargs sscanf() sscanf
467 @ cdecl strcat(str str) strcat
468 @ cdecl strchr(str long) strchr
469 @ cdecl strcmp(str str) strcmp
470 @ cdecl strcoll(str str) strcoll
471 @ cdecl strcpy(ptr str) strcpy
472 @ cdecl strcspn(str str) strcspn
473 @ cdecl strerror(long) strerror
474 @ cdecl strftime(ptr long str ptr) strftime
475 @ cdecl strlen(str) strlen
476 @ cdecl strncat(str str long) strncat
477 @ cdecl strncmp(str str long) strncmp
478 @ cdecl strncpy(ptr str long) strncpy
479 @ cdecl strpbrk(str str) strpbrk
480 @ cdecl strrchr(str long) strrchr
481 @ cdecl strspn(str str) strspn
482 @ cdecl strstr(str str) strstr
483 @ cdecl strtod(str ptr) strtod
484 @ cdecl strtok(str str) strtok
485 @ cdecl strtol(str ptr long) strtol
486 @ cdecl strtoul(str ptr long) strtoul
487 @ cdecl strxfrm(ptr str long) strxfrm
488 @ varargs swprintf(wstr wstr) wsprintfW
489 @ stub swscanf
490 @ cdecl system(str) CRTDLL_system
491 @ cdecl tan(double) tan
492 @ cdecl tanh(double) tanh
493 @ cdecl time(ptr) CRTDLL_time
494 @ stub tmpfile
495 @ cdecl tmpnam(str) CRTDLL_tmpnam
496 @ cdecl tolower(long) tolower
497 @ cdecl toupper(long) toupper
498 @ cdecl towlower(long) towlower
499 @ cdecl towupper(long) towupper
500 @ stub ungetc
501 @ stub ungetwc
502 @ cdecl vfprintf(ptr str ptr) CRTDLL_vfprintf
503 @ stub vfwprintf
504 @ stub vprintf
505 @ cdecl vsprintf(ptr str ptr) CRTDLL_vsprintf
506 @ cdecl vswprintf(ptr wstr ptr) CRTDLL_vswprintf
507 @ stub vwprintf
508 @ cdecl wcscat(wstr wstr) CRTDLL_wcscat
509 @ cdecl wcschr(wstr long) CRTDLL_wcschr
510 @ cdecl wcscmp(wstr wstr) CRTDLL_wcscmp
511 @ cdecl wcscoll(wstr wstr) CRTDLL_wcscoll
512 @ cdecl wcscpy(ptr wstr) CRTDLL_wcscpy
513 @ cdecl wcscspn(wstr wstr) CRTDLL_wcscspn
514 @ stub wcsftime
515 @ cdecl wcslen(wstr) CRTDLL_wcslen
516 @ cdecl wcsncat(wstr wstr long) CRTDLL_wcsncat
517 @ cdecl wcsncmp(wstr wstr long) CRTDLL_wcsncmp
518 @ cdecl wcsncpy(ptr wstr long) CRTDLL_wcsncpy
519 @ cdecl wcspbrk(wstr wstr) CRTDLL_wcspbrk
520 @ cdecl wcsrchr(wstr long) CRTDLL_wcsrchr
521 @ cdecl wcsspn(wstr wstr) CRTDLL_wcsspn
522 @ cdecl wcsstr(wstr wstr) CRTDLL_wcsstr
523 @ stub wcstod
524 @ cdecl wcstok(wstr wstr) CRTDLL_wcstok
525 @ cdecl wcstol(wstr ptr long) CRTDLL_wcstol
526 @ cdecl wcstombs(ptr ptr long) CRTDLL_wcstombs
527 @ stub wcstoul
528 @ stub wcsxfrm
529 @ cdecl wctomb(ptr long) CRTDLL_wctomb
530 @ stub wprintf
531 @ stub wscanf