1 # C RunTime DLL. All functions use cdecl!
9 debug_channels (crtdll)
11 @ cdecl ??2@YAPAXI@Z(long) CRTDLL_new
12 @ cdecl ??3@YAXPAX@Z(long) CRTDLL_delete
13 @ cdecl ?_set_new_handler@@YAP6AHI@ZP6AHI@Z@Z(ptr) CRTDLL_set_new_handler
24 @ forward _CIpow ntdll._CIpow
32 @ cdecl __GetMainArgs(ptr ptr ptr long) CRTDLL__GetMainArgs
33 @ extern __argc_dll CRTDLL_argc_dll
34 @ extern __argv_dll CRTDLL_argv_dll
35 @ cdecl __dllonexit() CRTDLL___dllonexit
36 @ cdecl __doserrno() CRTDLL___doserrno
38 @ cdecl __isascii(long) CRTDLL___isascii
39 @ cdecl __iscsym(long) CRTDLL___iscsym
40 @ cdecl __iscsymf(long) CRTDLL___iscsymf
41 @ stub __mb_cur_max_dll
42 @ stub __pxcptinfoptrs
43 @ forward __threadhandle kernel32.GetCurrentThread
44 @ forward __threadid kernel32.GetCurrentThreadId
45 @ cdecl __toascii(long) CRTDLL___toascii
46 @ cdecl _abnormal_termination() CRTDLL__abnormal_termination
47 @ cdecl _access(str long) CRTDLL__access
48 @ extern _acmdln_dll CRTDLL_acmdln_dll
50 @ cdecl _amsg_exit(long) CRTDLL__amsg_exit
51 @ cdecl _assert(ptr ptr long) CRTDLL__assert
52 @ extern _basemajor_dll CRTDLL_basemajor_dll
53 @ extern _baseminor_dll CRTDLL_baseminor_dll
54 @ extern _baseversion_dll CRTDLL_baseversion_dll
55 @ cdecl _beep(long long) CRTDLL__beep
57 @ cdecl _c_exit() CRTDLL__c_exit
58 @ cdecl _cabs(long) CRTDLL__cabs
59 @ cdecl _cexit() CRTDLL__cexit
61 @ cdecl _chdir(str) CRTDLL__chdir
62 @ cdecl _chdrive(long) CRTDLL__chdrive
63 @ cdecl _chgsign(double) CRTDLL__chgsign
67 @ cdecl _close(long) CRTDLL__close
68 @ cdecl _commit(long) CRTDLL__commit
69 @ extern _commode_dll CRTDLL_commode_dll
70 @ cdecl _control87(long long) CRTDLL__control87
71 @ cdecl _controlfp(long long) CRTDLL__controlfp
72 @ cdecl _copysign(double double) CRTDLL__copysign
76 @ cdecl _creat(str long) CTRDLL__creat
85 @ extern _environ_dll CRTDLL_environ_dll
86 @ cdecl _eof(long) CRTDLL__eof
87 @ cdecl _errno() CRTDLL__errno
88 @ cdecl _except_handler2(ptr ptr ptr ptr) CRTDLL__except_handler2
97 @ cdecl _exit(long) CRTDLL__exit
98 @ cdecl _expand(ptr long) CRTDLL__expand
99 @ cdecl _fcloseall() CRTDLL__fcloseall
101 @ cdecl _fdopen(long ptr) CRTDLL__fdopen
102 @ cdecl _fgetchar() CRTDLL__fgetchar
104 @ cdecl _filbuf(ptr) CRTDLL__filbuf
107 @ cdecl _fileno(ptr) CRTDLL__fileno
108 @ cdecl _findclose(long) CRTDLL__findclose
109 @ cdecl _findfirst(str ptr) CRTDLL__findfirst
110 @ cdecl _findnext(long ptr) CRTDLL__findnext
111 @ cdecl _finite(double) CRTDLL__finite
112 @ cdecl _flsbuf(long ptr) CRTDLL__flsbuf
113 @ cdecl _flushall() CRTDLL__flushall
114 @ extern _fmode_dll CRTDLL_fmode_dll
117 @ cdecl _fpreset() CRTDLL__fpreset
118 @ cdecl _fputchar(long) CRTDLL__fputchar
120 @ cdecl _fsopen(str str long) CRTDLL__fsopen
121 @ cdecl _fstat(long ptr) CRTDLL__fstat
122 @ cdecl _ftime(ptr) CRTDLL__ftime
123 @ forward _ftol ntdll._ftol
124 @ cdecl _fullpath(ptr str long) CRTDLL__fullpath
127 @ cdecl _get_osfhandle(long) CRTDLL__get_osfhandle
130 @ cdecl _getcwd(ptr long) CRTDLL__getcwd
131 @ cdecl _getdcwd(long ptr long) CRTDLL__getdcwd
132 @ cdecl _getdiskfree(long ptr) CRTDLL__getdiskfree
133 @ forward _getdllprocaddr kernel32.GetProcAddress
134 @ cdecl _getdrive() CRTDLL__getdrive
135 @ forward _getdrives kernel32.GetLogicalDrives
139 @ cdecl _global_unwind2(ptr) CRTDLL__global_unwind2
140 @ cdecl _heapchk() CRTDLL__heapchk
141 @ cdecl _heapmin() CRTDLL__heapmin
142 @ cdecl _heapset(long) CRTDLL__heapset
143 @ cdecl _heapwalk(ptr) CRTDLL__heapwalk
144 @ cdecl _hypot(double double) hypot
145 @ cdecl _initterm(ptr ptr) CRTDLL__initterm
146 @ extern _iob __CRTDLL_iob
147 @ cdecl _isatty(long) CRTDLL__isatty
148 @ cdecl _isctype(long long) CRTDLL__isctype
174 @ cdecl _isnan(double) CRTDLL__isnan
175 @ forward _itoa ntdll._itoa
176 @ cdecl _itow(long str long) CRTDLL__itow
177 @ cdecl _j0(double) j0
178 @ cdecl _j1(double) j1
179 @ cdecl _jn(long double) jn
182 @ cdecl _loaddll(str) CRTDLL__loaddll
183 @ cdecl _local_unwind2(ptr long) CRTDLL__local_unwind2
186 @ cdecl _lrotl (long long) CRTDLL__lrotl
187 @ cdecl _lrotr (long long) CRTDLL__lrotr
188 @ cdecl _lsearch(ptr ptr long long ptr) CRTDLL__lsearch
189 @ cdecl _lseek(long long long) CRTDLL__lseek
190 @ forward _ltoa ntdll._ltoa
191 @ cdecl _ltow(long str long) CRTDLL__ltow
192 @ cdecl _makepath (ptr str str str str) CRTDLL__makepath
196 @ cdecl _mbccpy (str str) CRTDLL__mbccpy
207 @ cdecl _mbscat(str str) strcat
210 @ cdecl _mbscpy(ptr str) strcpy
213 @ cdecl _mbsdup(str) CRTDLL__strdup
214 @ cdecl _mbsicmp(str str) CRTDLL__mbsicmp
215 @ cdecl _mbsinc(str) CRTDLL__mbsinc
216 @ cdecl _mbslen(str) CRTDLL__mbslen
233 @ cdecl _mbsrchr(str long) CRTDLL__mbsrchr
242 @ cdecl _memccpy(ptr ptr long long) memccpy
243 @ forward _memicmp ntdll._memicmp
244 @ cdecl _mkdir(str) CRTDLL__mkdir
246 @ cdecl _msize(ptr) CRTDLL__msize
248 @ cdecl _onexit(ptr) CRTDLL__onexit
249 @ cdecl _open(str long) CRTDLL__open
250 @ cdecl _open_osfhandle(long long) CRTDLL__open_osfhandle
251 @ extern _osmajor_dll CRTDLL_osmajor_dll
252 @ extern _osminor_dll CRTDLL_osminor_dll
253 @ extern _osmode_dll CRTDLL_osmode_dll
254 @ extern _osver_dll CRTDLL_osver_dll
255 @ extern _osversion_dll CRTDLL_osversion_dll
266 @ cdecl _read(long ptr long) CRTDLL__read
267 @ cdecl _rmdir(str) CRTDLL__rmdir
269 @ cdecl _rotl (long long) CRTDLL__rotl
270 @ cdecl _rotr (long long) CRTDLL__rotr
274 @ cdecl _setjmp (ptr) CRTDLL__setjmp
275 @ cdecl _setmode(long long) CRTDLL__setmode
277 @ cdecl _sleep(long) CRTDLL__sleep
286 @ cdecl _spawnve(long str ptr ptr) CRTDLL__spawnve
289 @ cdecl _splitpath (str ptr ptr ptr ptr) CRTDLL__splitpath
290 @ cdecl _stat (str ptr) CRTDLL__stat
292 @ cdecl _strcmpi(str str) strcasecmp
293 @ cdecl _strdate(str) CRTDLL__strdate
294 @ cdecl _strdec(str str) CRTDLL__strdec
295 @ cdecl _strdup(str) CRTDLL__strdup
296 @ cdecl _strerror(long) CRTDLL__strerror
297 @ cdecl _stricmp(str str) strcasecmp
299 @ cdecl _strinc(str) CRTDLL__strinc
300 @ forward _strlwr ntdll._strlwr
301 @ cdecl _strncnt(str long) CRTDLL__strncnt
302 @ cdecl _strnextc(str) CRTDLL__strnextc
303 @ cdecl _strnicmp(str str long) strncasecmp
304 @ cdecl _strninc(str long) CRTDLL__strninc
305 @ cdecl _strnset(str long long) CRTDLL__strnset
306 @ cdecl _strrev(str) CRTDLL__strrev
307 @ cdecl _strset(str long) CRTDLL__strset
308 @ cdecl _strspnp(str str) CRTDLL__strspnp
309 @ cdecl _strtime(str) CRTDLL__strtime
310 @ forward _strupr ntdll._strupr
311 @ cdecl _swab(str str long) CRTDLL__swab
312 @ extern _sys_errlist sys_errlist
313 @ extern _sys_nerr_dll CRTDLL__sys_nerr
314 @ cdecl _tell(long) CRTDLL__tell
315 @ cdecl _tempnam(str ptr) CRTDLL__tempnam
317 @ cdecl _tolower(long) CRTDLL__toupper
318 @ cdecl _toupper(long) CRTDLL__tolower
321 @ forward _ultoa ntdll._ultoa
322 @ cdecl _ultow(long str long) CRTDLL__ultow
323 @ cdecl _umask(long) CRTDLL__umask
325 @ cdecl _unlink(str) CRTDLL__unlink
326 @ cdecl _unloaddll(long) CRTDLL__unloaddll
328 @ cdecl _vsnprintf(ptr long ptr ptr) vsnprintf
330 @ cdecl _wcsdup(wstr) CRTDLL__wcsdup
331 @ forward _wcsicmp ntdll._wcsicmp
332 @ cdecl _wcsicoll(wstr wstr) CRTDLL__wcsicoll
333 @ forward _wcslwr ntdll._wcslwr
334 @ forward _wcsnicmp ntdll._wcsnicmp
335 @ cdecl _wcsnset(wstr long long) CRTDLL__wcsnset
336 @ cdecl _wcsrev(wstr) CRTDLL__wcsrev
337 @ cdecl _wcsset(wstr long) CRTDLL__wcsset
338 @ forward _wcsupr ntdll._wcsupr
339 @ extern _winmajor_dll CRTDLL_winmajor_dll
340 @ extern _winminor_dll CRTDLL_winminor_dll
341 @ extern _winver_dll CRTDLL_winver_dll
342 @ cdecl _write(long ptr long) CRTDLL__write
345 @ cdecl _y0(double) y0
346 @ cdecl _y1(double) y1
347 @ cdecl _yn(long double) yn
348 @ cdecl abort() CRTDLL_abort
349 @ cdecl abs(long) abs
350 @ cdecl acos(double) acos
351 @ cdecl asctime(ptr) asctime
352 @ cdecl asin(double) asin
353 @ cdecl atan(double) atan
354 @ cdecl atan2(double double) atan2
355 @ cdecl atexit(ptr) CRTDLL_atexit
356 @ cdecl atof(str) atof
357 @ cdecl atoi(str) atoi
358 @ cdecl atol(str) atol
359 @ cdecl bsearch(ptr ptr long long ptr) bsearch
360 @ cdecl calloc(long long) CRTDLL_calloc
361 @ cdecl ceil(double) ceil
362 @ cdecl clearerr(ptr) CRTDLL_clearerr
363 @ cdecl clock() CRTDLL_clock
364 @ cdecl cos(double) cos
365 @ cdecl cosh(double) cosh
366 @ cdecl ctime(ptr) ctime
367 @ cdecl difftime(long long) CRTDLL_difftime
368 @ cdecl div(long long) div
369 @ cdecl exit(long) CRTDLL_exit
370 @ cdecl exp(double) exp
371 @ cdecl fabs(double) fabs
372 @ cdecl fclose(ptr) CRTDLL_fclose
373 @ cdecl feof(ptr) CRTDLL_feof
374 @ cdecl ferror(ptr) CRTDLL_ferror
375 @ cdecl fflush(ptr) CRTDLL_fflush
376 @ cdecl fgetc(ptr) CRTDLL_fgetc
377 @ cdecl fgetpos(ptr ptr) CRTDLL_fgetpos
378 @ cdecl fgets(ptr long ptr) CRTDLL_fgets
380 @ cdecl floor(double) floor
381 @ cdecl fmod(double double) fmod
382 @ cdecl fopen(str str) CRTDLL_fopen
383 @ varargs fprintf(ptr str) CRTDLL_fprintf
384 @ cdecl fputc(long ptr) CRTDLL_fputc
385 @ cdecl fputs(str ptr) CRTDLL_fputs
387 @ cdecl fread(ptr long long ptr) CRTDLL_fread
388 @ cdecl free(ptr) CRTDLL_free
389 @ cdecl freopen(str str ptr) CRTDLL_freopen
390 @ cdecl frexp(double ptr) frexp
391 @ varargs fscanf(ptr str) CRTDLL_fscanf
392 @ cdecl fseek(ptr long long) CRTDLL_fseek
393 @ cdecl fsetpos(ptr ptr) CRTDLL_fsetpos
394 @ cdecl ftell(ptr) CRTDLL_ftell
396 @ cdecl fwrite(ptr long long ptr) CRTDLL_fwrite
398 @ cdecl getc(ptr) CRTDLL_getc
399 @ cdecl getchar() CRTDLL_getchar
400 @ cdecl getenv (str) CRTDLL_getenv
401 @ cdecl gets(ptr) CRTDLL_gets
402 @ cdecl gmtime(ptr) gmtime
403 @ forward is_wctype ntdll.iswctype
404 @ cdecl isalnum(long) isalnum
405 @ cdecl isalpha(long) isalpha
406 @ cdecl iscntrl(long) iscntrl
407 @ cdecl isdigit(long) isdigit
408 @ cdecl isgraph(long) isgraph
410 @ cdecl islower(long) islower
411 @ cdecl isprint(long) isprint
412 @ cdecl ispunct(long) ispunct
413 @ cdecl isspace(long) isspace
414 @ cdecl isupper(long) isupper
415 @ cdecl iswalnum(long) CRTDLL_iswalnum
416 @ forward iswalpha ntdll.iswalpha
417 @ cdecl iswascii(long) CRTDLL_iswascii
418 @ cdecl iswcntrl(long) CRTDLL_iswcntrl
419 @ forward iswctype ntdll.iswctype
420 @ cdecl iswdigit(long) CRTDLL_iswdigit
421 @ cdecl iswgraph(long) CRTDLL_iswgraph
422 @ cdecl iswlower(long) CRTDLL_iswlower
423 @ cdecl iswprint(long) CRTDLL_iswprint
424 @ cdecl iswpunct(long) CRTDLL_iswpunct
425 @ cdecl iswspace(long) CRTDLL_iswspace
426 @ cdecl iswupper(long) CRTDLL_iswupper
427 @ cdecl iswxdigit(long) CRTDLL_iswxdigit
428 @ cdecl isxdigit(long) isxdigit
429 @ cdecl labs(long) labs
430 @ cdecl ldexp(double long) ldexp
431 @ cdecl ldiv(long long) ldiv
433 @ cdecl localtime(ptr) localtime
434 @ cdecl log(double) log
435 @ cdecl log10(double) log10
436 @ cdecl longjmp(ptr long) CRTDLL_longjmp
437 @ cdecl malloc(ptr) CRTDLL_malloc
438 @ cdecl mblen(str long) mblen
439 @ forward mbstowcs ntdll.mbstowcs
440 @ cdecl mbtowc(ptr ptr long) CRTDLL_mbtowc
441 @ cdecl memchr(ptr long long) memchr
442 @ cdecl memcmp(ptr ptr long) memcmp
443 @ cdecl memcpy(ptr ptr long) memcpy
444 @ cdecl memmove(ptr ptr long) memmove
445 @ cdecl memset(ptr long long) memset
446 @ cdecl mktime(ptr) mktime
447 @ cdecl modf(double ptr) modf
448 @ cdecl perror(str) CRTDLL_perror
449 @ cdecl pow(double double) pow
450 @ varargs printf() printf
451 @ cdecl putc(long ptr) CRTDLL_putc
452 @ cdecl putchar(long) CRTDLL_putchar
453 @ cdecl puts(str) CRTDLL_puts
454 @ cdecl qsort(ptr long long ptr) qsort
456 @ cdecl rand() CRTDLL_rand
457 @ cdecl realloc(ptr long) CRTDLL_realloc
458 @ cdecl remove(str) CRTDLL_remove
459 @ cdecl rename(str str) CRTDLL_rename
460 @ cdecl rewind(ptr) CRTDLL_rewind
462 @ cdecl setbuf(ptr ptr) CRTDLL_setbuf
463 @ cdecl setlocale(long ptr) CRTDLL_setlocale
465 @ cdecl signal(long ptr) CRTDLL_signal
466 @ cdecl sin(double) sin
467 @ cdecl sinh(double) sinh
468 @ varargs sprintf() sprintf
469 @ cdecl sqrt(double) sqrt
470 @ cdecl srand(long) srand
471 @ varargs sscanf() sscanf
472 @ cdecl strcat(str str) strcat
473 @ cdecl strchr(str long) strchr
474 @ cdecl strcmp(str str) strcmp
475 @ cdecl strcoll(str str) strcoll
476 @ cdecl strcpy(ptr str) strcpy
477 @ cdecl strcspn(str str) strcspn
478 @ cdecl strerror(long) CRTDLL_strerror
479 @ cdecl strftime(ptr long str ptr) strftime
480 @ cdecl strlen(str) strlen
481 @ cdecl strncat(str str long) strncat
482 @ cdecl strncmp(str str long) strncmp
483 @ cdecl strncpy(ptr str long) strncpy
484 @ cdecl strpbrk(str str) strpbrk
485 @ cdecl strrchr(str long) strrchr
486 @ cdecl strspn(str str) strspn
487 @ cdecl strstr(str str) strstr
488 @ cdecl strtod(str ptr) strtod
489 @ cdecl strtok(str str) strtok
490 @ cdecl strtol(str ptr long) strtol
491 @ cdecl strtoul(str ptr long) strtoul
492 @ cdecl strxfrm(ptr str long) strxfrm
493 @ varargs swprintf(wstr wstr) wsprintfW
495 @ cdecl system(str) CRTDLL_system
496 @ cdecl tan(double) tan
497 @ cdecl tanh(double) tanh
498 @ cdecl time(ptr) CRTDLL_time
500 @ cdecl tmpnam(str) CRTDLL_tmpnam
501 @ cdecl tolower(long) tolower
502 @ cdecl toupper(long) toupper
503 @ forward towlower ntdll.towlower
504 @ forward towupper ntdll.towupper
507 @ cdecl vfprintf(ptr str ptr) CRTDLL_vfprintf
510 @ cdecl vsprintf(ptr str ptr) vsprintf
511 @ cdecl vswprintf(ptr wstr ptr) CRTDLL_vswprintf
513 @ forward wcscat ntdll.wcscat
514 @ forward wcschr ntdll.wcschr
515 @ forward wcscmp ntdll.wcscmp
516 @ cdecl wcscoll(wstr wstr) CRTDLL_wcscoll
517 @ forward wcscpy ntdll.wcscpy
518 @ forward wcscspn ntdll.wcscspn
520 @ forward wcslen ntdll.wcslen
521 @ forward wcsncat ntdll.wcsncat
522 @ forward wcsncmp ntdll.wcsncmp
523 @ forward wcsncpy ntdll.wcsncpy
524 @ cdecl wcspbrk(wstr wstr) CRTDLL_wcspbrk
525 @ forward wcsrchr ntdll.wcsrchr
526 @ forward wcsspn ntdll.wcsspn
527 @ forward wcsstr ntdll.wcsstr
529 @ forward wcstok ntdll.wcstok
530 @ forward wcstol ntdll.wcstol
531 @ forward wcstombs ntdll.wcstombs
534 @ cdecl wctomb(ptr long) CRTDLL_wctomb