Implemented simple caching of client connections.
[wine] / dlls / wininet / wininet.spec
1 @ stdcall InternetInitializeAutoProxyDll(long)
2 @ stub ShowCertificate
3 @ stdcall CommitUrlCacheEntryA(str str double double long str long str str)
4 @ stub CommitUrlCacheEntryW
5 @ stub CreateUrlCacheContainerA
6 @ stub CreateUrlCacheContainerW
7 @ stub CreateUrlCacheEntryA
8 @ stub CreateUrlCacheEntryW
9 @ stdcall CreateUrlCacheGroup(long ptr)
10 @ stub DeleteIE3Cache
11 @ stub DeleteUrlCacheContainerA
12 @ stub DeleteUrlCacheContainerW
13 @ stdcall DeleteUrlCacheEntry(str)
14 @ stdcall DeleteUrlCacheGroup(double long ptr) DeleteUrlCacheGroup
15 @ stdcall DllInstall(long ptr) WININET_DllInstall
16 @ stub FindCloseUrlCache
17 @ stub FindFirstUrlCacheContainerA
18 @ stub FindFirstUrlCacheContainerW
19 @ stdcall FindFirstUrlCacheEntryA(str ptr ptr)
20 @ stub FindFirstUrlCacheEntryExA
21 @ stub FindFirstUrlCacheEntryExW
22 @ stdcall FindFirstUrlCacheEntryW(wstr ptr ptr)
23 @ stub FindNextUrlCacheContainerA
24 @ stub FindNextUrlCacheContainerW
25 @ stub FindNextUrlCacheEntryA
26 @ stub FindNextUrlCacheEntryExA
27 @ stub FindNextUrlCacheEntryExW
28 @ stub FindNextUrlCacheEntryW
29 @ stub FreeUrlCacheSpaceA
30 @ stub FreeUrlCacheSpaceW
31 @ stub FtpCommandA
32 @ stub FtpCommandW
33 @ stdcall FtpCreateDirectoryA(ptr str)
34 @ stdcall FtpCreateDirectoryW(ptr wstr)
35 @ stdcall FtpDeleteFileA(ptr str)
36 @ stub FtpDeleteFileW
37 @ stdcall FtpFindFirstFileA(ptr str str long long)
38 @ stdcall FtpFindFirstFileW(ptr wstr wstr long long)
39 @ stdcall FtpGetCurrentDirectoryA(ptr str ptr)
40 @ stdcall FtpGetCurrentDirectoryW(ptr wstr ptr)
41 @ stdcall FtpGetFileA(ptr str str long long long long)
42 @ stdcall FtpGetFileW(ptr wstr wstr long long long long)
43 @ stdcall FtpOpenFileA(ptr str long long long)
44 @ stdcall FtpOpenFileW(ptr wstr long long long)
45 @ stdcall FtpPutFileA(ptr str str long long)
46 @ stub FtpPutFileW
47 @ stdcall FtpRemoveDirectoryA(ptr str)
48 @ stub FtpRemoveDirectoryW
49 @ stdcall FtpRenameFileA(ptr str str)
50 @ stub FtpRenameFileW
51 @ stdcall FtpSetCurrentDirectoryA(ptr str)
52 @ stdcall FtpSetCurrentDirectoryW(ptr wstr)
53 @ stub GetUrlCacheConfigInfoA
54 @ stub GetUrlCacheConfigInfoW
55 @ stdcall GetUrlCacheEntryInfoA(str ptr long)
56 @ stdcall GetUrlCacheEntryInfoExA(str ptr ptr str ptr ptr long)
57 @ stdcall GetUrlCacheEntryInfoExW(wstr ptr ptr wstr ptr ptr long)
58 @ stub GetUrlCacheEntryInfoW
59 @ stub GetUrlCacheHeaderData
60 @ stub GopherCreateLocatorA
61 @ stub GopherCreateLocatorW
62 @ stub GopherFindFirstFileA
63 @ stub GopherFindFirstFileW
64 @ stub GopherGetAttributeA
65 @ stub GopherGetAttributeW
66 @ stub GopherGetLocatorTypeA
67 @ stub GopherGetLocatorTypeW
68 @ stub GopherOpenFileA
69 @ stub GopherOpenFileW
70 @ stdcall HttpAddRequestHeadersA(ptr str long long)
71 @ stub HttpAddRequestHeadersW
72 @ stdcall HttpEndRequestA(ptr ptr long long)
73 @ stdcall HttpEndRequestW(ptr ptr long long)
74 @ stdcall HttpOpenRequestA(ptr str str str str ptr long long)
75 @ stdcall HttpOpenRequestW(ptr wstr wstr wstr wstr ptr long long)
76 @ stdcall HttpQueryInfoA(ptr long ptr ptr ptr)
77 @ stdcall HttpQueryInfoW(ptr long ptr ptr ptr)
78 @ stdcall HttpSendRequestA(ptr str long ptr long)
79 @ stdcall HttpSendRequestExA(long ptr ptr long long)
80 @ stub HttpSendRequestExW
81 @ stdcall HttpSendRequestW(ptr wstr long ptr long)
82 @ stub IncrementUrlCacheHeaderData
83 @ stdcall InternetAttemptConnect(long)
84 @ stdcall InternetAutodial(long ptr)
85 @ stub InternetAutodialCallback
86 @ stdcall InternetAutodialHangup(long)
87 @ stdcall InternetCanonicalizeUrlA(str str ptr long)
88 @ stdcall InternetCanonicalizeUrlW(wstr wstr ptr long)
89 @ stdcall InternetCheckConnectionA(ptr long long)
90 @ stdcall InternetCheckConnectionW(ptr long long)
91 @ stdcall InternetCloseHandle(long)
92 @ stdcall InternetCombineUrlA(str str str ptr long)
93 @ stdcall InternetCombineUrlW(wstr wstr wstr ptr long)
94 @ stub InternetConfirmZoneCrossing
95 @ stdcall InternetConnectA(ptr str long str str long long long)
96 @ stdcall InternetConnectW(ptr wstr long wstr wstr long long long)
97 @ stdcall InternetCrackUrlA(str long long ptr)
98 @ stdcall InternetCrackUrlW(wstr long long ptr)
99 @ stub InternetCreateUrlA
100 @ stub InternetCreateUrlW
101 @ stub InternetDebugGetLocalTime
102 @ stub InternetDial
103 @ stub InternetErrorDlg
104 @ stdcall InternetFindNextFileA(ptr ptr)
105 @ stub InternetFindNextFileW
106 @ stub InternetGetCertByURL
107 @ stdcall InternetGetConnectedState(ptr long)
108 @ stdcall InternetGetCookieA(str str ptr long)
109 @ stdcall InternetGetCookieW(wstr wstr ptr long)
110 @ stdcall InternetGetLastResponseInfoA(ptr str ptr)
111 @ stub InternetGetLastResponseInfoW
112 @ stub InternetGoOnline
113 @ stub InternetHangUp
114 @ stdcall InternetLockRequestFile(ptr ptr)
115 @ stdcall InternetOpenA(str long str str long)
116 @ stdcall InternetOpenW(wstr long wstr wstr long)
117 @ stub InternetOpenServerPushParse
118 @ stdcall InternetOpenUrlA(ptr str str long long long)
119 @ stdcall InternetOpenUrlW(ptr wstr wstr long long long)
120 @ stdcall InternetQueryDataAvailable(ptr ptr long long)
121 @ stdcall InternetQueryOptionA(ptr long ptr ptr)
122 @ stdcall InternetQueryOptionW(ptr long ptr ptr)
123 @ stdcall InternetReadFile(ptr ptr long ptr)
124 @ stdcall InternetReadFileExA(ptr ptr long long)
125 @ stdcall InternetReadFileExW(ptr ptr long long)
126 @ stub InternetServerPushParse
127 @ stdcall InternetSetCookieA(str str str)
128 @ stdcall InternetSetCookieW(wstr wstr wstr)
129 @ stub InternetSetDialState
130 @ stub InternetSetFilePointer
131 @ stdcall InternetSetOptionA(ptr long ptr long)
132 @ stdcall InternetSetOptionW(ptr long ptr long)
133 @ stub InternetSetOptionExA
134 @ stub InternetSetOptionExW
135 @ stdcall InternetSetStatusCallback(ptr ptr) InternetSetStatusCallbackA
136 @ stdcall InternetSetStatusCallbackA(ptr ptr)
137 @ stub InternetSetStatusCallbackW
138 @ stub InternetShowSecurityInfoByURL
139 @ stub InternetTimeFromSystemTime
140 @ stub InternetTimeToSystemTime
141 @ stdcall InternetUnlockRequestFile(ptr)
142 @ stdcall InternetWriteFile(ptr ptr long ptr)
143 @ stub InternetWriteFileExA
144 @ stub InternetWriteFileExW
145 @ stdcall IsHostInProxyBypassList(long str long)
146 @ stub LoadUrlCacheContent
147 @ stub ParseX509EncodedCertificateForListBoxEntry
148 @ stub ReadUrlCacheEntryStream
149 @ stdcall RetrieveUrlCacheEntryFileA(str ptr ptr long)
150 @ stub RetrieveUrlCacheEntryFileW
151 @ stub RetrieveUrlCacheEntryStreamA
152 @ stub RetrieveUrlCacheEntryStreamW
153 @ stub RunOnceUrlCache
154 @ stub SetUrlCacheConfigInfoA
155 @ stub SetUrlCacheConfigInfoW
156 @ stdcall SetUrlCacheEntryGroup(str long double ptr long ptr)
157 @ stub SetUrlCacheEntryInfoA
158 @ stub SetUrlCacheEntryInfoW
159 @ stub SetUrlCacheHeaderData
160 @ stub ShowClientAuthCerts
161 @ stub ShowSecurityInfo
162 @ stub ShowX509EncodedCertificate
163 @ stub UnlockUrlCacheEntryFile
164 @ stub UnlockUrlCacheEntryStream
165 @ stub UpdateUrlCacheContentPath