Moved a few non-standard headers into their respective dlls.
[wine] / dlls / ddraw / ddraw.spec
1 name ddraw
2 type win32
3
4 import ole32.dll
5 import user32.dll
6 import x11drv.dll
7 import gdi32.dll
8 import kernel32.dll
9
10 @ stub DDHAL32_VidMemAlloc
11 @ stub DDHAL32_VidMemFree
12 @ stub DDInternalLock
13 @ stub DDInternalUnlock
14 @ stub DSoundHelp
15 @ stdcall DirectDrawCreate(ptr ptr ptr) DirectDrawCreate
16 @ stdcall DirectDrawCreateClipper(long ptr ptr) DirectDrawCreateClipper
17 @ stdcall DirectDrawCreateEx(ptr ptr ptr ptr) DirectDrawCreateEx
18 @ stdcall DirectDrawEnumerateA(ptr ptr) DirectDrawEnumerateA
19 @ stdcall DirectDrawEnumerateW(ptr ptr) DirectDrawEnumerateW
20 @ stdcall DirectDrawEnumerateExA(ptr ptr long) DirectDrawEnumerateExA
21 @ stdcall DirectDrawEnumerateExW(ptr ptr long) DirectDrawEnumerateExW
22 @ stdcall DllCanUnloadNow() DDRAW_DllCanUnloadNow
23 @ stdcall DllGetClassObject(ptr ptr ptr) DDRAW_DllGetClassObject
24 @ stub GetNextMipMap
25 @ stub GetSurfaceFromDC
26 @ stub HeapVidMemAllocAligned
27 @ stub InternalLock
28 @ stub InternalUnlock
29 @ stub LateAllocateSurfaceMem
30 @ stub VidMemAlloc
31 @ stub VidMemAmountFree
32 @ stub VidMemFini
33 @ stub VidMemFree
34 @ stub VidMemInit
35 @ stub VidMemLargestFree
36 @ stub thk1632_ThunkData32
37 @ stub thk3216_ThunkData32