Added stubs for HttpEndRequestA/W, InternetReadFileExA/W,
[wine] / dlls / wininet / wininet.spec
1 init    WININET_LibMain
2
3 @ stub InternetInitializeAutoProxyDll
4 @ stub ShowCertificate
5 @ stdcall CommitUrlCacheEntryA(str str long long long str long str str) CommitUrlCacheEntryA
6 @ stub CommitUrlCacheEntryW
7 @ stub CreateUrlCacheContainerA
8 @ stub CreateUrlCacheContainerW
9 @ stub CreateUrlCacheEntryA
10 @ stub CreateUrlCacheEntryW
11 @ stdcall CreateUrlCacheGroup(long ptr) CreateUrlCacheGroup
12 @ stub DeleteIE3Cache
13 @ stub DeleteUrlCacheContainerA
14 @ stub DeleteUrlCacheContainerW
15 @ stdcall DeleteUrlCacheEntry(str) DeleteUrlCacheEntry
16 @ stdcall DeleteUrlCacheGroup(long long ptr) DeleteUrlCacheGroup
17 @ stdcall DllInstall(long ptr) WININET_DllInstall
18 @ stub FindCloseUrlCache
19 @ stub FindFirstUrlCacheContainerA
20 @ stub FindFirstUrlCacheContainerW
21 @ stdcall FindFirstUrlCacheEntryA(str ptr ptr) FindFirstUrlCacheEntryA
22 @ stub FindFirstUrlCacheEntryExA
23 @ stub FindFirstUrlCacheEntryExW
24 @ stdcall FindFirstUrlCacheEntryW(wstr ptr ptr) FindFirstUrlCacheEntryW
25 @ stub FindNextUrlCacheContainerA
26 @ stub FindNextUrlCacheContainerW
27 @ stub FindNextUrlCacheEntryA
28 @ stub FindNextUrlCacheEntryExA
29 @ stub FindNextUrlCacheEntryExW
30 @ stub FindNextUrlCacheEntryW
31 @ stub FreeUrlCacheSpaceA
32 @ stub FreeUrlCacheSpaceW
33 @ stdcall FtpCreateDirectoryA(ptr str)  FtpCreateDirectoryA
34 @ stub FtpCreateDirectoryW
35 @ stdcall FtpDeleteFileA(ptr str) FtpDeleteFileA
36 @ stub FtpDeleteFileW
37 @ stdcall FtpFindFirstFileA(ptr str str long long) FtpFindFirstFileA
38 @ stub FtpFindFirstFileW
39 @ stdcall FtpGetCurrentDirectoryA(ptr str ptr) FtpGetCurrentDirectoryA
40 @ stub FtpGetCurrentDirectoryW
41 @ stdcall FtpGetFileA(ptr str str long long long long) FtpGetFileA
42 @ stub FtpGetFileW
43 @ stdcall FtpOpenFileA(ptr str long long long) FtpOpenFileA
44 @ stub FtpOpenFileW
45 @ stdcall FtpPutFileA(ptr str str long long) FtpPutFileA
46 @ stub FtpPutFileW
47 @ stdcall FtpRemoveDirectoryA(ptr str) FtpRemoveDirectoryA
48 @ stub FtpRemoveDirectoryW
49 @ stdcall FtpRenameFileA(ptr str str) FtpRenameFileA
50 @ stub FtpRenameFileW
51 @ stdcall FtpSetCurrentDirectoryA(ptr str) FtpSetCurrentDirectoryA
52 @ stub FtpSetCurrentDirectoryW
53 @ stub GetUrlCacheConfigInfoA
54 @ stub GetUrlCacheConfigInfoW
55 @ stdcall GetUrlCacheEntryInfoA(str ptr long) GetUrlCacheEntryInfoA
56 @ stub GetUrlCacheEntryInfoExA
57 @ stub GetUrlCacheEntryInfoExW
58 @ stub GetUrlCacheEntryInfoW
59 @ stub GetUrlCacheHeaderData
60 @ stub GopherCreateLocatorA
61 @ stub GopherCreateLocatorW
62 @ stub GopherFindFirstFileA
63 @ stub GopherFindFirstFileW
64 @ stub GopherGetAttributeA
65 @ stub GopherGetAttributeW
66 @ stub GopherGetLocatorTypeA
67 @ stub GopherGetLocatorTypeW
68 @ stub GopherOpenFileA
69 @ stub GopherOpenFileW
70 @ stdcall HttpAddRequestHeadersA(ptr str long long) HttpAddRequestHeadersA
71 @ stub HttpAddRequestHeadersW
72 @ stdcall HttpEndRequestA(ptr ptr long long) HttpEndRequestA
73 @ stdcall HttpEndRequestW(ptr ptr long long) HttpEndRequestW
74 @ stdcall HttpOpenRequestA(ptr str str str str ptr long long) HttpOpenRequestA
75 @ stub HttpOpenRequestW
76 @ stdcall HttpQueryInfoA(ptr long ptr ptr ptr) HttpQueryInfoA
77 @ stub HttpQueryInfoW
78 @ stdcall HttpSendRequestA(ptr str long ptr long) HttpSendRequestA
79 @ stdcall HttpSendRequestExA(long ptr ptr long long) HttpSendRequestExA
80 @ stub HttpSendRequestExW
81 @ stub HttpSendRequestW
82 @ stub IncrementUrlCacheHeaderData
83 @ stdcall InternetAttemptConnect(long) InternetAttemptConnect
84 @ stdcall InternetAutodial(long ptr) InternetAutoDial
85 @ stub InternetAutodialCallback
86 @ stub InternetAutodialHangup
87 @ stdcall InternetCanonicalizeUrlA(str str ptr long) InternetCanonicalizeUrlA
88 @ stub InternetCanonicalizeUrlW
89 @ stdcall InternetCheckConnectionA(ptr long long) InternetCheckConnectionA
90 @ stub InternetCheckConnectionW
91 @ stdcall InternetCloseHandle(long) InternetCloseHandle
92 @ stub InternetCombineUrlA
93 @ stub InternetCombineUrlW
94 @ stub InternetConfirmZoneCrossing
95 @ stdcall InternetConnectA(ptr str long str str long long long) InternetConnectA
96 @ stub InternetConnectW
97 @ stdcall InternetCrackUrlA(str long long ptr) InternetCrackUrlA
98 @ stub InternetCrackUrlW
99 @ stub InternetCreateUrlA
100 @ stub InternetCreateUrlW
101 @ stub InternetDebugGetLocalTime
102 @ stub InternetDial
103 @ stub InternetErrorDlg
104 @ stdcall InternetFindNextFileA(ptr ptr) InternetFindNextFileA
105 @ stub InternetFindNextFileW
106 @ stub InternetGetCertByURL
107 @ stdcall InternetGetConnectedState(ptr long) InternetGetConnectedState
108 @ stdcall InternetGetCookieA(str str ptr long) InternetGetCookieA
109 @ stub InternetGetCookieW
110 @ stdcall InternetGetLastResponseInfoA(ptr str ptr) InternetGetLastResponseInfoA
111 @ stub InternetGetLastResponseInfoW
112 @ stub InternetGoOnline
113 @ stub InternetHangUp
114 @ stdcall InternetLockRequestFile(ptr ptr) InternetLockRequestFile
115 @ stdcall InternetOpenA(str long str str long) InternetOpenA
116 @ stub InternetOpenServerPushParse
117 @ stdcall InternetOpenUrlA(ptr str str long long long) InternetOpenUrlA
118 @ stub InternetOpenUrlW
119 @ stub InternetOpenW
120 @ stdcall InternetQueryDataAvailable(ptr ptr long long) InternetQueryDataAvailable
121 @ stdcall InternetQueryOptionA(ptr long ptr ptr) InternetQueryOptionA
122 @ stub InternetQueryOptionW
123 @ stdcall InternetReadFile(ptr ptr long ptr) InternetReadFile
124 @ stdcall InternetReadFileExA(ptr ptr long long) InternetReadFileExA
125 @ stdcall InternetReadFileExW(ptr ptr long long) InternetReadFileExW
126 @ stub InternetServerPushParse
127 @ stdcall InternetSetCookieA(str str str) InternetSetCookieA
128 @ stub InternetSetCookieW
129 @ stub InternetSetDialState
130 @ stub InternetSetFilePointer
131 @ stdcall InternetSetOptionA(ptr long ptr long) InternetSetOptionA
132 @ stdcall InternetSetOptionW(ptr long ptr long) InternetSetOptionW
133 @ stub InternetSetOptionExA
134 @ stub InternetSetOptionExW
135 @ stdcall InternetSetStatusCallback(ptr ptr) InternetSetStatusCallback
136 @ stub InternetShowSecurityInfoByURL
137 @ stub InternetTimeFromSystemTime
138 @ stub InternetTimeToSystemTime
139 @ stdcall InternetUnlockRequestFile(ptr) InternetUnlockRequestFile
140 @ stdcall InternetWriteFile(ptr ptr long ptr) InternetWriteFile
141 @ stub InternetWriteFileExA
142 @ stub InternetWriteFileExW
143 @ stub IsHostInProxyBypassList
144 @ stub LoadUrlCacheContent
145 @ stub ParseX509EncodedCertificateForListBoxEntry
146 @ stub ReadUrlCacheEntryStream
147 @ stdcall RetrieveUrlCacheEntryFileA(str ptr ptr long) RetrieveUrlCacheEntryFileA
148 @ stub RetrieveUrlCacheEntryFileW
149 @ stub RetrieveUrlCacheEntryStreamA
150 @ stub RetrieveUrlCacheEntryStreamW
151 @ stub RunOnceUrlCache
152 @ stub SetUrlCacheConfigInfoA
153 @ stub SetUrlCacheConfigInfoW
154 @ stdcall SetUrlCacheEntryGroup(str long long ptr long ptr) SetUrlCacheEntryGroup
155 @ stub SetUrlCacheEntryInfoA
156 @ stub SetUrlCacheEntryInfoW
157 @ stub SetUrlCacheHeaderData
158 @ stub ShowClientAuthCerts
159 @ stub ShowSecurityInfo
160 @ stub ShowX509EncodedCertificate
161 @ stub UnlockUrlCacheEntryFile
162 @ stub UnlockUrlCacheEntryStream
163 @ stub UpdateUrlCacheContentPath