advapi32: Fixed building TRUSTEEs with objects.
[wine] / dlls / crypt32 / crypt32.spec
1 @ stdcall CertAddCRLContextToStore(long ptr long ptr)
2 @ stdcall CertAddCTLContextToStore(long ptr long ptr)
3 @ stdcall CertAddCertificateContextToStore(long ptr long ptr)
4 @ stdcall CertAddEncodedCRLToStore(long long ptr long long ptr)
5 @ stdcall CertAddEncodedCTLToStore(long long ptr long long ptr)
6 @ stdcall CertAddEncodedCertificateToStore(long long ptr long long ptr)
7 @ stub CertAddEncodedCertificateToSystemStoreA
8 @ stub CertAddEncodedCertificateToSystemStoreW
9 @ stdcall CertAddEnhancedKeyUsageIdentifier(ptr str)
10 @ stdcall CertAddSerializedElementToStore(ptr ptr long long long long ptr ptr)
11 @ stdcall CertAddStoreToCollection(ptr ptr long long)
12 @ stdcall CertAlgIdToOID(long)
13 @ stdcall CertCloseStore(ptr long)
14 @ stub CertCompareCertificate
15 @ stub CertCompareCertificateName
16 @ stub CertCompareIntegerBlob
17 @ stub CertComparePublicKeyInfo
18 @ stdcall CertControlStore(long long long ptr)
19 @ stdcall CertCreateCRLContext(long ptr long)
20 @ stdcall CertCreateCTLContext(long ptr long)
21 @ stub CertCreateCertificateChainEngine
22 @ stdcall CertCreateCertificateContext(long ptr long)
23 @ stdcall CertDeleteCRLFromStore(ptr)
24 @ stdcall CertDeleteCTLFromStore(ptr)
25 @ stdcall CertDeleteCertificateFromStore(ptr)
26 @ stub CertDuplicateCRLContext
27 @ stub CertDuplicateCTLContext
28 @ stdcall CertDuplicateCertificateContext(ptr)
29 @ stdcall CertDuplicateStore(ptr)
30 @ stub CertEnumCRLContextProperties
31 @ stdcall CertEnumCRLsInStore(ptr ptr)
32 @ stub CertEnumCTLContextProperties
33 @ stdcall CertEnumCTLsInStore(ptr ptr)
34 @ stdcall CertEnumCertificateContextProperties(ptr long)
35 @ stdcall CertEnumCertificatesInStore(long ptr)
36 @ stdcall CertFindAttribute(str long ptr)
37 @ stub CertFindCTLInStore
38 @ stdcall CertFindCertificateInStore(long long long long ptr ptr)
39 @ stdcall CertFindExtension(str long ptr)
40 @ stdcall CertFindRDNAttr(str ptr)
41 @ stub CertFindSubjectInCTL
42 @ stdcall CertFreeCRLContext(ptr)
43 @ stdcall CertFreeCTLContext(ptr)
44 @ stub CertFreeCertificateChain
45 @ stub CertFreeCertificateChainEngine
46 @ stdcall CertFreeCertificateContext(ptr)
47 @ stdcall CertGetCRLContextProperty(ptr long ptr ptr)
48 @ stub CertGetCRLFromStore
49 @ stdcall CertGetCTLContextProperty(ptr long ptr ptr)
50 @ stub CertGetCertificateChain
51 @ stdcall CertGetCertificateContextProperty(ptr long ptr ptr)
52 @ stdcall CertGetEnhancedKeyUsage(ptr long ptr ptr)
53 @ stub CertGetIntendedKeyUsage
54 @ stub CertGetIssuerCertificateFromStore
55 @ stdcall CertGetNameStringA(ptr long long ptr ptr long)
56 @ stdcall CertGetNameStringW(ptr long long ptr ptr long)
57 @ stub CertGetPublicKeyLength
58 @ stdcall CertGetSubjectCertificateFromStore(ptr long ptr)
59 @ stdcall CertGetValidUsages(long ptr ptr ptr ptr)
60 @ stub CertIsRDNAttrsInCertificateName
61 @ stdcall CertNameToStrA(long ptr long ptr long)
62 @ stdcall CertNameToStrW(long ptr long ptr long)
63 @ stdcall CertOIDToAlgId(str)
64 @ stdcall CertOpenStore(str long long long ptr)
65 @ stdcall CertOpenSystemStoreA(long str)
66 @ stdcall CertOpenSystemStoreW(long wstr)
67 @ stdcall CertRDNValueToStrA(long ptr ptr long)
68 @ stdcall CertRDNValueToStrW(long ptr ptr long)
69 @ stdcall CertRemoveEnhancedKeyUsageIdentifier(ptr str)
70 @ stdcall CertRemoveStoreFromCollection(long long)
71 @ stdcall CertSaveStore(long long long long ptr long)
72 @ stdcall CertSerializeCRLStoreElement(ptr long ptr ptr)
73 @ stdcall CertSerializeCTLStoreElement(ptr long ptr ptr)
74 @ stdcall CertSerializeCertificateStoreElement(ptr long ptr ptr)
75 @ stdcall CertSetCRLContextProperty(ptr long long ptr)
76 @ stdcall CertSetCTLContextProperty(ptr long long ptr)
77 @ stdcall CertSetCertificateContextProperty(ptr long long ptr)
78 @ stdcall CertSetEnhancedKeyUsage(ptr ptr)
79 @ stub CertStrToNameA
80 @ stub CertStrToNameW
81 @ stub CertVerifyCRLRevocation
82 @ stub CertVerifyCRLTimeValidity
83 @ stub CertVerifyCTLUsage
84 @ stub CertVerifyRevocation
85 @ stub CertVerifySubjectCertificateContext
86 @ stdcall CertVerifyTimeValidity(ptr ptr)
87 @ stub CertVerifyValidityNesting
88 @ stub CreateFileU
89 @ stub CryptAcquireContextU
90 @ stub CryptCloseAsyncHandle
91 @ stub CryptCreateAsyncHandle
92 @ stub CryptDecodeMessage
93 @ stdcall CryptDecodeObject(long str ptr long long ptr ptr)
94 @ stdcall CryptDecodeObjectEx(long str ptr long long ptr ptr ptr)
95 @ stub CryptDecryptAndVerifyMessageSignature
96 @ stub CryptDecryptMessage
97 @ stdcall CryptEncodeObject(long str ptr ptr ptr)
98 @ stdcall CryptEncodeObjectEx(long str ptr long ptr ptr ptr)
99 @ stub CryptEncryptMessage
100 @ stub CryptEnumOIDFunction
101 @ stdcall CryptEnumOIDInfo(long long ptr ptr)
102 @ stub CryptEnumProvidersU
103 @ stub CryptExportPKCS8
104 @ stdcall CryptExportPublicKeyInfo(long long long ptr ptr)
105 @ stdcall CryptExportPublicKeyInfoEx(long long long str long ptr ptr ptr)
106 @ stdcall CryptFindOIDInfo(long ptr long)
107 @ stub CryptFormatObject
108 @ stdcall CryptFreeOIDFunctionAddress(long long)
109 @ stub CryptGetAsyncParam
110 @ stdcall CryptGetDefaultOIDDllList(long long ptr ptr)
111 @ stdcall CryptGetDefaultOIDFunctionAddress(long long wstr long ptr ptr)
112 @ stub CryptGetMessageCertificates
113 @ stub CryptGetMessageSignerCount
114 @ stdcall CryptGetOIDFunctionAddress(long long str long ptr ptr)
115 @ stdcall CryptGetOIDFunctionValue(long str str wstr ptr ptr ptr)
116 @ stdcall CryptHashCertificate(long long long ptr long ptr ptr)
117 @ stub CryptHashMessage
118 @ stub CryptHashPublicKeyInfo
119 @ stub CryptHashToBeSigned
120 @ stub CryptImportPKCS8
121 @ stdcall CryptImportPublicKeyInfo(long long ptr ptr)
122 @ stdcall CryptImportPublicKeyInfoEx(long long ptr long long ptr ptr)
123 @ stdcall CryptInitOIDFunctionSet(str long)
124 @ stdcall CryptInstallOIDFunctionAddress(ptr long str long ptr long)
125 @ stub CryptLoadSip
126 @ stdcall CryptMemAlloc(long)
127 @ stdcall CryptMemFree(ptr)
128 @ stdcall CryptMemRealloc(ptr long)
129 @ stub CryptMsgCalculateEncodedLength
130 @ stub CryptMsgClose
131 @ stub CryptMsgControl
132 @ stub CryptMsgCountersign
133 @ stub CryptMsgCountersignEncoded
134 @ stub CryptMsgEncodeAndSignCTL
135 @ stub CryptMsgGetAndVerifySigner
136 @ stub CryptMsgGetParam
137 @ stub CryptMsgOpenToDecode
138 @ stub CryptMsgOpenToEncode
139 @ stub CryptMsgSignCTL
140 @ stub CryptMsgUpdate
141 @ stub CryptMsgVerifyCountersignatureEncoded
142 @ stdcall CryptProtectData(ptr wstr ptr ptr ptr long ptr)
143 @ stdcall CryptQueryObject(long ptr long long long ptr ptr ptr ptr ptr ptr)
144 @ stdcall CryptRegisterDefaultOIDFunction(long str long wstr)
145 @ stdcall CryptRegisterOIDFunction(long str str wstr str)
146 @ stub CryptRegisterOIDInfo
147 @ stdcall CryptSIPAddProvider(ptr)
148 @ stdcall CryptSIPLoad(ptr long ptr)
149 @ stdcall CryptSIPRemoveProvider(ptr)
150 @ stdcall CryptSIPRetrieveSubjectGuid(wstr long ptr)
151 @ stub CryptSetAsyncParam
152 @ stdcall CryptSetOIDFunctionValue(long str str wstr long ptr long)
153 @ stub CryptSetProviderU
154 @ stub CryptSignAndEncodeCertificate
155 @ stub CryptSignAndEncryptMessage
156 @ stdcall CryptSignCertificate(long long long ptr long ptr ptr ptr ptr)
157 @ stub CryptSignHashU
158 @ stub CryptSignMessage
159 @ stub CryptSignMessageWithKey
160 @ stdcall CryptUnprotectData(ptr ptr ptr ptr ptr long ptr)
161 @ stdcall CryptUnregisterDefaultOIDFunction(long str wstr)
162 @ stdcall CryptUnregisterOIDFunction(long str str)
163 @ stub CryptUnregisterOIDInfo
164 @ stdcall CryptVerifyCertificateSignature(long long ptr long ptr)
165 @ stdcall CryptVerifyCertificateSignatureEx(long long long ptr long ptr long ptr)
166 @ stub CryptVerifyDetachedMessageHash
167 @ stub CryptVerifyDetachedMessageSignature
168 @ stub CryptVerifyMessageHash
169 @ stdcall CryptVerifyMessageSignature(ptr long ptr long ptr ptr ptr)
170 @ stub CryptVerifyMessageSignatureWithKey
171 @ stub CryptVerifySignatureU
172 @ stdcall I_CryptAllocTls()
173 @ stdcall I_CryptCreateLruCache(ptr ptr)
174 @ stub I_CryptCreateLruEntry
175 @ stdcall I_CryptDetachTls(long)
176 @ stdcall I_CryptFindLruEntryData(long long long)
177 @ stdcall I_CryptFlushLruCache(ptr long long)
178 @ stdcall I_CryptFreeLruCache(ptr long long)
179 @ stdcall I_CryptFreeTls(long long)
180 @ stub I_CryptGetDefaultCryptProv
181 @ stub I_CryptGetDefaultCryptProvForEncrypt
182 @ stdcall I_CryptGetOssGlobal(long)
183 @ stdcall I_CryptGetTls(long)
184 @ stub I_CryptInsertLruEntry
185 @ stdcall I_CryptInstallAsn1Module(long long long)
186 @ stdcall I_CryptInstallOssGlobal(long long long)
187 @ stub I_CryptReleaseLruEntry
188 @ stdcall I_CryptSetTls(long ptr)
189 @ stub I_CryptUninstallOssGlobal
190 @ stub PFXExportCertStore
191 @ stub PFXImportCertStore
192 @ stub RegCreateHKCUKeyExU
193 @ stub RegCreateKeyExU
194 @ stub RegDeleteValueU
195 @ stub RegEnumValueU
196 @ stub RegOpenHKCUKeyExU
197 @ stub RegOpenKeyExU
198 @ stub RegQueryInfoKeyU
199 @ stub RegQueryValueExU
200 @ stub RegSetValueExU