Buffer overflows and strncpy fixes.
[wine] / dlls / shell32 / shell.spec
1 name    shell
2 type    win16
3
4   1 pascal   RegOpenKey(long str ptr) RegOpenKey16
5   2 pascal   RegCreateKey(long str ptr) RegCreateKey16
6   3 pascal   RegCloseKey(long) RegCloseKey16
7   4 pascal   RegDeleteKey(long str) RegDeleteKey16
8   5 pascal   RegSetValue(long str long str long) RegSetValue16
9   6 pascal   RegQueryValue(long str ptr ptr) RegQueryValue16
10   7 pascal   RegEnumKey(long long ptr long) RegEnumKey16
11   9 pascal16 DragAcceptFiles(word word) DragAcceptFiles16
12  11 pascal16 DragQueryFile(word s_word ptr s_word) DragQueryFile16
13  12 pascal16 DragFinish(word) DragFinish16
14  13 pascal16 DragQueryPoint(word ptr) DragQueryPoint16
15  20 pascal16 ShellExecute(word str str str str s_word) ShellExecute16
16  21 pascal16 FindExecutable(str str ptr) FindExecutable16
17  22 pascal16 ShellAbout(word ptr ptr word) ShellAbout16
18  33 pascal16 AboutDlgProc(word word word long) AboutDlgProc16
19  34 pascal16 ExtractIcon(word str s_word) ExtractIcon16
20  36 pascal16 ExtractAssociatedIcon(word ptr ptr) ExtractAssociatedIcon16
21  37 pascal   DoEnvironmentSubst(ptr word) DoEnvironmentSubst16
22  38 pascal   FindEnvironmentString(ptr) FindEnvironmentString16
23  39 pascal16 InternalExtractIcon(word ptr s_word word) InternalExtractIcon16
24  40 pascal16 ExtractIconEx(str word ptr ptr word) ExtractIconEx16
25 # 98 stub SHL3216_THUNKDATA16
26 # 99 stub SHL1632_THUNKDATA16
27
28 #100   4  0550  HERETHARBETYGARS exported, shared data
29 #101   8  010e  FINDEXEDLGPROC exported, shared data
30 101 pascal DllEntryPoint(long word word word long word) SHELL_DllEntryPoint
31
32 102 pascal16 RegisterShellHook(word word) RegisterShellHook16
33 103 pascal   ShellHookProc(word word long) ShellHookProc16
34
35 157 stub RESTARTDIALOG
36 #  166 PICKICONDLG
37
38 262 pascal16 DriveType(long) GetDriveType16
39
40 #  263 SH16TO32DRIVEIOCTL
41 #  264 SH16TO32INT2526
42 #  300 SHGETFILEINFO
43 #  400 SHFORMATDRIVE
44 401 stub SHCHECKDRIVE
45 #  402 _RUNDLLCHECKDRIVE
46
47 # 8 WEP 
48 #32 WCI