Created separate libraries for dplay, shfolder, shlwapi, wow32 and
[wine] / dlls / wsock32 / wsock32.spec
1 name    wsock32
2 type    win32
3
4 import  ws2_32.dll
5
6   1 forward accept ws2_32.accept
7   2 forward bind ws2_32.bind
8   3 forward closesocket ws2_32.closesocket
9   4 forward connect ws2_32.connect
10   5 forward getpeername ws2_32.getpeername
11   6 forward getsockname ws2_32.getsockname
12   7 forward getsockopt ws2_32.getsockopt
13   8 forward htonl ws2_32.htonl
14   9 forward htons ws2_32.htons
15  10 forward inet_addr ws2_32.inet_addr
16  11 forward inet_ntoa ws2_32.inet_ntoa
17  12 forward ioctlsocket ws2_32.ioctlsocket
18  13 forward listen ws2_32.listen
19  14 forward ntohl ws2_32.ntohl
20  15 forward ntohs ws2_32.ntohs
21  16 forward recv ws2_32.recv
22  17 forward recvfrom ws2_32.recvfrom
23  18 forward select ws2_32.select
24  19 forward send ws2_32.send
25  20 forward sendto ws2_32.sendto
26  21 forward setsockopt ws2_32.setsockopt
27  22 forward shutdown ws2_32.shutdown
28  23 forward socket ws2_32.socket
29  51 forward gethostbyaddr ws2_32.gethostbyaddr
30  52 forward gethostbyname ws2_32.gethostbyname
31  53 forward getprotobyname ws2_32.getprotobyname
32  54 forward getprotobynumber ws2_32.getprotobynumber
33  55 forward getservbyname ws2_32.getservbyname
34  56 forward getservbyport ws2_32.getservbyport
35  57 forward gethostname ws2_32.gethostname
36 101 forward WSAAsyncSelect ws2_32.WSAAsyncSelect
37 102 forward WSAAsyncGetHostByAddr ws2_32.WSAAsyncGetHostByAddr
38 103 forward WSAAsyncGetHostByName ws2_32.WSAAsyncGetHostByName
39 104 forward WSAAsyncGetProtoByNumber ws2_32.WSAAsyncGetProtoByNumber
40 105 forward WSAAsyncGetProtoByName ws2_32.WSAAsyncGetProtoByName
41 106 forward WSAAsyncGetServByPort ws2_32.WSAAsyncGetServByPort
42 107 forward WSAAsyncGetServByName ws2_32.WSAAsyncGetServByName
43 108 forward WSACancelAsyncRequest ws2_32.WSACancelAsyncRequest
44 109 forward WSASetBlockingHook ws2_32.WSASetBlockingHook
45 110 forward WSAUnhookBlockingHook ws2_32.WSAUnhookBlockingHook
46 111 forward WSAGetLastError ws2_32.WSAGetLastError
47 112 forward WSASetLastError ws2_32.WSASetLastError
48 113 forward WSACancelBlockingCall ws2_32.WSACancelBlockingCall
49 114 forward WSAIsBlocking ws2_32.WSAIsBlocking
50 115 forward WSAStartup ws2_32.WSAStartup
51 116 forward WSACleanup ws2_32.WSACleanup
52 151 forward __WSAFDIsSet ws2_32.__WSAFDIsSet
53 500 forward WEP ws2_32.WEP
54
55 # applications *should* 'degrade gracefully if these are not present
56 # ... as it is, they don't
57 #1000 stub WSApSetPostRoutine
58 1001 stdcall WsControl(long long ptr ptr ptr ptr) WsControl
59 1100 stdcall inet_network(str) inet_network
60 1101 stdcall getnetbyname(str) getnetbyname
61 #1102 stub rcmd
62 #1103 stub rexec
63 #1104 stub rresvport
64 #1105 stub sethostname
65 #1106 stub dn_expand
66 1107 stdcall WSARecvEx(long ptr long ptr) WSARecvEx
67 1108 stdcall s_perror(str) WS_s_perror
68 1109 stub GetAddressByNameA
69 1110 stub GetAddressByNameW
70 #1111 stub EnumProtocolsA
71 #1112 stub EnumProtocolsW
72 #1113 stub GetTypeByNameA
73 #1114 stub GetTypeByNameW
74 #1115 stub GetNameByTypeA
75 #1116 stub GetNameByTypeW
76 #1117 stub SetServiceA
77 #1118 stub SetServiceW
78 #1119 stub GetServiceA
79 #1120 stub GetServiceW
80 #1130 stub NPLoadNameSpaces
81 #1140 stub TransmitFile
82 #1141 stub AcceptEx
83 #1142 stub GetAcceptExSockaddrs