Added HttpOpenRequestW, HttpQueryInfoW, HttpSendRequestW.
[wine] / dlls / wininet / wininet.spec
1 @ stdcall InternetInitializeAutoProxyDll(long) InternetInitializeAutoProxyDll
2 @ stub ShowCertificate
3 @ stdcall CommitUrlCacheEntryA(str str long long long str long str str) CommitUrlCacheEntryA
4 @ stub CommitUrlCacheEntryW
5 @ stub CreateUrlCacheContainerA
6 @ stub CreateUrlCacheContainerW
7 @ stub CreateUrlCacheEntryA
8 @ stub CreateUrlCacheEntryW
9 @ stdcall CreateUrlCacheGroup(long ptr) CreateUrlCacheGroup
10 @ stub DeleteIE3Cache
11 @ stub DeleteUrlCacheContainerA
12 @ stub DeleteUrlCacheContainerW
13 @ stdcall DeleteUrlCacheEntry(str) DeleteUrlCacheEntry
14 @ stdcall DeleteUrlCacheGroup(long long ptr) DeleteUrlCacheGroup
15 @ stdcall DllInstall(long ptr) WININET_DllInstall
16 @ stub FindCloseUrlCache
17 @ stub FindFirstUrlCacheContainerA
18 @ stub FindFirstUrlCacheContainerW
19 @ stdcall FindFirstUrlCacheEntryA(str ptr ptr) FindFirstUrlCacheEntryA
20 @ stub FindFirstUrlCacheEntryExA
21 @ stub FindFirstUrlCacheEntryExW
22 @ stdcall FindFirstUrlCacheEntryW(wstr ptr ptr) FindFirstUrlCacheEntryW
23 @ stub FindNextUrlCacheContainerA
24 @ stub FindNextUrlCacheContainerW
25 @ stub FindNextUrlCacheEntryA
26 @ stub FindNextUrlCacheEntryExA
27 @ stub FindNextUrlCacheEntryExW
28 @ stub FindNextUrlCacheEntryW
29 @ stub FreeUrlCacheSpaceA
30 @ stub FreeUrlCacheSpaceW
31 @ stdcall FtpCreateDirectoryA(ptr str) FtpCreateDirectoryA
32 @ stdcall FtpCreateDirectoryW(ptr wstr) FtpCreateDirectoryW
33 @ stdcall FtpDeleteFileA(ptr str) FtpDeleteFileA
34 @ stub FtpDeleteFileW
35 @ stdcall FtpFindFirstFileA(ptr str str long long) FtpFindFirstFileA
36 @ stdcall FtpFindFirstFileW(ptr wstr wstr long long) FtpFindFirstFileW
37 @ stdcall FtpGetCurrentDirectoryA(ptr str ptr) FtpGetCurrentDirectoryA
38 @ stdcall FtpGetCurrentDirectoryW(ptr wstr ptr) FtpGetCurrentDirectoryW
39 @ stdcall FtpGetFileA(ptr str str long long long long) FtpGetFileA
40 @ stdcall FtpGetFileW(ptr wstr wstr long long long long) FtpGetFileW
41 @ stdcall FtpOpenFileA(ptr str long long long) FtpOpenFileA
42 @ stdcall FtpOpenFileW(ptr wstr long long long) FtpOpenFileW
43 @ stdcall FtpPutFileA(ptr str str long long) FtpPutFileA
44 @ stub FtpPutFileW
45 @ stdcall FtpRemoveDirectoryA(ptr str) FtpRemoveDirectoryA
46 @ stub FtpRemoveDirectoryW
47 @ stdcall FtpRenameFileA(ptr str str) FtpRenameFileA
48 @ stub FtpRenameFileW
49 @ stdcall FtpSetCurrentDirectoryA(ptr str) FtpSetCurrentDirectoryA
50 @ stdcall FtpSetCurrentDirectoryW(ptr wstr) FtpSetCurrentDirectoryW
51 @ stub GetUrlCacheConfigInfoA
52 @ stub GetUrlCacheConfigInfoW
53 @ stdcall GetUrlCacheEntryInfoA(str ptr long) GetUrlCacheEntryInfoA
54 @ stub GetUrlCacheEntryInfoExA
55 @ stub GetUrlCacheEntryInfoExW
56 @ stub GetUrlCacheEntryInfoW
57 @ stub GetUrlCacheHeaderData
58 @ stub GopherCreateLocatorA
59 @ stub GopherCreateLocatorW
60 @ stub GopherFindFirstFileA
61 @ stub GopherFindFirstFileW
62 @ stub GopherGetAttributeA
63 @ stub GopherGetAttributeW
64 @ stub GopherGetLocatorTypeA
65 @ stub GopherGetLocatorTypeW
66 @ stub GopherOpenFileA
67 @ stub GopherOpenFileW
68 @ stdcall HttpAddRequestHeadersA(ptr str long long) HttpAddRequestHeadersA
69 @ stub HttpAddRequestHeadersW
70 @ stdcall HttpEndRequestA(ptr ptr long long) HttpEndRequestA
71 @ stdcall HttpEndRequestW(ptr ptr long long) HttpEndRequestW
72 @ stdcall HttpOpenRequestA(ptr str str str str ptr long long) HttpOpenRequestA
73 @ stdcall HttpOpenRequestW(ptr wstr wstr wstr wstr ptr long long) HttpOpenRequestW
74 @ stdcall HttpQueryInfoA(ptr long ptr ptr ptr) HttpQueryInfoA
75 @ stdcall HttpQueryInfoW(ptr long ptr ptr ptr) HttpQueryInfoW
76 @ stdcall HttpSendRequestA(ptr str long ptr long) HttpSendRequestA
77 @ stdcall HttpSendRequestExA(long ptr ptr long long) HttpSendRequestExA
78 @ stub HttpSendRequestExW
79 @ stdcall HttpSendRequestW(ptr wstr long ptr long) HttpSendRequestW
80 @ stub IncrementUrlCacheHeaderData
81 @ stdcall InternetAttemptConnect(long) InternetAttemptConnect
82 @ stdcall InternetAutodial(long ptr) InternetAutoDial
83 @ stub InternetAutodialCallback
84 @ stdcall InternetAutodialHangup(long) InternetAutodialHangup
85 @ stdcall InternetCanonicalizeUrlA(str str ptr long) InternetCanonicalizeUrlA
86 @ stdcall InternetCanonicalizeUrlW(wstr wstr ptr long) InternetCanonicalizeUrlW
87 @ stdcall InternetCheckConnectionA(ptr long long) InternetCheckConnectionA
88 @ stdcall InternetCheckConnectionW(ptr long long) InternetCheckConnectionW
89 @ stdcall InternetCloseHandle(long) InternetCloseHandle
90 @ stub InternetCombineUrlA
91 @ stub InternetCombineUrlW
92 @ stub InternetConfirmZoneCrossing
93 @ stdcall InternetConnectA(ptr str long str str long long long) InternetConnectA
94 @ stdcall InternetConnectW(ptr wstr long wstr wstr long long long) InternetConnectW
95 @ stdcall InternetCrackUrlA(str long long ptr) InternetCrackUrlA
96 @ stub InternetCrackUrlW
97 @ stub InternetCreateUrlA
98 @ stub InternetCreateUrlW
99 @ stub InternetDebugGetLocalTime
100 @ stub InternetDial
101 @ stub InternetErrorDlg
102 @ stdcall InternetFindNextFileA(ptr ptr) InternetFindNextFileA
103 @ stub InternetFindNextFileW
104 @ stub InternetGetCertByURL
105 @ stdcall InternetGetConnectedState(ptr long) InternetGetConnectedState
106 @ stdcall InternetGetCookieA(str str ptr long) InternetGetCookieA
107 @ stdcall InternetGetCookieW(wstr wstr ptr long) InternetGetCookieW
108 @ stdcall InternetGetLastResponseInfoA(ptr str ptr) InternetGetLastResponseInfoA
109 @ stub InternetGetLastResponseInfoW
110 @ stub InternetGoOnline
111 @ stub InternetHangUp
112 @ stdcall InternetLockRequestFile(ptr ptr) InternetLockRequestFile
113 @ stdcall InternetOpenA(str long str str long) InternetOpenA
114 @ stdcall InternetOpenW(wstr long wstr wstr long) InternetOpenW
115 @ stub InternetOpenServerPushParse
116 @ stdcall InternetOpenUrlA(ptr str str long long long) InternetOpenUrlA
117 @ stdcall InternetOpenUrlW(ptr wstr wstr long long long) InternetOpenUrlW
118 @ stdcall InternetQueryDataAvailable(ptr ptr long long) InternetQueryDataAvailable
119 @ stdcall InternetQueryOptionA(ptr long ptr ptr) InternetQueryOptionA
120 @ stub InternetQueryOptionW
121 @ stdcall InternetReadFile(ptr ptr long ptr) InternetReadFile
122 @ stdcall InternetReadFileExA(ptr ptr long long) InternetReadFileExA
123 @ stdcall InternetReadFileExW(ptr ptr long long) InternetReadFileExW
124 @ stub InternetServerPushParse
125 @ stdcall InternetSetCookieA(str str str) InternetSetCookieA
126 @ stdcall InternetSetCookieW(wstr wstr wstr) InternetSetCookieW
127 @ stub InternetSetDialState
128 @ stub InternetSetFilePointer
129 @ stdcall InternetSetOptionA(ptr long ptr long) InternetSetOptionA
130 @ stdcall InternetSetOptionW(ptr long ptr long) InternetSetOptionW
131 @ stub InternetSetOptionExA
132 @ stub InternetSetOptionExW
133 @ stdcall InternetSetStatusCallback(ptr ptr) InternetSetStatusCallback
134 @ stub InternetShowSecurityInfoByURL
135 @ stub InternetTimeFromSystemTime
136 @ stub InternetTimeToSystemTime
137 @ stdcall InternetUnlockRequestFile(ptr) InternetUnlockRequestFile
138 @ stdcall InternetWriteFile(ptr ptr long ptr) InternetWriteFile
139 @ stub InternetWriteFileExA
140 @ stub InternetWriteFileExW
141 @ stub IsHostInProxyBypassList
142 @ stub LoadUrlCacheContent
143 @ stub ParseX509EncodedCertificateForListBoxEntry
144 @ stub ReadUrlCacheEntryStream
145 @ stdcall RetrieveUrlCacheEntryFileA(str ptr ptr long) RetrieveUrlCacheEntryFileA
146 @ stub RetrieveUrlCacheEntryFileW
147 @ stub RetrieveUrlCacheEntryStreamA
148 @ stub RetrieveUrlCacheEntryStreamW
149 @ stub RunOnceUrlCache
150 @ stub SetUrlCacheConfigInfoA
151 @ stub SetUrlCacheConfigInfoW
152 @ stdcall SetUrlCacheEntryGroup(str long long ptr long ptr) SetUrlCacheEntryGroup
153 @ stub SetUrlCacheEntryInfoA
154 @ stub SetUrlCacheEntryInfoW
155 @ stub SetUrlCacheHeaderData
156 @ stub ShowClientAuthCerts
157 @ stub ShowSecurityInfo
158 @ stub ShowX509EncodedCertificate
159 @ stub UnlockUrlCacheEntryFile
160 @ stub UnlockUrlCacheEntryStream
161 @ stub UpdateUrlCacheContentPath