Authors: Greg Turner <gmturner007@ameritech.net>, Ove Kaaven <ovek@transgaming.com>
[wine] / dlls / wsock32 / wsock32.spec
1   1 forward accept ws2_32.accept
2   2 forward bind ws2_32.bind
3   3 forward closesocket ws2_32.closesocket
4   4 forward connect ws2_32.connect
5   5 forward getpeername ws2_32.getpeername
6   6 forward getsockname ws2_32.getsockname
7   7 forward getsockopt ws2_32.getsockopt
8   8 forward htonl ws2_32.htonl
9   9 forward htons ws2_32.htons
10  10 forward inet_addr ws2_32.inet_addr
11  11 forward inet_ntoa ws2_32.inet_ntoa
12  12 forward ioctlsocket ws2_32.ioctlsocket
13  13 forward listen ws2_32.listen
14  14 forward ntohl ws2_32.ntohl
15  15 forward ntohs ws2_32.ntohs
16  16 forward recv ws2_32.recv
17  17 forward recvfrom ws2_32.recvfrom
18  18 forward select ws2_32.select
19  19 forward send ws2_32.send
20  20 forward sendto ws2_32.sendto
21  21 forward setsockopt ws2_32.setsockopt
22  22 forward shutdown ws2_32.shutdown
23  23 forward socket ws2_32.socket
24  51 forward gethostbyaddr ws2_32.gethostbyaddr
25  52 forward gethostbyname ws2_32.gethostbyname
26  53 forward getprotobyname ws2_32.getprotobyname
27  54 forward getprotobynumber ws2_32.getprotobynumber
28  55 forward getservbyname ws2_32.getservbyname
29  56 forward getservbyport ws2_32.getservbyport
30  57 forward -noimport gethostname ws2_32.gethostname
31 101 forward WSAAsyncSelect ws2_32.WSAAsyncSelect
32 102 forward WSAAsyncGetHostByAddr ws2_32.WSAAsyncGetHostByAddr
33 103 forward WSAAsyncGetHostByName ws2_32.WSAAsyncGetHostByName
34 104 forward WSAAsyncGetProtoByNumber ws2_32.WSAAsyncGetProtoByNumber
35 105 forward WSAAsyncGetProtoByName ws2_32.WSAAsyncGetProtoByName
36 106 forward WSAAsyncGetServByPort ws2_32.WSAAsyncGetServByPort
37 107 forward WSAAsyncGetServByName ws2_32.WSAAsyncGetServByName
38 108 forward WSACancelAsyncRequest ws2_32.WSACancelAsyncRequest
39 109 forward WSASetBlockingHook ws2_32.WSASetBlockingHook
40 110 forward WSAUnhookBlockingHook ws2_32.WSAUnhookBlockingHook
41 111 forward WSAGetLastError ws2_32.WSAGetLastError
42 112 forward WSASetLastError ws2_32.WSASetLastError
43 113 forward WSACancelBlockingCall ws2_32.WSACancelBlockingCall
44 114 forward WSAIsBlocking ws2_32.WSAIsBlocking
45 115 forward WSAStartup ws2_32.WSAStartup
46 116 forward WSACleanup ws2_32.WSACleanup
47 151 forward __WSAFDIsSet ws2_32.__WSAFDIsSet
48 500 forward WEP ws2_32.WEP
49
50 # applications *should* 'degrade gracefully if these are not present
51 # ... as it is, they don't
52 #1000 stub WSApSetPostRoutine
53 1001 stdcall WsControl(long long ptr ptr ptr ptr) WsControl
54 1100 stdcall inet_network(str) WSOCK32_inet_network
55 1101 stdcall getnetbyname(str) WSOCK32_getnetbyname
56 #1102 stub rcmd
57 #1103 stub rexec
58 #1104 stub rresvport
59 #1105 stub sethostname
60 #1106 stub dn_expand
61 1107 stdcall WSARecvEx(long ptr long ptr) WSARecvEx
62 1108 stdcall s_perror(str) s_perror
63 1109 stub GetAddressByNameA
64 1110 stub GetAddressByNameW
65 1111 stdcall EnumProtocolsA(ptr ptr ptr) EnumProtocolsA
66 1112 stdcall EnumProtocolsW(ptr ptr ptr) EnumProtocolsW
67 #1113 stub GetTypeByNameA
68 #1114 stub GetTypeByNameW
69 #1115 stub GetNameByTypeA
70 #1116 stub GetNameByTypeW
71 #1117 stub SetServiceA
72 #1118 stub SetServiceW
73 #1119 stub GetServiceA
74 #1120 stub GetServiceW
75 #1130 stub NPLoadNameSpaces
76 #1140 stub TransmitFile
77 #1141 stub AcceptEx
78 #1142 stub GetAcceptExSockaddrs