1 # C RunTime DLL. All functions use cdecl!
6 1 cdecl ??2@YAPAXI@Z(long) CRTDLL_new
7 2 cdecl ??3@YAXPAX@Z(long) CRTDLL_delete
8 3 cdecl ?_set_new_handler@@YAP6AHI@ZP6AHI@Z@Z(ptr) CRTDLL_set_new_handler
19 14 cdecl _CIpow() CRTDLL__CIpow
27 22 cdecl __GetMainArgs(ptr ptr ptr long) CRTDLL__GetMainArgs
28 23 extern __argc_dll CRTDLL_argc_dll
29 24 extern __argv_dll CRTDLL_argv_dll
30 25 cdecl __dllonexit() CRTDLL__dllonexit
36 31 stub __mb_cur_max_dll
37 32 stub __pxcptinfoptrs
38 33 cdecl __threadhandle() GetCurrentThread
39 34 cdecl __threadid() GetCurrentThreadId
41 36 cdecl _abnormal_termination() CRTDLL__abnormal_termination
42 37 cdecl _access(str long) CRTDLL__access
43 38 extern _acmdln_dll CRTDLL_acmdln_dll
44 39 stub _aexit_rtn_dll
47 42 extern _basemajor_dll CRTDLL_basemajor_dll
48 43 extern _baseminor_dll CRTDLL_baseminor_dll
49 44 extern _baseversion_dll CRTDLL_baseversion_dll
54 49 cdecl _cexit(long) CRTDLL__cexit
56 51 cdecl _chdir(str) CRTDLL__chdir
57 52 cdecl _chdrive(long) CRTDLL__chdrive
62 57 cdecl _close(long) CRTDLL__close
64 59 extern _commode_dll CRTDLL_commode_dll
80 75 extern _environ_dll CRTDLL_environ_dll
82 77 cdecl _errno() CRTDLL__errno
83 78 cdecl _except_handler2(ptr ptr ptr ptr) CRTDLL__except_handler2
96 91 cdecl _fdopen(long ptr) CRTDLL__fdopen
100 95 stub _fileinfo_dll
104 99 cdecl _findfirst(str ptr) CRTDLL__findfirst
105 100 cdecl _findnext(long ptr) CRTDLL__findnext
109 104 extern _fmode_dll CRTDLL_fmode_dll
112 107 cdecl _fpreset() CRTDLL__fpreset
115 110 cdecl _fsopen(str str long) CRTDLL__fsopen
116 111 cdecl _fstat(long ptr) CRTDLL__fstat
118 113 cdecl _ftol() CRTDLL__ftol
119 114 cdecl _fullpath(ptr str long) CRTDLL__fullpath
122 117 stub _get_osfhandle
125 120 cdecl _getcwd(ptr long) CRTDLL__getcwd
126 121 cdecl _getdcwd(long ptr long) CRTDLL__getdcwd
127 122 stub _getdiskfree
128 123 stub _getdllprocaddr
129 124 cdecl _getdrive() CRTDLL__getdrive
134 129 cdecl _global_unwind2(ptr) CRTDLL__global_unwind2
139 134 cdecl _hypot(double double) hypot
140 135 cdecl _initterm(ptr ptr) CRTDLL__initterm
141 136 extern _iob CRTDLL_iob
142 137 cdecl _isatty(long) CRTDLL__isatty
143 138 cdecl _isctype(long long) CRTDLL__isctype
147 142 stub _ismbbkalnum
149 144 stub _ismbbkpunct
165 160 stub _ismbcsymbol
170 165 cdecl _itoa(long ptr long) CRTDLL__itoa
172 167 cdecl _j0(double) j0
173 168 cdecl _j1(double) j1
174 169 cdecl _jn(long double) jn
178 173 cdecl _local_unwind2(ptr long) CRTDLL__local_unwind2
181 176 cdecl _lrotl (long long) CRTDLL__lrotl
185 180 cdecl _ltoa(long str long) CRTDLL__ltoa
187 182 cdecl _makepath (ptr str str str str) CRTDLL__makepath
192 187 stub _mbcjistojms
193 188 stub _mbcjmstojis
202 197 cdecl _mbscat(str str) strcat
205 200 cdecl _mbscpy(ptr str) strcpy
208 203 cdecl _mbsdup(str) CRTDLL__strdup
209 204 cdecl _mbsicmp(str str) CRTDLL__mbsicmp
210 205 cdecl _mbsinc(str) CRTDLL__mbsinc
211 206 cdecl _mbslen(str) CRTDLL__mbslen
228 223 cdecl _mbsrchr(str long) CRTDLL__mbsrchr
238 233 cdecl _memicmp(str str long) CRTDLL__memicmp
239 234 cdecl _mkdir(str) CRTDLL__mkdir
244 239 cdecl _open(str long) CRTDLL__open
245 240 cdecl _open_osfhandle(long long) CRTDLL__open_osfhandle
246 241 extern _osmajor_dll CRTDLL_osmajor_dll
247 242 extern _osminor_dll CRTDLL_osminor_dll
248 243 extern _osmode_dll CRTDLL_osmode_dll
249 244 extern _osver_dll CRTDLL_osver_dll
250 245 extern _osversion_dll CRTDLL_osversion_dll
260 255 stub _pwctype_dll
261 256 cdecl _read(long ptr long) CRTDLL__read
264 259 cdecl _rotl (long long) CRTDLL__rotl
268 263 stub _seterrormode
270 265 cdecl _setmode(long long) CRTDLL__setmode
272 267 cdecl _sleep(long) CRTDLL__sleep
284 279 cdecl _splitpath (str ptr ptr ptr ptr) CRTDLL__splitpath
285 280 cdecl _stat (str ptr) CRTDLL__stat
287 282 cdecl _strcmpi(str str) CRTDLL__strcmpi
288 283 cdecl _strdate(str) CRTDLL__strdate
290 285 cdecl _strdup(str) CRTDLL__strdup
292 287 cdecl _stricmp(str str) CRTDLL__strcmpi
295 290 cdecl _strlwr(str) CRTDLL__strlwr
298 293 cdecl _strnicmp(str str long) CRTDLL__strnicmp
304 299 cdecl _strtime(str) CRTDLL__strtime
305 300 cdecl _strupr(str) CRTDLL__strupr
307 302 stub _sys_errlist
308 303 stub _sys_nerr_dll
310 305 cdecl _tempnam(str ptr) CRTDLL__tempnam
311 306 stub _timezone_dll
316 311 cdecl _ultoa(long ptr long) CRTDLL__ultoa
320 315 cdecl _unlink(str) CRTDLL__unlink
325 320 cdecl _wcsdup(wstr) CRTDLL__wcsdup
326 321 cdecl _wcsicmp(wstr wstr) CRTDLL__wcsicmp
327 322 cdecl _wcsicoll(wstr wstr) CRTDLL__wcsicoll
328 323 cdecl _wcslwr(wstr) CRTDLL__wcslwr
329 324 cdecl _wcsnicmp(wstr wstr long) CRTDLL__wcsnicmp
330 325 cdecl _wcsnset(wstr long long) CRTDLL__wcsnset
331 326 cdecl _wcsrev(wstr) CRTDLL__wcsrev
332 327 cdecl _wcsset(wstr long) CRTDLL__wcsset
333 328 cdecl _wcsupr(wstr) CRTDLL__wcsupr
334 329 extern _winmajor_dll CRTDLL_winmajor_dll
335 330 extern _winminor_dll CRTDLL_winminor_dll
336 331 extern _winver_dll CRTDLL_winver_dll
337 332 cdecl _write(long ptr long) CRTDLL__write
340 335 cdecl _y0(double) y0
341 336 cdecl _y1(double) y1
342 337 cdecl _yn(long double) yn
344 339 cdecl abs(long) abs
345 340 cdecl acos(double) acos
346 341 cdecl asctime(ptr) asctime
347 342 cdecl asin(double) asin
348 343 cdecl atan(double) atan
349 344 cdecl atan2(double double) atan2
350 345 cdecl atexit(ptr) CRTDLL_atexit
351 346 cdecl atof(str) atof
352 347 cdecl atoi(str) atoi
353 348 cdecl atol(str) atol
355 350 cdecl calloc(long long) CRTDLL_calloc
356 351 cdecl ceil(double) ceil
358 353 cdecl clock() CRTDLL_clock
359 354 cdecl cos(double) cos
360 355 cdecl cosh(double) cosh
361 356 cdecl ctime(ptr) ctime
363 358 cdecl div(long long) div
364 359 cdecl exit(long) CRTDLL_exit
365 360 cdecl exp(double) exp
366 361 cdecl fabs(double) fabs
367 362 cdecl fclose(ptr) CRTDLL_fclose
368 363 cdecl feof(ptr) CRTDLL_feof
370 365 cdecl fflush(ptr) CRTDLL_fflush
371 366 cdecl fgetc(ptr) CRTDLL_fgetc
373 368 cdecl fgets(ptr long ptr) CRTDLL_fgets
375 370 cdecl floor(double) floor
376 371 cdecl fmod(double double) fmod
377 372 cdecl fopen(str str) CRTDLL_fopen
378 373 varargs fprintf(ptr str) CRTDLL_fprintf
379 374 cdecl fputc(long ptr) CRTDLL_fputc
380 375 cdecl fputs(str ptr) CRTDLL_fputs
382 377 cdecl fread(ptr long long ptr) CRTDLL_fread
383 378 cdecl free(ptr) CRTDLL_free
384 379 cdecl freopen(str str ptr) CRTDLL_freopen
385 380 cdecl frexp(double ptr) frexp
386 381 varargs fscanf(ptr str) CRTDLL_fscanf
387 382 cdecl fseek(ptr long long) CRTDLL_fseek
388 383 cdecl fsetpos(ptr ptr) CRTDLL_fsetpos
389 384 cdecl ftell(ptr) CRTDLL_ftell
391 386 cdecl fwrite(ptr long long ptr) CRTDLL_fwrite
393 388 cdecl getc(ptr) CRTDLL_getc
395 390 cdecl getenv (str) CRTDLL_getenv
396 391 cdecl gets(ptr) CRTDLL_gets
397 392 cdecl gmtime(ptr) gmtime
399 394 cdecl isalnum(long) isalnum
400 395 cdecl isalpha(long) isalpha
401 396 cdecl iscntrl(long) iscntrl
402 397 cdecl isdigit(long) isdigit
403 398 cdecl isgraph(long) isgraph
405 400 cdecl islower(long) islower
406 401 cdecl isprint(long) isprint
407 402 cdecl ispunct(long) ispunct
408 403 cdecl isspace(long) isspace
409 404 cdecl isupper(long) isupper
423 418 cdecl isxdigit(long) isxdigit
424 419 cdecl labs(long) labs
425 420 cdecl ldexp(double long) ldexp
426 421 cdecl ldiv(long long) ldiv
428 423 cdecl localtime(ptr) localtime
429 424 cdecl log(double) log
430 425 cdecl log10(double) log10
431 426 cdecl longjmp(ptr long) CRTDLL_longjmp
432 427 cdecl malloc(ptr) CRTDLL_malloc
433 428 cdecl mblen(str long) mblen
434 429 cdecl mbstowcs(ptr str long) CRTDLL_mbstowcs
435 430 cdecl mbtowc(ptr ptr long) CRTDLL_mbtowc
436 431 cdecl memchr(ptr long long) memchr
437 432 cdecl memcmp(ptr ptr long) memcmp
438 433 cdecl memcpy(ptr ptr long) memcpy
439 434 cdecl memmove(ptr ptr long) memmove
440 435 cdecl memset(ptr long long) memset
441 436 cdecl mktime(ptr) mktime
442 437 cdecl modf(double ptr) modf
444 439 cdecl pow(double double) pow
445 440 varargs printf() printf
446 441 cdecl putc(long ptr) CRTDLL_putc
447 442 cdecl putchar(long) CRTDLL_putchar
448 443 cdecl puts(str) CRTDLL_puts
449 444 cdecl qsort(ptr long long ptr) qsort
451 446 cdecl rand() CRTDLL_rand
452 447 cdecl realloc(ptr long) CRTDLL_realloc
453 448 cdecl remove(str) CRTDLL_remove
454 449 cdecl rename(str str) CRTDLL_rename
457 452 cdecl setbuf(ptr ptr) CRTDLL_setbuf
458 453 cdecl setlocale(long ptr) CRTDLL_setlocale
460 455 cdecl signal(long ptr) CRTDLL_signal
461 456 cdecl sin(double) sin
462 457 cdecl sinh(double) sinh
463 458 varargs sprintf() sprintf
464 459 cdecl sqrt(double) sqrt
465 460 cdecl srand(long) CRTDLL_srand
466 461 varargs sscanf() sscanf
467 462 cdecl strcat(str str) strcat
468 463 cdecl strchr(str long) strchr
469 464 cdecl strcmp(str str) strcmp
470 465 cdecl strcoll(str str) strcoll
471 466 cdecl strcpy(ptr str) strcpy
472 467 cdecl strcspn(str str) strcspn
473 468 cdecl strerror(long) strerror
474 469 cdecl strftime(ptr long str ptr) strftime
475 470 cdecl strlen(str) strlen
476 471 cdecl strncat(str str long) strncat
477 472 cdecl strncmp(str str long) strncmp
478 473 cdecl strncpy(ptr str long) strncpy
479 474 cdecl strpbrk(str str) strpbrk
480 475 cdecl strrchr(str long) strrchr
481 476 cdecl strspn(str str) strspn
482 477 cdecl strstr(str str) strstr
483 478 cdecl strtod(str ptr) strtod
484 479 cdecl strtok(str str) strtok
485 480 cdecl strtol(str ptr long) strtol
486 481 cdecl strtoul(str ptr long) strtoul
487 482 cdecl strxfrm(ptr str long) strxfrm
488 483 varargs swprintf() wsprintfW
490 485 cdecl system(str) CRTDLL_system
491 486 cdecl tan(double) tan
492 487 cdecl tanh(double) tanh
493 488 cdecl time(ptr) CRTDLL_time
495 490 cdecl tmpnam(str) CRTDLL_tmpnam
496 491 cdecl tolower(long) tolower
497 492 cdecl toupper(long) toupper
498 493 cdecl towlower(long) towlower
499 494 cdecl towupper(long) towupper
502 497 cdecl vfprintf(ptr str ptr) CRTDLL_vfprintf
505 500 cdecl vsprintf(ptr str ptr) CRTDLL_vsprintf
506 501 cdecl vswprintf(ptr wstr ptr) CRTDLL_vswprintf
508 503 cdecl wcscat(wstr wstr) CRTDLL_wcscat
509 504 cdecl wcschr(wstr long) CRTDLL_wcschr
510 505 cdecl wcscmp(wstr wstr) CRTDLL_wcscmp
511 506 cdecl wcscoll(wstr wstr) CRTDLL_wcscoll
512 507 cdecl wcscpy(ptr wstr) CRTDLL_wcscpy
513 508 cdecl wcscspn(wstr wstr) CRTDLL_wcscspn
515 510 cdecl wcslen(wstr) CRTDLL_wcslen
516 511 cdecl wcsncat(wstr wstr long) CRTDLL_wcsncat
517 512 cdecl wcsncmp(wstr wstr long) CRTDLL_wcsncmp
518 513 cdecl wcsncpy(ptr wstr long) CRTDLL_wcsncpy
519 514 cdecl wcspbrk(wstr wstr) CRTDLL_wcspbrk
520 515 cdecl wcsrchr(wstr long) CRTDLL_wcsrchr
521 516 cdecl wcsspn(wstr wstr) CRTDLL_wcsspn
522 517 cdecl wcsstr(wstr wstr) CRTDLL_wcsstr
524 519 cdecl wcstok(wstr wstr) CRTDLL_wcstok
525 520 cdecl wcstol(wstr ptr long) CRTDLL_wcstol
526 521 cdecl wcstombs(ptr ptr long) CRTDLL_wcstombs
529 524 cdecl wctomb(ptr long) CRTDLL_wctomb