Moved the int 9 (keyboard) handler to dlls/winedos.
[wine] / dlls / winedos / winedos.spec
1 name winedos
2 type win32
3 init DOSVM_Init
4
5 import user32.dll
6 import kernel32.dll
7 import ntdll.dll
8
9 debug_channels (int module relay)
10
11 @ stdcall GetCurrent() MZ_Current
12 @ stdcall LoadDPMI() MZ_AllocDPMITask
13 @ stdcall LoadDosExe(str long) MZ_LoadImage
14 @ stdcall Exec(ptr str long ptr) MZ_Exec
15 @ stdcall Exit(ptr long long) MZ_Exit
16 @ stdcall RunInThread(ptr long) MZ_RunInThread
17
18 @ stdcall Enter(ptr) DOSVM_Enter
19 @ stdcall Wait(long long) DOSVM_Wait
20 @ stdcall QueueEvent(long long ptr ptr) DOSVM_QueueEvent
21 @ stdcall OutPIC(long long) DOSVM_PIC_ioport_out
22 @ stdcall SetTimer(long) DOSVM_SetTimer
23 @ stdcall GetTimer() DOSVM_GetTimer
24
25 @ stdcall KbdReadScan(ptr) INT_Int09ReadScan