Declare debug channels in all dlls that need them; added imports of
[wine] / dlls / ddraw / ddraw.spec
1 name ddraw
2 type win32
3
4 import ole32.dll
5 import user32.dll
6 import x11drv.dll
7 import gdi32.dll
8 import kernel32.dll
9
10 debug_channels (ddraw)
11
12 @ stub DDHAL32_VidMemAlloc
13 @ stub DDHAL32_VidMemFree
14 @ stub DDInternalLock
15 @ stub DDInternalUnlock
16 @ stub DSoundHelp
17 @ stdcall DirectDrawCreate(ptr ptr ptr) DirectDrawCreate
18 @ stdcall DirectDrawCreateClipper(long ptr ptr) DirectDrawCreateClipper
19 @ stdcall DirectDrawCreateEx(ptr ptr ptr ptr) DirectDrawCreateEx
20 @ stdcall DirectDrawEnumerateA(ptr ptr) DirectDrawEnumerateA
21 @ stdcall DirectDrawEnumerateW(ptr ptr) DirectDrawEnumerateW
22 @ stdcall DirectDrawEnumerateExA(ptr ptr long) DirectDrawEnumerateExA
23 @ stdcall DirectDrawEnumerateExW(ptr ptr long) DirectDrawEnumerateExW
24 @ stdcall DllCanUnloadNow() DDRAW_DllCanUnloadNow
25 @ stdcall DllGetClassObject(ptr ptr ptr) DDRAW_DllGetClassObject
26 @ stub GetNextMipMap
27 @ stub GetSurfaceFromDC
28 @ stub HeapVidMemAllocAligned
29 @ stub InternalLock
30 @ stub InternalUnlock
31 @ stub LateAllocateSurfaceMem
32 @ stub VidMemAlloc
33 @ stub VidMemAmountFree
34 @ stub VidMemFini
35 @ stub VidMemFree
36 @ stub VidMemInit
37 @ stub VidMemLargestFree
38 @ stub thk1632_ThunkData32
39 @ stub thk3216_ThunkData32