Added support for #pragma code_page.
[wine] / dlls / shell32 / shell.spec
1 rsrc    version16.res
2
3   1 pascal   RegOpenKey(long str ptr) RegOpenKey16
4   2 pascal   RegCreateKey(long str ptr) RegCreateKey16
5   3 pascal   RegCloseKey(long) RegCloseKey16
6   4 pascal   RegDeleteKey(long str) RegDeleteKey16
7   5 pascal   RegSetValue(long str long str long) RegSetValue16
8   6 pascal   RegQueryValue(long str ptr ptr) RegQueryValue16
9   7 pascal   RegEnumKey(long long ptr long) RegEnumKey16
10   9 pascal16 DragAcceptFiles(word word) DragAcceptFiles16
11  11 pascal16 DragQueryFile(word s_word ptr s_word) DragQueryFile16
12  12 pascal16 DragFinish(word) DragFinish16
13  13 pascal16 DragQueryPoint(word ptr) DragQueryPoint16
14  20 pascal16 ShellExecute(word str str str str s_word) ShellExecute16
15  21 pascal16 FindExecutable(str str ptr) FindExecutable16
16  22 pascal16 ShellAbout(word ptr ptr word) ShellAbout16
17  33 pascal16 AboutDlgProc(word word word long) AboutDlgProc16
18  34 pascal16 ExtractIcon(word str s_word) ExtractIcon16
19  36 pascal16 ExtractAssociatedIcon(word ptr ptr) ExtractAssociatedIcon16
20  37 pascal   DoEnvironmentSubst(ptr word) DoEnvironmentSubst16
21  38 pascal   FindEnvironmentString(ptr) FindEnvironmentString16
22  39 pascal16 InternalExtractIcon(word ptr s_word word) InternalExtractIcon16
23  40 pascal16 ExtractIconEx(str word ptr ptr word) ExtractIconEx16
24 # 98 stub SHL3216_THUNKDATA16
25 # 99 stub SHL1632_THUNKDATA16
26
27 #100   4  0550  HERETHARBETYGARS exported, shared data
28 #101   8  010e  FINDEXEDLGPROC exported, shared data
29 101 pascal DllEntryPoint(long word word word long word) SHELL_DllEntryPoint
30
31 102 pascal16 RegisterShellHook(word word) RegisterShellHook16
32 103 pascal   ShellHookProc(word word long) ShellHookProc16
33
34 157 stub RESTARTDIALOG
35 #  166 PICKICONDLG
36
37 262 pascal16 DriveType(long) DriveType16
38
39 #  263 SH16TO32DRIVEIOCTL
40 #  264 SH16TO32INT2526
41 #  300 SHGETFILEINFO
42 #  400 SHFORMATDRIVE
43 401 stub SHCHECKDRIVE
44 #  402 _RUNDLLCHECKDRIVE
45
46 # 8 WEP
47 #32 WCI