Release 980614
[wine] / relay32 / crtdll.spec
1 # C RunTime DLL. All functions use cdecl!
2 name    crtdll
3 type    win32
4
5   1 cdecl ??2@YAPAXI@Z(long) CRTDLL_new
6   2 cdecl ??3@YAXPAX@Z(long) CRTDLL_delete
7   3 cdecl ?_set_new_handler@@YAP6AHI@ZP6AHI@Z@Z(ptr) CRTDLL_set_new_handler
8   4 stub _CIacos
9   5 stub _CIasin
10   6 stub _CIatan
11   7 stub _CIatan2
12   8 stub _CIcos
13   9 stub _CIcosh
14  10 stub _CIexp
15  11 stub _CIfmod
16  12 stub _CIlog
17  13 stub _CIlog10
18  14 stub _CIpow
19  15 stub _CIsin
20  16 stub _CIsinh
21  17 stub _CIsqrt
22  18 stub _CItan
23  19 stub _CItanh
24  20 stub _HUGE_dll
25  21 stub _XcptFilter
26  22 cdecl __GetMainArgs(ptr ptr ptr long) CRTDLL__GetMainArgs
27  23 extern __argc_dll CRTDLL_argc_dll
28  24 extern __argv_dll CRTDLL_argv_dll
29  25 stub __dllonexit
30  26 stub __doserrno
31  27 stub __fpecode
32  28 stub __isascii
33  29 stub __iscsym
34  30 stub __iscsymf
35  31 stub __mb_cur_max_dll
36  32 stub __pxcptinfoptrs
37  33 stub __threadhandle
38  34 stub __threadid
39  35 stub __toascii
40  36 cdecl _abnormal_termination() CRTDLL__abnormal_termination
41  37 cdecl _access(str long) CRTDLL__access
42  38 extern _acmdln_dll CRTDLL_acmdln_dll
43  39 stub _aexit_rtn_dll
44  40 stub _amsg_exit
45  41 stub _assert
46  42 extern _basemajor_dll CRTDLL_basemajor_dll
47  43 extern _baseminor_dll CRTDLL_baseminor_dll
48  44 extern _baseversion_dll CRTDLL_baseversion_dll
49  45 stub _beep
50  46 stub _beginthread
51  47 stub _c_exit
52  48 stub _cabs
53  49 cdecl _cexit(long) CRTDLL__cexit
54  50 stub _cgets
55  51 cdecl _chdir(str) CRTDLL__chdir
56  52 cdecl _chdrive(long) CRTDLL__chdrive
57  53 stub _chgsign
58  54 stub _chmod
59  55 stub _chsize
60  56 stub _clearfp
61  57 cdecl _close(long) CRTDLL__close
62  58 stub _commit
63  59 extern _commode_dll CRTDLL_commode_dll
64  60 stub _control87
65  61 stub _controlfp
66  62 stub _copysign
67  63 stub _cprintf
68  64 stub _cpumode_dll
69  65 stub _cputs
70  66 stub _creat
71  67 stub _cscanf
72  68 stub _ctype
73  69 stub _cwait
74  70 stub _daylight_dll
75  71 stub _dup
76  72 stub _dup2
77  73 stub _ecvt
78  74 stub _endthread
79  75 extern _environ_dll CRTDLL_environ_dll
80  76 stub _eof
81  77 cdecl _errno() CRTDLL__errno
82  78 stub _except_handler2
83  79 stub _execl
84  80 stub _execle
85  81 stub _execlp
86  82 stub _execlpe
87  83 stub _execv
88  84 stub _execve
89  85 stub _execvp
90  86 stub _execvpe
91  87 stub _exit
92  88 stub _expand
93  89 stub _fcloseall
94  90 stub _fcvt
95  91 cdecl _fdopen(long ptr) CRTDLL__fdopen
96  92 stub _fgetchar
97  93 stub _fgetwchar
98  94 stub _filbuf
99  95 stub _fileinfo_dll
100  96 stub _filelength
101  97 stub _fileno
102  98 stub _findclose
103  99 stub _findfirst
104 100 stub _findnext
105 101 stub _finite
106 102 stub _flsbuf
107 103 stub _flushall
108 104 extern _fmode_dll CRTDLL_fmode_dll
109 105 stub _fpclass
110 106 stub _fpieee_flt
111 107 cdecl _fpreset() CRTDLL__fpreset
112 108 stub _fputchar
113 109 stub _fputwchar
114 110 stub _fsopen
115 111 stub _fstat
116 112 stub _ftime
117 113 cdecl _ftol(double) CRTDLL__ftol
118 114 cdecl _fullpath(ptr str long) CRTDLL__fullpath
119 115 stub _futime
120 116 stub _gcvt
121 117 stub _get_osfhandle
122 118 stub _getch
123 119 stub _getche
124 120 cdecl _getcwd(ptr long) CRTDLL__getcwd
125 121 stub _getdcwd
126 122 stub _getdiskfree
127 123 stub _getdllprocaddr
128 124 cdecl _getdrive() CRTDLL__getdrive
129 125 stub _getdrives
130 126 stub _getpid
131 127 stub _getsystime
132 128 stub _getw
133 129 cdecl _global_unwind2(ptr) CRTDLL__global_unwind2
134 130 stub _heapchk
135 131 stub _heapmin
136 132 stub _heapset
137 133 stub _heapwalk
138 134 cdecl _hypot(double double) hypot
139 135 cdecl _initterm(ptr ptr) CRTDLL__initterm
140 136 extern _iob CRTDLL_iob
141 137 cdecl _isatty(long) CRTDLL__isatty
142 138 cdecl _isctype(long long) CRTDLL__isctype
143 139 stub _ismbbalnum
144 140 stub _ismbbalpha
145 141 stub _ismbbgraph
146 142 stub _ismbbkalnum
147 143 stub _ismbbkana
148 144 stub _ismbbkpunct
149 145 stub _ismbblead
150 146 stub _ismbbprint
151 147 stub _ismbbpunct
152 148 stub _ismbbtrail
153 149 stub _ismbcalpha
154 150 stub _ismbcdigit
155 151 stub _ismbchira
156 152 stub _ismbckata
157 153 stub _ismbcl0
158 154 stub _ismbcl1
159 155 stub _ismbcl2
160 156 stub _ismbclegal
161 157 stub _ismbclower
162 158 stub _ismbcprint
163 159 stub _ismbcspace
164 160 stub _ismbcsymbol
165 161 stub _ismbcupper
166 162 stub _ismbslead
167 163 stub _ismbstrail
168 164 stub _isnan
169 165 cdecl _itoa(long ptr long) CRTDLL__itoa
170 166 stub _itow
171 167 cdecl _j0(double) j0
172 168 cdecl _j1(double) j1
173 169 cdecl _jn(long double) jn
174 170 stub _kbhit
175 171 stub _lfind
176 172 stub _loaddll
177 173 cdecl _local_unwind2(ptr long) CRTDLL__local_unwind2
178 174 stub _locking
179 175 stub _logb
180 176 cdecl _lrotl (long long) CRTDLL__lrotl
181 177 stub _lrotr
182 178 stub _lsearch
183 179 stub _lseek
184 180 cdecl _ltoa(long str long) CRTDLL__ltoa
185 181 stub _ltow
186 182 stub _makepath
187 183 stub _matherr
188 184 stub _mbbtombc
189 185 stub _mbbtype
190 186 stub _mbccpy
191 187 stub _mbcjistojms
192 188 stub _mbcjmstojis
193 189 stub _mbclen
194 190 stub _mbctohira
195 191 stub _mbctokata
196 192 stub _mbctolower
197 193 stub _mbctombb
198 194 stub _mbctoupper
199 195 stub _mbctype
200 196 stub _mbsbtype
201 197 cdecl _mbscat(str str) CRTDLL__mbscat
202 198 stub _mbschr
203 199 stub _mbscmp
204 200 cdecl _mbscpy(ptr str) CRTDLL__mbscpy
205 201 stub _mbscspn
206 202 stub _mbsdec
207 203 stub _mbsdup
208 204 cdecl _mbsicmp(str str) CRTDLL__mbsicmp
209 205 cdecl _mbsinc(str) CRTDLL__mbsinc
210 206 stub _mbslen
211 207 stub _mbslwr
212 208 stub _mbsnbcat
213 209 stub _mbsnbcmp
214 210 stub _mbsnbcnt
215 211 stub _mbsnbcpy
216 212 stub _mbsnbicmp
217 213 stub _mbsnbset
218 214 stub _mbsncat
219 215 stub _mbsnccnt
220 216 stub _mbsncmp
221 217 stub _mbsncpy
222 218 stub _mbsnextc
223 219 stub _mbsnicmp
224 220 stub _mbsninc
225 221 stub _mbsnset
226 222 stub _mbspbrk
227 223 cdecl _mbsrchr(str long) CRTDLL__mbsrchr
228 224 stub _mbsrev
229 225 stub _mbsset
230 226 stub _mbsspn
231 227 stub _mbsspnp
232 228 stub _mbsstr
233 229 stub _mbstok
234 230 stub _mbstrlen
235 231 stub _mbsupr
236 232 stub _memccpy
237 233 cdecl _memicmp(str str long) CRTDLL__memicmp
238 234 cdecl _mkdir(str) CRTDLL__mkdir
239 235 stub _mktemp
240 236 stub _msize
241 237 stub _nextafter
242 238 stub _onexit
243 239 cdecl _open(str long) CRTDLL__open
244 240 cdecl _open_osfhandle(long long) CRTDLL__open_osfhandle
245 241 extern _osmajor_dll CRTDLL_osmajor_dll
246 242 extern _osminor_dll CRTDLL_osminor_dll
247 243 extern _osmode_dll CRTDLL_osmode_dll
248 244 extern _osver_dll CRTDLL_osver_dll
249 245 extern _osversion_dll CRTDLL_osversion_dll
250 246 stub _pclose
251 247 stub _pctype_dll
252 248 stub _pgmptr_dll
253 249 stub _pipe
254 250 stub _popen
255 251 stub _purecall
256 252 stub _putch
257 253 stub _putenv
258 254 stub _putw
259 255 stub _pwctype_dll
260 256 stub _read
261 257 stub _rmdir
262 258 stub _rmtmp
263 259 cdecl _rotl (long long) CRTDLL__rotl
264 260 stub _rotr
265 261 stub _scalb
266 262 stub _searchenv
267 263 stub _seterrormode
268 264 stub _setjmp
269 265 cdecl _setmode(long long) CRTDLL__setmode
270 266 stub _setsystime
271 267 cdecl _sleep(long) CRTDLL__sleep
272 268 stub _snprintf
273 269 stub _snwprintf
274 270 stub _sopen
275 271 stub _spawnl
276 272 stub _spawnle
277 273 stub _spawnlp
278 274 stub _spawnlpe
279 275 stub _spawnv
280 276 stub _spawnve
281 277 stub _spawnvp
282 278 stub _spawnvpe
283 279 cdecl _splitpath (str ptr ptr ptr ptr) CRTDLL__splitpath
284 280 cdecl _stat (str ptr) CRTDLL__stat
285 281 stub _statusfp
286 282 cdecl _strcmpi(str str) CRTDLL__strcmpi
287 283 stub _strdate
288 284 stub _strdec
289 285 cdecl _strdup(str) CRTDLL__strdup
290 286 stub _strerror
291 287 cdecl _stricmp(str str) CRTDLL__strcmpi
292 288 stub _stricoll
293 289 stub _strinc
294 290 cdecl _strlwr(str) CRTDLL__strlwr
295 291 stub _strncnt
296 292 stub _strnextc
297 293 cdecl _strnicmp(str str long) CRTDLL__strnicmp
298 294 stub _strninc
299 295 stub _strnset
300 296 stub _strrev
301 297 stub _strset
302 298 stub _strspnp
303 299 stub _strtime
304 300 cdecl _strupr(str) CRTDLL__strupr
305 301 stub _swab
306 302 stub _sys_errlist
307 303 stub _sys_nerr_dll
308 304 stub _tell
309 305 cdecl _tempnam(str ptr) CRTDLL__tempnam
310 306 stub _timezone_dll
311 307 stub _tolower
312 308 stub _toupper
313 309 stub _tzname
314 310 stub _tzset
315 311 stub _ultoa
316 312 stub _ultow
317 313 stub _umask
318 314 stub _ungetch
319 315 cdecl _unlink(str) CRTDLL__unlink
320 316 stub _unloaddll
321 317 stub _utime
322 318 stub _vsnprintf
323 319 stub _vsnwprintf
324 320 cdecl _wcsdup(wstr) CRTDLL__wcsdup
325 321 cdecl _wcsicmp(wstr wstr) CRTDLL__wcsicmp
326 322 cdecl _wcsicoll(wstr wstr) CRTDLL__wcsicoll
327 323 cdecl _wcslwr(wstr) CRTDLL__wcslwr
328 324 cdecl _wcsnicmp(wstr wstr long) CRTDLL__wcsnicmp
329 325 stub _wcsnset
330 326 cdecl _wcsrev(wstr) CRTDLL__wcsrev
331 327 stub _wcsset
332 328 cdecl _wcsupr(wstr) CRTDLL__wcsupr
333 329 extern _winmajor_dll CRTDLL_winmajor_dll
334 330 extern _winminor_dll CRTDLL_winminor_dll
335 331 extern _winver_dll CRTDLL_winver_dll
336 332 cdecl _write(long ptr long) CRTDLL__write
337 333 stub _wtoi
338 334 stub _wtol
339 335 cdecl _y0(double) y0
340 336 cdecl _y1(double) y1
341 337 cdecl _yn(long double) yn
342 338 stub abort
343 339 cdecl abs(long) abs
344 340 cdecl acos(double) acos
345 341 cdecl asctime(ptr) asctime
346 342 cdecl asin(double) asin
347 343 cdecl atan(double) atan
348 344 cdecl atan2(double double) atan2
349 345 cdecl atexit(ptr) CRTDLL_atexit
350 346 cdecl atof(str) atof
351 347 cdecl atoi(str) atoi
352 348 cdecl atol(str) atol
353 349 stub bsearch
354 350 cdecl calloc(long long) CRTDLL_calloc
355 351 cdecl ceil(double) ceil
356 352 stub clearerr
357 353 cdecl clock() CRTDLL_clock
358 354 cdecl cos(double) cos
359 355 cdecl cosh(double) cosh
360 356 cdecl ctime(ptr) ctime
361 357 stub difftime
362 358 cdecl div(long long) div
363 359 cdecl exit(long) CRTDLL_exit
364 360 cdecl exp(double) exp
365 361 cdecl fabs(double) fabs
366 362 cdecl fclose(ptr) CRTDLL_fclose
367 363 cdecl feof(ptr) CRTDLL_feof
368 364 stub ferror
369 365 cdecl fflush(ptr) CRTDLL_fflush
370 366 cdecl fgetc(ptr) CRTDLL_fgetc
371 367 stub fgetpos
372 368 cdecl fgets(ptr long ptr) CRTDLL_fgets
373 369 stub fgetwc
374 370 cdecl floor(double) floor
375 371 cdecl fmod(double double) fmod
376 372 cdecl fopen(str str) CRTDLL_fopen
377 373 varargs fprintf() CRTDLL_fprintf
378 374 cdecl fputc(long ptr) CRTDLL_fputc
379 375 cdecl fputs(str ptr) CRTDLL_fputs
380 376 stub fputwc
381 377 cdecl fread(ptr long long ptr) CRTDLL_fread
382 378 cdecl free(ptr) CRTDLL_free
383 379 stub freopen
384 380 cdecl frexp(double ptr) frexp
385 381 varargs fscanf() CRTDLL_fscanf
386 382 cdecl fseek(ptr long long) CRTDLL_fseek
387 383 cdecl fsetpos(ptr ptr) CRTDLL_fsetpos
388 384 cdecl ftell(ptr) CRTDLL_ftell
389 385 stub fwprintf
390 386 cdecl fwrite(ptr long long ptr) CRTDLL_fwrite 
391 387 stub fwscanf
392 388 cdecl getc(ptr) CRTDLL_getc
393 389 stub getchar
394 390 cdecl getenv (str) CRTDLL_getenv
395 391 cdecl gets(ptr) CRTDLL_gets
396 392 cdecl gmtime(ptr) gmtime
397 393 stub is_wctype
398 394 cdecl isalnum(long) isalnum
399 395 cdecl isalpha(long) isalpha
400 396 cdecl iscntrl(long) iscntrl
401 397 cdecl isdigit(long) isdigit
402 398 cdecl isgraph(long) isgraph
403 399 stub isleadbyte
404 400 cdecl islower(long) islower
405 401 cdecl isprint(long) isprint
406 402 cdecl ispunct(long) ispunct
407 403 cdecl isspace(long) isspace
408 404 cdecl isupper(long) isupper
409 405 stub iswalnum
410 406 stub iswalpha
411 407 stub iswascii
412 408 stub iswcntrl
413 409 stub iswctype
414 410 stub iswdigit
415 411 stub iswgraph
416 412 stub iswlower
417 413 stub iswprint
418 414 stub iswpunct
419 415 stub iswspace
420 416 stub iswupper
421 417 stub iswxdigit
422 418 cdecl isxdigit(long) isxdigit
423 419 cdecl labs(long) labs
424 420 cdecl ldexp(double long) ldexp
425 421 cdecl ldiv(long long) ldiv
426 422 stub localeconv
427 423 cdecl localtime(ptr) localtime
428 424 cdecl log(double) log
429 425 cdecl log10(double) log10
430 426 cdecl longjmp(ptr long) CRTDLL_longjmp
431 427 cdecl malloc(ptr) CRTDLL_malloc
432 428 cdecl mblen(str long) CRTDLL_mblen
433 429 cdecl mbstowcs(ptr str long) CRTDLL_mbstowcs
434 430 cdecl mbtowc(ptr ptr long) CRTDLL_mbtowc
435 431 cdecl memchr(ptr long long) memchr
436 432 cdecl memcmp(ptr ptr long) memcmp
437 433 cdecl memcpy(ptr ptr long) memcpy
438 434 cdecl memmove(ptr ptr long) memmove
439 435 cdecl memset(ptr long long) memset 
440 436 cdecl mktime(ptr) mktime
441 437 cdecl modf(double ptr) modf
442 438 stub perror
443 439 cdecl pow(double double) pow
444 440 varargs printf() printf
445 441 cdecl putc(long ptr) CRTDLL_putc
446 442 cdecl putchar(long) CRTDLL_putchar
447 443 cdecl puts(str) CRTDLL_puts
448 444 cdecl qsort(ptr long long ptr) qsort
449 445 stub raise
450 446 cdecl rand() CRTDLL_rand
451 447 cdecl realloc(ptr long) CRTDLL_realloc
452 448 stub remove
453 449 cdecl rename(str str) CRTDLL_rename
454 450 stub rewind
455 451 stub scanf
456 452 cdecl setbuf(ptr ptr) CRTDLL_setbuf
457 453 cdecl setlocale(long ptr) CRTDLL_setlocale
458 454 stub setvbuf
459 455 cdecl signal(long ptr) CRTDLL_signal
460 456 cdecl sin(double) sin
461 457 cdecl sinh(double) sinh
462 458 varargs sprintf() sprintf
463 459 cdecl sqrt(double) sqrt
464 460 cdecl srand(long) CRTDLL_srand
465 461 varargs sscanf() sscanf
466 462 cdecl strcat(str str) strcat
467 463 cdecl strchr(str long) strchr
468 464 cdecl strcmp(str str) strcmp
469 465 cdecl strcoll(str str) strcoll
470 466 cdecl strcpy(ptr str) strcpy
471 467 cdecl strcspn(str str) strcspn
472 468 stub strerror
473 469 cdecl strftime(ptr long str ptr) strftime
474 470 cdecl strlen(str) strlen
475 471 cdecl strncat(str str long) strncat
476 472 cdecl strncmp(str str long) strncmp
477 473 cdecl strncpy(ptr str long) strncpy
478 474 cdecl strpbrk(str str) strpbrk
479 475 cdecl strrchr(str long) strrchr
480 476 cdecl strspn(str str) strspn
481 477 cdecl strstr(str str) strstr
482 478 cdecl strtod(str ptr) strtod
483 479 cdecl strtok(str str) strtok
484 480 cdecl strtol(str ptr long) strtol
485 481 cdecl strtoul(str ptr long) strtoul
486 482 cdecl strxfrm(ptr str long) strxfrm
487 483 varargs swprintf() wsprintf32W
488 484 stub swscanf
489 485 cdecl system(str) CRTDLL_system
490 486 cdecl tan(double) tan
491 487 cdecl tanh(double) tanh
492 488 cdecl time(ptr) CRTDLL_time
493 489 stub tmpfile
494 490 cdecl tmpnam(str) CRTDLL_tmpnam
495 491 cdecl tolower(long) tolower
496 492 cdecl toupper(long) toupper
497 493 cdecl towlower(long) towlower
498 494 cdecl towupper(long) towupper
499 495 stub ungetc
500 496 stub ungetwc
501 497 cdecl vfprintf(ptr str ptr) CRTDLL_vfprintf
502 498 stub vfwprintf
503 499 stub vprintf
504 500 cdecl vsprintf(ptr str ptr) CRTDLL_vsprintf
505 501 cdecl vswprintf(ptr wstr ptr) CRTDLL_vswprintf
506 502 stub vwprintf
507 503 cdecl wcscat(wstr wstr) CRTDLL_wcscat
508 504 cdecl wcschr(wstr long) CRTDLL_wcschr
509 505 cdecl wcscmp(wstr wstr) CRTDLL_wcscmp
510 506 cdecl wcscoll(wstr wstr) CRTDLL_wcscoll
511 507 cdecl wcscpy(ptr wstr) CRTDLL_wcscpy
512 508 cdecl wcscspn(wstr wstr) CRTDLL_wcscspn
513 509 stub wcsftime
514 510 cdecl wcslen(wstr) CRTDLL_wcslen
515 511 cdecl wcsncat(wstr wstr long) CRTDLL_wcsncat
516 512 cdecl wcsncmp(wstr wstr long) CRTDLL_wcsncmp
517 513 cdecl wcsncpy(ptr wstr long) CRTDLL_wcsncpy
518 514 stub wcspbrk
519 515 cdecl wcsrchr(wstr long) CRTDLL_wcsrchr
520 516 cdecl wcsspn(wstr wstr) CRTDLL_wcsspn
521 517 cdecl wcsstr(wstr wstr) CRTDLL_wcsstr
522 518 stub wcstod
523 519 stub wcstok
524 520 stub wcstol
525 521 cdecl wcstombs(ptr ptr long) CRTDLL_wcstombs
526 522 stub wcstoul
527 523 stub wcsxfrm
528 524 stub wctomb
529 525 stub wprintf
530 526 stub wscanf