Make functions static.
[wine] / dlls / shell32 / shell32.spec
1 # Functions exported by the Win95 shell32.dll
2 # (these need to have these exact ordinals, for some
3 #  win95 and winNT dlls import shell32.dll by ordinal)
4 # This list was updated to dll version 4.72
5
6    2 stdcall -noname SHChangeNotifyRegister(long long long long long ptr)
7    4 stdcall -noname SHChangeNotifyDeregister(long)
8    5 stdcall -noname SHChangeNotifyUpdateEntryList(long long long long)
9    9 stub -noname PifMgr_OpenProperties
10   10 stub -noname PifMgr_GetProperties
11   11 stub -noname PifMgr_SetProperties
12   13 stub -noname PifMgr_CloseProperties
13   15 stdcall -noname ILGetDisplayName(ptr ptr)
14   16 stdcall -noname ILFindLastID(ptr)
15   17 stdcall -noname ILRemoveLastID(ptr)
16   18 stdcall -noname ILClone(ptr)
17   19 stdcall -noname ILCloneFirst(ptr)
18   20 stdcall -noname ILGlobalClone(ptr)
19   21 stdcall -noname ILIsEqual(ptr ptr)
20   23 stdcall -noname ILIsParent(ptr ptr long)
21   24 stdcall -noname ILFindChild(ptr ptr)
22   25 stdcall -noname ILCombine(ptr ptr)
23   26 stdcall -noname ILLoadFromStream(ptr ptr)
24   27 stdcall -noname ILSaveToStream(ptr ptr)
25   28 stdcall -noname SHILCreateFromPath(ptr ptr ptr) SHILCreateFromPathAW
26   29 stdcall -noname PathIsRoot(ptr) PathIsRootAW
27   30 stdcall -noname PathBuildRoot(ptr long) PathBuildRootAW
28   31 stdcall -noname PathFindExtension(ptr) PathFindExtensionAW
29   32 stdcall -noname PathAddBackslash(ptr) PathAddBackslashAW
30   33 stdcall -noname PathRemoveBlanks(ptr) PathRemoveBlanksAW
31   34 stdcall -noname PathFindFileName(ptr) PathFindFileNameAW
32   35 stdcall -noname PathRemoveFileSpec(ptr) PathRemoveFileSpecAW
33   36 stdcall -noname PathAppend(ptr ptr) PathAppendAW
34   37 stdcall -noname PathCombine(ptr ptr ptr) PathCombineAW
35   38 stdcall -noname PathStripPath(ptr)PathStripPathAW
36   39 stdcall -noname PathIsUNC(ptr) PathIsUNCAW
37   40 stdcall -noname PathIsRelative(ptr) PathIsRelativeAW
38   41 stdcall -noname IsLFNDriveA(str)
39   42 stdcall -noname IsLFNDriveW(wstr)
40   43 stdcall -noname PathIsExe(ptr) PathIsExeAW
41   45 stdcall -noname PathFileExists(ptr) PathFileExistsAW
42   46 stdcall -noname PathMatchSpec(ptr ptr) PathMatchSpecAW
43   47 stdcall -noname PathMakeUniqueName(ptr long ptr ptr ptr)PathMakeUniqueNameAW
44   48 stdcall -noname PathSetDlgItemPath(long long ptr) PathSetDlgItemPathAW
45   49 stdcall -noname PathQualify(ptr) PathQualifyAW
46   50 stdcall -noname PathStripToRoot(ptr) PathStripToRootAW
47   51 stdcall -noname PathResolve(str long long) PathResolveAW
48   52 stdcall -noname PathGetArgs(str) PathGetArgsAW
49   53 stdcall DoEnvironmentSubst(long long) DoEnvironmentSubstAW
50   55 stdcall -noname PathQuoteSpaces(ptr) PathQuoteSpacesAW
51   56 stdcall -noname PathUnquoteSpaces(str) PathUnquoteSpacesAW
52   57 stdcall -noname PathGetDriveNumber(str) PathGetDriveNumberAW
53   58 stdcall -noname ParseField(str long ptr long) ParseFieldAW
54   59 stdcall -noname RestartDialog(long wstr long)
55   60 stdcall -noname ExitWindowsDialog(long)
56   61 stdcall -noname RunFileDlg(long long long str str long)
57   62 stdcall -noname PickIconDlg(long long long long)
58   63 stdcall -noname GetFileNameFromBrowse(long long long long str str str)
59   64 stdcall -noname DriveType(long)
60   65 stub -noname InvalidateDriveType
61   66 stdcall -noname IsNetDrive(long)
62   67 stdcall -noname Shell_MergeMenus(long long long long long long)
63   68 stdcall -noname SHGetSetSettings(ptr long long)
64   69 stub -noname SHGetNetResource
65   70 stdcall -noname SHCreateDefClassObject(long long long long long)
66   71 stdcall -noname Shell_GetImageList(ptr ptr)
67   72 stdcall -noname Shell_GetCachedImageIndex(ptr ptr long) Shell_GetCachedImageIndexAW
68   73 stdcall -noname SHShellFolderView_Message(long long long)
69   74 stdcall -noname SHCreateStdEnumFmtEtc(long ptr ptr)
70   75 stdcall -noname PathYetAnotherMakeUniqueName(ptr wstr wstr wstr)
71   76 stub DragQueryInfo
72   77 stdcall -noname SHMapPIDLToSystemImageListIndex(ptr ptr ptr)
73   78 stdcall -noname OleStrToStrN(str long wstr long) OleStrToStrNAW
74   79 stdcall -noname StrToOleStrN(wstr long str long) StrToOleStrNAW
75   83 stdcall -noname CIDLData_CreateFromIDArray(ptr long ptr ptr)
76   84 stub SHIsBadInterfacePtr
77   85 stdcall -noname OpenRegStream(long str str long) shlwapi.SHOpenRegStreamA
78   86 stdcall -noname SHRegisterDragDrop(long ptr)
79   87 stdcall -noname SHRevokeDragDrop(long)
80   88 stdcall -noname SHDoDragDrop(long ptr ptr long ptr)
81   89 stdcall -noname SHCloneSpecialIDList(long long long)
82   90 stdcall -noname SHFindFiles(ptr ptr)
83   91 stub SHFindComputer
84   92 stdcall -noname PathGetShortPath(ptr) PathGetShortPathAW
85   93 stdcall -noname Win32CreateDirectory(wstr ptr) Win32CreateDirectoryAW
86   94 stdcall -noname Win32RemoveDirectory(wstr) Win32RemoveDirectoryAW
87   95 stdcall -noname SHLogILFromFSIL(ptr)
88   96 stdcall -noname StrRetToStrN(ptr long ptr ptr) StrRetToStrNAW
89   97 stdcall -noname SHWaitForFileToOpen (long long long)
90   98 stdcall -noname SHGetRealIDL(ptr ptr ptr)
91   99 stdcall -noname SetAppStartingCursor(long long)
92  100 stdcall -noname SHRestricted(long)
93
94  102 stdcall -noname SHCoCreateInstance(wstr ptr long ptr ptr)
95  103 stdcall -noname SignalFileOpen(long)
96  104 stdcall -noname FileMenu_DeleteAllItems(long)
97  105 stdcall -noname FileMenu_DrawItem(long ptr)
98  106 stdcall -noname FileMenu_FindSubMenuByPidl(long ptr)
99  107 stdcall -noname FileMenu_GetLastSelectedItemPidls(long ptr ptr)
100  108 stdcall -noname FileMenu_HandleMenuChar(long long)
101  109 stdcall -noname FileMenu_InitMenuPopup(long)
102  110 stdcall -noname FileMenu_InsertUsingPidl (long long ptr long long ptr)
103  111 stdcall -noname FileMenu_Invalidate(long)
104  112 stdcall -noname FileMenu_MeasureItem(long ptr)
105  113 stdcall -noname FileMenu_ReplaceUsingPidl(long long ptr long ptr)
106  114 stdcall -noname FileMenu_Create(long long long long long)
107  115 stdcall -noname FileMenu_AppendItem(long ptr long long long long) FileMenu_AppendItemAW
108  116 stdcall -noname FileMenu_TrackPopupMenuEx(long long long long long long)
109  117 stdcall -noname FileMenu_DeleteItemByCmd(long long)
110  118 stdcall -noname FileMenu_Destroy(long)
111  119 stdcall -noname IsLFNDrive(ptr) IsLFNDriveAW
112  120 stdcall -noname FileMenu_AbortInitMenu()
113  121 stdcall -noname SHFlushClipboard()
114  122 stdcall -noname RunDLL_CallEntry16(long long long str long) #name wrong?
115  123 stdcall -noname SHFreeUnusedLibraries()
116  124 stdcall -noname FileMenu_AppendFilesForPidl(long ptr long)
117  125 stdcall -noname FileMenu_AddFilesForPidl(long long long ptr long long ptr)
118  126 stdcall -noname SHOutOfMemoryMessageBox(long long long)
119  127 stdcall -noname SHWinHelp(long long long long)
120  129 stdcall -noname DAD_AutoScroll(long ptr ptr)
121  130 stdcall -noname DAD_DragEnter(long)
122  131 stdcall -noname DAD_DragEnterEx(long long long)
123  132 stdcall -noname DAD_DragLeave()
124  134 stdcall -noname DAD_DragMove(long long)
125  136 stdcall -noname DAD_SetDragImage(long long)
126  137 stdcall -noname DAD_ShowDragImage(long)
127  139 stub Desktop_UpdateBriefcaseOnEvent
128  140 stdcall -noname FileMenu_DeleteItemByIndex(long long)
129  141 stdcall -noname FileMenu_DeleteItemByFirstID(long long)
130  142 stdcall -noname FileMenu_DeleteSeparator(long)
131  143 stdcall -noname FileMenu_EnableItemByCmd(long long long)
132  144 stdcall -noname FileMenu_GetItemExtent(long long)
133  145 stdcall -noname PathFindOnPath(ptr ptr) PathFindOnPathAW
134  146 stdcall -noname RLBuildListOfPaths()
135  147 stdcall -noname SHCLSIDFromString(long long) SHCLSIDFromStringAW
136  149 stdcall -noname SHFind_InitMenuPopup(long long long long)
137
138  151 stdcall -noname SHLoadOLE(long)
139  152 stdcall -noname ILGetSize(ptr)
140  153 stdcall -noname ILGetNext(ptr)
141  154 stdcall -noname ILAppend(long long long)
142  155 stdcall -noname ILFree(ptr)
143  156 stdcall -noname ILGlobalFree(ptr)
144  157 stdcall -noname ILCreateFromPath(ptr) ILCreateFromPathAW
145  158 stdcall -noname PathGetExtension(str long long) PathGetExtensionAW
146  159 stdcall -noname PathIsDirectory(ptr) PathIsDirectoryAW
147  160 stub SHNetConnectionDialog
148  161 stdcall -noname SHRunControlPanel(long long)
149  162 stdcall -noname SHSimpleIDListFromPath(ptr) SHSimpleIDListFromPathAW
150  163 stdcall -noname StrToOleStr(wstr str) StrToOleStrAW
151  164 stdcall -noname Win32DeleteFile(str) Win32DeleteFileAW
152  165 stdcall -noname SHCreateDirectory(long ptr)
153  166 stdcall -noname CallCPLEntry16(long long long long long long)
154  167 stdcall -noname SHAddFromPropSheetExtArray(long long long)
155  168 stdcall -noname SHCreatePropSheetExtArray(long str long)
156  169 stdcall -noname SHDestroyPropSheetExtArray(long)
157  170 stdcall -noname SHReplaceFromPropSheetExtArray(long long long long)
158  171 stdcall -noname PathCleanupSpec(ptr ptr)
159  172 stdcall -noname SHCreateLinks(long str ptr long ptr)
160  173 stdcall -noname SHValidateUNC(long long long)
161  174 stdcall -noname SHCreateShellFolderViewEx(ptr ptr)
162  175 stdcall -noname SHGetSpecialFolderPath(long long long long) SHGetSpecialFolderPathAW
163  176 stdcall -noname SHSetInstanceExplorer(long)
164  177 stub DAD_SetDragImageFromListView
165  178 stdcall -noname SHObjectProperties(long long wstr wstr)
166  179 stdcall -noname SHGetNewLinkInfoA(str str ptr long long)
167  180 stdcall -noname SHGetNewLinkInfoW(wstr wstr ptr long long)
168  181 stdcall -noname RegisterShellHook(long long)
169  182 varargs -noname ShellMessageBoxW(long long long str long)
170  183 varargs -noname ShellMessageBoxA(long long long str long)
171  184 stdcall -noname ArrangeWindows(long long long long long)
172  185 stub SHHandleDiskFull
173  186 stdcall -noname ILGetDisplayNameEx(ptr ptr ptr long)
174  187 stub ILGetPseudoNameW
175  188 stdcall -noname ShellDDEInit(long)
176  189 stdcall -noname ILCreateFromPathA(str)
177  190 stdcall -noname ILCreateFromPathW(wstr)
178  191 stdcall -noname SHUpdateImageA(str long long long)
179  192 stdcall -noname SHUpdateImageW(wstr long long long)
180  193 stdcall -noname SHHandleUpdateImage(ptr)
181  194 stub SHCreatePropSheetExtArrayEx
182  195 stdcall -noname SHFree(ptr)
183  196 stdcall -noname SHAlloc(long)
184  197 stub SHGlobalDefect
185  198 stdcall -noname SHAbortInvokeCommand()
186  199 stub SHGetFileIcon
187  200 stub SHLocalAlloc
188  201 stub SHLocalFree
189  202 stub SHLocalReAlloc
190  203 stub AddCommasW
191  204 stub ShortSizeFormatW
192  205 stub Printer_LoadIconsW
193  206 stub Link_AddExtraDataSection
194  207 stub Link_ReadExtraDataSection
195  208 stub Link_RemoveExtraDataSection
196  209 stub Int64ToString
197  210 stub LargeIntegerToString
198  211 stub Printers_GetPidl
199  212 stub Printers_AddPrinterPropPages
200  213 stub Printers_RegisterWindowW
201  214 stub Printers_UnregisterWindow
202  215 stdcall -noname SHStartNetConnectionDialog(long str long)
203  243 stdcall @(long long) shell32_243
204  244 stdcall -noname SHInitRestricted(ptr ptr)
205  249 stdcall -noname PathParseIconLocation(ptr) PathParseIconLocationAW
206  250 stdcall -noname PathRemoveExtension(ptr) PathRemoveExtensionAW
207  251 stdcall -noname PathRemoveArgs(ptr) PathRemoveArgsAW
208  256 stdcall @(ptr ptr) SHELL32_256
209 #299 stub Shl1632_ThunkData32
210 #300 stub Shl3216_ThunkData32
211
212  505 stdcall SHRegCloseKey (long)
213  506 stdcall SHRegOpenKeyA (long str long)
214  507 stdcall SHRegOpenKeyW (long wstr long)
215  508 stub SHRegQueryValueA
216  509 stdcall SHRegQueryValueExA(long str ptr ptr ptr ptr)
217  510 stdcall SHRegQueryValueW (long long long long)
218  511 stdcall SHRegQueryValueExW (long wstr ptr ptr ptr ptr)
219  512 stdcall SHRegDeleteKeyW (long wstr)
220
221  520 stdcall -noname SHAllocShared(ptr long long)
222  521 stdcall -noname SHLockShared(long long)
223  522 stdcall -noname SHUnlockShared(ptr)
224  523 stdcall -noname SHFreeShared(long long)
225  524 stdcall -noname RealDriveType(long long)
226  525 stub RealDriveTypeFlags
227
228  640 stdcall -noname NTSHChangeNotifyRegister(long long long long long long)
229  641 stdcall -noname NTSHChangeNotifyDeregister(long)
230
231  643 stub SHChangeNotifyReceive
232  644 stdcall -noname SHChangeNotification_Lock(long long ptr ptr)
233  645 stdcall -noname SHChangeNotification_Unlock(long)
234  646 stub SHChangeRegistrationReceive
235  647 stub ReceiveAddToRecentDocs
236  648 stub SHWaitOp_Operate
237
238  650 stdcall -noname PathIsSameRoot(ptr ptr) PathIsSameRootAW
239
240 # nt40/win98
241  651 stdcall -noname ReadCabinetState(long long) # OldReadCabinetState
242  652 stdcall -noname WriteCabinetState(long)
243  653 stdcall -noname PathProcessCommand(long long long long) PathProcessCommandAW
244
245 # win98
246  654 stdcall @(long long) shell32_654 # ReadCabinetState@8
247  660 stdcall -noname FileIconInit(long)
248  680 stdcall -noname IsUserAdmin()
249
250 # >= NT5
251  714 stdcall @(ptr) SHELL32_714 # PathIsTemporaryW
252  730 stdcall -noname RestartDialogEx(long wstr long long)
253
254 1217 stub FOOBAR1217   # no joke! This is the real name!!
255
256 #
257 # version 4.0 (win95)
258 # _WIN32_IE >= 0x0200
259 #
260 @ stdcall CheckEscapesA(str long)
261 @ stdcall CheckEscapesW(wstr long)
262 @ stdcall CommandLineToArgvW(wstr ptr)
263 @ stdcall Control_FillCache_RunDLL(long long long long) Control_FillCache_RunDLLA
264 @ stdcall Control_FillCache_RunDLLA(long long long long)
265 @ stdcall Control_FillCache_RunDLLW(long long long long)
266 @ stdcall Control_RunDLL(ptr ptr str long) Control_RunDLLA
267 @ stdcall Control_RunDLLA(ptr ptr str long)
268 @ stub Control_RunDLLAsUserW
269 @ stdcall Control_RunDLLW(ptr ptr wstr long)
270 @ stdcall -private DllCanUnloadNow() SHELL32_DllCanUnloadNow
271 @ stdcall -private DllGetClassObject(long long ptr) SHELL32_DllGetClassObject
272 @ stdcall DllInstall(long wstr)SHELL32_DllInstall
273 @ stdcall -private DllRegisterServer() SHELL32_DllRegisterServer
274 @ stdcall -private DllUnregisterServer() SHELL32_DllUnregisterServer
275 @ stdcall DoEnvironmentSubstA(str str)
276 @ stdcall DoEnvironmentSubstW(wstr wstr)
277 @ stdcall DragAcceptFiles(long long)
278 @ stdcall DragFinish(long)
279 @ stdcall DragQueryFile(long long ptr long) DragQueryFileA
280 @ stdcall DragQueryFileA(long long ptr long)
281 @ stub DragQueryFileAorW
282 @ stdcall DragQueryFileW(long long ptr long)
283 @ stdcall DragQueryPoint(long ptr)
284 @ stdcall DuplicateIcon(long long)
285 @ stdcall ExtractAssociatedIconA(long str ptr)
286 @ stdcall ExtractAssociatedIconExA(long str long long)
287 @ stdcall ExtractAssociatedIconExW(long wstr long long)
288 @ stdcall ExtractAssociatedIconW(long wstr ptr)
289 @ stdcall ExtractIconA(long str long)
290 @ stdcall ExtractIconEx(ptr long ptr ptr long) ExtractIconExA
291 @ stdcall ExtractIconExA(str long ptr ptr long)
292 @ stdcall ExtractIconExW(wstr long ptr ptr long)
293 @ stdcall ExtractIconW(long wstr long)
294 @ stub ExtractIconResInfoA
295 @ stub ExtractIconResInfoW
296 @ stub ExtractVersionResource16W
297 @ stub FindExeDlgProc
298 @ stdcall FindExecutableA(ptr ptr ptr)
299 @ stdcall FindExecutableW(wstr wstr wstr)
300 @ stub FixupOptionalComponents
301 @ stdcall FreeIconList(long)
302 @ stub InternalExtractIconListA
303 @ stub InternalExtractIconListW
304 @ stub OCInstall
305 @ stub OpenAs_RunDLL
306 @ stub OpenAs_RunDLLA
307 @ stub OpenAs_RunDLLW
308 @ stub PrintersGetCommand_RunDLL
309 @ stub PrintersGetCommand_RunDLLA
310 @ stub PrintersGetCommand_RunDLLW
311 @ stub RealShellExecuteA
312 @ stub RealShellExecuteExA
313 @ stub RealShellExecuteExW
314 @ stub RealShellExecuteW
315 @ stub RegenerateUserEnvironment
316 @ stdcall SHAddToRecentDocs (long ptr)
317 @ stdcall SHAppBarMessage(long ptr)
318 @ stdcall SHBrowseForFolder(ptr) SHBrowseForFolderA
319 @ stdcall SHBrowseForFolderA(ptr)
320 @ stdcall SHBrowseForFolderW(ptr)
321 @ stdcall SHChangeNotify (long long ptr ptr)
322 @ stub SHChangeNotifySuspendResume
323 @ stdcall SHCreateDirectoryExA(long str ptr)
324 @ stdcall SHCreateDirectoryExW(long wstr ptr)
325 @ stub SHCreateProcessAsUserW
326 @ stdcall SheChangeDirA(str)
327 @ stub SheChangeDirExA
328 @ stub SheChangeDirExW
329 @ stdcall SheChangeDirW(wstr)
330 @ stub SheConvertPathW
331 @ stub SheFullPathA
332 @ stub SheFullPathW
333 @ stub SheGetCurDrive
334 @ stdcall SheGetDirA(long long)
335 @ stub SheGetDirExW
336 @ stdcall SheGetDirW (long long)
337 @ stub SheGetPathOffsetW
338 @ stdcall ShellAboutA(long str str long)
339 @ stdcall ShellAboutW(long wstr wstr long)
340 @ stdcall ShellExecuteA(long str str str str long)
341 @ stdcall ShellExecuteEx (long) ShellExecuteExA
342 @ stdcall ShellExecuteExA (long)
343 @ stdcall ShellExecuteExW (long)
344 @ stdcall ShellExecuteW (long wstr wstr wstr wstr long)
345 @ stub ShellHookProc
346 @ stdcall Shell_NotifyIcon(long ptr) Shell_NotifyIconA
347 @ stdcall Shell_NotifyIconA(long ptr)
348 @ stdcall Shell_NotifyIconW(long ptr)
349 @ stdcall SHEmptyRecycleBinA(long str long)
350 @ stdcall SHEmptyRecycleBinW(long wstr long)
351 @ stub SheRemoveQuotesA
352 @ stub SheRemoveQuotesW
353 @ stub SheSetCurDrive
354 @ stub SheShortenPathA
355 @ stub SheShortenPathW
356 @ stub SHExtractIconsW
357 @ stdcall SHFileOperation(ptr) SHFileOperationA
358 @ stdcall SHFileOperationA(ptr)
359 @ stdcall SHFileOperationW(ptr)
360 @ stdcall SHFormatDrive(long long long long)
361 @ stdcall SHFreeNameMappings(ptr)
362 @ stdcall SHGetDataFromIDListA(ptr ptr long ptr long)
363 @ stdcall SHGetDataFromIDListW(ptr ptr long ptr long)
364 @ stdcall SHGetDesktopFolder(ptr)
365 @ stdcall SHGetFileInfo(ptr long ptr long long) SHGetFileInfoA
366 @ stdcall SHGetFileInfoA(ptr long ptr long long)
367 @ stdcall SHGetFileInfoW(ptr long ptr long long)
368 @ stdcall SHGetInstanceExplorer(long)
369 @ stdcall SHGetMalloc(ptr)
370 @ stdcall SHGetNewLinkInfo(str str ptr long long) SHGetNewLinkInfoA
371 @ stdcall SHGetPathFromIDList(ptr ptr) SHGetPathFromIDListA
372 @ stdcall SHGetPathFromIDListA(ptr ptr)
373 @ stdcall SHGetPathFromIDListW(ptr ptr)
374 @ stdcall SHGetSettings(ptr long)
375 @ stdcall SHGetSpecialFolderLocation(long long ptr)
376 @ stdcall SHHelpShortcuts_RunDLL(long long long long) SHHelpShortcuts_RunDLLA
377 @ stdcall SHHelpShortcuts_RunDLLA(long long long long)
378 @ stdcall SHHelpShortcuts_RunDLLW(long long long long)
379 @ stub SHInvokePrinterCommandA
380 @ stub SHInvokePrinterCommandW
381 @ stub SHIsFileAvailableOffline
382 @ stdcall SHLoadInProc(long)
383 @ stub SHLoadNonloadedIconOverlayIdentifiers
384 @ stub SHPathPrepareForWriteA
385 @ stub SHPathPrepareForWriteW
386 @ stdcall SHQueryRecycleBinA(str ptr)
387 @ stdcall SHQueryRecycleBinW(wstr ptr)
388 @ stub SHUpdateRecycleBinIcon
389 @ stdcall StrChrA(str long) shlwapi.StrChrA
390 @ stdcall StrChrIA(str long) shlwapi.StrChrIA
391 @ stdcall StrChrIW(wstr long) shlwapi.StrChrIW
392 @ stdcall StrChrW(wstr long) shlwapi.StrChrW
393 @ stdcall StrCmpNA(str str long) shlwapi.StrCmpNA
394 @ stdcall StrCmpNIA(str str long) shlwapi.StrCmpNIA
395 @ stdcall StrCmpNIW(wstr wstr long) shlwapi.StrCmpNIW
396 @ stdcall StrCmpNW(wstr wstr long) shlwapi.StrCmpNW
397 @ stdcall StrCpyNA (ptr str long) kernel32.lstrcpynA
398 @ stdcall StrCpyNW(wstr wstr long) shlwapi.StrCpyNW
399 @ stdcall StrNCmpA(str str long) shlwapi.StrCmpNA
400 @ stdcall StrNCmpIA(str str long) shlwapi.StrCmpNIA
401 @ stdcall StrNCmpIW(wstr wstr long) shlwapi.StrCmpNIW
402 @ stdcall StrNCmpW(wstr wstr long) shlwapi.StrCmpNW
403 @ stdcall StrNCpyA (ptr str long) kernel32.lstrcpynA
404 @ stdcall StrNCpyW(wstr wstr long) shlwapi.StrCpyNW
405 @ stdcall StrRChrA(str str long) shlwapi.StrRChrA
406 @ stdcall StrRChrIA(str str long) shlwapi.StrRChrIA
407 @ stdcall StrRChrIW(str str long) shlwapi.StrRChrIW
408 @ stdcall StrRChrW(wstr wstr long) shlwapi.StrRChrW
409 @ stub StrRStrA
410 @ stdcall StrRStrIA(str str str) shlwapi.StrRStrIA
411 @ stdcall StrRStrIW(wstr wstr wstr) shlwapi.StrRStrIW
412 @ stub StrRStrW
413 @ stdcall StrStrA(str str) shlwapi.StrStrA
414 @ stdcall StrStrIA(str str) shlwapi.StrStrIA
415 @ stdcall StrStrIW(wstr wstr) shlwapi.StrStrIW
416 @ stdcall StrStrW(wstr wstr) shlwapi.StrStrW
417 @ stub WOWShellExecute
418
419 #
420 # version 4.70 (IE3.0)
421 # _WIN32_IE >= 0x0300
422 #
423
424 #
425 # version 4.71 (IE4.0)
426 # _WIN32_IE >= 0x0400
427 #
428 @ stdcall DllGetVersion(ptr)SHELL32_DllGetVersion
429 @ stub SHGetFreeDiskSpace
430 @ stdcall SHGetSpecialFolderPathA(long ptr long long)
431 @ stdcall SHGetSpecialFolderPathW(long ptr long long)
432 #
433 # version 4.72 (IE4.01)
434 # _WIN32_IE >= 0x0401
435 # no new exports
436 #
437
438 #
439 # version 5.00 (Win2K)
440 # _WIN32_IE >= 0x0500
441 #
442 @ stub ShellExec_RunDLL
443 @ stub ShellExec_RunDLLA
444 @ stub ShellExec_RunDLLW
445 @ stdcall SHBindToParent(ptr ptr ptr ptr)
446 @ stdcall SHGetDiskFreeSpaceA(str ptr ptr ptr) kernel32.GetDiskFreeSpaceExA
447 @ stdcall SHGetDiskFreeSpaceExA(str ptr ptr ptr) kernel32.GetDiskFreeSpaceExA
448 @ stdcall SHGetDiskFreeSpaceExW(wstr ptr ptr ptr) kernel32.GetDiskFreeSpaceExW
449 @ stdcall SHGetFolderPathA(long long long long ptr)
450 @ stdcall SHGetFolderPathW(long long long long ptr)
451 @ stdcall SHGetFolderLocation(long long long long ptr)
452 @ stub SHGetIconOverlayIndexA
453 @ stub SHGetIconOverlayIndexW
454
455 # version 6.0 (WinXP)
456 # _WIN32_IE >= 0x600
457 @ stdcall SHDefExtractIconA(str long long ptr ptr long)
458 @ stdcall SHDefExtractIconW(wstr long long ptr ptr long)